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Introduction 
Welcome to the MicroGDS 2010 Foundation Training Course. This course presents an overview 
and introduction to the basics of MicroGDS.  

You should work through all the exercises in the Apartment block file, and complete the steps in the 
Examples file where you see  in the margin. 

Where you see  please carefully read the steps, you do not have to complete the example unless 
you wish. 

When you have completed the Apartment block exercises, your finished drawing should look similar 
to this: 

 

Note that graphics are drawn in colours according to the MicroGDS colour palette. Therefore, your 
graphics may vary in colour from the illustrations shown here. 
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Setting up the MicroGDS training data 
Before starting this course you will need to copy the MicroGDS training folder to your computer. The 
folder contains MicroGDS library data files such as doors and windows, plus style files for a 
selection of line and character styles which you will use throughout the course. 

Although this course is written for MicroGDS 2010, please ensure that you have installed any 
MicroGDS updates; you can check for updates from the MicroGDS Help menu.  

In the following instructions drive C:\ has been used. If you are using another drive, substitute your 
preferred drive letter wherever you see C:\.  

  Copy the ‘MicroGDS 2010 Foundation Training Data’ folder to your preferred location. 

Your MicroGDS 2010 Foundation Training folder contains: 
• Library folder 
•  Raster folder 
• Style files folder 
• 2010 Training Course.MTF 

In preparation for the training course, you, or your computer administrator, should start MicroGDS 
and configure your preferences. 

1. Start MicroGDS. 

2. On the File menu, click Preferences.   

3. On the Preferences dialog box, click the General tab (if it is not already selected). 

4. Select the ‘Floating prompt bar’ check box.  

Typed coordinates and distances are entered in a prompt bar. By default the prompt bar is 
docked at the bottom of the MicroGDS window. When you are learning MicroGDS it is useful to 
float the prompt bar so you can display it in a prominent position. 
 
You will now map the File Locations preference for Templates to the location in which you 
copied the training data. For example, C:\MicroGDS 2010 Foundation Training Data 
 
You can use a template when you create a single-user document. Templates can contain 
graphics, colours, styles, etc. which are automatically copied into a new document.  

5. Click the File Locations tab. 

6. Click Browse next to the Templates box and locate your MicroGDS 2010 Foundation Training 
Data folder.  

Note that from this point the “MicroGDS 2010 Foundation Training Data” folder will be referred 
to as the “MicroGDS Training” folder. 

7. Click OK to close the Preferences dialog box. 
8. Close MicroGDS by selecting Exit from the File menu. 

9. At the prompt to save your modified personal settings, click Yes. 

You are now ready to start the MicroGDS 2010 Foundation Training Course. 
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1. Introducing MicroGDS documents 

In this section you will learn how to: 

♦ start MicroGDS 

♦ create a single-user document 

♦ rename a window definition 

♦ close a single-user document 

♦ save a single-user document 

♦ exit MicroGDS 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Creating a new single-user document 
The MicroGDS window 
Renaming a window definition 
Saving documents 
Exiting MicroGDS 
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Creating a new MicroGDS document 
In MicroGDS, you can have single-user and multi-user documents. In this training course we use 
only single-user documents. A single-user document has a .MAN extension and can only be edited 
by one person at a time. 

When you create a single-user document, MicroGDS automatically creates a window definition.  A 
window definition provides a view onto the graphical data. By default, the first window definition in a 
document is the principle window definition. It is this window definition that opens each time you 
open the document. You can create additional window definitions to show different parts of a 
drawing. You will learn more about window definitions later on 
in the course. 

 Let’s start by creating a new single-user document: 

1. Start MicroGDS. 

2. On the File menu, click New. 

3. On the Create a New File dialog box, ensure Blank is 
selected and click OK.  

A new MicroGDS single-user document is created. 

Renaming a window definition 
When you create a new window definition in a single user document, MicroGDS assigns it a name 
with a sequential number, Window1, Window2, etc. You can change the name, and MicroGDS 
saves the window definition with the name the next time you save the document. 

 We will now rename our default window definition. 

1. On the Document Organizer, place your mouse pointer over ‘Window1’ and 
click the right mouse button to open the shortcut menu. 

2. Select Rename. 

3. Type Doors and press Enter. 
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The MicroGDS window 
Before going any further, let’s spend a little time looking at the MicroGDS window and the drawing 
area. 

 

 

 

The initial size of the area in which you draw is normally about that of an A4 sheet of paper. This 
area is called the view extent. The maximum extent of a MicroGDS drawing is 50,000km.  

scroll bars 

You can pan around your window using the scroll bars. The vertical scroll bar is on the right of each 
document window and the horizontal scroll bar is at the bottom.  

zoom bar 

The zoom bar is on the left of the document window. Click above the slider to zoom out, and below 
to zoom in; or drag the slider up and down.  

Document 
Organizer 

Hint area and prompt bar Information bar 

Menu bar      Toolbars                     Status bars 

Document  window 
      (view extent) 

Viewing 
buttons 

Properties 
window 

Mini Window 
Editor 

Zoom bar 

Navigate  
window 

Scroll bars 
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viewing buttons 

The default set of viewing buttons is also on the left of the document window, above the zoom bar. 
You can use the following buttons to change the view: 

  expands the current view to fit the window 

   zooms in to a rectangular area that you specify 

   zooms to show the selected graphics 

   zooms to show all the graphics 

Navigate window 

The Navigate window lets you move around a drawing using a thumbnail of the 
view. 

Mouse wheel 

In addition to the navigation tools described above, you can use the mouse 
wheel to navigate around the drawing. 

Roll the mouse wheel forwards and backwards to zoom in and out of your 
drawing. Hold the mouse wheel down and move the mouse to pan around your 
drawing. Note the pointer shape changes to a hand symbol. 

Document Organizer 

The Document Organizer provides a central point from which you can work with window definitions, 
layers and styles. It is covered later on in this course. 

Mini Window Editor 

The Mini Window Editor enables you to work with phases. It is covered later on in this course. 

The menu bar 

The menu bar provides commands to create and edit your drawings. The commands are grouped 
together into a number of categories. Click on some of the menu bar headings to see the 
commands they offer. 

The toolbars 

The toolbars provide an alternative means of selecting many of the menu commands. 

The status toolbars display information about the active drawing such as the scale, the units of 
measurement, and the angle of the axes. You can use the status toolbars to modify the settings 
shown. 

The hint area 

MicroGDS displays helpful information about the current command. For example, In the Construct 
Circle 2 Points command, the hint area displays ‘First Point of circle’ indicating a coordinate position 
is expected. 
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The prompt bar 

The prompt bar was discussed earlier and you will have set your preferences to float the prompt bar. 
This is the area where you type data such as a distance radius or coordinate related to the current 
command. 

The Properties window 

The Properties window is your main tool for changing and querying the 
properties of a drawing.  

The Properties window is blank until you select graphics. We will cover 
selecting graphics in the next section. 

 

 

 

 

 

 

 

 

 

Saving a MicroGDS document 
You can save a MicroGDS document at any time. You can also save a document with a new name. 

 Now, save your MicroGDS document as we will use it for 
future examples. 

1. On the File menu, click Save MAN File. 

2. Using the Save As dialog box, navigate to your 
MicroGDS Training folder and save your document as 
Examples. Don’t worry about the file name extension 
as MicroGDS adds it automatically.  

3. Exit from MicroGDS. 
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Exercise 1 
In this first exercise you will start MicroGDS, create a new blank document based on a template, 
and save it for future use, then exit MicroGDS. 

1. Start MicroGDS. 

2. On the File menu, click New. 

3. On the Create a New File dialog box, select ‘From template’. 

4. Click Next, select ‘2010 Training Course.MTF’, and then click Open. 

A new single-user document is opened based on the 2010 Training Course template. 

5. Rename Window1 as Apartment C3. 

6. Save the document as Apartment block in your MicroGDS Training folder. 

7. Exit from MicroGDS. 
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2. Let’s get drawing 

In this section you will learn how to: 

♦ use the Line command 

♦ use snapcodes 

♦ select graphics 

♦ delete graphics 

♦ use snap guides 

♦ use the current position in conjunction with snap guides 

♦ trace graphics 

♦ type distances 

♦ save a view 

  

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Constructing lines 
Using snapcodes 
Selecting graphics 
Deleting graphics 
Using snap guides 
Specifying positions 
Tracing graphics 
Typing distances 
Saving views 
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The Line command 
The Line command enables you to draw straight lines between specified points. You can leave the 
line open or close the line to form a polygon. 

 To construct a line: 

1. Start MicroGDS. 

2. Select your Examples file from the recently-used file list at the bottom 
of the File menu. 

3. On the Construct menu, click Line. 

4. Move the mouse pointer over the drawing area.  

You’ll see a representation of the current command, in this case a 
line, attached to the mouse pointer. This serves as a reminder of the 
command that is active. 

5. Create a series of lines as shown, simply by snapping points on the 
screen. 

6. When you have specified all the points of a line, press Enter to end 
the line. 

Note you can close a line, so your last point joins your first point, by 
pressing Ctrl+Enter. 

7. To deselect the Line command press Esc. 

Snapcodes 
Snapcodes are drawing aids which are used with other commands to help you draw and place 
graphics accurately. Snapcodes allow you to snap onto a specific location when you are picking a 
point. For example, you can accurately pick the end point of a line or the middle of a line or the 
centre of a circle. MicroGDS shows only one snapcode at a time and is constantly calculating which 
snapcode is nearest to the pointer. Where more than one snapcode is detected within the snap 
radius, you can press Spacebar to cycle through. 

The illustration to the right shows the snapcodes MicroGDS 
offers by simply hovering over the graphics. 

Box  one of nine justification points around a text box 
(corners, mid-points, and centre) 

Centre centre of curvature of an arc or circle 

End nearest end of a line  

Inside centre of gravity of an area in a 2D primitive, or 
centre of a clump in a 3D primitive 

Line   nearest point on a line 
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Middle middle of the nearest line segment 

Normal  position on the nearest line to create a ninety 
degree angle  

Point vertex of a line, or intersection of two lines 

Tangent
  

position on the nearest line to create a tangent 

You will also see the word ‘Dot’ which represents the position of the mouse pointer (when there are 
no underlying editable or hittable graphics) 

Selecting graphics 
Many MicroGDS commands require you to select graphics. For example, if you want to move, 
change, or delete graphics you must select the graphics. 

Whenever you create new graphics they are automatically selected.   

The selected graphics are displayed in dark blue—this is because they are using the default 
selection colour. Also note when you hover over a line, the whole line is highlighted and details 
about the line are given in an InfoTip. 

To select graphics you can click Select Primitives on the Edit menu, and click the graphic line you 
wish to select. 

You can select all of the graphics by clicking Select All on the Edit menu, or by pressing F7. 

As we progress through this course you will be introduced to other ways to select graphics. 

To deselect graphics you can click Deselect All on the Edit menu, or click in white space in the 
drawing area, or press F8. 

 Practice selecting and deselecting the line you have just drawn. 

Deleting graphics 
When graphics are selected they can be deleted either by pressing the Delete key or by selecting 
Delete on the Edit menu. 

 Delete your graphics by selecting them and then clicking the Delete key. 

Introduction to snap guides 
MicroGDS provides an intelligent snap guide system to help you position and align graphics more 
precisely. Snap guides are temporary construction lines that MicroGDS automatically creates for 
you. Snap guides toggle on and off via the information bar at the bottom of your screen. 

By default snap guides are horizontal and vertical dashed lines which project across your screen. 
You will see snap guides whenever you create graphics.  
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The current position 
Each time you click on the screen a small circle is displayed. This circle 
marks the current position. You can use the current position in conjunction 
with the snap guides to help you place graphics. 

 Let’s draw some graphics using snap guides. 

1. On the Construct menu, click Line.  

2. Click a start position towards the bottom left corner of the drawing area. 

3. Move your pointer to the right. When your pointer is horizontally aligned 
with the first point you’ll see a dotted snap guide.  

4. Click along the snap guide with a Line snap to ensure the line is drawn 
horizontally. 

5. Continue using snap guides to draw the shape illustrated on the right. 
At this stage do not end the Line command. 

Notice that the angle is displayed alongside the snap guide.  

6. Now to align the last point with the start position, move your 
pointer (without clicking) and hover over the start position.  

7. Wait until the snap guides flash and then move the pointer away.  

Notice that the current position marker has now moved to the 
start of the line.  

8. Move your pointer up the vertical snap guide to the point where 
the two guides intersect, and click with a Point snap to place the 
line. This ensures the line is at a right angle. 

9. Click on the start position again. 

10. For now, leave the above graphics on the screen. You will use them in the next 
example. 

The Trace commands 
There are four Trace commands available from the Construct menu: 

 Trace Open 
 Trace Closed  
 Trace Area 
 Trace Spaghetti 

We will look at the first two here. 

Trace Open 

Use Trace Open to construct a single line or a set of open parallel lines by tracing existing graphics. 

You can supply offsets which allow you to create multiple lines at the same time. A positive offset 
will draw a line to the left of the direction in which you draw. A negative offset will draw a line to the 
right of the direction in which you draw. You can repeat a specified offset by typing ‘r’ and the 
number of times for the repeat. 
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To end the current trace, press Enter.  If you specify three or more points and press Ctrl+Enter, the 
last point is joined to the first.  

You can stop the trace command from following the existing graphics by pressing Tab. The traced 
lines will draw a straight line from the current position to the next traced point. 

Prior to confirming the next trace point MicroGDS highlights the trace path. If the path highlighted 
goes in the wrong direction you can press the spacebar for an alternative route. 

 Let’s see how the trace open command works using the shape we drew in the previous example. 

1. On the Construct menu, click Trace, Open.  

2. In the Trace dialog box, type an offset of 10 and click OK.  

3. To draw the line illustrated, place one snap at the start position 
and a second snap as illustrated. The Trace command follows 
the existing line.  

4. To finish the line press Enter.  

5. Delete the line by pressing the Delete key. 

Tracing with multiple offsets 
1. Press Enter to reopen the Trace dialog box, type 5 5 

and press Enter (or click OK).  

2. Click on the bottom left corner of the graphic. 

3. Now take the pointer to the top left corner of the graphic 
and hover, but do not click. MicroGDS chooses the 
shortest path to trace. Press the Spacebar to see any 
alternative paths to trace. When MicroGDS highlights 
the path illustrated, click the mouse button (ensure you 
have a Point snap). 

4. Press Ctrl+Enter to join the last point of the trace to the 
first point. 

5. Press Delete to delete your trace lines. 
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Using the Tab key to jump between two points 
1. The Trace command should still be selected. 

2. Click on the corners as shown in the illustration. Take the pointer 
up the vertical snap guide and hover over the top horizontal line. 

3. Press Tab to see the trace jump between possible paths. Select 
the trace path as illustrated. 

4. Click a Point snap at the intersection of the snap guide and the 
horizontal line of the shape. Click another Point snap on the top 
left corner. 

5. To close the shape press Ctrl+Enter. 

6. Press Esc to end the trace command. 

 

 

 

 

 

 

 

Trace Closed 

 The Trace Closed command has the same features as Trace Open, but 
if you use the command with offsets, the ends of the traced lines are joined 
together (closed). This is particularly useful for constructing walls. 

 

 

 

 

 A very useful feature of this command is that where a line created by the 
Trace Closed command abuts another line, an opening is automatically 
created. 

Note that to create an opening the two abutting lines must be in the same 
linestyle and in the same object. You will learn about linestyles and objects 
later in this course. 

 You will now delete your graphics. 

1. On the Edit menu, click Select All. 

2. Press Delete. 
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Typing distances 
When you are drawing, moving, or altering graphics, you can specify a position relative to the 
current position by typing a distance. As soon as you start to type a number you will be presented 
with the Data Entry bar, which we refer to as the prompt bar. 

 

When you have typed a distance, press Enter or click the 
tick button. The distance is constrained from the current 
position in all directions. Typed distances are particularly 
useful when used in conjunction with the snap guides. 

 Let’s practise by creating the ‘T’ shape illustrated, using 
the Trace Open command with snap guides and typed 
distances. 

1. On the Construct menu, click Trace, Open. 

2. In the Trace dialog box, type 0 50mm 

This will create two parallel lines one at the pointer 
position and one 50mm to the left of the direction of 
line you are drawing. 

3. Click the first position at the bottom left of the drawing 
area. 

4. Type 500mm 

Note that the prompt bar is displayed as soon as you 
start to type. 

5. Move the prompt bar to the centre of the screen.  

6. Press Enter or click    

7. Click the second position with a Line snap, along the horizontal snap guide roughly under the 
centre of the axes. Note that the line will be 500mm long regardless of where you click. 

8. As you cannot see the end of the line, zoom out by carefully rolling the mouse wheel towards 
you. You may also need to pan (hold the mouse wheel down and move your mouse) to centre 
the graphics. 

Note that if at any time you click the mouse button accidentally and place the graphics at the 
wrong position you can press Backspace to remove the last position. 

9. Continue to type distances and give Line snaps along the snap guides to complete the “T” 
shape.  

10. Press Ctrl+Enter to close your graphics. 

11. Press Esc to end the Trace command. 

12. Close your file, without saving it. 
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Exercise 2 
In this exercise you will use the Trace Open command in conjunction with snap guides and typed 
distances to trace the external wall of the apartment block. The external wall will be 350mm thick. 

1. Open the Apartment block file. 

2. On the Construct menu, click Trace, Open.   

3. Enter offsets of 0 350mm, and using typed distances, construct the external walls of the 
apartment block as illustrated below. 

4. Make sure you use Line snaps on the snap guides. 

Note: The paper size is much smaller than the building. Use the mouse wheel to zoom and pan. 
Don’t worry if you cannot see the end of a line when you place it down, MicroGDS will restrict 
the length of the line to the distance you have typed. 

5. Press Ctrl+Enter to join the graphics and then Esc to end the Trace command. At this stage, do 
not construct the dimensions. 

 

   Trace 
 direction 

start here 

6. Click Draw Extents to show your graphics as large as possible in the window. 

7. Drag the slider of the zoom bar up a little to leave some white space around the building. 

You can save and name views of a window definition. This enables you to restore views very 
quickly. 

8. To save your current view: 

a) on the Window menu, click View Parameters 

b) in the View Parameters dialog box click Create Saved View 

c) type Plan view and click OK 

 



MicroGDS 2010 Foundation Training   Page 17 

To select views, choose the required view from the ‘Load dialog with’ list in the dialog box and 
click Apply. 

We will now set this view as the default view. The default view is the one that is opened each 
time the ‘Apartment C3’ window definition in the Apartment block file is opened. 

9. On the Document Organizer click the Window Definitions tab. 

10. Click the plus sign next to ‘Apartment C3’, and select ‘Plan view’. Click your right mouse button 
and select ‘Set as default’ from the shortcut menu. 

11. On the File menu, click Save MAN File. 
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3. Rectangles 

In this section you will learn how to: 

♦ draw rectangles 

♦ use snap guides and distances with rectangles 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Constructing rectangles 
Using snapcodes 
Using snap guides 
Typing distances 
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Constructing Rectangles 
A useful tool to quickly create the rough outline of buildings and spaces is the Rectangle command. 
You can draw rectangles by giving two corner positions, by giving the X and Y sizes, by giving an 
area, or a mixture of position and size or area. 

The Rectangle command, along with many others, is implied. This means you can continue to 
create rectangles of varying sizes without the need to reselect the command. 

 Let’s create some rectangle of fixed sizes. 

1. Open the Examples file. 

2. On the Construct menu, click Rectangle. 

3. Press Enter to display the Rectangle dialog box. 

‘Use snaps’ means that you define the size of the rectangle 
by giving snaps. You can also type distances or supply 
coordinates. 

4. In the dialog box, type 1000 for the X size and 500 for the Y 
size.  

You can move from the X size box to the Y size box by 
pressing Tab. 

5. Click OK or press Enter. 

You supply two positions to place a fixed sized rectangle. The first position fixes the centre of 
the rectangle, the centre of one of the edges, or the position of one corner. The second position 
defines the direction of the rectangle. You can choose from one of nine positions to place a 
rectangle of fixed size.  

6. Draw rectangles as illustrated using appropriate 
snapcodes. (You will need to use your mouse wheel to 
pan and zoom the view.) 

7. On the File menu, click Close MAN File. 

8. Do not save the file. 
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Using snap guides and distances with rectangles 

One of the major advantages of using snap guides and typed distances is that you do not need to 
remember complicated coordinates or create construction lines offset from existing graphics. 

The illustration on the right shows an existing rectangle. 

 

The following example shows how to position another fixed size 
rectangle above the first leaving a distance of 300mm between the two.  

 You need not do this example, unless you wish to. 

Attached to the mouse pointer is a second rectangle waiting for 
placement. 

1. Hover over the top left corner of the existing rectangle, and wait for 
the guide lines to flash, to redefine the current position. 

 
 
 
 
 
 
 

2. Type 300mm (the prompt bar automatically opens when you 
start typing).  

The first corner of the rectangle is now fixed at a radius of 
300mm from the top left corner (the current position) of the 
existing rectangle. 

3. Use the vertical guide line to align the first corner of the rectangle 
above the existing rectangle. 

4. Finally, place a second snap to define the direction of the opposite 
corner of the rectangle. 
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Exercise 3 
In this exercise you will use the Rectangle command in conjunction with typed distances to 
construct the internal walls of the apartment block. 

1. The Apartment block.MAN file should be open from Exercise 2. 

2. Using the Construct, Rectangle command, place the rectangles with their given sizes as 
illustrated, using snap guides and typed distances. The numbers in brackets are the order in 
which you should place your rectangles. 

For each rectangle you do not have to start the command again, as the Rectangle command is 
implied. To create rectangles of different sizes press Enter to open the Rectangle dialog box. 
 
If you find placing the rectangles a problem refer to the previous section Using snap guides and 
distances with rectangles. It may help you. 
 
You will tidy up the graphics using editing commands at a later stage in this course. 

3. Save your file, but do not close it. 
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4. Circles and arcs 

In this section you will learn how to: 

♦ construct circles 

♦ construct arcs 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Constructing circles 
Constructing arcs 
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Constructing Circles and arcs 

Drawing circles 

MicroGDS offers a number of ways in which to create circles. All circle commands can be found on 
the Construct menu. 

Let’s look at two examples; you do not have to do these examples.  

 These steps will create a circle if you know the radius and the 
centre position: 

1. On the Construct menu, click Circle Radius Centre. 

2. Type the radius at the prompt bar. 

3. Click on the drawing to define the centre of the circle. 

 

 These steps will create a circle to fit tangentially between three 
lines: 

1. On the Construct menu, click Circle, 3 Points. 

2. Click a Tangent snap to each of the three lines in turn. 

To use a Tangent snap simply hover over a line and type ‘T’. 

Drawing arcs 

There are a number of ways of defining arcs. All arc commands are 
available from the Construct menu.  

There are additional arc commands on the Construct, Curve submenu, which construct a series of 
connecting arcs and clouds. 

 These steps will create an arc where the centre of the arc, the radius, and the start and finish                                  
points on the circumference, are known: 

1. On the Construct menu, click Arc, Radius Centre Point Point. 

2. Type a value for the radius. 

3. Supply a centre position for the arc. 

4. Supply two snaps, one for the start of the arc, the other at the 
end of the arc. 
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Creating a door  
 Let’s practice using rectangles and arcs by creating a plan of a door in the Examples file. 

1. Open the Examples file. 

First we will create rectangles to represent the door frame and door leaf. 

2. Create a rectangle with an X size of 50 and a Y size of 100, and place the rectangle in the 
bottom left of your drawing area. 

3. Create a second rectangle of 35 x 700 to represent the door leaf, and place as shown (zoom 
out as necessary). 

4. On the Construct menu, click Arc, Centre Point Point. 

5. Click the positions indicated. Use a horizontal snap 
guide to place the third snap of the arc. (Hover over 
the top line of the frame and slide your mouse pointer 
to the right.) 

 

 

 

 

6. Finally, create another rectangle of 50 x 100 to represent the other door frame, and place with 
an End snap at the end of the arc as shown. 

7. Click Draw Extents and then use the zoom bar slider to create some 
white space around your door. 

8. To save your current view, on the View parameters dialog box, click 
Create Saved View. In the View Name dialog box, type Single door 
and click OK. 

9. Save your Examples file, but do not close it. 
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Exercise 4 
In this exercise we will use one of the circle commands to create three 
columns at the front of the apartment block.  

You now have both your Examples file and your Apartment block file 
open. A simple way of selecting files when there is more than one open,
is to use the Document Organizer 

 
list. 

1. From the Document Organizer list, select Apartment block.MAN. 

2. On the Construct menu, click Circle, Radius Centre. Type 175 for the 
radius of the circle and press Enter. 

We are going to place the first column 1500mm below the bottom left 
of the building. 

3. Hover over the bottom left corner of the wall to set a new current position. 

4. To place the column, type 1500mm. This will restrict the column to a 1500mm radius from the 
current position. 

5. Move the pointer below the corner and when the guide shows -90º, place the circle with a Line 
snap. 

The Construct Circle Radius Centre command is still active. 

6. Place the second column aligned with the bottom right wall as above. 

Now we will use a Middle snap on the wall to place the centre column. 

7. Move the pointer along the wall until you find the Middle snap as illustrated, wait until the snap 
guides flash and then type 1500mm. (Notice that your current position has moved.) 

8. Move the pointer down until the snap guide label shows -90, and place the circle with a Line 
snap. 

9. Save the file.  
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5. Objects, primitives and selecting graphics 

In this section you will learn about: 

♦ primitives and objects 

♦ selecting primitives and objects 

♦ using shortcut keys to select graphics 

♦ naming objects 

♦ creating new objects 

♦ moving the hook point of an object 

♦ creating objects from selected graphics 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Selecting graphics  
Selecting graphics by fence 
Creating new objects 
Moving the object hook point 
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Working with primitives and objects 
All graphics in MicroGDS are made up of primitives and objects. A primitive is a 
basic graphical element such as a line or text. An object is a collection of 
primitives. 

Every primitive belongs in an object. Each object has a name and can be treated 
as a single entity that you can edit, move, delete and so on. Object names are 
made up of up to six facets. Each facet is separated by a colon. An example of 
an object name might be TABLE:120:80 

The name of the current object is shown on a status toolbar. The object name is 
also displayed in the InfoTip when you hover over graphics. If you draw 
something without giving it a name, by default it will be called no:name. 

Selecting graphics as primitives or objects 

 To select graphics in MicroGDS, you must first set the appropriate mode, depending upon 
whether you want to select the graphics as primitives or objects.  

• To select primitives, on the Edit menu, click Select Primitives, or press F9. 
 

• To select objects, On the Edit menu, click Select Objects, or press F10. 

Selecting graphics using a selection box 

 When in Select mode, you can select adjacent primitives by enclosing them in 
a rectangle.  

• To define the rectangle, give two Dot snaps as illustrated. 
 

• To include all primitives that cross the boundary of the enclosing rectangle, 
press Tab before giving the second Dot snap. When you press Tab, the 
bounding rectangle changes from a solid line to a dotted line as illustrated. 

You can use Tab to toggle between selecting primitives within the rectangle and 
those that cross the boundary of the rectangle. 

 

 

Selecting graphics using the Shift key 
• You can select multiple primitives or objects that are not adjacent, by pressing Shift and clicking 

each item. 
 

• To deselect an item, press Shift and click it again. 

Selecting and deselecting all editable graphics 
• To select all editable primitives, on the Edit menu, click Select All, or press F7. 

 
• To deselect all editable primitives, on the Edit menu, click Deselect All, or press F8. 
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Selecting graphics using a fence 

You can select multiple graphics by drawing a fence.  

You can draw an open line that passes through the graphics to be selected, or a polygon that either 
includes or excludes the graphics to be selected. You must first decide whether you wish to select 
the graphics as primitives or objects. 

 These steps outline how to select graphics using a fence. 

1. To select the graphics as primitives, press F9, or as objects, press F10. 

2. On the Edit menu, click Fence, or press F6. 

3. Draw a fence with Dot snaps through the graphics you wish to select. Press Enter to end the 
line. 

The fence you have drawn selects all the primitives that the line passes through. 
 

Note: To draw a closed fence, place any number of dot snaps and press Ctrl+Enter to close the 
fence; then specify a position inside the fence to select graphics inside the fence, or outside to 
select graphics outside the fence. 

Naming objects 

It is usual practice to name an object when you create it. You should give an object a sensible 
name as this will make it easier to recognize, reuse, and most importantly, filter graphics in the 
drawing.  

If your graphics represent a door then the object name should include the word ‘Door’ and any other 
appropriate attributes the door may have. 

An example object name for a softwood door with a vision panel could be named  

A:DOOR:SOFTWOOD:VP 

You can also use pre-created object naming assistants to avoid having to type a new object name 
each time. Naming assistants are not covered in this course, but full details are available from the 
online Help. 

Once you have created a new object, all new graphics will be part of that object until you select an 
existing object or primitive or create a new object. 

Displaying toolbars 

You can display any number of MicroGDS toolbars in a window. In the next section you will use the 
Object toolbar which is not displayed by default. 

 To display the Object toolbar: 

1. Click Ctrl+T to open the Customize dialog box. 

2. On the Toolbars tab, select ‘Objects (System)’ and click OK. 

 These steps outline how to create a new object. 

1. On the Object menu, click New. 
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2. In the New Object dialog box, type a new name, or select a name from the Name Assistant list 
if offered. 

3. As this is now a new object you are asked to place the hook point. Click an appropriate point for 
the object origin (hook point). 

The object hook point is represented by a butterfly shape. The hook point can be thought of as 
the ‘handle’ of the object. 
 
Any new graphics that you now draw will become part of the new object. 

Moving an object’s hook point 

In order to precisely place the graphics, you may sometimes need to change the hook point of an 
object. 

 These steps outline how to move or change the hook point of an object. 

1. Press F10 (Select Object mode) and click on an object to select it.  

2. On the Object menu, click Hook. 

3. Specify a new position for the hook point. 

Creating a new object from selected graphics 

You can also create a new object from selected graphics. This command is useful if you have a 
selection of primitives which should have been part of the same object, but some primitives 
currently belong to another object. 

 We will rename the primitives forming the door in the Examples file. 

1. From the Document Organizer list, select the Examples file. 

2. On the Edit menu, click Select Primitives (or press F9). 

3. Start a selection box by clicking above the top left corner of the door, 
and end the box by clicking below the bottom right of the door. 

4. On the Object menu, click New from Selection. 

5. In the New Object from Selection dialog box, type Door:800, and click 
OK. 

6. Place the hook point on the bottom left corner of the door frame with a 
Point snap. 

7. Hover over the graphics and check that the InfoTip shows the correct object name, the 
highlighted graphics contain the complete door, and the hook point position is correct. 

Note that MicroGDS has finished this command in Object mode. 

8. Save your file. 
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Exercise 5 
In this exercise you will rename the various objects you have created in the apartment block. You 
will then create a new object for the Terrace and the kitchen worktop.  

Renaming objects 
• Select the Apartment block file. 

To rename the external wall graphics: 

1. Hold down Shift and select the two primitives (the inner and outer lines) which represent the 
external walls, and the three columns. 

2. On the Object menu, click New from Selection, and name the object External walls. 

3. Place the hook point at the bottom left corner of the building. 

Tip: as you have just created a new object, you are still in object mode, so clicking any one of 
the partitions will select them all. 

To rename the internal wall graphics: 

1. Select the internal partitions. 

2. On the Object menu, click New from Selection, and name the object Internal walls 

3. Place the hook point on any of the internal walls. 

Creating the Terrace 
1. On the Object menu, click New. 

2. In the New Object dialog box, type Terrace and place the hook point on the external wall. 

3. Create a rectangle 8550 x 5000 to represent the terrace and place as shown. 
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Creating a Kitchen worktop 

You will now create a work surface around the kitchen. 

1. First of all, use a combination of viewing commands to redefine the view so that it is centred 
and visible in the window. 

2. Create a new object called Kitchen:worktop and place the hook point on the far right corner of 
the wall. 

3. On the Construct menu, click Trace, Closed, and type offsets of 0 600 

4. Start at the opening to the kitchen and click point snaps and a middle snap to create the work 
surface illustrated.  

5. Press Enter to finish the Trace command. 

 
6. To save your current view, on the View Parameters dialog box, click Create Saved View. Then, 

in the View Name dialog box, type Apartment C3 with terrace, and click OK.  

Note that this saves the view, not the file. 

7. To make ‘Apartment C3 with terrace’ your default view, on the Window Definitions tab select the 
view and, on the shortcut menu, click ‘Set as default’.  

8. Save the apartment block file. 
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6. Linestyles 

In this section you will learn how to: 

♦ set up a style search path 

♦ use linestyles 

♦ create linestyles 

♦ select linestyles 

♦ use a mask linestyle 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Editing the style search path 
Using style files 
Changing the current linestyle 
Creating and modifying styles 
Using linestyles 
Working with styles in the Document Organizer 
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Linestyles 
In MicroGDS, you can enhance the look of your drawing by using linestyles. A linestyle is made up 
of one or more strokes, and each stroke defines one or more characteristics for the line. For 
example, a stroke can define the thickness and colour of the line, a pattern such as dashes, spaces, 
and dots, or a fill of a specified opacity. 

By default a new MicroGDS document contains two linestyles, DEFAULT which is a thin solid line, 
and an invisible line called BLANK. 

When you create and modify linestyles in a single user-document, they are saved as part of the 
document. These styles are called local styles.  

You can also access existing linestyles which are stored in external style files. This enables you to 
share styles between documents and even colleagues. 

There are two places in which MicroGDS looks for style files. The first is in the default location set 
for styles and fonts in your preferences. The other is in the document’s style search path. The style 
search path defines the locations in which MicroGDS looks for style files. 

An external style file containing linestyles is called LINES.STY.  

Style files have been supplied for you to use with this training course. Before you can use the styles 
in the external style files, you will need to set up a style 
search path pointing to the style files. 

 To set up a style search path for the Examples file.  

1. Select the Examples file. 

2. On the File menu, click Style Search Path. 

3. On the Edit Search Path dialog box, click Add. 

4. Click , browse to C:\MicroGDS 2010 Foundation 
Training Data\Style files and then click OK. 

5. On the Edit Search Path dialog box, click OK. 

Using linestyles 

You can use linestyles that exist in the document, or in style files. You can select a linestyle from: 

  the Line list on a status toolbar 

 the Linestyle list in the Properties window 

 the Styles tab on the Document Organizer 

You can assign a linestyle to existing graphics by selecting the primitives or objects you would like 
to set a linestyle to. Then, from the Line list on a status toolbar, Document Organizer, or Properties 
window select a linestyle. The selected graphics change to the chosen linestyle, and that linestyle 
becomes the ‘current linestyle’. Any new graphics will also be drawn in the current linestyle. 
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Let’s practice assigning linestyles to graphics in the Examples file. 

1. Using Select Primitive mode (F9), select the two rectangles that represent the frame of the door 
you previously created. 

2. From the drop-down list on a status toolbar, select the linestyle 0005mm. 

As you can see the two selected rectangles are immediately drawn with a 5mm thick linestyle.  

3. Press F8 to deselect the graphics.    

Creating a new linestyle 

You have already seen you can apply existing linestyles to graphics. In this section you will learn 
how to create new linestyles. 

Whenever you create a new linestyle you have to modify an 
existing linestyle. As discussed earlier, MicroGDS has two 
built-in linestyles DEFAULT and BLANK created for you. 

 Let’s create a new linestyle in the Examples file. 

1. Ensure that none of your graphics are selected.  

2. From the Line list on the status toolbar, select the 
linestyle DEFAULT 

3. On the Styles menu, click Linestyle Modify. 

4. In the Linestyle dialog box, select the Fill Stroke type 
option. 

The linestyle dialog box has many options some of 
which we will not cover in this training course. Please 
refer to the online Help for further information about 
creating complex linestyles. 

5. Click Save As, and name your linestyle Filled Style 1, 
click OK and then click Close. 

The linestyle will be saved in your Examples file. 

6. Save the Examples file. 

 As an introduction to creating linestyles, we will look at 
four commonly used linestyles. Create them only if you wish.  

 Example 1: how to create a thickened linestyle. 

 Example 2: how to create a dashed linestyle. 

 Example 3: how to create a filled linestyle with a border. 

 Example 4: how to create a linestyle with endmarks. 
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Example 1: 10mm thickened linestyle 

This example creates a thickened linestyle. 

1. From the status toolbar, select the linestyle DEFAULT 

2. On the Styles menu, click Linestyle Modify. 

3. Make sure that Units are set to mm 

MicroGDS shows and interprets the values you type or select 
in the current display units. 

4. In the Thickness box type 10 

5. In the Offset box type 5 

MicroGDS draws a thickened line justified from the centre of 
the line. You will often want the linestyle to be thickened on 
the inside or outside of the graphic. The offset option allows 
this. 

6. Save the linestyle as 10mm and close the Linestyle dialog 
box. 

Example 2: 4mm dashed linestyle 

This example creates a dashed linestyle. 

1. From the status toolbar, select the linestyle DEFAULT 

2. On the Styles menu, click Linestyle Modify. 

3. From the Co-ord space list, select Output. 

Output space is used where the linestyle details must be 
constant, irrespective of the scale of the data. 

You use the start, middle, and end panes to define the line 
and gap lengths of a patterned linestyle. 

4. Drag fixed length lines  to each of the three panes, 
double-click over each one and select 2mm from the list. 

5. Drag an elastic space  to the middle pane underneath the 
fixed length line and select 3mm from the list. 

6. Drag a final fixed length line under the elastic space in the 
middle pane and select 2mm from the list. 

7. Save the linestyle as Dashed 4mm and close the Linestyle 
dialog box. 
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Example 3: percentage filled linestyle 

In this example the first stroke defines the border, and a new 
stroke is added to define the fill. 

You can only see the effect of a filled linestyle if the graphics you 
assign to the linestyle form a closed polygon. 

1. From the status toolbar, select the linestyle DEFAULT 

2. On the Styles menu, click Linestyle Modify. 

3. Click ‘New stroke’. 

This adds a second stroke to the linestyle. 

4. Under ‘Stroke type’, select Fill. 

5. Select 50% from the Percent fill list. 

6. Select colour 6 from the Colour list. 

7. Save the linestyle as Fill 50% and close the Linestyle dialog 
box. 

 

Example 4: linestyle with endmarks 

The final example is a linestyle with an arrowhead at each end of 
the line. This linestyle is useful for dimension lines. 

1. From the status toolbar, select the linestyle DEFAULT 

2. On the Styles menu, click Linestyle Modify. 

3. Click ‘New stroke’. 

This adds another stroke to the linestyle. The first stroke 
creates the line between the arrowheads, and the new stoke 
will define the type and size of arrowheads. 

4. Under the ‘Stroke type’, click Vertex. 

5. Under Vertex, select the ‘Start vertex’ check box. 

Linestyle symbols are stored in MicroGDS font files. You can 
select the font file containing the symbol you require from this 
list. 

6. From the Font list under ‘Symbol details’, select Symbol. 

7. From the list beside the Vertex Start check box, select an 
arrowhead (190). 

8. To set the size of the arrow head select 20mm from the size 
box list. 

9. Now you will repeat the process for the arrow at the other end 
of the line. This time select arrowhead 191. 

10. Save the linestyle as Dimension 20, and close the Linestyle 
dialog box. 
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Using a mask linestyle 

Mask linestyles are a special type of filled linestyle that can be used to mask out parts of your 
drawing. A mask linestyle is defined with 0% fill (so it has no colour), is opaque (so that the graphics 
underneath it are not seen), and has no border. 

You might use a mask linestyle, for example, to insert a window into a wall which uses a filled 
linestyle. If the window is enclosed in a mask linestyle, the filled linestyle disappears under the 
window mask. You will see an example of this later in the course. 
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Exercise 6 
In this exercise you will set up a style search path for the Apartment block file, and use some of the 
pre-created linestyles. 

• Select the Apartment block file. 

Setting a style search path 
• Set up a style search path to attach the style file in the MicroGDS Training folder to the 

Apartment block, just as you did in the Examples file. 

Assigning linestyles to existing graphics 
1. If any graphics are currently selected, press F8 to deselect them. 

2. Press F10 (Select Object mode) and select the external walls. 

3. From the Line list on the status toolbar, select ExWalls. 

4. Select the internal walls. 

5. From the Line list on the status toolbar, select IntWalls. 

The styles ExWalls and IntWalls are filled linestyles with a border. Both styles are stored in the 
LINES.STY file which is accessed via your style search path.  

6. To see how these styles are defined. Select a primitive for each style and on the Styles menu, 
click Linestyle Modify. 

7. Close the Linestyle dialog box when you have finished. 

8. Save your file. 
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7. Character styles and text 

Use this section to learn how to: 

♦ select charstyles 

♦ create text 

♦ edit text 

♦ alter the width of text 

♦ create new charstyles 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Using charstyles 
Altering text 
Editing text 
Changing text justification 
Changing the text wrapping 
Constructing text 
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Charstyles 
A character style (charstyle) contains formatting that can be applied to a piece of text. Charstyles 
define the font, font size, font style, orientation, and space around a block of text. They can also 
specify other properties such as the text direction and text colour. 

MicroGDS supplies a built-in charstyle called DEFAULT which is available to all your documents. 
However, this is a basic style and you will often want to create text of a specific size or with specific 
characteristics. 

Creating text 

 Let’s practice creating some text in the Examples file. 

1. Select the Examples file. 

2. On the Object menu, click New, and in the Name 
box type Text. Place the hook point below the 
door. 

3. On the Construct menu, click Text. 

4. In the New Text dialog box, type 800mm single 
leaf door 

Text can have one of nine justification points. 
The justification point acts as a handle when 
placing text. It also controls the layout of the 
lines of text, aligning them to the left, centre, or 
right. 

5. Press the mouse button over the justification button and click Centre Centre. 

6. Click OK to close the New Text dialog box. 

7. Place the text below the door. 

The text is far too small, so we will now change its size and choose a more suitable font. 

Selecting charstyles 

You can change charstyles by selecting them from the Charstyle list on the status toolbar. You can 
also select charstyles from the Properties window and the Document Organizer, in the same way as 
for linestyles. 

 Character styles are stored in the style file CHARS.STY which you set a path to in the previous 
chapter, with the style search path command.  

To select a new charstyle from the status toolbar: 

1. Ensure your text is still selected (zoom in if necessary). 

2. From the Charstyle list on the status toolbar, select Arial 0050mm 

The text is immediately updated. 

3. Press F8 to deselect your text. 
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Editing text 

You can change many characteristics of existing text using the Edit Text dialog box. 

 To edit text, double-click any existing text to open the Edit Text dialog box. 

Using the Edit Text dialog box, you can: 

• Change the wording of your text. 
• Add a border to your text block by selecting the 

Apply linestyle check box, and selecting a 
linestyle. 

• Change the direction of the text and wrap the text 
to a specified width. 

• Change the font, font size, text colour, or background colour.  
• Make the text bold, italic, underlined, or strikethrough. 
• Change the case to upper, lower, toggle case, or capitalize each word. 
• Align the text to the left, centre, right, or justified. 
• If you select part of your text in the Edit Text dialog box, you can further change how the 

individual elements of your text appear. 

Altering the text width 

Once you have placed your text on your drawing you can alter the width of the text block. 

 The steps to alter the width of a text block are:  

1. On the Alter menu, click Text, Width, and specify the justification point around which to format 
the text.  

As you move your pointer a ghost rectangle indicates the current width of the text block. 

2. Click the mouse button to format the text to the width of the box. 

Creating a new charstyle 

 Let’s practice creating a new charstyle based on a Windows™ font in the 
Examples file. 

1. Ensure none of your text is selected.  

2. From the Char list on the status toolbar, select the charstyle DEFAULT 

3. On the Styles menu, click Charstyle Modify. 

4. On the Charstyle dialog box, click Windows. 

5. On the Font dialog box, select Times New Roman, Regular and click OK. 

6. In the Size Height box, select 40mm 

If you leave the Width box set to 0 (zero), MicroGDS determines the 
width based on the height. 

7. Click Save As, and save the charstyle as Times 0040mm 

8. Click OK and then close the Charstyle dialog box. 

9. Save the Examples file. 
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Exercise 7 
In this exercise you will select a charstyle from the status toolbar and add text to the Apartment 
block file. 

1. Select the Apartment block file. 

2. Create a new object called Room:text and place the hook point on a corner of the outside wall. 

3. Select the charstyle Arial 0350mm from the status toolbar.  

4. On the Construct menu, click Text, and set the justification to Centre, Centre. 

5. Create a new text block for each room and the terrace, labelling as shown below. 

6. Create a new object called Paving:text and place the object hook point on the corner of the 
terrace. 

7. Now create a new text block, change the justification to Top Left, select the Wrap option, and 
type the following: 

Crushed hardcore to fill in the proposed raised terrace area finished with ornamental 
paving slabs by Paviours Inc. ® on a mortar bed. The edges of the terrace area to match 
the block wall construction of the apartment block. 

Note that you will find the registered trademark symbol on the Insert Symbol list at the bottom of 
the New Text dialog box. 

8. Use the spell checker to ensure you have not made any mistakes. 

9. Place the text as illustrated, using the Alter, Text, Width command to fit the text as shown. 

Note that you need to use a Box snap on the right of the text, so you may need to pan the 
window by holding down the mouse wheel and moving the mouse. 

10. Save your file. 
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8. Layers and phases 

In this section you will learn how to: 

♦ use the Mini Window Editor 

♦ use the Window Editor 

♦ rename an existing layer 

♦ create a new layer 

♦ move graphics between layers 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Using the Mini Window Editor 
The Window Editor 
Creating and modifying layers and phases 
Creating new layers 
Renaming a layer 
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Working with layers and phases 
All the work you have done so far has been on a single layer of a drawing. All MicroGDS drawings 
can be separated into layers. Different layers can have different properties, giving you more control 
over your drawing. For example, you might hold furniture on one layer, walls on another, lighting on 
another, and so on. 

Each time you create a layer, MicroGDS automatically creates a phase for that layer. A phase is a 
view onto the graphics on a layer. Each phase is usually displayed in a different colour. A single set 
of graphics can be used to produce a number of different drawings by varying the different 
combinations of phases. 

MicroGDS provides two editors that you can use to work with layers and phases in a window - the 
Mini Window Editor that you can use for common basic functions, and the full Window Editor which 
also has more advanced features. 

The Mini Window Editor  

The Mini Window Editor is available from the Window menu. 

You can use the Mini Window Editor to select the phase on 
which to work (the current phase shows a bullet beside the 
phase number). You can also set the editing status of 
graphics referenced by the phase which can be:  

Editable (E) – you can make changes to the graphics 
Hittable (H) – you can snap to existing graphics 
Visible (V) – you can only view graphics  
Invisible (I) – you cannot see graphics 

You can also change the colour of the phase using the Colour list, add a phase label, and use a 
shortcut menu for other tasks, such as to create a new layer and phase and reorder phases. 

Note that MicroGDS assigns a link number to every layer in a document. Link numbers are used to 
uniquely identify each layer.  

The Window Editor 

The Window Editor contains the full features for 
working with layers and phases in the current window. 

 Let’s look at the full Window Editor. 

1. From the Document Organizer list, select 
Examples.MAN. 

2. Press F2, or on the File menu, click Window, Edit. 

Some of the additional options on the Window 
Editor enable you to: 
• rename a layer 
• assign a window label and a layer label 
• set style overrides 
• mark a phase to be drawn on the screen but 

not printed (or published or exported) 
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There are other more advanced features on the Window Editor such as setting up filters, 
cloning layers, and setting window-based attributes which are not covered in this course. 

Renaming a layer 

You can rename layers as you create them or at a later time. Since MicroGDS assigns a default 
name to layers you may find it helpful to rename them.  

 These steps outline how to rename a layer. 

1. Select a phase that references the layer you wish to rename. 

2. On the Window Editor click the Layer tab, and then click ‘Rename layer’. 

3. In the Layer Name dialog box, type the new name for the layer and click OK. 

Creating a new layer and phase 

When you create a new layer, MicroGDS also creates a new phase in the window definition 
enabling you to view the data stored on the new layer.  

MicroGDS assigns a colour to the phase, which you can change if you wish. 

 These steps outline how to create a new layer and change the phase colour. 

1. On the Window Editor click the Layer tab, and then click ‘New layer & phase’. 

2. In the Layer Name dialog box, type a suitable layer name and click OK. 

3. To change the default colour for the phase, place the pointer on the phase colour in the Window 
Editor, and select a colour from the colour list. 

4. Click Close to close the Window Editor. 

Note that the Mini Window Editor reflects any changes made in the Window Editor. 

Moving graphics between layers  

To move the graphics from one layer to another, you cut them to the Windows clipboard and then 
paste them back to a different layer.  

 These steps outline how to move graphics from one layer to another: 

1. In Select Object mode, select the objects you wish to move. 

2. Press Ctrl+X, or on the Edit menu, click Cut. 

3. In the Mini Window Editor, double-click a phase that references the layer you would like to 
move the objects to. 

4. Move the pointer back into your document window, and press Ctrl+V, or on the Edit menu, click 
Paste. 

Note that the colour of the graphics changes to match the colour of the phase on which they 
now reside. 
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Exercise 8 
In this exercise you will rename the default layer in the Apartment block file. You will then create 
two new layers and name them appropriately. 

Renaming the default layer and phase 
• In the Apartment block file, open the Window Editor (F2), click the Layer tab, and rename the 

default layer Building structure 

Creating a new layer and phase 
1. Create a new layer and phase, and name it Internal walls 

2. Close the Window Editor. 

Moving the Internal walls to a new layer 
1. In Select Object mode (F10), select the Internal walls and cut them to the clipboard (Ctrl+X). 

2. In the Mini Window Editor, double-click the Internal walls phase to make it the current phase. 

3. Move the mouse pointer back to the drawing area and press Ctrl+V to paste the internal walls 
to their new phase. 

4. Deselect the Internal walls graphics (F8) to confirm that they are now drawn in the new phase 
colour. 

Creating two more layers and phases 

We will now create two more layers and phases which we will use later in the course. 

1. Create a new layer and phase and name it Doors and windows 

2. Create another new layer and phase and name it Fixtures and fittings 

3. Close the Window Editor. 

4. Save your file. 
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9. Copying, moving, and scaling graphics 

In this section you will learn how to: 

♦ move and copy primitives and objects 

♦ rotate and scale graphics 

♦ transform graphics using Alter Move 

♦ insert instance objects 

♦ set up a library alias 

♦ copy objects from an aliased library 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Copying graphics 
Moving graphics 
Rotating graphics 
Working with instance objects 
Using aliases 
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Copying, moving, and scaling graphics 
In this section you will learn some of the ways you can manipulate graphics. In MicroGDS copying, 
moving, and scaling graphics is called transforming graphics. 

Copying objects and primitives 

You can choose to use Explorer-like behaviour for selecting, moving 
and copying graphics by selecting ‘Explorer-like selection and drag-
and-drop’ in your Preferences. In this training course we will use the 
standard MicroGDS method of copying graphics. 

To copy objects or primitives you can use the Construct Repeat 
command or press Ctrl and click onto the selected graphics. Prior to 
placing your graphics you can press Enter to display the Transform dialog 
box. 

Let’s practice copying the door object you created in the Examples file. 
You will use Ctrl to copy the door and place it 1000mm below the original. 

 

1. Open the Examples file. 

2. Press F10 to select Select Object mode. 

3. Hold down Ctrl and click onto the door. 

4. Type 1000, and use a vertical guide to place a copy of the door directly 
below the original. 

5. Click Draw Extents. 

6. Create a new saved view and name it. 

Rotating and scaling graphics 

You can rotate and/or scale objects or primitives when you copy graphics.  

 If you copy graphics in object mode, all the primitives are copied to a 
new object with the same name. 

 If you copy graphics in primitive mode, the primitives are copied into 
the current object. A new object is not created.   

 These steps outline how to copy graphics using the Construct Repeat command. 

1. Select the graphics you wish to repeat 

2. On the Construct menu, click Repeat. 

3. Click a position you want to move from (this does not necessarily have to be on the graphics).  

The graphics are attached to the cursor. 

4. Press Enter to open the Transform dialog box, to rotate, scale and/or mirror the graphics. 

5. Click a position on the screen, or type a distance, or supply coordinates, for the graphics to 
move to. 
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Moving and transforming graphics using the Alter Move command 

You can move graphics using the Alter, Move command. 

While the graphics are attached to your pointer, you can press Enter to display the Transform dialog 
box to scale, rotate and mirror your graphics. 

 These steps outline how to move graphics using the Alter Move command. 

1. Select the graphics you want to copy (either select as primitives F9, or as objects, F10). 

2. On the Alter menu, click Move. 

3. Click a position you want to move from.  

The graphics are attached to the cursor. 

4. If you wish to rotate, scale and/or mirror the graphics, press Enter. 

5. Click a position on the screen, or type a distance, or supply coordinates, for the graphics to 
move to. 

Moving and transforming graphics using Ctrl+Shift 

 Let’s see how moving and rotating graphics works with the door in the Examples file. 

1. In Select Object mode, hold down Ctrl+Shift, and click on one copy of the door. 

The graphics are picked up at the position you click. This position will be used to place your 
copy. 

2. With the door attached to the mouse pointer, press Enter.  

MicroGDS displays the Transform dialog box.  

3. To rotate the door by 90 degrees, type 90 in the Angle box and click OK. 

4. Click a position to place the door. 

The door is rotated by 90 degrees in an anticlockwise direction as 
shown.  

5. Press F8 to deselect the graphics. 

6. Save the Examples file. 

Copying objects from library files 

You can copy objects from other MicroGDS single-user documents. There are a number of ways to 
copy an object. You can: 

 open the document, select the object to copy, copy it to the clipboard, and paste the copy into 
your current document 

 use the Object, Insert command 

 define an alias and use the Library Files tab on the Document Organizer.  

We will look at defining an alias later in this section. 
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 These steps outline how to copy objects using the Object 
Insert command. 

1. On the Object menu, click Insert. 

2. On the Object Insert dialog box, click Browse and select a 
MicroGDS man file. 

3. Click Open. 

4. Click List and select an object you want to copy from the 
library file. 

At this stage, you have options to ‘Insert’ or ‘Insert Link’ into 
your current document. Choosing Insert will copy the object into your current document. You 
are then able to edit and manipulate the object as you please. 

5. Click Insert. 

The object is attached to the mouse pointer by its hook point. If you wish, you can press Enter 
to transform the graphics. 

6. Place the object and then close the Object Insert dialog box. 

Instance objects 

An instance object is a reference to another object (the 'source' object). The source object can exist 
in a different document or in the same document. The instance object does not contain graphics of 
its own in the current document; instead, it has a link to the source object in the document in which 
it is stored. If the source object is edited, the instance objects can all be updated to make the 
changes visible. 

Copying an instance object as a link 

Choosing Insert Link on the Object Insert dialog box will create an instance object in your current 
document.  

1. Click Insert Link. 

The object is attached to the mouse pointer by its hook point. At this point you can press Enter 
to transform your graphics if you wish. 

2. Place the object and then close the Object Insert dialog box. 

Setting up an alias  

MicroGDS comes with a supplied library of objects which you will find useful. You can also create 
libraries of your own objects that you can then insert into other documents.  

To copy objects from a library using the Document Organizer, you first need to create an alias 
linking your Examples file to that library.  

You will now create an alias to link the Examples file to the 
MicroGDS Training library folder. You will be using this library 
later in the course. 

 

1. On the File menu, click Aliases. 

2. On the Aliases dialog box, click Add.  
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3. On the Alias Editor, type MicroGDS Training Library in the Name box. 

4. Browse to the folder C:\MicroGDS 2010 Foundation Training Data\Library. If you cannot find the 
folder, ask your system administrator for its location.  

5. From the Type list, select Library 

6. Click OK and then click OK again on the Alias Editor. 

You can now access the MicroGDS Training Course Library using the Library Files tab on the 
Document Organizer. 

Inserting objects from an aliased library 

 These steps outline how to insert an object from an aliased Library using the Document 
Organizer. 

1. On the Document Organizer, click the Library Files tab. 

2. Click the plus sign to open one of the aliased library files. 

3. Click the plus sign next to a man file.  

All objects within the file are listed. 

4. To see a preview of an object, click the Toggle Preview button. 

5. Choose an object from the list and click the right mouse button over the 
object.  

6. On the shortcut menu, click Insert or ‘Insert link’. 

The object is attached to the pointer by its hook point. 

7. Press Enter if you want to transform the object before you place it or place 
the object accordingly. 

To place multiple copies of the object, hold down Ctrl as you place each 
object. 
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Exercise 9 
In this exercise you will add an alias linking the Apartment block file to the MicroGDS Training 
Library folder. You will then copy the internal doors from the library file into your apartment block. 

Adding an alias to the MicroGDS Training library folder 
1. Open the Apartment block file. 

2. Follow the previous steps to add an alias linking the Apartment block to the MicroGDS Training 
Library folder. 

Make sure you browse to the Library folder supplied with this training course. 

Note: You may need to ‘refresh’ the contents of the Library Files tab to see the added library. 
To do this, click any other tab on the Document Organizer and then redisplay the Library Files 
tab. 

Inserting the doors 

You will now insert the internal doors and glazed screen from one of the MAN files in your aliased 
Library file as illustrated below: 
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1. In the Mini Window Editor, double-click the Doors and 
windows phase to make it current. 

2. On the Document Organizer, click the Library Files tab 
Organizer. 

3. Click the + sign to the left of Library to expand the library 
contents 

4. Expand the ‘Windows and doors.man’ file. 

5. Expand the Doors(2) layer, then right-click over the 
DOOR:800R object and select ‘Insert Instance’. 

To see a preview of the doors and windows in the Library 
files, ensure you have the Toggle Preview button selected. 

6. Press Ctrl and place the first door in Bathroom 1. 

7. Press Enter and use the Transform dialog box to rotate the 
doors for the bedrooms and bathrooms as required. 

8. Now select GLAZED:SCREEN from the same layer in the 
library file and select the ‘Insert Instance’ command. 

9. Press Enter and in the Angle box on the Transform dialog box, 
type -90 

10. Place the screen in the opening adjacent to Bathroom 2. 

11. Using the same techniques, place the remaining doors as 
follows: 

a) DOOR:1200SS: use a transform angle of 90 and place down in the cupboard (to the right of 
the living area). 

b) Repeat for DOOR:600R. 

c) DOOR:1500DSS: use a transform angle of 180 
and place the door with a Middle snap as shown.  

Notice that the wall shows through behind the 
doors, even though the door has a masked 
linestyle. This is due to the order of the phases 
and we will change this when you have finished 
placing your doors. 

d) Using the Document Organizer, select and copy 
the door again, and hover over the door you 
have just placed where the two arcs touch. Wait 
for the snap guides to flash, follow them up 
vertically and place the door with a Point snap in the wall opposite. 

Phases are drawn (and printed) in the order in which they are listed on the Window Editor. Each 
phase is drawn on top of the previous phase. The order in which phases are drawn can be 
important, especially when you are using opaque filled linestyles, mask linestyles, or raster 
images. 

12. In the Mini Window Editor, drag the ‘Doors and windows’ phase to the bottom of the list. 

The double doors are now drawn on top of the wall. 

13. Save the file. 
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10. Ruling lines and dividing paths 

In this section you will learn how to: 

♦ rule lines 

♦ divide distances 

♦ use construction lines  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Ruling lines 
Dividing a distance between two points 
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Ruling lines  
In this section you will look at ruling lines. These are straight lines which lie entirely in one direction, 
drawn to the window extent. You might want to rule a series of lines, for example, as temporary 
construction lines at set intervals. 

There are four rule commands that you can use to rule lines horizontally, vertically, at any angle, or 
parallel to an imaginary line. For example, if you want to draw ruled lines horizontally across the 
screen, you use the Rule X command. 

Ruled lines can be offset in the same way as the Trace commands. Simply type the offset values at 
the prompt bar, prior to placing the lines. 

 These steps outline how to rule a line across the screen. 

1. On the Construct menu, click Rule X. 

2. Type a positive offset to draw the line above the pointer; 
type a negative offset to draw the line below the 
pointer. 

To rule a line from the top to bottom of the screen: 

1. On the Construct menu, click Rule Y. 

2. Type a positive offset to draw the line to the left of 
the pointer; type a negative offset to draw the line 
to the right of the pointer. 

 

 

Repeating ruled lines 

You can repeat the number of lines across your screen at different offsets or by the same offset a 
number of times. 

 These steps outline how to repeat ruled lines using different offsets. 

1. From the Construct menu, select one of the rule commands. 

2. Type your offsets, leaving a space between each. 

Positive and negative values are both allowed.  

3. Snap at a position on your screen to place the lines.  

The example below uses Rule X with offsets of 10mm -50mm and 10mm. Each value is offset from 
the previous. 
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Repeating ruled lines with the same offset 

e below uses Rule Y and has an offset of 0 to place the first line under the pointer and 
n offset of 10 followed by r5, which means the 10 offset will be repeated 5 times. 

 

When repeating the same offset press r followed by the number of repeats.  

The exampl
a

 

 

Dividing paths 
MicroGDS offers commands to equally divide a distance, an angle or a path into a series of lines. 
The Divide commands have similar dialog boxes in which to specify the number of divisions or 

ance. 

• 

 equally between 

• ons 

Snap on the screen for the start of the division and then snap at where you want to divide 
to. 

intervals. 

 These steps outline two methods to divide a dist

1. On the Construct menu, click Divide Distance. 

2. In the Divide Distance dialog box, do one of the following: 

select the Number option and type the number of divisions 

When you specify a number of divisions, MicroGDS divides the distance
two given points by that number (spaces between the lines). 

The example shows a rectangle divided by 5 creating five equal areas. 

select the Increment option and type a distance to specify the space between the divisi

You can choose between having a fixed length division line which can be justified left, 
centre, or right, or define the length of your division lines with snaps on your screen. 
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When you specify a number of increments, MicroGDS divides the given distance by 
increments at the specified intervals. The example shows a line divided by increments of 
10mm. 
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Exercise 10 
In this exercise you will use Rule X, Rule Y, and Divide Distance, to create construction lines. You 
will then use these construction lines to place the windows.  

The windows have been created for you in the Library folder. Note that they all have a masked 
linestyle. 

Ruling lines 
1. Open the Apartment block file. 

2. If Doors and Windows is not the current phase, indicated on the status toolbar, make it current 
by double-clicking its phase in the Mini Window Editor. 

3. Create a new object and name it Construction:lines 

4. From the Line list on the status toolbar, select Dota. 

5. Use the Rule X and Rule Y commands to place the construction lines for setting out the 
windows and external doors, as shown here: 

 
Note that the vertical construction lines Rule Y are offset 1200mm (1a, 1b, 1c) and -1200mm 
(2a, 2b, 2c) from the outside wall corners.  
 
The horizontal line Rule X is offset 700mm from the top of the Living area wall. 

 



MicroGDS 2010 Foundation Training   Page 59 

Dividing paths 

To help place the windows in Bathroom 2, we will use the Divide Distance command. 

1. If the Paths toolbar is not already displayed, press 
Ctrl+T and select Paths. 

2. Zoom in to the area illustrated using the Zoom to 
Rectangle tool on the View toolbar.  

3. On the Construct menu, click Divide, Distance. 

4. In the Divide Distance dialog box, type 2 in the 
Number box. 

5. Divide Bathroom 2 by clicking on the inside of the internal partitions (1 and 2), to specify the 
distance to divide. Then click two points either side of the wall (3 and 4), to create the dividing 
line. 

Inserting the windows 

You will now insert the windows using the construction lines you have just created: 
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1. On the Document Organizer, click the Library Files tab. 

2. Expand the ‘Windows and doors.man’ file and then expand Windows (1). 

3. Right-click on WIND:1200:SHUTTER and, on the shortcut menu, click ‘Insert object’. 

First you will place the windows in the kitchen and in the bottom wall of the Living area. 

4. Holding down Ctrl, place the four windows with Point snaps at the intersection of the 
construction lines and the inside edge of the wall. 

5. Now place the two windows in the top wall of the Living area, first by pressing Enter and in the 
Transform dialog box select ‘Mirror in angle’ before placing. 

6. Place the window in Bedroom 1, first by pressing Enter and in the Transform dialog box type  -
90 in the Angle box, clear ‘Mirror in angle’, and click the wall with a Middle snap. 

You will now place the small windows in Bedroom 2, and Bathrooms 1 and 2. 

7. Right-click on WIND:450, select ‘Insert object’, then hold down Ctrl and place the two small 
windows in the bottom wall of bedroom 2. 

8. Press Enter to open the Transform dialog box and select -90 from the Angle list. Hold down Ctrl 
and place the small window in Bathroom 1 and Bathroom 2. 

9. In Select Object mode, you can now select and delete the construction lines. 

 
10. Save your file. 
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11. Dimensions 

In this section you will learn how to: 

♦ create an automatic object name 

♦ use dimensions 

♦ split dimensions 

♦ merge dimensions 

♦ change the dimension units 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

The Set Name dialog box 
Constructing dimensions 
Merging chain and run dimensions 
Splitting chain and run dimensions 
Working with dimensions 
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Dimensions 
To help you create dimensions, MicroGDS provides some control over the way dimensions look. 
You can choose the appearance of the dimensioning lines and dimensioning text, and set your 
preferred naming method. Further controls let you choose the length of the leader lines and whether 
or not to use intelligent text for linear dimensions that are dynamically updated. 

Use the Customize dialog box (Ctrl+T) to display the Dimensions toolbar. 

Setting the object name for dimensions 

MicroGDS can automatically create an object for each dimension on your drawing using the Name 
command on the Set menu. The Set Name dialog box has a list of three options for dimensions: 

 ‘No new object’ means that dimensions are created in the 
current object. 

 ‘First facet’ replaces the first facet at the beginning of the 
object name which you are dimensioning. 

For example, if Walls:External is the current object and you 
are using the Chain dimension command, the new object for 
the dimension line would be DIMCHAIN:External. 

 ‘Last facet’ adds a new facet at the end of the object name which you are dimensioning. 

The previous example would then have the name Walls:External:DIMCHAIN 

 The steps to automatically create a new object for each dimension line are: 

1. On the Set menu, click Name. 

2. From Dimensions list on the Set Name dialog box, select either ‘First facet’ or ‘Last facet’. 

Setting the default styles for dimensions 

To define the way dimensions look on your drawing you can 
set a default linestyle and charstyle. These are set on the 
Dimensions tab of the Preferences dialog box. All types of 
dimensions are listed together with the linestyle and 
charstyle each type will use. You can change the default 
styles to any linestyle and charstyle available to the current 
document. 

 The steps to assign a linestyle and charstyle for 
dimensions are:  

1. On the File menu, click Preferences, and then click the 
Dimensions tab. 

2. From the list of available linestyles and charstyles, select 
the style to use. 

3. Or to use the current styles, select the options ‘Use set 
linestyle’ and ‘Use set charstyle’. 
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Fixing the length of the leader lines 

The ‘Fixed length leader lines’ option defines 
the undershoot and overshoot values for t
dimension line. 

he 

line. 

Use intelligent text’ option is selected, dimensions are automatically updated if you edit the 
data. 

Dimensioning your drawing 

t a string of dimensions. You can also dimension an angle, an arc length, or 

k at a few examples of how to use the 
dimen

 to create a single dimension line from one point to 

ension, Distance. 

oints on your screen. 

tion through which the chain dimension line 

is selected, click 
ength. 

Click at each dimension point. 

dius. 

3. 

ust finish on the arc or circle you are 
dimensioning. 

 
overshoot 

undershoot 

 5000 

The undershoot is the distance between the 
point being dimensioned and the end of the 
leader line. The overshoot is the distance the 
leader line extends beyond the dimensioning 

If the ‘

MicroGDS provides several commands to dimension your drawing. You can dimension between 
two points or construc
the radius of an arc. 

In this section we will loo
sion commands. 

 The steps
another are: 

1. On the Construct menu, click Dim

2. Click two p

 

 The steps to create a chain of dimensions are: 

1. On the Construct menu, click Dimension, Chain. 

2. By default, chain dimensions are drawn horizontally. If 
you want to change to vertical dimensioning, press Tab. 

3. Click a posi
is to pass. 

4. If the ‘Fixed length leader lines’ option 
again to define an undershoot l

5. 

 

 The steps to create a radius dimension are: 

1. On the Construct menu, click Dimension, Ra

2. Click a point at the start of your leader line. 

Click a second (and any further points). 

The final point m
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Splitting dimensions 

When you use intelligent text, you can split dimensions. 
MicroGDS recalculates the measurement for each split 
component.  

 The steps to split a dimension are: 

1. On the Alter menu, click Dimension, Split. 

2. Click on the dimension line and then click the point at 
which you wish to split the dimension.  

The dimension line is split in two and the dimensions 
are automatically recalculated. 

 

 

 

Merging dimensions 

When you use intelligent text, you can also merge 
dimensions. 

 The steps to merge a dimension are: 

1. On the Alter menu, click Dimension, Merge. 

2. Click the two adjacent lines you wish to merge.  

The dimension line is merged and the dimensions are 
recalculated. 

Changing dimension units 

You can also change the unit of measurement. 

 The steps to change the dimension units are: 

1. Select the dimension text for which you wish to change the units. 

2. In the Text section of the Properties window, change the dimension units to inches by selecting 
from the list.  

Note that you can also change the number of decimal places if you wish.  
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Exercise 11 
In this exercise you will add dimensions to the apartment block. You will need to first change the 
dimension preference to fixed length leader lines, otherwise the leader line on the top dimension 
would be drawn all the way down to the kitchen wall. 

1. On the Preferences dialog box, click the Dimensions tab and then select the ‘Fixed length 
leader lines’ check box. 

2. From the Chain Linestyle list, select Dim Arrow and from the Charstyle list, select Arial 0350. 

3. Set the same Linestyle and Charstyle for Distance. 

4. Type 100mm in the Overshoot box. 

Note when you construct a dimension using fixed length leader lines, MicroGDS prompts you 
for the end position of the leader lines. 

5. Set the object name for dimensions to ‘Last facet’. 

6. Select the outside wall to make it the current object. 

7. On the Construct menu, click Dimension, Chain. Click once for the position of the dimension 
line, and once below that point for the end of the leader line, then click the end of the wall (third 
click) for the start of the dimension points as illustrated. 

8. Click the rest of the points as illustrated, and press Enter to complete the command. 

 
 

 



Page 66  MicroGDS Foundation Training 

        

9. Press Tab to change the direction when dimensioning vertically. 
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10. For the two internal dimensions, use the Construct, Dimension, Distance command. 
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12. Altering graphics 

In this section you will learn how to: 

♦ shorten and lengthen lines 

♦ join two polygons with coincident edges 

♦ delete a line segment 

♦ delete a vertex 

♦ move a line segment 

♦ move a vertex 

♦ move several vertices 

♦ join two lines together 

♦ intersect lines 

♦ fillet and chamfer 

♦ set editing restrictions 

 

 

 

 

 

 

 

 

Useful Help topics 

Trimming and extending lines 
Gluing primitives 
Deleting line segments 
Deleting vertices 
Moving line segments 
Working with boxed vertices 
Joining primitives 
Creating and removing fillets 
Creating and removing chamfers 
Restricting editing 
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Altering graphics 
MicroGDS provides many commands to alter existing graphics. In this section we will look at a few 
of these commands. 

 Use the Customize dialog box (Ctrl+T) to display the Segments toolbar. 

Shortening and lengthening a line 

You can use Alter, Trim to shorten or lengthen a line. 

 The steps to shorten or lengthen a line are: 

1. On the Alter menu, click Trim. 

2. Click near the end of the line to shorten or lengthen 

3. Click to where you want to shorten or lengthen the line. 

 

 

 

Joining two polygons 

You can use Alter, Glue to join two primitives together where the lines are coincident. The lines that 
are touching are removed, and the remaining graphics are joined to form a single primitive. 

 The steps to glue two primitives are: 

1. On the Alter menu, click Glue. 

2. Click anywhere on the first primitive. 

Note that the first primitive you select defines the object name 
and linestyle of the resulting glued primitive. 

3. Click anywhere on the second primitive. 

The two primitives are joined and the coincident lines are 
removed. 

 

 

 

 

You can also glue two overlapping shapes to remove the 
intersecting graphics, creating closed shapes out of the remainder. 
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Deleting a line segment 

You can remove a line segment from a primitive: 

 The steps to remove a line from a primitive are: 

1. On the Alter menu, click Segment, Delete. 

2. Click the line segment to delete. 

 

 

 

Deleting a vertex 

You can delete a vertex. 

 The steps to delete a vertex are: 

1. On the Alter menu, click Vertex, Delete. 

2. Click a position on the line near to, or on, the vertex to delete. 

 

 

Moving a line segment 

You can move a line segment between two vertices. Any joined 
adjacent lines will stretch orthogonally with the moved line. 

 The steps to move a line segment are: 

1. On the Alter menu, click Segment, Move. 

2. Click the segment to move. 

3. Click a position for the moved segment. 

 

 

Moving a vertex 

You can move a vertex. Any joined adjacent lines will stretch with the 
moved vertex. 

 The steps to move a vertex are: 

1. On the Alter menu, click Vertex, Move. 

2. Click on, or near to, the vertex. 

3. Click a position for the moved vertex. 
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Moving several vertices 

You can move several vertices at the same time using Alter, Box Move. All the vertices to move 
must be enclosed in a box. If the box also encloses a dimension line, the dimensions will 
automatically update. 

 The steps to move several vertices are: 

1. On the Alter menu, click Box, Move. 

2. Click to define one corner of the box. 

As you move the pointer, a rectangle is dragged 
to indicate the box. 

3. Click a second position to define the diagonally 
opposite corner of the box. 

4. Click on one of the two vertices enclosed in the 
box. This is the position from which the vertices 
will move. 

5. Click the position to which the vertices will be 
moved. 

Note that you can move the vertices in any 
direction.  
 
The vertices are moved. The line segments and 
dimensions attached to the moved vertices are 
modified where necessary. 
 

 

 

 

Joining two lines together 

You can use Alter, Join to join two unconnected primitives together. MicroGDS will create a new 
line between the two lines if the lines don’t touch.. 

 The steps to join two open primitives together are: 

1. On the Alter menu, click Join. 

2. Click each end of the lines to join. 
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Intersecting lines 

Intersect joins two lines together, each line will extend to meet at the 
intersection. 

  The steps to intersect lines are: 

1. On the Alter menu, click Intersect. 

2. Click each end of the lines to intersect. 

 

 

 

Fillet and Chamfer 

You can add a fillet or chamfer to joined adjacent lines. The lines 
must be joined at their intersection point. 

  The steps to add a Fillet are: 

1. On the Alter menu, click Fillet. 

2. Type a radius for the fillet. 

3. Click on or near the corner you want to fillet. 

 

 

 

 

 

  The steps to add a scotia are: 

The lines must be joined at their intersection point. 

1. On the Alter menu, click Fillet. 

2. Type a negative radius for a scotia. 

3. Click on or near the corner to which you want to add the scotia. 
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  The steps to add a chamfer are: 

The lines must be joined at their intersection point. 

1. On the Alter menu, click Chamfer. 

2. Type the size of the chamfer you require. 

3. Click on or near the corner to which you want to add the chamfer. 

 

 

 

Restricting editing 

As you have already discovered earlier in this course, you can set the status of phases to hittable or 
visible, preventing you from editing MicroGDS data. You can also temporarily restrict editing a 
range of objects or styles on editable phases by using the Set Edit command.  

The Set Edit command is particularly useful if you have a busy and complicated drawing and you do 
not want to accidentally edit or delete graphics close to the area on which you are working. 

 The steps to temporarily restrict editing a range of objects using the Set Edit command are: 

• On the Set menu, click Edit, or press F3. 

Or 

1. Click the SETEDIT button on the information bar. 

MicroGDS displays the Set Edit Filter Editor. 

2. On the Set Edit Filter Editor click Pick next to the 
object list, and click on the object you wish to add.  

3. Click the Pick button again to add additional object 
names. 
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To broaden the Set Edit range you can use wildcards. 
 
For example, picking an object called 
“WIND:1200:SHUTTER” will restrict editing 
to windows called “WIND:1200:SHUTTER”. 
To include all windows in the Set Edit list, 
and assuming all of your windows start with 
the facet “WIND”, delete the trailing facets of 
the object name and add ** after the word 
WIND. 
 

 

 

 

 

 

For more information about wildcards and the other filter options, click the Help button on the 
Set Edit Filter Editor. 
 

• To invert the set edit restriction, select Exclude from the Action list. 
Note that whenever Set Edit is active the word SETEDIT is displayed in red in the information 
bar.  

 

 

 To unset Set Edit: 

• Click SETEDIT on the information bar. 

 To change the Set Edit restrictions: 

• Double-click SETEDIT. The Set Edit Filter Editor is displayed for you to change your selections.  
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Exercise 12 

In this exercise you will first use Set Edit to restrict 
editing to the internal walls, then use Alter Glue to 
join the walls. 

1. Open the Apartment block file. 

2. On the Set menu, click Edit, and using Pick 
Object, select the Internal walls. 

3. Glue the three internal wall rectangles together 
between Bathroom 1 and Bathroom 2 as shown. 

 

 

 

 

4. Glue the cupboard wall rectangles together at the end of the 
Dining room as shown. 

5. To unset Set Edit, click SETEDIT on the information bar. 

 
 
 
 
 
 

6. You will now reduce the kitchen size by 300mm using Alter, Box, 
Move. The existing dimensions will update 
automatically. 

7. Place the box as illustrated, ensuring your line 
is between the windows and includes the 
dimension line. 

8. Click the bottom right corner of the kitchen. 

9. Type 300mm 

10. Move the pointer back to the bottom left corner 
of the kitchen and click, (the move will be 
restricted to 300mm). 

The dimension is updated to 3300. 

11. Press Esc and then F8. 
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13. Assembly objects 

In this section you will learn how to: 

♦ create an assembly object 

♦ close an assembly object 

♦ open an assembly object for editing 

♦ dissolve an assembly object  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Working with assembly objects 
Creating new assembly objects 
Editing assembly objects 
Opening an assembly object 
Closing an assembly object 
Dissolving an assembly 
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Assembly Objects 
An assembly object is a collection of objects that can be used and manipulated as a group. An 
assembly object contains only other objects; it does not contain any primitives of its own. 

For example, suppose you are designing a living room layout, you might arrange a coffee table a 
chair and sofa objects into an assembly, which you could then place and move about as a group. 

 Let’s open a library file which contains some furniture objects. 

1. On the Document Organizer, click the Library Files tab. 

2. Select Living room layout.man and from the shortcut menu, select ‘Open for edit’. 

Creating an assembly object from existing objects 
 Let’s create an assembly object from the furniture in the living room furniture file: 

1. In Select Object mode, hold down Shift, and select the table and chair objects. 

2. On the Object menu, click Assembly, New from 
Selection. 

3. In the New Assembly from Selection dialog box, 
type Living room layout 

4. Place the hook point of the new assembly 
object on the corner of the chair. 

The new assembly object is immediately 
opened for editing, and its extent is set to the 
boundaries of the objects it contains. 
 
Notice that when an assembly object is open 
for editing, any part of the view extent that is 
outside the extent of the assembly object is 
shaded. Note also that the object is now listed 
as a Plain assembly in the Properties window. 

Closing an assembly object 

We will now close the assembly object.  
• To close the furniture assembly object, double-click outside the assembly object’s boundary. 

Alternatively, on the Object menu, click Assembly, Close. 

Opening an assembly object for editing 

To make changes to the contents of an assembly object, you must first open the assembly. You can 
then use any of the editing commands on graphics held in the assembly. 

 We will now open the assembly object ready for editing: 

• Double-click a graphic in the assembly object 

Alternatively, on the Object menu, click Assembly, Open, and then click anywhere on the table 
or chairs. 

You can now use any of the editing commands on the graphics. 
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Dissolving an assembly object 

 Finally we will break the furniture assembly object back to its original, constituent plain objects: 

1. In Select Object mode, select one of the furniture objects within the assembly. 

2. On the Object menu, click Assembly, Dissolve. 

3. Click on one of the furniture graphics.  

Note that the object you clicked is now listed as a Plain object in the Properties window. 

4. Close the file without saving. 
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Exercise 13 
In this exercise you will copy two bathroom assembly objects from the library file. You will then 
create a new furniture layer and phase and copy the dining room, living room, and bedroom 
furniture assembly objects from the library into the apartment block. 

1. Open the Apartment block file. 

2. Using the Mini Window Editor, make ‘Fixtures and fittings’ the current phase.  

3. On the Document Organizer, click the Library Files tab. 

4. Open Sanitary.MAN and expand the SANI WARE layer. 

5. Using the ‘Insert object’ command on the shortcut menu, copy the bathroom assembly layouts 
into the apartment. (En suite Bathroom fittings to Bathroom 1 and Bathroom fittings to Bathroom 
2.) 

6. Create a new layer and phase and name it Furniture 

7. From the Library Files tab in the Document Organizer, open Furniture.man, and FURNITURE. 

8. Again, use the ‘Insert object’ command to copy the Lounge Suite and Dining Suite assembly 
objects into the apartment. 

 
We will now open the Lounge Suite assembly object, move one of the sofas, and close the 
assembly object. 

9. Double-click any of the objects in the Lounge Suite assembly, to open it. 
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10. In Select Object mode, (F10), click on the right hand sofa to select it. 

11. On the Alter menu, click Move. Click a point on the right hand sofa to pick it up, press Enter to 
open the Transform dialog box and type -90 in the Angle box. Place the sofa as shown. 

12. To close the assembly, double-click outside the assembly object extent. 

 
13. Save and close your file. 
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14. Photos, and laying out a page for printing 

In this section you will learn how to: 

♦ create a print layout view 

♦ tile windows 

♦ create a photo 

♦ scale a photo 

♦ edit a photo 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Switching to Print layout view 
Working with window photos 
Constructing window photos 
Changing the view of a window photo 
Changing the boundary of a window photo 
Altering window photos 
Burning in window photos 
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Using print layout view 
A print layout view shows how the graphics will look when you print the view. You set a paper size, 
an orientation, and margins for the layout. 

We will now create a new window definition for the layout view: 

1. In the Examples file, on the File menu, click Window, 
New. 

2. On the Document Organizer, click the Window 
definitions tab. 

3. Place the mouse pointer over the name of your new 
window and right-click to open the shortcut menu. 

4. Select Rename, and type Layout 

5. On the View menu, click Print Layout. 

6. On the Page Setup dialog box, select: 

Paper size: ISO A4 
Orientation: Portrait 

7. Click OK to close the dialog box. 

8. On the View menu, click Zoom, Extents. 

 

Tiling windows 

You can have any number of MicroGDS windows 
open at the same time. To view more than one 
window at a time, you can tile them horizontally or 
vertically. 

1. Ensure you have saved and closed your 
Apartment block file. 

2. In your Examples file, open the Doors window 
definition (as well as the Layout window 
definition). 

3. On the viewing buttons on the Doors window 
definition, click ‘Draw extents’. 

4. On the Window menu, click Tile Vertically. 

The two window definitions are displayed side-by-
side. 
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Working with photos 
A photo primitive is a 'snapshot' of the graphics in one window definition (the 'source' window), that 
is displayed in another window definition (the 'destination' window). 

You can use photos to compose plot collages. For example, if you have a standard window 
definition called FRAME and a plan of a building called PLAN, you can construct photos of both and 
combine them in another window definition called PLOT. 

The windows can be in the same document or in different documents. The graphics will 
automatically update as changes are made to the source window definition. 

In this section, you will take a photo of the door, scale it, and place it in the drawing frame that you 
have just created.  

Placing a photo of the door in the print  layout view 
1. On the Construct menu, click Photo. 

A camera is attached to the pointer. 

2. Click a position in the Doors window definition. 

The position you click will be used to place the photo. A 
photographic slide is now attached to the pointer in place of the 
camera. 

3. Press Enter to display the Photo Transform dialog box. Ensure the 
‘Rotation angle’ is set to 0, and in the ‘Scale view’ box type 1:10 
and click OK. 

4. Make the Layout window definition the active window by clicking 
on the title bar, and then place the photo by clicking in the centre 
of the window. 

5. Press Esc, and deselect the graphics (F8). 

6. Save your file. 

Editing a photo 

You can use the Alter Segment Move command to change the aspect of a photo by moving any of 
its borders. You can also change the boundary of the photo by swapping its boundary with a closed 
line primitive. 

 To change the boundary of a photo: 

1. On the Alter Menu, click Photo, Boundary, and then specify a position on the border of the 
photo whose boundary you want to change. 

If the photo boundary is outside the extent of the print layout view, switch to 2D and zoom out a 
little, then specify the position. 

2. Specify a position on the closed line primitive whose boundary you want to use. 

The photo boundary is swapped with the line primitive. 

Note that you can also change the view of a photo within the photo border using the Photo View 
command. 
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Burning in photos 

You can also burn in photos. Once a photo is burnt in, it is no longer linked to the original graphics 
and can be edited locally. 

 To burn in a photo: 

1. Select the photo you want to burn in. 

2. On the Alter menu, click Photo, Burn in. 

Note that if the photo contains assembly objects they are converted to plain objects. 

3. Save and close your Examples file. 
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Exercise 14 
In this exercise you are going to create a new print layout window definition and copy into it a 
drawing frame from the MicroGDS training library. You will then create a photo of the apartment 
block, scale it, and copy it into the drawing frame. Finally you will create a photo of the bathroom 1 
layout, scale it, and copy it into the drawing frame. 

1. Open the Apartment block file. 

2. Create a new window definition and name it 
A1 Plot 

3. On the View Menu, click Print Layout. 

4. On the Page Setup dialog box, select A1 and 
Landscape 

5. Click Draw Extents. 

6. On the View menu, click Save View1. 

7. Copy the ‘Title Block:A1’ object from the 
Drawing frame.A1 MAN in the MicroGDS 
Training course library. 

8. Ensure you have closed your Examples file. 

9. Open the Apartment C3 window definition and on the Window menu, click Tile Horizontally. 

10. Click Draw Extents. 

11. Create a photo of the apartment block at 1:50 and place it in the drawing frame as illustrated. 

12. In the Apartment block window definition, zoom in to the bathroom 1 layout and create a photo 
at 1:25 and place the photo in the drawing frame as illustrated. 

13. Save your file. 
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15. Working with raster files 

In this section you will learn how to: 

♦ add a raster alias 

♦ insert a raster image into your drawing 

♦ change the size of a raster image 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Inserting raster images 
Opening raster files for editing 
Altering raster images 
Working with raster files in the Document Organizer 
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Using raster images 
A raster image is a picture composed of a rectangular area of pixels. The image can represent data 
such as a scanned drawing. You can edit the size and location of a raster image in a file, but you 
cannot change with the pixels in the image. 

The raster image formats that you can use in MicroGDS are listed in Help. 

It is good practice to set up aliases when working with raster files. However if this is not necessary 
you can insert a raster image using the Raster command on the Construct menu. 

Setting up a raster alias 

 To set up a raster alias: 

1. On the File menu, click Aliases, and then click Add. 

2. Click Browse, and select the folder containing the raster images you require. 

3. Click OK. 

4. In the Name box on the Alias Editor, type a name for the file containing the raster images, and 
from the Type list, select Raster. 

5. Click OK to close the Alias Editor dialog box, and OK to close the Alias dialog box. 

Inserting a raster image into a document 

 To insert a raster image into a document: 

1. On the Document Organizer, click the Raster Files tab. 

2. Double-click your alias location. 

3. To display a preview of an image, ensure Toggle Preview is switched on. 

4. Drag the raster image into your window, and place it as required. 

5. You can accept the resolution offered or change it if necessary. 

6. Click OK. 

When a raster image is selected, MicroGDS displays the boundary of the image, overlaid with a 
grid of dots. 

Changing the size of a raster image 

 To change the size of a raster image: 

1. Select your raster image. 

2. On the Alter menu, click Transform, Stretch. 

3. Click the bottom left corner of the image (the base of stretching), click on the top right corner of 
your image (the point to stretch from), and click on the point to stretch to. 

 Note that you can switch between equal and unequal stretching before you give the final point 
by pressing Tab. 

 

 



Page 88  MicroGDS Foundation Training 

Exercise 15 
In this exercise you will add a new alias pointing to the 
MicroGDS Training Course library. You will then insert 
a MicroGDS logo from the library to your drawing frame, 
and stretch it to fit. 

1. In the Apartment block file, close the Apartment 
block window definition and in the top right corner 
of the Layout window definition, click the Maximize 
button. 

2. Set up a raster alias to point to the Raster file in 
your MicroGDS Training Course folder. 

3. Create a new layer and phase and name it Raster 

4. Rename your default layer Graphics 

5. Zoom in to the title block as illustrated. 

6. From the Raster Files tab on the Document 
Organizer, drag the Splash-2.tif image into your 
drawing, and place it with a Point snap as 
illustrated. 

7. Accept the raster resolution offered. 

8. On the Alter menu, click Transform, Stretch. 

Press Tab for equal stretch (do not hold Tab down).  

9. Click on the bottom left of the image, then the top right of the 
image, and stretch it until it reaches the other side of the title 
block. 

10. Press F8 to deselect your graphics. 

The raster image is sitting on top of the text block graphics, 
obscuring the lines. You will now change the phase order to 
correct this. 

11. In the Mini Window Editor, drag the Graphics phase below the 
Raster phase. 

12. Finally, double-click on each of the text blocks, and update 
them as illustrated. 

13. Click Draw Extents. 

 

 

 

 



MicroGDS 2010 Foundation Training   Page 89 

16. Printing 

In this section you will learn how to: 

♦ create a plot  

♦ scale a plot 

♦ use the rasterize option in the Print dialog box 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Useful Help topics 

Printing files 
Setting print layout options 
Setting print options 
Print layout view parameters 
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Printing 
When you print a 2D view, MicroGDS prints exactly what is in view in the current view. If you want 
to print all the graphics in a window, ensure that they are completely in view. 

When you print a print layout view, MicroGDS always 
prints the entire print layout view. If you wish to print your 
drawing, complete the steps below: 

 To print a print layout view: 

1. On the File menu, click Print. 

2. If necessary, select a printer from the list. 

3. Select the paper size you require. 

4. Select Portrait or Landscape. 

5. Select the scale, or click Fit to fit the plot to the paper 
size. 

6. For a colour plot, ensure the Black and white check 
box is not selected. 

You can also change margins and align the view on 
the paper. 

7. To print your drawing, click OK. 

You can also print multiple views from one window 
definition, from different window definitions, or even from 
different documents using the Batch Print facility. For more 
details, refer to MicroGDS Help. 

 
Rasterizing within MicroGDS    

Some plotter drivers have limitations, or are not capable of expressing the whole range of colour 
effects that MicroGDS can generate. To overcome this you can draw your graphics to a raster 
image in MicroGDS before printing. 

 The steps to rasterize within MicroGDS are: 

1. On the Print dialog box, click the Processing tab. 

2. Select the Enabled check box. 

3. You can specify the resolution of the printed raster image by dragging the slider or clicking a 
point on the scale. 

A low resolution produces 'blocky' graphics; a high resolution produces more accurate graphics, 
but may take longer to process. 

 



MicroGDS 2010 Foundation Training   Page 91 

 

Exercise 16 
Printing parts of your drawing to scale 

In MicroGDS you can select a part of your drawing 
to print. You can select the scale at which to print, 
and the paper size on which you wish to print. 

1. On the Document Organizer, open the 
Apartment C window definition. 

2. Zoom in to the Bathroom 1 layout. 

3. On the File menu, click Print. 

4. On the Print dialog box, select the printer you 
require. Set the Paper to A4, Scale to 1:20, and 
select the Landscape option. 

5. On the Processing tab, select the Enabled 
check box, and move the Resolution slider to the right. 

 

6. Click OK to print your drawing at a scale of 1:20. 

Your view is plotted centered on your A4 sheet. 

7. Save and close all your files. 

8.  Exit MicroGDS. 

 

 

 

 

 

 

 

 

Congratulations! You have now completed the MicroGDS 
Foundation Training Course. 
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