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A Quick Start to using MicroGDS BIM
This Quick Start tutorial introduces you to the basics of creating an intelligent drawing using the BIM
components supplied with MicroGDS 2010. Here we demonstrate how to construct the external walls of a
building, and then add doors, internal walls, windows, and block trench work. You’ll see how we can
accomplish this in about 60 to 90 minutes.

To use the MicroGDS intelligent BIM components, you need to use object names that match the provided
schemas. Each schema governs which objects are assigned a set of predefined attributes, along with
predefined default values. To follow the tutorial, we’ve supplied you with the appropriate data:
D a training MAN file which has the appropriate layers and style search path set up
D customized layer and object naming configuration files which set up the appropriate naming
conventions
D a library of user-defined objects that you can use or customize to create new openings
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Step 1: Getting started
1 Unzip the contents of the Quick start.zip file to a folder of your choice.
This gives you a new folder called Quick start which contains the Training.MAN file and three
subfolders.
2 Start MicroGDS and open Training.MAN.
The default window (called Window1) opens in MicroGDS. This window has three layers added, one
for each type of BIM component that we’ll be creating.
Structuring your drawing on different layers makes the process of moving, filtering, and just generally
working with objects easier in the future.
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Step 2: Creating the external wall
1 In the Mini Window Editor, double-click phase 1 (GF-Wall-External) to make it current:

You can open the Mini Window Editor from the Window menu, or by pressing CTRL+1.
2 On the Object menu, click New.
3 On the New Object dialog box, select Standard External Cavity Wall and click OK.

This provides an object name of IfcWallStandardCase: and sets up the correct objectstyle.
Press ESC to place the hook point at the current axes’ origin.
Let’s briefly look at what the objectstyle sets up.
4 If the Properties window is not currently displayed, press CTRL+Q or open it from the Window menu.
Properties for the new object are shown:

The attributes are automatically provided by the schema Brick-Cavity-Block which is set in the
Objectstyle property. The default values shown are also set in the schema; you can change any value in
the Properties window in the usual way. If you find that you often use the same set of values, you can
change the default values in the schema. We’ll actually be doing this towards the end of the tutorial.
5 Use the Construct, Rectangle command

to create the wall about the cavity centre line.

Set the first position at 0,0,0 and the second position at 6000,8000,0

3

The wall parameters are clearly visible in the 2D view:

The view is currently drawn using an automatic drawing style. You can use different drawing styles to
control the appearance of an object. Note that a drawing style is associated with a specific view, not
with a window.
6 On the viewing buttons, click the Drawing style icon

and select Perspective from the list.

The view is redrawn and now shows a 3D perspective view of the external wall of your dimensions, up
to a default height of 2.5m:

You can now see the wall layers—brick, cavity, and block—with each wall layer having a different
material assigned (shown in the Properties window).
Before placing a door in the wall, you’ll move the axes to the front left corner of the wall, making it
easier to place the door relative to this position.
7 Use the Set, Axes, Move command
, and use a point snap to move the axes’ origin to front, left
corner of the wall (coordinates 6127,–128,0), use a line snap to place the X axis along the bottom line,
then press ESC to retain the rotation of the Y axis:

point snap

line snap
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8 Use the Save View As command
the name Perspective.

on the View menu to save the perspective drawing style view to

The new view is added to the views for Window1. We’ll now make this the default view that will open
whenever you open Window1.
9 If necessary, open the Document Organizer by pressing F4 (or Window, Document Organizer).
10 On the Window Definitions tab, expand the views under Window1:
Window
Definitions tab

Currently View1 is shown in bold, indicating that this view will initially be displayed whenever you
open the window.
11 Right-click on Perspective and select Set as default from the shortcut menu.
‘Perspective’ is now shown in bold, becoming the default view that will be opened.
12 Now save the MAN file to a new name, so that you don’t overwrite the original tutorial file.
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Step 3: Inserting a door into the wall
1 In the Mini Window Editor, double-click phase 2 (GF-Doors) to make it current.
2 On the Object menu, click New, select Doors from the object list and click OK.

This provides an object name of IfcDoor: and sets up the correct objectstyle.
Press ESC to place the hook point of the door object at the current axes’ origin:

The door object picks up the wall to link with but we must now move the door in order for it to cut a
hole through the wall.
3 In Select Object mode (F10), hover over the door to highlight the object and then press
CTRL+SHIFT+O to pick up the door by its origin.
4 Type the new position for the door of 2000,0,0 l where the l (line) snapcode places the door precisely
on the brick layer of the wall.
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The door cuts through the wall with its depth automatically adjusting to match the thickness of the
wall:

Let’s now set some new values for some of the door properties.
First, zoom in to the door so that you will see how the door changes as we change its attribute values.
5 With the door object selected, use the Properties window to change the following values:
Operation type
SINGLE_SWING_RIGHT
Frame depth
80
Frame offset
85
Threshold depth
190
Threshold thickness
49
Threshold offset
–25
Click the existing value and then, depending on the attribute type, select from the list or type the new
value. Modified values are shown in bold, to show that their default values have been changed.
The door is immediately updated:
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Step 4: Inserting the windows
1 Make phase 3 (GF-Windows) the current phase.
2 We’ll be placing a window on the left side of the wall, so use the Orbit command
the view appropriately.
For example:

to rotate and roll
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3 Create a new object, selecting Windows from the object name list and then appending Kitchen to the
name.
4 Press ESC to place the object hook point at the current axes’ origin.
A single panel window is placed at the bottom, left corner of the wall. Again, the window picks up the
wall to link with but it must first be moved to cut a hole in the wall. If you use hidden line view
(CTRL+H), you can easily see that the window is currently sitting on the outside of the wall:

window is not yet
cutting a hole

5 Pick up the window object by its origin (CTRL+SHIFT+O) and then place the window as follows:
a) press ENTER to display the Transform dialog box and type –90 in the Angle box
The window changes orientation to lie in the same plane as the side wall.
b) type 2400 as the distance relative to the current position by which to move the object
c) move the mouse pointer over the bottom line of the left wall and use an l snapcode to snap to the
line
The window cuts through the wall:

Notice also that the window has a default height of 1000, set in the Height of base of opening attribute
(shown in the Properties window).
We’ll now change the window to be triple panelled, with equally spaced mullions.
6 With the window object selected, change the following attribute values in the Properties window:
Operation type
Overall width
Height of base of opening
First mullion offset
Second mullion offset

TRIPLE_PANEL_VERTICAL
1790
1100
0.33
0.66

The window is redrawn about its object origin accordingly:
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7 Create a second window object, changing the second facet to Single panel.
In the New Object dialog box, be sure to select Windows from the object list and then append Single
panel to the name. (Note that typing over the existing name in the box will not set up the objectstyle
correctly.)
8 Press ESC to place the hook point in the bottom left corner, then pick it up by its hook point and place
it somewhere to the right of the front door.
The window has a default base of 1000. Change this to 1100 to match the height of the first window.
We’ll move on now to drawing some internal walls.
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Step 5: Creating the internal walls
1 From the Drawing style list
select GA.
The view changes to show a 2D view of the building.

2 Again, use the Save View As command on the View menu and name the view General arrangement.
We’ll now create a new layer for the internal walls.
3 Right-click in the Mini Window Editor and select New Layer & Phase from the shortcut menu.
4 In the Layer Name dialog box, expand the categories as shown below and then select Internal Walls:

This provides a layer and phase name of GF-Wall-Internal and immediately makes the phase current.
5 Create a new object, selecting Standard Internal Block Wall from the object name list and click OK.
Then press ESC to set the object’s hook point at the axes’ origin.
6 We need to draw the graphics for the internal walls on the XY plane, so click
bar (at the bottom right of the MicroGDS window).
The button now shows:

on the information
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Now when we draw, all positions are drawn onto the XY plane ignoring any Z positions.
When drawing the internal walls, you will need to frequently zoom and pan the window. The easiest
way to do this is using the mouse wheel: press the wheel and drag to pan, and rotate to zoom.
7 Make sure that the perspective view is also open and then position the two views side-by-side
(Window, Tile Vertically). This will enable you to see the internal walls being constructed in both
viewing styles.
We’ll also be using snap guides as the method of aligning the internal walls, so make sure that you
have snap guides switched on
8 Zoom in to the bottom, left corner of the wall so that you can clearly identify the inner most layer:

9 Select the Construct, Line command
, hover over the inner corner of the wall and wait for the Point
snapcode to be displayed.
The current position marker now marks the corner:

hover to Point snap

current position marker

The next position will be measured from the marker.
10 Now type 1800, the distance at which to begin the internal wall from the current position, move the
pointer along the inner bottom line and click with a Line snap.
Draw three separate internal walls, pressing ENTER to end each, following the illustration and details
below.
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Remember to follow the snap guides when drawing inside the external walls and always use the inner
line of the external wall when snapping to or marking a position:
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2
9

6
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5

4
1
First internal wall:
Second internal wall:

Third internal wall:

7
4600 to 2
point snap to 3
hover over 1
1000 to 4
1700 to 5
point snap to 6
hover over 7
3300 to 8
point snap to 9

11 To finish off this part of the tutorial, return the Z=0 button to its off position, close the General
arrangement view and then maximize the Perspective view.
You now have the external and internal walls of your building, one door, and two or three windows. All
these components have been supplied with MicroGDS. We’ll now demonstrate how you can also use an
existing library object as a cutter which will create its own opening through an intelligent BIM wall.
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Step 6: Inserting a `user opening'
1 Use the Set, Axes, Normal command
to return the axes’ origin to 0,0,0
This will ensure that the library object will be correctly rotated on the wall.
2 Make phase 2 (GF-Doors) the current phase.
3 On the Document Organizer, click the Library Files tab:
Library Files tab

4 Now expand:
D the User openings folder
D the Library.Man file
D the Doors-External layer
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You will now see several UserOpening objects. We’re going to be inserting the
‘UserOpening-Door-Front with panel’ into the wall.
5 Right-click on UserOpening-Door-Front with panel and select Insert instance from the shortcut menu.
6 Place the door on the external wall, roughly here:

7 Now to associate the door with the wall and make a hole through the wall:
a) pick up the door by its origin, using CTRL+SHIFT+O
b) hover over the corner of the back wall to move the current position marker
c) type a distance of 665 along which to constrain the position of the door
d) move the mouse pointer over the bottom line of the left wall and use an l snapcode to snap to the
line
The door is positioned appropriately, cutting through the wall:

It’s probably a good idea to now practice putting more doors and windows into our building. You might
want to follow the illustration below or decide on a different arrangement. Remember to create the new
objects on the appropriate layers. Also remember that you need to rotate the axes when inserting user
opening objects:
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1 = IfcDoor

3

2 = UserOpening:Door:Internal:900

2

3 = UserOpening:Door:French:1250

1

4 = IfcWindow
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In the final part of the tutorial, we’re going to add a below-ground trench block. As we don’t yet have a
predefined trench block objectstyle, we’ll be creating a new one (based on an existing style). This will
show how you can begin building your own library of objectstyles that you can reuse and share with
others.
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Step 7: Creating a new objectstyle
1 On the Document Organizer, click the Styles tab and then navigate to Block schema:

2 Right-click on Block and select New based upon from the shortcut menu.
The Define Schema dialog box opens, with the properties and attributes for the Block schema.
This schema is to apply only to objects which have ‘trenchblock’ as a second facet, so under ‘Applies
to’, click ‘IfcWallStan...’ and then click Edit:

3 In the Schema Rule dialog box, change the Object filter to show:

We’re now going to change the default values to those appropriate to our trenchblock. As many
mnemonics have particularly long names, enlarge the Define Schema dialog box and then use the
divider between the mnemonic name and attribute value so that you can see all text in both columns.
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4 Now, under ‘Mnemonic’ set the first seven attribute values to read:
IfcExtrudedAreaSolid#Depth
600
IfcWallStandardCase#MGDSLinestyle
Trenchblock
IfcMaterialLayerSetUsage#OffsetFromReferenceLine
–155
IfcMaterialLayer#LayerThickness#1
310
IfcMaterial#Name#1
Block
IfcMaterial#MGDSSection-Linestyle#1
Section-Block
IfcMaterialLayer#IsVentilated#1
FALSE
5 Remove all other mnemonics and then save the schema as TrenchBlock and then close the Define
Schema dialog box.
Ensure that you exactly use this form of case for the name so that it matches that specified in the object
naming configuration file.
We now need to create a Trenchblock linestyle.
6 Under Linestyles on the Styles tab of the Document Organizer, navigate to Block.
7 From the shortcut menu, click New based upon.
8 Change the line Thickness to 310 then save the linestyle as Trenchblock.
We’re now ready to use our new Trenchblock objectstyle.
9 Using the Mini Window Editor, create a new layer and phase.
10 In the Layer Name dialog box, expand the ‘00 Ground Floor’ and Wall’ categories and then select
Below ground wall.

11 Using the Set, Axes, Move command
, move the axes to 0,0,–600 and press ESC.
This places the axes origin 600mm below ground. Now, when we draw the trenchblock outline, it will
be at the correct depth.
12 Create a new object, selecting Below ground trenchblock from the object name list and press ESC
when prompted for the object hook point.
13 From the Window Definitions tab on the Document Organizer, open the General arrangement view.
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14 Use the Construct, Rectangle command
at opposite corners:

and draw a rectangle by snapping on the cavity centre line,

Point snap

Point snap

You’ll need to zoom in to ensure that you snap to the cavity centre line:

Now switch back to Perspective view, and that’s it—we have now constructed an intelligent drawing,
using several components and different drawing techniques:

Notice that, for clarity, we have changed the phase colour of the internal walls in the illustration.
You can find more information about using and customizing the MicroGDS BIM components in the online
Help and in the Using MicroGDS 2010 User Guide.

