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3D Training Course 

Introducing the MicroGDS 3D training course 
 
The MicroGDS 3D training course introduces many of the advanced 3D 
commands and procedures in MicroGDS Compact3D and MicroGDS Pro. 
Each section has step-by-step instructions on how to use these commands; 
the data to enable you to follow these examples is available in the 3D 
Training Data folder.  
 
Each section ends with an exercise designed to consolidate the commands 
and procedures covered in that section. The exercises build up to produce a 
3D rendered model of a beach house as illustrated below. 
 

 
 
 
Before undertaking this course, you should be familiar with the following 
MicroGDS procedures: 
 
· constructing and editing graphics in 2D 
· creating and selecting objects and primitives 
· positioning the axes 
· creating and working with layers and phases 
 
If you are unsure of these basic concepts in MicroGDS, please refer to the 
Foundation and Advanced training courses.  
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Before you begin 
1. Ensure that either MicroGDS 7.1 Compact 3D, or Pro has been installed 

on your computer. 
 
2. Copy the 3D Training Data folder to your computer’s hard disk.  
 
MicroGDS documentation 
You will need a copy of the Using MicroGDS version 7.0 and Introducing 
MicroGDS version 7.1 user guides. 
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1 About 3D Coordinates 
This first section is designed to introduce constructing simple graphics in 3D 
space.  
 
In 2-Dimensional drawings you construct graphics using X and Y coordinates. 
When you draw 3D graphics, you supply a Z coordinate in addition to the X 
and Y coordinates. 
 
To illustrate the use of the Z coordinate: 
 
1. Start MicroGDS and create a new file. 
2. Draw a line using the Construct, Line command with the coordinates 5/5 

to 55/5. 
This constructs a line 50 units in the X direction and 0 units in the Y 
direction. If you omit the Z coordinate MicroGDS implies that the Z 
coordinate is 0.  

3.  Continue with the line command, now supplying coordinates of //20 
(where // implies the last X and Y positions on the screen), the line will 
project out of the screen by 20 units. 

4. To see the result, click the 3D View button. 

 
5. To complete the shape, type the coordinates 5/5, press ENTER and finally 

press CTRL+ENTER to close the primitive.   
 

 
To convert the above shape into a surface to which you could add a 
colour or a texture you would have to clump the primitive.  

6.  To clump the primitive, on the Solid menu, click Clump Create. 
Clumping primitives is covered in section 3. 

7. Close your file without saving the data. 
 
To create all your 3D data in this way would be extremely time consuming 
and not very pratical. MicroGDS provides many commands to simplfy 3D 
construction, which you will cover during this course.  
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1.1 Axes 
Throughout this course you will be repositioning the axes. You should 
therefore fully understand the rotation of the X, Y and Z axes. The diagram 
below illustrates when a positive value should be given to achieve a required 
rotation. The rule is quite simple, an anti -clockwise rotation is always positive 
and a clockwise rotation is negative (unless you have reversed this in your 
MicroGDS preferences). 

                             
1. To illustrate the need for rotating the axes, open the 3D Training data file, 

and then open the ‘Axes rotate’ window definition.  

A profile of a wine glass has been constructed using a combination of 2D 
commands. The profile has been positioned in the X, Y plane. 

2. Select the graphics and on the Solid menu, click Construct, Complete 
Revolve.  A 3D representation of the glass is created.  
Notice that the glass in 3D it is on its side. 

3. To view the glass in 3D, click the 3D View button. 
To stand the glass up you could use the Object, Reposition, or Alter 
Transform, 3D Rotate commands. However, in this exercise you will cut 
the glass to the Clipboard, spin the axes in the appropriate direction, and 
then paste the glass back to the drawing. 
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4. Select the glass, and click Cut on the Edit menu. The glass is now moved 
to the clipboard. 

5. On the Set menu, click Axes, Spin X, and at the prompt type 90.  
6. Click Edit, Paste.  

MicroGDS remembers the original orientation of the data and pastes it 
back to the screen, but because you rotated the axes so that the Y axis is 
now pointing out of the paper, the wineglass is now vertical.  

 

 
 
7. Click Edit Undo to undo the Paste command. 
8. Click Edit Undo to undo the Cut command. The wine glass is now back in 

its original position. 
9. To reset the axes as they were at the start of step 1, click Axes Spin X 

and at the prompt type –90. 
 

You will now reposition the wineglass using another method.  
 
10. On the Object menu, click Reposition. Type 0/0/0 to pick up the wine glass 

by its origin. 
11. To place the wineglass at the same position type // and press ENTER.  

MicroGDS now prompts for the position of the X axis.  The X axis stays 
the same, you need to reposition the Y axis. 

12.  Press TAB.  
The prompt bar now asks for the position of the Y axis. At the prompt bar 
type 0/0/1. 

This positions the Y axis, in the original position of the Z axis, thus 
standing the wineglass on its base. 

13. Save and close the Training Data file. 
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Exercise 1 Rotating the beach house steps 
 
1. In your 3D training data folder, open the Beach House.MAN file.  

To save time, the Beach House file has pre-created windows, each 
window consists of layers with data constructed for you. Most of the 3D 
work is constructed from 2D data. 

In this first exercise you will rotate the 2D steps objects. You will then 
switch to 3D and use the thumb wheels to move around your model. The 
viewing commands are covered in more detail in the next section.  

 
2. Open the Steps window definition. 
3. Change the scale to 1:50. 
4. Reset the axes onto one of the steps. 
5. In Object mode, cut the steps to the clipboard. 
6. Spin the axes in the X direction by 90d. 
7. Paste the steps back to the drawing. 
8. View your model in 3D. 

 
 
9. To see the second set of steps, drag the bottom thumbwheel to the left 

until the number reaches approximately 200.  
10. To return to your previous view, click Previous View. 
11. Save and close the Beach House file.  
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Viewing in 3D 
 
This section introduces the various ways to navigate round a 3D model and 
the different view modes available in MicroGDS.  
 
If you have a wheel mouse you can zoom in and out by rotating the wheel. 
Holding down the wheel pans around the scene. 

1.1 Navigating around the scene 
 
There are many ways to navigate around the scene in MicroGDS. The 
viewing buttons provide shortcuts to commands that control views and 
windows. 
 
All the navigation commands are available on the View menu and as buttons 
on the View toolbar: 
 

 
 
The viewing buttons are also available on the MicroGDS graphics window. 
You can select how to display your viewing buttons from the View Controls 
tab on your Preferences. 
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The viewing buttons, which are most applicable for navigating around a 3D 
view, are described in more detail below. See the MicroGDS Help topic ‘The 
viewing buttons’, for a full list of viewing commands. 

1.2 Adjusting the centre of the scene and correcting the perspective  
You will find that one of the most useful commands enables you to reposition 
the centre of the scene.   
 
1. Open Training Data.MAN and then open the Navigate window definition.  
2. On the View menu, click Change Centre.  

An arrowhead pointing to the current centre of the window with the other 
end attached to the mouse pointer provides feed back for the new centre 
position. 

3. Click on your drawing for a new centre position:  
The centre of the drawing is moved to its new position, and the window is 
panned if necessary. 

 
 

It is possible, when you have used the mouse wheel to pan around the 
scene, that the perspective view could look distorted as in the illustration 
below. To correct this and reset the view, on the View menu, click Zoom 
Reset.  

 
 
 
 
 
 
 
 
 
 
 

Current centre of 
the scene 

Click here for the new 
centre of the scene 

Click the Reset 
View button to 
correct the 
perspective 

Distorted view Reset view 
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1.3 Advancing in and out of the scene 
· To see the whole model, on the View menu click Zoom Extents  

You will see all of the graphics in the scene. The centre of the model will 
adjust to ensure all the graphics fit within the window.  

· To keep the scene’s current centre position, by moving along the eye 
ray and viewing the whole model in the window, on the View menu 
click Advance Model 

· To zoom into the selected primitives or objects, on the View menu, 
click Draw selection 

· To zoom into the selected graphics along the eye ray, on the View 
menu, click Advance Selection 

1.4 Using the Nudge buttons 
You can navigate around your scene by clicking any of the nudge buttons:  
 

·  right , left , up , down , forward , and back  
 
You can set the default nudge distance, and the shifted nudge distance 
(distance nudged with SHIFT held down), in the Nudge Parameters dialog 
box.  
 
1. To open the dialog box, on the View menu, click Nudge, Parameters.  
 

 
 
 
2. Type the values to set the default and Shifted nudge distances.   

. 
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1.5 Viewing modes  
There are three view modes: 
 

Swing Round ,  
Walk Through   
Slide Past  

 
The view modes have an effect on how you navigate around the scene when 
using the nudge buttons. 
 
The example below illustrates the different view modes when navigating 
using the nudge right button. 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
 
 
 
 
 
 
 
· If you wish, practice using the three viewing modes using the Navigate 

window definition. 
 
 
 

Swing Round mode 
 
The eye point swings around 
the look-at point 

Walk Through mode 
 
The look-at point moves and 
the eye point remains 
stationary 

Slide Past mode 
 
The eye point swings around 
the look-at point 

Original view 
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1.6 Using the Thumbwheels  
In a 3D view you can use the 3D round thumbwheel to move your eye 
position horizontally around the look at point, and the 3D wheel thumbwheel 
to move vertically around the look-at point. 

                          
 
 
  

 

 
 
 
  
 
 
 
 
 
1. If you wish, practice using the 3D thumbwheels in the Navigate window 

definition. 
2. Then, reset your view back to its original position by clicking Restore 

View, on the View menu. 

Dragging the 3D wheel thumbwheel up moves your 
eye position in a clockwise direction, around the 

look-at point 

Dragging the 3D round thumbwheel to the right 
moves your eye position in an anticlockwise 

direction, around the look-at point 
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1.7 The View Parameters dialog box 
In the view parameters dialog box you can: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
In a parallel view you can view your model in different common projections, 
such as Orthographic, Cabinet, and Cavalier. For more details on parallel 
projections, refer to Help. 
 
With orthographic projections you can create elevations and plan views from 
your model data.  
 
 
 
 
 
 
 
 
 
  
 
 
 
1. On the View Parameters dialog box, change Perspective to Parallel and 

from the bottom list select Orthographic. Using the Navigate window 
definition, select in turn each of the views as illustrated above.  

2. Change the View back to Perspective and, on the View menu, click 
Restore View. 

Top Bottom Left Right 

Back Front 

Change the view mode from 
 3D to 2D 

Change the view from a perspective to a 
parallel view 

Type a coordinate or pick (from the screen) 
new eye and look-at positions 

View the model as a 1, 2, or 3 point 
perspective and change the viewing angle from 
10 to 170 degrees. 

Rotate and roll the scene. 

Set a new view plane extent using the pick 
buttons and clicking onto the screen, or type in 
coordinates for the top right and bottom left of the 
extent 



  13 

 

3D Training Course 

1.8 The XY view button 
Another way to set an orthographic projection is to use the Axes XY Plane 
command.  
 
1. On the Set menu, click Axes Move, and click the axes positions illustrated 

below:  
2. On the View menu click Axes, XY plane. 
 
 
 
 
 
 
 
 
 
 
 
 

1.9 Hide Modes and options 
 
When you switch the view from 2D to 3D, you have the choice of how you 
view the data. You can display three-dimensional graphics in the following 
modes: 

· wireline shows the graphics as a wire frame 
· dotted shows hidden lines as dotted lines 
· clipped shows only graphics that lie behind the clipping plane  
· hide does not draw hidden lines 
· shaded shows graphics as a 3D model, using materials and lights  
· shaded view with edges shows graphics as shaded but with edges 

drawn 
 
 
1. In theTraining Data file open the Cuboid window definition. 
2. To see the view as a wireframe, press CTRL+W, or on the View menu, 

click Hide Mode, Wireline.  

 
 

Y 

X 

Z 
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Clipped views display graphics that lie behind the 'clipping plane’. To see a 
clipped view, you will need to first set a clipping point: 
 
1. On the View menu, click Hide Options, Set Clipping point.  
2. In the scene click a position for the clipping point.  

 
The view is immediately updated and your view is clipped.  

3. Select another View mode to remove the clipped view. 
4. To redisplay the clipped view on the View menu, click Hide Mode, 

Clipped. 
 

You can display your scene so that it is drawn as a wire frame, with all visible 
lines displayed in a solid line and all invisible lines displayed in a dotted 
linestyle. 
 

· To switch to dotted view, on the View menu, click Hide Mode, Dotted 

 
You can display your scene in a 3D view so that hidden lines are not drawn.  
 

· To switch to hidden view, press CTRL+H, or on the View menu, click 
Hide Mode, Hide 

 
 

The following are examples for you to look at; the methods for creating 
materials, lightstyles, etc., are covered later in this course.  

The set clipping 
point 
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You can display 3D graphics in your scene so that materials, the eye point, 
and lightstyles, are used to shade the graphics.  
 

· For an example, open the Block window definition 
 
To switch the view to shaded: 

· press CTRL+R, or on the View menu, click Hide Mode, Shaded 
 

 
. 
To show the geometry edges in a shaded view: 

· on the View menu, click Hide Mode, Shade with Edges 
 

 

Hide options 
When you construct a clump from a curved line primitive, MicroGDS facets 
the primitive so that the faces of the clump can be created. You can control 
how you view the facets. You can choose from: 
 
· Full (the default), displays the edges in the standard way. All lines are 

shown in the same weight. 
 
 
To show geometry with the facet edges drawn:  
1. On the View menu, click Hide Mode, Hide. 
2. On the View menu, click Hide Options, Show Smooth Edges, Full. 

You will not see any change as this way of viewing 3D graphics is the 
default. 
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· Partial, displays the edges in a lighter tone. 
To show geometry with the facet edges partially drawn:  

· On the View menu, click Hide Options, Show Smooth Edges, Partial 

 
 

· Omit, hides smooth edges. 
To show geometry with the facet edges omitted:  

· On the View menu, click Hide Options, Show Smooth Edges, Omit 

 
Showing and hiding intersecting lines  
You can show or hide intersecting lines where clump faces pass through 
each other. 
 
To show the intersection line between two clumps: 

·  On the View menu, click Hide Options, Show Intersection Lines 

 
 

Facets 

Intersection line 
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Exercise 1 Viewing data and saving 3D views 
 
In this exercise you will use the Training data file, and the Navigate window 
definition, to change and save views.  
 
1. Open your Training data file.  
2. Open the Navigate window definition. 
3. Change the View mode to Shaded With Edges. 
4. Change back to Hide mode. 
5. Use the 3D round thumbwheel to move the eye position horizontally 

around the look-at point, relative to the Z axis, and then on the View 
menu, click Previous View. Use the 3D wheel thumbwheel to move 
vertically around the look-at point, relative to the Z axis, and then on the 
View menu, click Previous View. 

 
When you are working on a 3D model, it is useful to be able to save different 
views of the model. You can do this by cloning your window definition, and 
then changing and saving the view.  
 
1. Move both the 3D round thumbwheel and the wheel thumbwheel to 0.  
2. On the File menu click Window, Clone. On the Copy Linked Layers dialog 

box, select ‘New Window refers to existing Layers’.  

 
3. On the View menu, click Save View. 
4. Rename your new window as ‘Navigate Back View’. 
5. Move the 3D round thumbwheel to 90. 
6. Repeat step 2 and 3 
7. Rename your second new window as ‘Navigate Left view’.  
8. Save and close your Training data file. 
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3 Creating 3D Graphics (Clumps)  
MicroGDS has a number commands to create predefined shape. You can use 
these shapes as basic building blocks for your 3D models. 

3.1 Constructing cuboids 
You can create cuboids using the Solid, Construct Cuboid command.  
 
For example, to create a cube 1000mm/1000mm/1000mm positioned in the 
drawing at 0/0: 
 
1. Open the Training Data file, create a new window definition and rename it ‘3D 

graphics’. 
2. On the Solid menu, click Construct, Cuboid. Press ENTER to display the 

Cuboid dialog box, and type 1000 for the X, Y, and Z sizes, and click OK. 
 

 
 
 

 
3. Enter coordinates of 0/0/0 ENTER followed by / ENTER, / ENTER, to position 

the cuboid around the current axes location. 
4. Change to 3D view and on the View menu, click Draw Extents. 
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The three examples below show a cuboid, which is 1000mm high and has the 
first and second corners defined by screen snaps. The position of the Z 
coordinate of the cuboid is restricted to 3 positions. 

 
To position the cuboid so the base sits on the XY plane and the cuboid is created 
above it: 

· use screen snaps to place the first two corners and then type a Z 
coordinate of 0/0/250 or greater  

 
To position the cuboid so it is centred about the XY plane: 

· use screen snaps to place the first two corners and then type a Z 
coordinate between 0/0/-249 and 0/0/249 

 
To position the cuboid so the base sits on the XY plane and the cuboid is created 
below it: 

· use screen snaps to place the first two corners and then type a Z 
coordinate of 0/0/-250 or a greater negative value 

 
 
5. Delete your cube. 
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3.2 Constructing cylinders 
To create a cylinder: 
1.  On the Solid menu, click Construct, Cylinder.  
2. To specify the dimensions directly on your drawing, click a position for the 

base of the cylinder, followed by a second position to define its circumference. 
Finally, type a Z coordinate for the cylinder height. 

 
3. Delete your cylinder. 
Another way to create a cylinder is:  
1. On the Solid menu, click Construct, Cylinder.  
2. Press ENTER to display the Cylinder dialog box. Enter a fixed Radius and 

height, for example:  

 
 
3. Click on your drawing to place the cylinder. 
4. Delete your cylinder. 

3.3 Constructing spheres 
To create a sphere: 
1. On the Solid menu, click Construct, Sphere. 
2. At the prompt bar type a radius for the sphere, press ENTER, and then 

specify a position on the drawing for the centre of the sphere. 

 
3. Delete your sphere. 
 

First Position Second Position  
Type a Z coordinate for 
the cylinder height for 
example //400  
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Constructing cones 
To create a cone: 
1. On the Solid menu, click Construct, Cone. 
2. Click on your drawing to specify the centre of the cone and the radius 

positions. As with constructing cylinders and cuboids, you are required to type 
a Z coordinate or snap on existing graphics which are not on the XY plane. 

 

  
 
 
 
Another way to create a cone is: 
 
1. On the Solid menu, click Construct, Cone.  
2. Press ENTER to display the Cone dialog box. Enter a fixed radius for the 

base and the top of the cone. To taper the cone to a point type 0 (zero) in the 
top radius box. Enter the height of the cone. 

 

 
 

3. Click on your drawing to place the cone. 
 
New primitives using the Cuboid, Cylinder, Sphere and Cone commands are 
created in the current object. They are called clumps, which is the term for a 
MicroGDS 3D primitive that comprises one, or more connected faces. All the 
faces in the above clumps are joined to form a closed shape; the clump is 
therefore a 'solid'. You can use all the Solid Boolean edit commands on solid 
clumps, you can also assign a colour or texture to each surface of a clump, and  
measure the volume of clumps. 
 
 

Type the X, Y and Z coordinates to 
specify the upper circumference of the 
cone. 
 
 

First Position 

Second  Position 
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3.4 Constructing clumps by extruding  

One of the most useful commands in MicroGDS when constructing 3D graphics, 
is the Extrude command. You can construct a clump by extruding the selected 
line primitives parallel to the Z-axis. 

1. In the Training data file, open the Extrude window definition. 
2. Switch to 3D view.  
3. In Primitive mode, select the graphics, and on the Solid menu, click Construct, 

Extrude. 
4. Type coordinates to extrude from (//0) and then type coordinates to extrude to 

(//400). The X and Y coordinates are ignored.    

 

 
 
 
 
 
 
Each extruded primitive is a separate clump. If you extrude closed primitives the 
clump becomes a solid clump. 
 
 

3 primitives selected in a 
2D view. 

The view is switched to 
3D and a Dot snap 
identifies the position to 
extrude from. 

The selected 2D 
primitives are extruded 
to //400 creating 3 solid 
clumps 

First position 
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You can also extrude open primitives in the same way. The extruded graphics 
become a mesh clump. 
1. Create a new window definition in the Training data file and rename the 

window ‘Mesh clump’. 
2. In 2D view, draw a simple primitive as illustrated below. 
3. Switch to 3D view. 
4. On the Solid menu, click Construct, Extrude. Type coordinates to extrude 

from (//0), and then type coordinates to extrude to (//400). The X and Y 
coordinates are ignored.  

  
You can measure the surface area of a mesh clump with the Measure Area 
command. 
 
To check if a clump is a solid or a mesh, use the Query command: 
 

 
 
 

 
 
You can use the Solid Boolean commands on clump meshes. You can also 
assign a colour or texture to each surface of a mesh clump.  These subjects are 
covered later in the course. 

The query window displays the 
primitive type. 

If the extrusion is a mesh 
clump then the surface area is 
calculated. 

If the extrusion is a solid 
clump, solid is reported in the 
query dialog here. 

The surface and volume are 
displayed when solid clumps 
are queried. 

2D primitive 
extruded primitive 
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3.5 Constructing clumps by sweeping 
 
You can use the Sweep command to create plinths, parapets, skirting, picture 
frames, and any type of data that requires a profile extruded along a line.     
 
1. Open the Training Data file and then open the Sweep window definition. 

You will need to reposition the axes so that negative Z projects down the line 
you are going to sweep. 

2. On the Set menu, click Axes Move, and click a Point snap on the end of the 
sweep line. You will now orientate the axes so that you are able to snap along 
the line in the negative Z direction.  Hold down SHIFT and press TAB to cycle 
the axes to  –Z.  Click a line snap along the sweep line and press ESC. 

 
3. Select your two profiles, and on the Solid menu, click Construct, Sweep. Click 

on the path line at the position at which you want the sweep to start. Click a 
second snap on the path at the position at which you want to end the sweep.  

   
 
 
 
 

 
Note that you can sweep the profile along the entire length of the line, by 
pressing CTRL when you click onto the sweep line. 

 

Position the two 
profiles orthogonal to 
the sweep line.  

Click a line snap 
for the start of 
the sweep.  

 

Click a line snap 
to position the 
end of the sweep 
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3.6 Constructing clumps by revolving 
There are three Solid commands, which take the selected primitives and revolve 
around the Y axis to form a clump: 

· Complete Revolve 

· Revolve from Position 

· Revolve from Angle 
If the selected primitives form a closed shape, the resulting clump is a solid 
clump. If the selected primitives are open lines, a mesh clump is created. The 
Revolve commands will fail if any line in the selected primitives cross the Y axes. 
 
Constructing clumps by a complete revolve 
1. In the Training data file, open the ‘Wine glass’ window definition. 
2. On the Set menu, click Axes, Reset and click on the base of the glass. 

Note that the Y axes is correctly placed to revolve around. 

3. Select the glass. 
4. On the Solid menu, click Construct, Complete revolve. 

5.  Click Undo. 
 
Constructing clumps by revolving from a position 
You can revolve a 2D profile round the Y axes from a position to a specified 
angle. 
  
1. The wine glass profile is already selected. 
2. On the Solid menu, click Construct, Revolve from Position.  
3. Click a position on the drawing, in this instance click 60 degrees from the X 

axis as illustrated below. Type an angle of 90 at the prompt.  

Y axes 

X axes Z axes 



 

27 3D Training Course 

The primitive revolves and creates a clump by the given angle, from the snap 
position. 

 
 
 
 
 
 
 
 
 
 
 
 
4. Click Undo. 
 
Constructing clumps by revolving from an angle 
You can revolve a 2D profile around the Y axes, from one angle to another. If the 
angles are positive the clump revolves in an anticlockwise direction around the Y 
axes, starting from the X axes. 
 
1. The wine glass profile is already selected. 
2. On the Solid menu, click Construct, Revolve from Angle. 

The prompt bar asks you to enter the angle from which you want the graphics 
to be revolved. 

3. At the prompt type 90 (this will start the revolve 90 degrees from the X axes).  
The prompt bar asks you to enter the angle to which you want the graphics to 
be revolved. 

4. At the prompt bar type 270 and press RETURN. This will revolve the graphics 
180 degrees. 

 
 
 
 
 
 
 
 
 
 
5. Click Undo. 
6. Save and close the Training data file. 

Y Axes 

     X Axes Z Axes 

First position 60 
degrees from the X-
axes. 
 

Type at the prompt 90 
 
 

X Axes 

Z Axes 

Y Axes 

 
 

Type an angle of 
90 at the prompt 
 
 

Type an angle of 
270 at the prompt 
 
 

Y Axes 

X Axes 
Z Axes 

      X Axes 
Z Axes 
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Exercise 3 Extruding the step supports and the steps 
 
In this exercise you will first extrude the step supports and then copy them to the 
other side of the deck. You will then extrude the step treads. 
 
1. Open the Beach house file, and then the Steps window definition. 
2. Check your scale is 1:50. 
3. Select the supports, one support for each set of steps. 
4. Extrude the supports by clicking Solid, Construct, Extrude, and extrude from 

//-208 to //r50. 
5. Copy the stair supports from their edge to //r-600. 
6. Select all 10 treads and extrude from //0 to //-975. 
7. Swing your graphics round to view your steps as illustrated below: 
 

 
8. Save the Beach house file. 
 
 
Exercise 4 Creating the support posts for the deck 
 
In this exercise you will create the support posts for the decking. 
 
1. Open the Posts window definition. 
2. Make the phase Support Posts the current editable phase. 
3. Set Axes Reset on to the square to the right of the bedroom. This will move 

your axes 300mm below the normal plane, creating a start position for the 
post. 

4. Create a new object called Deck:Support and place the origin with an inside 
snap onto one of the existing squares. 

5. Create a cube 250 x 250 x 1055 to represent the support posts. Click onto the 
square selected in 4 above. For the Z position type //2000. 

6. Set Axes Reset onto the cube. 
7. Cut the cube to the Clipboard. 
8. In Object mode, select all the 2D posts and use Object Replace to replace the 

2D representation of the posts with the new 3D version. 
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9. Switch to 3D view. 

 
10. Save your file. 
 
 
Exercise 5 Creating the support columns for the roof 
 
In this exercise you will create two columns to support the roof structure, and one 
column to support the garage roof. 
 
1. Open the Columns window definition and make the Columns phase the 

current editable phase. 
2. Change to 3D view. 
3. Set Axes Reset onto one of the front two columns (marked with crosshairs). 
4. Create a cylinder 150 radius x 3650 height and place the base of the cylinder 

on the intersection of the two crosses, and for the Z position type //3650. 
5. Repeat step 4 for the other front column. 
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6. Create a third cylinder to support the garage roof with a 75 radius and a 
height of 2500. Place on the intersection of the cross at the top left of the 
garage and snap onto the top of one of the other two columns to place the Z 
position. 

 
 

 
 
 
 
 
 
Exercise 6 Creating the deck cross beams and the deck 
 
In this exercise you will use the Extrude command to create the crossbeams that 
support the deck. You will then create the deck itself. 
 
1. Open the Floors window definition. 
2. Make phase Cross Beams the current editable phase. 
3. Set Axes Centre. 
4. Select the crossbeams, and extrude from the top of the posts to //r150. 
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5. Make phase Deck the current editable phase. 
6. Select the deck and extrude from the top of the crossbeam to //r45. 
7. Change to 3D view and change your 3D wheel thumbwheel to 0. 

The enlarged illustration below shows the deck supports sitting on top of the 
posts and the deck sitting on top of the supports. 

 
 

 
 
8. On the View menu, click Previous View. 
9. Save and close your Beach house file. 
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4 Clumps 

4.1 Creating clumps from 2D graphics 
A clump is a 3D primitive that comprises one or more joined faces.  

 
 
In MicroGDS there are two types of clumps, solid clumps and mesh clumps: 

· when faces are joined to form a closed shape the clump is solid: 

solid clump 
· when faces do not join to form a closed shape the clump is meshed: 

 

 mesh clump 
 

You can create a clump from selected closed primitives using the Clump 
command. The Clump command is useful for creating a surface, such as a floor, 
where you do not need to see around the edges or underneath. A clump created 
from 2D graphics has no depth; however you can add colour and texture to a 
clump, this is known as a material. 
 
To create a clump from selected primitives: 
1. Open the Training data file and create a new window definition and name it 

Clumps. 
2. Draw a rectangle. When you move your pointer over the rectangle a Dot snap 

is offered. 
3. On the Solid menu, click Clump, Create.  
4. The selected closed primitives become a clump. Now when you move your 

pointer over the rectangle a Face snap is offered. 
 
Retaining 2D graphics 
With most of the Solid Clump commands, if you press CTRL prior to supplying 
the last coordinate or snap position, the existing 2D graphics are retained. 

A clump with a single face 
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Separating clumps 
To separate a clump into its constituent line primitives, use the Unclump 
command. 
1.  Select your rectangle. 
2. On the Solid menu click Clump, Unclump. 
3. The selected clump becomes a closed primitive. When you move your pointer 

over the rectangle a Dot snap is offered. 
4. Delete your rectangle. 
 

4.2 Constructing clumps by extruding to a point 
You can create a clump which tapers to a point from an existing 2D footprint. 
 
To create a solid clump: 
1. In 2D view mode, construct a rectangle 500 x 500 and place at 0/0 0/0.  
2. Switch to 3D view. 
3. On the Solid menu, click Construct, Taper, and type 0/0/250. 
 
    
 
 
 
 
 
4. Delete your graphics. 
 
To create a mesh clump: 
1. Switch to 2D view.  
2. Construct two connected arcs as illustrated below. 
3. Switch to 3D view. 
4. On the Solid menu, click Construct Taper, and type 0/0/250. 
 
 
 
 
 
 
 
 
5. Save your Training data file. 
 

Open line primitive 

A mesh clump created by 
tapering a single line 
primitive.  

Closed line 
primitive 

A solid clump is 
created from the 
rectangle 
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4.3 Creating ruled surfaces 
The Rule Surface command creates a surface from one primitive to another. You 
can rule surfaces between open or closed primitives, the resulting clump is 
always a mesh clump. 
 
To rule between two closed line primitives: 
1. In the Training data file, open the ‘Rule surface closed’ window definition. 
2. On the Solid menu, click Rule Surface.  
3. Provide the snaps as illustrated below: 
 

Always use the N snap when ruling a surface between two closed primitives as 
the surface will twist if the snaps are not orthogonal to each other.  
 
To rule between two open line primitives: 
1. Open the ‘Rule surface open’ window definition. 
2. On the Solid menu, click Rule Surface. 
3. Click on one primitive and then the other. 
 
 
 
 
 
 
 
In general, when ruling a surface from one primitive to another, the primitives 
must be drawn in the same direction; if they are not the new ruled surface will 
twist in the middle. If the primitives are drawn in different directions, you can 
rectify this by selecting one of the primitives and on the Alter menu, click 
Reverse.  
 
 

First position 
use an M 
snap 
 
 

Second position, 
always use N snap  
 

A mesh clump is 
created between the 
two primitives. 
  

Line snap 
 

Line snap 
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4.4 Creating a surface by patching 
The Solid, Patch command creates a surface from four bounding primitives. 
 
1. Open the ‘Curtain’ window definition. 
2. Click each graphic to check that there are four line primitives, which form a 

closed boundary.   
3. On the Edit menu, click Select All. 
4. On the Solid menu, click Patch.  

A clump mesh is created within the boundaries or the four primitives. 
 
5. Save the Training data file. 
 

Select each primitive   
 
 

The primitives must 
only meet at the 
ends of the lines 
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The clump mesh was copied from this 
point. 

The top half of the cushion was copied 
to the clipboard. The axes were rotated 
in the X direction by 180 degrees, 
pasted back and positioned under the 
top of the cushion. All the graphics were 
selected and clumped to form a solid. 

The copy was rotated by 90 degrees 
and mirrored in angle. 

Creating solid geometry from meshes 
 
It is good practice, whenever possible, to create solid clumps from mesh clumps. 
This is because you can only use Boolean commands on solid clumps. With 
Boolean commands you can punch holes through clumps, create pockets, 
subtract one clump from another, use clash detection, and add clumps together. 
 
You can create solid clumps from meshes using the Clump Create command. 
The example below illustrates the creation of a cushion: 

 
1. In the Training data file, open the ‘Cushion’ window definition. 
2. On the Set menu, click Axes Reset, and click onto the graphics. 
3. Select the graphics, and on the Solid menu, click Patch. 
4. Select the resultant mesh clump by clicking on to the grid, and copy from the 

point illustrated above; rotate the copy by 90 degrees and select the Mirror in 
Angle checkbox. 
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The cushion has a smoothing 
angle set to 0 The cushion was smoothed with a 

smoothing angle of 45 

5. Place the copy down at the same point as it was copied from by typing // and 
press ENTER. 
You now have one quarter of the cushion. 

6. Select the two mesh clumps and copy from the same point as in 4 above; 
rotate the copy by 180 degrees and select the Mirror in angle checkbox. 

7. Place the copy down from the same point as it was copied from by typing // 
and press ENTER. 

8. Select all four mesh clumps and on the Solid menu, click Clump Create. 
 
To create the bottom half of the cushion: 
 
1. Select all graphics, and cut to the clipboard. 
2. On the Set menu, click Axes, Spin X and type 180 at the prompt bar. 
3. Paste the graphics back and place them by typing // and press ENTER. 
4. You will have to exactly position the graphics by zooming in and picking up 

the bottom corner of the underneath cushion, and moving it to match the 
bottom corner of the top cushion.  

5. Select all your graphics, and on the Solid menu, click Clump Create. 
 

The above example was clumped together to form a solid. This is possible 
because all the clumps have coincident edges of the same length, and the 
edges have opposite directions. 

 
6. Save and close the Training data file.  
 
Later in this course we will return to the cushion to explain smoothing clump 
edges, and removing non-planar surfaces. 

4.5 Smoothing a clump by an angle 
The cushion in the above example was created by clumping together a number 
of patched surfaces. By default MicroGDS automatically smoothes the clump 
faces.  
 
If you import your 3D data from external files the graphics are not smoothed. 
MicroGDS provides a method for smoothing clumps by selecting the Smooth 
Angle command and setting the smoothing angle to 0.  
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Exercise 7 Creating the parking area 
 
In this exercise you will create clumps from closed line primitives. One clump will 
represent the parking area and another two clumps will represent the grass 
areas. 
 
1. Open the Beach house file, and then open the ‘Landscaping’ window 

definition. 
2. Select the object ‘Drive’, and on the Solid menu, click Create Clump. 
3. Repeat step 2, selecting in turn the two objects ‘Grass:Area’. 
 
Exercise 8 Creating a roof light 
 
In this exercise you will use the Taper command to create a roof light in the 
entrance hall. 
 
1. Open the ‘Roof light’ window definition. 
2. Make the phase Roof light the current editable phase. 
3. On the Set menu, click Axes Reset, and click onto the roof light graphics.  
4. Select the roof light. 
5. Construct a taper to a height of 450 above the original graphics, holding down 

CTRL to retain the original graphics.  
6. Switch to 3D view to see your graphics as illustrated below: 

 
 
7. Save and close the Beach house file. 
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5 Data Management  

5.1 Layers, phases, windows and objects 
 
Before creating 3D models in MicroGDS it is good practice to plan your work.  
 
You can create a lot of 3D data in a short amount of time. However, viewing the 
data in wireline can become very difficult to see, simply because of the number of 
faces and edges in 3D geometry. On slower machines, viewing the whole model 
on the screen can take some time to refresh. 
 
One method you could use to structure your data in a more manageable way is 
to create several window definitions, and only view the data which is relevant to 
the area you are working on. For example in the beach house, if you were 
creating the roof light, you would not need access to the parking and grass areas, 
so they can be created in different window definitions. 
 

 
 
By creating layers you can further break down the amount of data you view at 
one time. Breaking down data like this can be achieved in a number of ways. In 
your window definition you could have one phase per layer, or you could 
separate a layer into several phases using inclusion lists. In the Mini Window 
Editor you can quickly change the status of any of the phases in your current 
window to Invisible, thereby reducing the amount of data viewed at any one time. 
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5.2  Converting graphics to facets  

MicroGDS converts graphics to facets for a number of operations, such as 
revolving primitives, and extruding solids. 

If you are extruding graphics with arcs, or constructing clumps by revolving, 
MicroGDS considers the arc as part of a full circle. For example, if the set 
number of facets is eight and the arc spans a quarter of a circle, when you 
extrude the arc MicroGDS creates two facets (a quarter of eight). You can 
change the number of facets to be used with the Facet command 
Reducing the number of facets prior to creating 3D data is one way of simplifying 
the model: 
1. Open the Training data file and the Pilaster window definition. 

Before you can revolve your pilaster, you must change the axes so that the 
graphics revolve around the Y axis. 

2. On the Set menu, click Axes, Spin X, and at the prompt type 90. 
3. Select the Pilaster and on the Solid menu, click Complete Revolve. Deselect 

your graphics. 
The pilaster below is created with the default number of facets (32). In the 
second example the number of facets is reduced to 6. As you can see the results 
are similar when the pilaster is rendered. 
 
 
 
 
 
 
 
To reduce the number of facets: 
1. On the Edit menu, click Undo. 
2. On the Set menu, click Facets and at the prompt type 6. 
3. On the Solid menu, click Complete Revolve, and deselect your graphics. 
 
 
 
 
 
 
 
 
 
Tip: If a 2D profile has curves with a large radius, MicroGDS will simplify the data 
and create a straight line from one end of the curve to the other. To retain the 
path of the curve you can first facet the primitive. 

The render result is similar to the first example, but with less than a 
quarter of the data to calculate, the time taken to render is reduced.   
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6 Editing 3D models 
 
You can edit 3D data using the Solid, Boolean commands. You can also edit 
3D data with many of the 2D Edit commands.  The following section covers 
most of the Boolean commands. 

6.1 Copying and transforming clumps 
You can copy, scale, mirror, and move, selected clumps with the Edit 
commands on the Alter menu. 

Copying and moving clumps 
You can copy a clump in the same way that you copy an object:  
 

· select a clump or clumps, press CTRL, and click a position on the 
clump to copy from, then click a new position to copy to 

or 
· on the Construct menu, click Repeat, and click a position on the clump 

to repeat from, and then click a new position to repeat to  
 
Similarly you can move a clump:  
 

· select the clump, press CTRL+SHIFT, and click a position on the 
clump to move from, then click a new position to move to 

or 
· on the Alter menu, click Move, and click a position on the clump to 

move from, then click a new position to move to 
 
You can scale, rotate, and mirror clumps during the copy or move process.  
 
You can also repeat clumps with the Construct, Array commands.  
 
In addition you can rotate clumps with the Alter, Transform, 2D, and 3D 
Rotate commands, and the Object, Reposition command.  
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6.2 Rotating clumps 
 
The example below illustrates a door rotated to a  new position using the  
Alter, Transform 2D command: 
 
 
 
 
 
 
 
 
 
 
There are two MicroGDS commands you can use to move and rotate a clump 
in 3D: 
 

· Alter, Transform, 3D rotate, and  
· Object, Reposition 

 
The example below illustrates a door handle rotated and moved to a new 
position on the door face using the Alter, Transform, 3D Rotate command.  
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1. Click a position 
to rotate about  

2. Click a position 
to rotate from  

3. Click a position 
to rotate to  

3. Click a position 
to rotate from  

1. Click a position to fix the 
X direction 

2. Click a position to 
fix the Y direction 

2. Click a position for the 
new X direction 

3. Click a position 
for the new Y 
direction 

1. Click a position to 
rotate to  
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The door handle is repositioned on the door face.  
 
The Alter, Transform, 3D Rotate command requires a minimum of seven 
snaps; one to select the clump and 6 snaps to relocate it. If your clump is a 
single object you can use the Object, Reposition command instead of the 3D 
Rotate command.  With the Object, Reposition command only 4 snaps are 
required for the whole procedure. 
 
The following is an example of repositioning the door handle using the Object, 
Reposition command: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

1.  Select the object to 
reposition 

4. Specify the orientation 
of the Y  

 

 
3. Specify the orientation of 
the X or press TAB to cycle 
through the possible axes, in 
the order X, Y, Z, -X, -Y, and   
-Z 

2. Click the new position 
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6.3 Deleting clumps 
You can delete a clump in exactly the same way as any other MicroGDS 
graphic by selecting the clump or clumps and pressing DELETE, or on the 
Edit menu clicking Delete. 
 

6.4 Editing clumps 
You can move the edge of a mesh clump using the Alter, Segment, Move 
command: 
 
 
 
 
 
 
 
 
 
Tip: To ensure the mesh remains flat click the Z=0 button prior to moving the 
edge. 
 

Click a line snap on the flat mesh 
to extend the edge 

Click a second position to extend 
the edge to  
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You can move any edge of a solid clump. This command is useful, for 
example, to create the slope for a pitched roof.  
 
To move the edge of a solid clump:  
1. In the Training data file, open the Cuboid window definition.  
2. On the Alter menu, click Segment Move. 
3. Click a line snap on the edge to move. 
4. Click a second position to move the edge to. 

 
5. On the Edit menu, click Undo. 

6.5 Moving and deleting clump faces    
You can move any face of a clump to a new position.  
To move the face of a clump:  
1. On the Solid menu, click Face, Move. 
2. Click the face to move, using a Face snap. 
3. Indicate the new position of the face, by clicking in the window, or type the  

3D coordinates of the position.  
 

 
You can also delete faces from clumps. 
 
To delete the face of a clump: 
1. On the Solid menu, click Face, Delete. 
2. Click the face to delete, using a Face snap. 

The face is deleted. 

3. On the Edit menu, click Undo. 
 
 
 
 
 
Note that when you delete a face of a solid clump, it becomes a mesh clump.  

Click a line snap on 
an edge of the cube 

Type a coordinate or 
click on the screen 
for the new position. 

Click the face to move 
 

Click the face to delete 
 

Click a position to extend 
the face of the clump to 
 



48  MicroGDS 

6.6 Splitting a clump into faces 
You can split a clump into its individual faces; each face becomes a separate 
mesh clump. In MicroGDS this is known as fragmenting a clump. 
 
To fragment a clump into its individual faces: 
1. Select the cube. 
2. On the Solid menu, click Clump, Fragment. 

Note that the ‘primitives selected’ change from 1 to 6. 

The clumps are separated into their constituent faces.  
 
 
 
 
 
 
 
 
 
 
To rejoin clump meshes together: 
1. Select the faces of the cube.  
2. On the Solid menu, click Clump, Create.  

Note that the ‘primitives selected’ change from 6 to 1. 
 
If two clumps have coincident edges of the same length, and the edges 
have opposite directions, the clumps are joined to form a single clump. For 
more information refer to Help.  

 

The clump is fragmented. 
(One of the meshes has 
been moved to see the 
result of the fragment.) 
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6.7 Slicing clumps 
You can slice a solid clump or a mesh clump in the XY plane. 
To slice a clump: 
1. Select the cube. 
2. Set the axes so that the XY plane defines the slice that you want to make, 

as illustrated below. 
3. On the Solid menu, click Boolean, Slice. 

The clumps are sliced in the XY plane. 

4. On the Edit menu, click Undo. 
 
If the original clump was a solid clump, faces are added to the cut surfaces to 
create two new solid clumps. If the original clump was a mesh clump, the cut 
surfaces remain open to create two new mesh clumps.  
 
You can slice a clump and leave either the clump above the XY plane or the 
clump beneath the XY plane. To slice and delete the clump below the XY 
plane: 
1. The axes are already set so that the XY plane defines the slice that you 

want to make.  
2. Select the cube. 

3. On the Solid menu, click Boolean, Slice Delete Below. 
4. On the Edit menu, click Undo. 
 

X 
Y 

Z 
The axes are 
repositioned 
here 
 

The X axis is placed 
with a middle snap 
along this line 
 
 

The Y axis is placed 
with a middle snap 
here 
 The clump is sliced 

at the XY plane. 
 (To see the result 
of the slice the top 
half of the clump 
has been moved) 

Original clump Slice Delete Below Slice Delete Above 
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To slice and remove the clump above the XY plane: 
1. The axes are already set so that the XY plane defines the slice that you 

want to make. 
2. Select the cube. 
3. On the Solid menu, click Boolean, Slice Delete Above. 
4. Click Undo. 
 

6.8 Adding clumps together 
You can create one clump by adding together clumps that intersect or touch 
each other. The result is a single clump on which you can perform more 
Boolean operations, for example, move, copy, and transform. The clump th at 
you add to is called the workpiece. 
 
To add a clump to the workpiece: 
 
1. Open the ‘Newel post’ window definition. 

 

 

The newel post has a ball on top of the post. They are currently two 
separate solid clumps. You will add the ball to the post.  

2. Select the ball to add to the newel post (the workpiece).  
Note that you can only add clumps to the workpiece if they are touching or 
intersecting, and are solid clumps. 

3. On the Solid menu, click Boolean, Add to Workpiece. 
4. Click the newel post. 
 
The ball is added to the newel post to make one solid clump. 
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6.9 Subtracting clumps 
You can take one clump away from another clump. The Subtract commands 
are useful for creating holes in walls, or removing parts of a clump.  
 

 
 
 
 
 
To subtract clumps from the workpiece: 
 
1. Open the ‘Newel post dimples’ window definition. 
2. Select the spheres around the outside of the newel post.  
3. On the Solid menu, click Boolean, Subtract from Workpiece. 
4. Click the newel post. 

The  spheres are subtracted from the post.  
 

Select 4 spheres  
around the side 
of the post  

Snap onto the 
post clump. The 
selected spheres 
are removed 
from the 
workpiece 

Before subtraction After subtraction 
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You can subtract a single solid clump from a selection of other solid clumps. 
 
The example below has a clump (the handrail) subtracted from the balusters.  

 
 
To subtract a solid clump or clumps from a single clump:  
1. Open the ‘Newel post and balusters’ window definition. 
2. In Object mode, select the balusters from which to subtract the handrail.  
3. On the Solid menu, click Boolean, Subtract from Selection. 
4. Click the handrail, holding down CTRL to retain the handrail.  

The handrail is subtracted from the balusters. 

6.10 Intersecting clumps 
You can create new solid clumps from the intersection between one solid 
clump and a selection of other solid clumps. 
 
The example below is created from the intersection of a rosette with a dome.  

 
 
To intersect clumps: 
1. Open the ‘Rosette’ window definition. 

The data contains two clumps, one a rosette and one a dome.  

Before subtraction After subtraction 
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2. Select one of the clumps that you want to intersect.  
3. On the Solid menu, click Boolean, Intersect with Selection. 
4. Click the clump that you want to intersect with the selected clump. 

Note that the rosette retains its shape, but now has a domed top.  
You can retain the graphics that represent the result of two overlapping 
clumps by holding down CTRL. 

6.11 Creating holes in solid clumps 
You can punch a hole through a solid clump using an existing closed line 
primitive to define the shape of the hole. 
 
The line primitive must lie in the XY plane if you want to use its true shape. If it 
does not, it is shadowed onto the XY plane. 
 
To punch a hole through a clump: 
 
1. In the Training Data file open the ‘Hospital Sign’ window definition. 
2. Spin your X axes by 90d, so that the H lies in the XY plane,.  
3. Select the signboard through which you will punch the hole.  
4. On the Solid menu, click Boolean, Punch. 
5. Click the letter H as the outline for the hole. 
6. Change the View Mode to Shaded, to clearly see the result.  

 
 
7. Change the view back to wireline and click Undo. If the post is now drawn 

in front of the H click CTRL+H. 

6.12 Creating  pockets in clumps 
As illustrated above, the Punch command creates holes all the way through a 
solid clump. The Pocket command punches though the clump until it meets a 
specified distance from the XY plane. 
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You can create a pocket in a solid clump using an existing closed line 
primitive to define the shape of the pocket.  
 
To create a pocket in a clump: 
1. Select the signboard in which to make the pocket.  
2. On the Solid menu, click Boolean, Pocket. 
3. Type 150 for the Z depth at which you want the pocket to start, and then 

press ENTER.  
4. Click the letter H as the outline for the pocket. 

 
 
5. Click Undo. 

6.13 Creating a profile of a clump 
You can create a 'profile' from a solid clump using an existing closed line 
primitive to define the shape of the profile. The area outside the closed line 
primitive is removed. 
 
The line primitive must lie in the XY plane if you want to use its true shape. If it 
does not, it is shadowed onto the XY plane. 
 
To profile a clump: 
1. Click the signboard from which to create the profile.  
2. On the Solid menu, click Boolean, Profile.  
3. Select the letter H to define the outline of the profile. 
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4. Click Undo 
 

6.14 Carving clumps 
The Carve command cuts away the clump outside of the selected closed line 
primitive similar to the profile command, until it meets a specified distance 
from the XY plane. 
  
You can carve a shape from a clump using an existing closed line primitive to 
define the shape of the carving. 
 
To carve a clump: 
1. Select the signboard from which to make the carving.  
2. On the Solid menu, click Boolean, Carve. 
3. Type 50 for the Z depth at which you want the carving to stop,  and press 

ENTER. 
4. Click the letter H, to be used as the outline for the carving.  
 

 
 

5. Save and close the Training Data file. 
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Exercise 9 Creating the ground floor  
 
The beach house ground floor is on three levels. In this exercise you will 
extrude the ground floor to one level and then use the Pocket command to 
create the different floor levels. 
 
1. In the Beach house file, open the ‘Floors’ window definition.  
2. On the Set menu, click Axes, Centre. 
3. Switch to 3D view. 
4. Select the object Floor:, and on the Solid menu, click Extrude, and extrude 

from the bottom of the posts //-300 to //1550. 
5. With the floor selected, on the Solid menu, click Boolean, Pocket. At the 

prompt type 950, then click onto the Living Room object.  

The height of the living room floor is changed to 950.  

6. Repeat step 5 as follows: 
· pocket the garage floor to 1400 
· pocket the store floor to 350 
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Exercise 10 Creating the steps 
 
In this exercise, you will use the Pocket command to create the steps between 
the living room and the store, and between the hall and the livi ng room. 
 
1. You have the ‘Floors’ window definition open from the previous exercise.  

First, you will create the steps between the living room and the store, as 
illustrated below: 

 
 

2. With the object Floor: selected, on the Solid menu, click Boolean, Pocket. 
At the prompt type 750 and click onto the top step.  

3. Repeat step 2, but type 550 and click onto the second step.  
 

 

Now you will create the steps between the hall and the living room.  

4. Repeat step 2 except at the prompt type 1350 and click onto the top step; 
for the bottom step, type 1150 and click onto the bottom step.  
 

 
 

5. Save your Beach house file. 
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Exercise 11 Creating the roofs 
 
In this exercise, you will use the Sweep command to create the main roof and 
the dormer roof. 
 
1. Open the ‘Roofs’ window definition. 
2. In primitive mode, select the ‘hipped roof profile’, as illustrated below:  

 
 
3. On the Solid menu, click Construct, Sweep, and click on the ‘hipped roof 

sweep line’. Hold down CTRL to retain the original graphics, and click 
again on the sweep line. 

4. Repeat 3 above, selecting the ‘dormer roof profile’. 
5. Using the bottom thumb wheel swing the axes to the right to 0.  
6. Select the ‘mono pitch roof profile’ and sweep it along the sweep line.  
7. On the View menu, click Previous View. 
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Exercise 12 Tidying up the pitched roofs 
 
In this exercise, you will use the Add to Workpiece command to join all the 
roof clumps into one; you will then use the Pocket, and Punch, commands to 
remove the unwanted portions of roof.  
 
1. Select the hipped roof clump. 
2. On the Solid menu, click Boolean, Add to Workpiece, and click onto the 

dormer roof clump. 
3. On the Set menu, click Axes Reset and click onto the triangle under the 

dormer roof, as illustrated below: 

 
4. Select the dormer roof clump 
5. On the Solid menu, click Boolean, Pocket, and type –5000 at the prompt. 

Click the triangle again. (This will delete the unwanted section of roof 
inside the building.) 

6. On the Set menu, click Axes Reset, and click the triangle under the hipped 
roof. 

7. Select the hipped roof clump. 
8. Click Solid, Boolean, Punch, and click the triangle under the hipped roof. 
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Exercise 13 Removing the corner from the mono pitched roof 
 
In this exercise you will delete the unwanted part of the mono pitch roof.  
1. View the model in 2D, and click onto the mono pitch roof, (check that the 

object selected is Mono pitch roof:). 
2. On the Set menu, click Axes, Centre, and select the mono pitch roof.  
3. On the Solid menu, click Boolean, Punch, and click onto the rectangle in 

the bottom right of the roof clump as illustrated below. Do not click the 
entrance area graphics. 

The unwanted part of the mono pitch roof is deleted. 
 

 
 

 
Exercise 14 Extruding the garage roof and entrance roof 
 
In this exercise you will extrude the entrance lobby roof and the garage roof.  
1. View your model in 3D and swing round to the entrance hall.  
2. On the Set menu, click Axes, Centre. 
3. Select the Entrance lobby roof inner rectangle and on the Solid menu, click 

Extrude, and extrude from //3150 to //3350.  
4. Extrude the outer rectangle from the top of the previous extrusion to //R50.  
5. Swing your view round to the garage. 
6. Select the Garage roof and extrude the inner rectangle from //3900 to 

//4100. Extrude the outer rectangle from the top of the previous extrusion 
to //R50. 
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Exercise 15 Constructing the kitchen roof 
 
In this exercise, you will extrude the kitchen roof and then use the Slice 
command to create the roof slopes. 
 
1. Swing the view round to the kitchen roof (0 degrees on the bottom 

thumbwheel will give you a good view). 
2. Select the kitchen roof graphics and extrude from //4250 to //6000.  

You will now use the Slice command to cut the clump into two to create 
the roof and the fascia. 

3. Move the axes to //4325 and click Solid, Boolean, Slice. This will cut the 
clump into two. 

You will now use the Slice Above command to create the slopes to the 
kitchen roof. 

4. Select the top half of the previously sliced clump. 
5. Move the axes to the bottom corner of the top extrusion, furthest away 

from the garage as illustrated below: 
 

 
 

6. Spin the axes in the Y direction by –22 degrees. On the Solid menu, click 
Boolean, Slice Delete Above. 

7. Move the axes to the other side of the roof and spin the axes in the Y 
direction by 44 degrees. Click Solid, Boolean, Slice Delete Above. 
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8. On the status bar, change the Angle from Skew to 0d. (This will keep the 
axes in the same position but alter the XY plane to a normal orientation.) 

9. Spin the axes in the X direction by –22 degrees and click Solid, Boolean, 
Slice Delete Above. 

10. Save your Beach House file. 

You have now finished creating the roof of the beach house as illustrated 
below: 

 
 
Exercise 16 Creating the walls 
 
In this exercise, you will extrude the walls and then use the Subtract from 
Workpiece command to take the inside cube from the outside cube.  
 
1. Open the ‘Walls’ window definition. Check the scale is set to 1:50.  

First, you will extrude the store and toilet area walls. 

2. On the Set menu, click Axes Centre. 
3. In object mode, select the store area wall and extrude from // -300 to a 

snap on the top of the main roof pitch.  
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4. Extrude the fill-in piece at the rear of the entrance hall (as illustrated 

above) from the underside of the entrance roof to the same height as the 
store area. 

Two clumps have been created, and you now need to remove the inside 
clump from the outside clump. 

5. Deselect your graphics, press F9 (primitive mode), and click the inside 
wall. Click Solid, Boolean, Subtract from Workpiece and click the outside 
wall. 

6. To check that this has worked, deselect the clump and press CTRL+H to 
see your walls in hidden line view. 
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7. Press CTRL+W to return to wireline view. 
8. Reselect the clump and click Solid, Boolean, Add to Workpiece, and add 

the fill-in piece of wall to the Store area. 

You will now remove the top portion of the wall.  

9. Make the roof phase editable. 
10. Select the mono pitched roof clump. Hold down CTRL to retain the clumps, 

and then click Solid, Boolean, Subtract from Workpiece. 
11. Click on to the wall clump and note that two primitives are now selected.  
12. Select the primitive above the roofline and delete it.  
13. Go to Hidden View – your graphics should now be as illustrated below: 

 

 

Next you will extrude the main living area walls. 

14. On the Set menu click Axes centre. 
15. In object mode, select the main area wall, and extrude from // -300 to a 

snap on the top of the main roof pitch.  

Again two clumps have been created, and you now need to remove the 
inside clump from the outside clump. 

16. To select the inside wall, hold down CTRL and click the outside wall. Click 
Solid, Boolean, Subtract from Workpiece and click the outside wall.  

You will now remove the top portion of the wall.  

17. Select the main roof clump, and click Solid, Boolean, Subtract from 
Workpiece, holding down CTRL to retain the clump. 

18. Click the wall clump and note that this time three primitives have been 
created. 
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19. Select the two primitives above the line of  the roof and delete them. Go to 
Hidden line view (CTRL+H) to see the result. 

 

Finally, you will extrude the garage, kitchen and entrance walls.  

20. Go back to wireline view and swing your model round to view each wall 
primitive as appropriate. 

21. Select the Garage, Kitchen and Entrance wall primitives in turn and 
extrude from //-300 to the underside of their corresponding roofs.  

22. You have now finished extruding the walls. Go to Hidden Line view and 
swing round your model to view it. 
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Exercise 17 Adding the doors and windows 
 
In this exercise you will punch holes in the walls to make room for the 
windows and doors. To save time, the clumps required to form the holes for 
the windows and doors have been created for you.  
 
First, you will use Add to Workpiece command to merge the walls into one 
clump. 
 
1. Select one of the wall clumps and click Solid, Boolean, Add to Workpiece. 

Select the other four clumps in turn to create one clump for the walls.  
2. Make the phase ‘Openings solid’, the current editable phase.  
3. In Object mode, select the window and door openings.  
4. Use Solid, Boolean, Subtract from Workpiece to subtract them from the 

walls. 
5. To add the windows and doors, drag the layer WINDOWS AND DOORS 

from the Layers tab on the Document Organiser into the Mini Window 
Editor. 
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7 RENDERING  
 

7.1 Rendering views  
   
Up to now you have viewed your scene in the MicroGDS window using 
window definitions. You can render a 3D view to create an image that uses 
lights, materials, and an environment that you have set up.  
 
This section briefly gets you started and will enable you to render your view. 
You will re-visit the renderer and its options after you have covered the topics 
Working with materials, Working with lightstyles, and Environment shaders.  
 
To render a 3D model: 
 
· Open the Training data file and the Block window definition. 

Selecting a render view quality 
You can render your model in one of seven render modes ranging in output 
quality from a flat mode, which is very similar to a flat shaded view in the 
normal MicroGDS drawing window, to a very high quality render mode, 
Raytrace Full. However, the more sophisticated the render quality, the more 
realistic the image is, but the longer the image will take to render.  
 
· On the Render menu click Quality, Preview. 

Preview mode is a mid-range quality render, which is quick to refresh. 

Lighting the scene 
Although you have not yet created lights in your scene, you can still render the 
model by switching on the default light. 
 
To switch on the default light: 
 
1. On the Render menu, click Default Light. A tick adjacent to the command 

indicates the light is on. 

Setting the render window size 
You can select the size at which rendered images are displayed.  
 
2. On the File menu, click Preferences, and click the Renderer tab.   
3. From the Image size list, select Render Window.  

Selecting ‘Render Window’ means that the render window expands to 
match the size of your current graphics window: if the graphics window is 
maximised the rendering could take a long time with a complex model.  

4. Select the Save preferences box and click OK. 



68  MicroGDS  

 

 
5. To prevent the render window from filling the whole screen ensure your 

current window is not maximised; if it is then click the restore button.  

Updating the render data 
The first time you render a model in each new document in a MicroGDS 
session, you must provide the renderer with all the information about the 
model. 
 
· On the Render menu, click Update All.  

Refreshing the scene 
To see your model rendered you must refresh the scene.  
· On the Render menu, click Refresh. 

Whenever the render window is on the screen, you can double-click inside 
the window to refresh it.  

A rendered image of your block is displayed in the render window as 
illustrated below: 

 

 
 

If you want to stop MicroGDS from rendering, press CTRL+BREAK.  
 
Whenever you make edits to the scene or change the view, you must update 
the renderer. The Update All command can take a long time with complex 
models. MicroGDS therefore provides four other Update commands to speed 
up the process: 
·  Environment updates the environment settings 
·  Geometry updates any changes to geometry in the model  
·  Lights  updates lighting and shadows in the scene 

You do not need to update the scene when switching on 
and off the default light. 

·  View  updates the view extent, line of sight, and projection  
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8 Working with materials 
 
You have learnt how to create and edit 3D geometry in MicroGDS and view 
your model in various ways including a shaded view. In a shaded view, 3D 
geometry is displayed in different shades of grey. This is because MicroGDS 
has assigned a default colour of white to each clump, and an eye light is 
added so that you can see the data. 
 
In this section you will learn how to assign various colours and textures to 
your 3D models. These colours and textures are called materials. You can 
create a material with a combination of the five shaders listed below. Each  
shader defines an aspect of the material’s appearance:  
 
Colour  defines the colour of the surface 
Reflectance defines how much light is reflected by a surface 
Transparency defines how much light can pass through a surface 
Displacement simulates small surface perturbations without changing the 

geometry 
Texture space defines how the previous four shaders are wrapped around 

the object 
 

8.1 The Colour shader 
Colour shaders define the colour of a surface at any point in space. It can be a 
simple colour, or a complex surface pattern.  You specify a colour shader on 
the Colour tab of the Material dialog box. 
 
Colour shaders are divided into two categories:  
· Solid shaders 

The effect is constant over a surface and throughout a clump. 
· Wrapped shaders 

Wrapped shaders depend on the position of a particular point on a surface 
in 2D 'Texture space', defined by a Texture space shader . Imagine the 
graphics are wrapped with wrapping paper.  

For a full list of Colour shaders available in MicroGDS, see Colour shaders in 
Help. 
 
As you will see from the Help there are many Colour shaders. The following 
examples illustrate the basic principles of how to change the properties of 
some of the Colour shaders. 

Plain colour shader 
You use the Plain Colour shader to create a material with a single colour. 
When you create a material, it immediately becomes current and any selected 
clumps are assigned that material. Any new clumps you create are also 
assigned the current material. 
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To create a material using the Plain Colour shader:  
1. Open the Training data file, and the Material1 window definition.  
2. Select the small table in the view. 
3. On the File menu, click Material Modify. 

The Material dialog box is displayed: 

 
4. Select Plain from the Shader list. 
5. To specify a custom colour, double-click the current colour, and click  to 

display the Define Colour dialog box. 
 

 
6. Choose a green/blue colour, click OK, and click the Preview button to see 

the result. 
 

 
7. Click Save As and name the material ‘table’. 

To see the result of assigning your material:  
8. On the Render menu, click Update All. 
9. On the Render menu, click Refresh. 

The render window is updated to show your material.  
10. Save and close the Training data file. 
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Exercise 18 Adding materials to the Beach house walls  
  
In this exercise you will add plain colour to the Beach house walls. Note that 
you will be adding a Displacement shader to this material at a later stage.  
 
1. Open the Beach house file, and the ‘Walls’ window definition.  
2. Select the wall clump and create a plain material of your choice for the 

walls. Something like wheat is a suitable colour. 
3. Save your material and name it walls. 
4. Press CTRL+R to see a shaded view of the walls. 

 
 
5. To view the walls in the Renderer click Render, Update All and then 

Render, Refresh. 
6. Save and close the Beach house file. 
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Wrapped Image colour shader 
 
You use the Wrapped Image Colour shader to create a texture by wrapping 
an image.  
 
1. Open the file Training data, and the Material1 window definition.  
2. Select the floor clump. 
3. On the File menu, click Material Modify. 
4. Select Wrapped Image from the Shader list.  
5. Click  to display the standard file selector to select the image file.  
6. Browse to your MicroGDS program files\Textures and select 

Floors\redpave.bmp. 
 

 
 

The Softness property in the wrapped image shader has a default value of 
1.0. Any number less than 1 will sharpen the image, and any value greater 
then 1.0 will blur the image. 
Note: You will need to know the real world size of your bitmap file to 
enable you to map the image to MGDS geometry accurately. 
The above example, REDPAVE.bmp, is an image file of blocks. Each 
block in a real world is 200mm x 100mm including one joint. Therefore a 
real world dimension of this image file is 400mm by 400mm. 

 
 

7. To set the size of your image file, click on the Texture space tab then 
select Object Axis from the list.  Double-click on the Scale box and type 
400. (The Texture space tab will be fully explained later).  

 
8. Click Preview to see the result. 
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9. Save the material as ‘Brick floor’. 
10. Click Render, Update All, and Render, Refresh to see the results.  
11. Save and close the Training data file. 

 
Exercise 19 Adding a wood texture to the deck 
 
In this exercise you will add a wood texture to the deck.  
 
1. Open the Beach house file, and the ‘Floor’ window definition. 
2. Select the deck. 
3. Open the Material dialog box. 
4. From the Colour shader tab, select Wrapped Image.  
5. Click  to display the standard file selector. 
6. Browse to your MicroGDS program files\Textures\ and select 

Wood\Mwd0159.bmp. 
7. Click the Texture space tab and select Object Axis, and in the scale box 

type 800. 
8. Save the material as Deck. 

 
9. Click Render, Update All, and Render, Refresh, to see the results.  
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Wrapped Textured Brick colour shader 
 
Use the Wrapped Textured Brick colour shader to create a complex brick 
pattern. The brick colour is made up of two colours that are randomly mixed to 
form a 'base colour'. The base colour is then varied to create a textured effect.  
 
1. Open the Material dialog box. 
2. On the Colour tab, select Wrapped Texture Brick from the list.  
 

 
 
The attributes for Wrapped Textured Brick are as follows:  
 
Scale  

  
Scale of the brick pattern (usually set to 1:0) 

Brick Width 
  

Width of the bricks (at a scale of 1.0) in millimetres. (Note 
the default of 215mm is typical for UK standard bricks width) 

Brick Height 
  

Height of the bricks (at a scale of 1.0) in millimetres. (Note 
the default of 65mm is typical for UK standard bricks height)  

Mortar Size 
  

Width of the space between the bricks (at a scale of 1.0) in 
millimetres   

Brick Colour 1 
Brick Colour 2 
Mortar Colour

   

One colour for the bricks  
Another colour for the bricks  
Colour for the space between the bricks 

Rough Scale 
  

Defines the complexity of the rough edge of the bricks.   
Values less than 1.0 represent rougher edge of the pattern 
and values greater than 1.0 create more complex edge.  

Rough Amplitude Magnitude of the roughness.  Values less than 1.0 produce 
smaller amplitude and values greater than 1.0 produce a 
more wobbly pattern. 

 
3. In the previous example you set the Texture space object axis to 400. The 

wrapped brick texture has its own scale property and therefore the Texture 
space setting should be reset to the default value of 1.  

4. Click Preview to see the result. 
5. Close the Material dialog box without saving the mater ial. 
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Exercise 20 Adding a wrapped checker material to the floor 
 
In this exercise you will add a checker pattern to the internal floor of the beach 
house.  
 
1. Open the Beach house file, and the ‘Floors’ window definition.  
2. Select the floor. 
3. Open the Material dialog box. 
4. On the Colour tab, select Wrapped Checker from the list.  
5. Change the Size attribute to 800mm. 
6. Click the Texture space tab and select Object Axis, and ensure the scale is 

set to 1. 
7. Click Preview. 
8. Save the material as ‘Internal floor’. 
9. Click Render, Update All, and Render, Refresh, to see the results.  

 

 
 
You are also going to add a wrapped roof tile material to the roofs.  
 
1. Open the ‘Roof’ window definition, and select the roof clumps.  
2. Move the axes to the top of the hipped roof and set the object hook to 

0/0/0. 
3. Open the Material dialog box, click the Colour tab, and select Wrapped 

Roof Tiles from the list. 
4. Set the following attributes: 

Scale = 1 
Pattern = Flat 
Tile length = 200 
Tile width = 450 
Tile Thickness =8 
Use the default settings for the remaining attributes. 
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5. Click the Texture space tab, and select Object Axis XY from the list.  
6. Save the material as ‘Slate roof’. 
 

 
 
7. Update the renderer, and then refresh to see the results.  
8. Save and close the Beach house file. 
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8.2 The Reflectance shader 
 
Reflectance shaders define how much light is reflected by a surface towards 
the eye position: that is they define the 'finish' of the material. The overall 
effect depends upon the material properties of the surface, and the lighting 
that illuminates the surface. 
 
You can use Reflectance shaders to create, for example: 
 
· a dull and non-glossy material (Matte) 
· a material with a specular metallic appearance (Metal), or  
· a highly-polished material (Plastic) 
 
Preview, Full, Raytrace Preview, and Raytrace Full render qualities support 
reflectancy. 
 
For a full list of Reflectance shaders available in MicroGDS see Help.  
 
The default Reflectance shader is Matte which has only two attributes, 
Ambient Factor and Diffuse Factor. For materials that do not reflect light use 
the matte option. 
 
Many of the Reflectance shaders have a number of options. To illustrate the 
properties of this shader you will look in more detail at Glass, Gold, and 
Plastic. 

Glass Reflectance shader 
1. Open the Training data file, and the Glass Ball window definition.  
2. In primitive mode, select the glass ball. 
3. Open the Material dialog box. 
4. On the Reflectance tab, select Glass from the list.  

The Glass Reflectance shader reflects and transmits light.  
 

 
 



78  MicroGDS  

 

The attributes are: 
Specular factor The brightness of light highlights over the surface, the 

higher the value the brighter the highlights. 
Mirror factor Adjust this value to increase or decrease the reflections of 

the surrounding geometry. (Note the mirror factor is only 
effective if you have surrounding geometry in your model). 

Transmission 
factor 

Change this attribute to set the degree of transparency of 
the geometry. 

Roughness The roughness attribute affects the spread of specular 
light over the surface. The higher the value the greater 
spread of specular light over the geometry. 

Refraction  The default value in the refraction attribute has been set 
for glass. In most cases this value will not need to be 
changed. 
The index of refraction of some common elements is 
listed below: 
ice   = 1.31 
water   = 1.333 
plexiglas  = 1.51 
dense glass  = 1.66 
diamond  = 2.417 

 
5. Save the material as Glass and render the image.  

You will not see the glass effect in a Shaded view, or in any View quality 
less than Preview in the render. 
 

 
 
6. Save and close the Training data file. 
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Exercise 21 Adding glass to the Beach house 
 
In this exercise you are going to add glass to the front of the beach House.  
 
1. Open the Beach house file, and the ‘Walls’ window definition.  
2. Select the walls layer and create a new object called Glass.  
3. Switch to 2D view and zoom in to the front window as illustrated below: 
 

 
4. Create a rectangle with a fixed Y size of 6mm, and position the rectangle 

with middle snaps in the window as illustrated below: 
 

 
5. Extrude the rectangle from //950 to //4500.  
6. Open the Material dialog box. 
7. From the Colour tab, select Plain from the list. Click   to display the 

Define colour dialog box. Select a light bronze colour.  
8. Click the Reflectance tab, and from the list select Glass. Accept the default 

settings offered. 
9. Save the material as GLASS (all uppercase). 
10. Render your image to see the result.  
11. Save and close the Beach house file. 
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Gold Reflectance shader 
1. Open the Training data file, and the Glass ball window definition.  
2. Select the stand underneath the glass ball. 
3. Open the Material dialog box. 
4. Click the Colour tab, select Plain from the list, and select the colour Gold.  
5. From the Reflectance Shader list, select Gold. 
 

 
 
The attributes are: 
 
Ambient 
factor  

The Ambient Factor attribute controls the amount of ambient 
light that is reflected from a reflectance material. The higher the 
number, the more light is reflected. 

Diffuse 
factor  

The Diffuse Factor attribute controls the amount of diffuse light 
that is reflected from a reflectance material. The higher the 
number, the more light is reflected. 

Specular 
factor   

The brightness of Light highlights over the surface, the higher 
the value the brighter the highlights. 

Mirror factor Adjust this value to increase or decrease the reflections of the 
surrounding geometry. (Note the mirror factor is only eff ective if 
you have surrounding geometry in your model.)  

Roughness
  

The roughness attribute affects the spread of specular light 
over the surface. The higher the value the greater spread of 
specular light over the geometry. 

 

 
 
 
 

A roughness value of 0.4 A roughness value of 0.1 (Default) 
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6. Change the Mirror factor to 0.4. 
7. Save the material as Gold. 
8. To see your material, select Render Update All, and Render Refresh.  

 

 

Plastic Reflectance shader 
Use the Plastic Reflectance shader when you require highly polished 
materials without reflections.  
 
You will add a plastic finish to the small table that you coloured green on page 
69. 
 
1. In the Training data file, open the ‘Material1’ window definition.  
2. Select the small green table. 
3. Open the Material dialog box, click the Reflectance tab, and select Plastic 

from the list. 
Plastic has the same attributes as gold with the exception of Specular 
Colour which replaces the mirror attribute. You can change the colour of 
the specular highlights in the material. 

4. Click the Preview button. 
 

 
 
5. To see your material, select Render Update All, and Render Refresh.  
6. Save and close the Training data file. 
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Exercise 22 Adding a Reflectance shader to the floor 
 
In this exercise you will create a shiny surface and apply it to the tiled floor of 
the Beach house. To see the effects of the reflections in the floor you will first 
need some geometry in the room. 
 
1. Open the Beach house file, and the ‘Floor’ window definition.  
2. Create a new layer FURNITURE. 
3. Display the library tab in the Document Organizor and select the file 

FURNITURE. 
4. Copy as instances, the following items, and place them as illustrated 

below. Place them with Face snaps on the floor, which is at 950mm above 
the Set axes normal position. 
 

 
 

From the sofas layer: 
  Guest Chair Triple Seat: (rotate 180) 
  Guest Chair Double Seat:  
From the Table layer: 
  Table: 

5. Select the Floor and open the Material dialog box. 
6. Select the Reflectance tab.  
7. Select Mirror from the list and change the attributes as listed below:  
 
Ambient factor  The default Ambient factor of .1 is far too low and creates 

a dark material. A good starting point for this attribute is 
1.0. 
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Diffuse factor  The diffuse factor is the spread of light over the material, 
the default value is 0.1. This attribute should be increased 
to 1.0. 

 
Specular factor  This attribute is most effective on rounded edges, curved 

surfaces, and when point and spot lights are used. There 
are no curved surfaces in the floor. Setting a high 
specular value will wash the checker pattern out of the 
floor. Therefore set a very low specular value of 0.1  

 
Mirror factor To reduce the floor reflection, change the default mirror 

attribute from 0.8 to 0.2. 
 
Roughness  The roughness attribute adjusts the height of 

perturbations, a higher value increases the spread of 
specular highlight over the material. You have a low 
specular value resulting in a very smooth floor and 
therefore this attribute has little effect in your floor. Set a 
low value of .001. 

 
8. To see your material, select Render Update All,  and Render Refresh. 
 

 
 
9. Save and close the Beach house file. 
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Transparency shaders 
Transparency shaders define how much light can pass through a material 
(how transparent or opaque it is).  
 
When you select a Transparency shader, the effect is applied to a  material 
only when the Transparency check box is selected. Full, Raytrace Preview, 
and Raytrace Full render qualities support transparency.  
 
There are nine Transparency shaders available in MicroGDS. See Help for a 
full list. 
 
To illustrate the properties of the Transparency shader, you will look in more 
detail at the Fractional transparency shader in conjunction with the Wrapped 
Image colour shader. 

The Fractional Transparency shader 
Use the Fractional Transparency shader to create a uniform transparency  
through your geometry. 
 
The attributes are: 
 
Coverage Defines the transparency by entering a coverage factor 

between 0 and 1. 
0 produces a filter that transmits light of all colours 
1 produces a filter that transmits no colours. 

 
1. On the Material dialog box, select the Transparency tab, and select 

Fractional from the list. 
2. Select the Transparency check box. 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 

Select this check box. 
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Wrapped Stencil Transparency shader 
The Wrapped Stencil Transparency shader is ideal for removing a background 
colour from an image. This is used when you place photographs of trees, 
people, etc. in a 3D scene. This shader is used in conjunction with the 
Wrapped Image option in the Colour shader. 
 
The attributes are: 
File name The image file to be used. The files must be BMP, TGA, 

JPG or TIF format. Note that highly compressed JPG 
files are not suitable as stencils because artefacts 
introduced in the image create unwanted data around 
the edges of the image. 

Transparent colour The colour for the transparent part of the stencil.  
 
It is advisable when creating the image to be used as a stencil to make the 
transparent colour unique from the image colour.  
Note that the behaviour of Wrapped shaders also depends upon the selected 
Texture space shader. 
The following is an example of how to create a tree using the Wrapped Stencil 
Transparency shader: 
 
1. Open the image file Tree.tif in a Paint program and ensure the background 

is a solid colour.  
Note the size of the image file and calculate the aspect ratio. The image 
below is 494 X 562 pixels high. Therefore the aspect ratio of this image is 
the height / width which = 1.137656. You will need this value later on.  
 

 
 
1. Open the Training data file, and the Tree window definition.  
2. Change the scale to 1:1. 
3. Select the clump mesh, which is 7000 X 8000, and is an approximate size 

of a tree in a real world. 
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4. On the File menu, click Material Modify. 
5. Click the Colour tab and select Wrapped Image from the list. Browse for 

the image file ‘3D Training data\Tree.tif’. Press ENTER to confirm your 
selection. 

6. Select the Transparency check box on the Material dialog box. 
7. Click the Transparency tab, and select Wrapped Stencil from the list. 

Browse for your image file ‘3D Training data\Tree.tif’. Press ENTER to 
confirm your selection. 

8. Select magenta as the transparent colour attribute.  
This means that any magenta in the image file will be flagged as 
transparent. 

9. Click the Texture space tab and select Arbitrary Plane from the list.  
Type in the following values: 
 
Scale 7000 (The width of the rectangle in MicroGDS.)  
Aspect 
Ratio 

1.137656 (The height of the image is calculated from the 
dividing the image files height and width.) 

Origin -3500/00/00 (The origin of an Image file origin is at the 
bottom left hand corner. Type the offset from the object hook 
point to corner of the rectangle.)  

Normal 
Vector 

0/0/1 (The normal vector defines which face of a clump you 
wish to map your image onto.) 

Up Vector 0/1/0 (The Up vector defines the rotation of the image.)  
 

10. From the Preview list, select ‘Selected Primitives’, and click the Preview 
button. 

 

 
 
11. Save the material as Tree and render the scene.  
12. Save and close the Training data file. 
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8.3 Displacement  shaders 
Displacement shaders define small perturbations (peaks and troughs) on the 
surface of the material, so that the way in which the surface reacts to light 
falling upon it is changed. 
 
Preview, Full, Raytrace Preview, and Raytrace Full render qualities support 
displacement. The effect of a Displacement shader is applied to a material 
only if the Displacement check box is selected on the Material dialog. 
 
There are twelve Displacement shaders available in MicroGDS. For a full list 
see Help. 
 
To illustrate the properties of this shader, you will look in more detail at the 
Rough and Wrapped Bump Map Displacement shaders.  

Rough 
You can use the Rough Displacement shader to simulate an effect of rough 
ground, or any material that has an uneven surface.  
 

 
 
The attributes are: 
Scale  Defines the scale of the displacement pattern.  
Amplitude Defines the height of the surface displacements. The higher 

the number the more pronounced the roughness will be.   
Detail You can select one of seven preset levels of roughness 

detail ranging from None, which removes any perturbations, 
to Extremely High, which produces a high level of detail.  

Sharpness  Defines how sharp the transitions between peaks and 
troughs are to be. 

 
The above example illustrates the effect of the sharpness attribute. In the 
nearest panel, which has a sharpness setting of 1, the trough edges are 
clearly defined and very sharp. In the panel that is furthest from you, which 
has a sharpness setting of 4, the transition from one peak to the next is very 
soft. 
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Exercise 23 Adding a rough finish to the walls of the Beach house 
  
In this exercise you are going to add a rough finish to the be ach house walls: 
 
1. Open the Beach House file, and the ‘Wall’ window definition.  
2. Select the walls. 
3. Open the Material dialog box, and select the Displacement check box.  
4. On the Displacement tab select Rough, and specify the following settings:  

Scale = 200 
Amplitude = 0.3 
Detail = High 
Sharpness = 5 
 
Your walls will now have a rough finish as illustrated below: 
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Wrapped Bump Map 
You can use an image file to create an embossed effect on the surface of your 
geometry. The example below uses a Colour shader of gold and a black and 
white image file. White areas have maximum displacement and black areas 
have no displacement.  
 

 
 
The attributes for Wrapped Bump Map are:  
 
File name The image file to be used. The example above shows that 

"\PATTERNS\Wrought1.bmp" file is selected. 

Softness The Softness property in the wrapped image shader has a 
default value of 1.0. Any number less than 1.0 will sharpen the 
image, any value greater then 1.0 will blur the image.  

Amplitude Type a number to define the maximum amplitude of 
displacement. 
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Exercise 24 Mapping a texture file to the house gable end 
In this exercise you are going to map an image file onto the front gable end of 
the Beach house, using the Wrapped Bump Map Displacement shader.  
1. Open the Beach House file and the ‘Gable End’ window definition. 
2. Reset the axes onto the profile shape. Click onto the profile and sweep 

along the graphics as illustrated. 

Profile

Sweep line

 
3. Select the roof clump and click Solid, Boolean, Subtract from Workpiece.  
4. Holding down CTRL click on the profile shape. 
5. Delete the two pieces of profile above the roof.  

 
6. Select the clump. 
7. Open the Material dialog box, and select the Displacement tab.  
8. Select the Displacment check box. 
9. Select Wrapped Bump Map from the list. 
10. Browse to the file ‘Beach House\textures\Palm.tif’. 
 



3D Training Course  91   

 

11. Set the Softness to 5.0 and the Amplitude to 1.0. 
12. Click the Texture space tab and set the attributes as illustrated below:  

 

 
 

13. Save your material as ‘Palm tree’. 
14. Update the renderer and refresh the scene.  

 

 
 

15. Save and close your Beach house file. 
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8.4 The Texture space shader 
You have visited the Texture space shader on a number of occasions during 
the Materials topic. This has been necessary as Wrapped shaders in the 
Colour, Transparency, and Displacement shaders use the Textu re space 
shader attributes to scale and position the image accurately onto your 
geometry. 
 
Texture space shaders are used in conjunction with other material shaders.  
For example, you use Texture space shaders when you map an image file 
onto 3D models or when you set the aspect ratio or the orientation in which 
the image is to be mapped.  Additionally, Texture space shaders can be used 
in conjunction with other shaders that require you to specify the size, such as 
a combination of Colour shaders and Transparency shaders, or Colour 
shaders and Displacement shaders. 
 
The are nine Texture space shaders available in MicroGDS. For a full list of 
Texture space shaders see Help. 
 
The following example illustrates how different Texture space shaders affect a 
Wrapped Grid Colour shader. 
1. Open the Training data file, and check that the Scale is 1:50.  
2. Select the ‘600x600 Cube’ window definition. 

 
3. Open the Material dialog box, and select from the Colour tab, Wrapped 

Grid. 
4. Enter the following values: 

80 for the width  
180 for the height 
20 for the grid size 

5. Click the Texture space tab. Select Object Axis from the list and set the 
scale attribute to 1.0 

6. Click the preview button. 
7. Save the material as Grid and render the scene.  
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At a scale of 1 this will create 5 gridlines vertically 80mm apart and 2 
horizontal gridlines 180mm apart on each face of the cube, plus a gridline 
along each edge. 

Auto Axis and Object Axis 
Auto Axis creates a Texture space that selects the normal axis that is most 
closely aligned with the surface at each point. 
 
Object Axis creates a Texture space that selects the object axis that is most 
closely aligned with the surface at each point. 
 
To see the difference between Auto Axis and Object Axis:  
1. Select the cube and cut it to the clipboard. 
2. On the Set menu, click Spin Axes Y and type –10. Paste the cube back to 

your drawing. 
3. On the Texture Space tab, select Object Axis. 
4. Update and refresh the renderer 
5. On the Texture Space Tab, select Auto Axis and change the Texture 

space scale to 0.02. 
6. Update and refresh the renderer. 

 

Object X, Y and Z Planes 
Object X, Y or Z Plane Texture space shaders create a Texture space in 
which all points in space are mapped onto a plane of constant X, Y or Z in 
object coordinates. The pattern is aligned to the object's hook poin t. 
In the following illustration the cube base is sitting on the normal XY plane.  

 

Object XY plane 
The Object XY Axes creates a Texture space that selects the X or Y object 
axis that is most closely aligned with the surface at each point. The Z axis is 
ignored. 

Auto Axis Object Axis 

Object Y Plane Object X Plane Object Z plane 
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This shader is useful for shaders such as Wrapped Roof Tiles, where you 
want the shader to wrap around a building, even when the roof is shallower 
than a 45 degree slope. 
 
Scale and Aspect ratio Attribute 

The Scale attribute applies to all of the Texture Space shaders, apart from 
cylindrical and spherical. 

To double the number of grid lines, type a scale of 0.5; to half the number of 
grid lines type a scale of 2.  

 

 

This method of scaling applies only to procedural textures which are 
generated by repeating a defined pattern such as wrapped bricks, wrapped 
grid, and wrapped wood textures. 

If you are using a wrapped image shader, at a scale of 1.0 the image is 
projected onto a one-millimetre square. This may distort the image if it was not 
originally square. The scale multiplies the 1mm square. Therefore, for an 
image 100mm square, enter a scale factor of 100 

For example: 

 

 
 
 

Scale 2.0 
 

Scale 1.0 
 

Scale 0.5 
 

Bitmap image file 
 

MicroGDS data 
Cube 600X600X600 

 

Texture space 
Auto Axis  

Scale = 600 
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Arbitrary Plane Texture space shader 
The Arbitrary Plane Texture space shader creates a Texture space in which 
all points are mapped onto a plane of a specified origin and orientation. 
Together with scale, this shader has a number of additional attributes.  

Aspect ratio 

The aspect ratio applies to the vertical scale of the texture map. For example 
a square image file that is mapped to non-square geometry would tile across 
the surface. 

 

  

 

In the above example, the aspect ratio was calculated by dividing the width of 
the geometry by its height. 

Origin 

The position of the texture is set with the Origin Attribute relative to th e object 
hook point. 

 
In the Origin box, enter the position of the bottom left corner of the bitmap file 
relative to the object’s hook point. 

Normal Vector 

The Normal Vector controls which face you are applying the texture to.  
Double-clicking onto the Normal Vector attribute displays the Vector dialog 
box. 

 

Bitmap image file 
 

MicroGDS data 
Cube 600X600X300 

 

Texture space 
Object X plane  

Scale = 600 
Aspect ratio = 0.5 
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The default setting for this attribute is a value of 1.0 in the Z box. This will map 
the texture in a similar way to the Object Z plane shader. If you remove the 
value in the Z box and type 1.0 in either of the X or Y boxes, the image will 
map onto the surfaces as they would if you use the Texture space shaders 
Object X and Object Y planes. 

You can mirror the texture on the surface by typing -1 in the X Y or Z dialog 
boxes. For example: 

 

 

Up Vector 

The Up Vector defines the orientation of the image relative to the object axes. 
Double-clicking the Up Vector attribute displays the Up Vector dialog box. 

An up vector is calculated as a direction in X,Y,Z. 

The following examples illustrate how to rotate a texture map around the 
surface of a cube in increments of 90 degrees, using a combination of the 
normal vector and the up vector. 

The normal vector was set to the X plane (1/0/0).  

 

 

The up vector would only effect the Z and Y direction. The X vector is i gnored. 

The normal vector was set to the negative Y plane (0/-1/0). 

.  

 

The image is projected onto the 
negative Y plane as a normal vector 
0\1\0. Note the image is mirrored 

To correct the mirrored image on 
the negative Y plane type 0/-1/0 
as a normal vector 

Up vector 0/0/1 Up vector 0/-1/0 Up vector 0/0/-1 Up vector 0/1/0 

Up vector 0/0/1 Up vector -1/0/0 Up vector 0/0/-1 Up vector 1/0/0 
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The up vector would only effect the X and Z direction. The Y vector is ignored.  

The normal vector was set to the negative Z Plane (0/-1/0). 

.  

The up vector would only effect the X and Y direction. The Z vector is ignored. 

Cylindrical Texture space shader  

Use the Cylindrical Texture space shader to create a Texture space in which 
all points are mapped onto a cylinder. 

The attributes for Cylindrical Texture space shader are:  
Scale around the axis
  

The number of repeats around the cylinder. If you 
are mapping a wrapped image around a cylinder, 
enter a scale of 1 to stretch the image map once 
around the circumference. 
To repeat a pattern a number of times, divide the 
scale of 1.0 by the number of repeats you require. 
If you are wrapping a procedural shader such as 
wrapped grid around a cylinder, divide 1 by the 
circumference of the cylinder. 

In the following example a Wrapped Grid Colour shader is used to illustrate 
the scale around the axis. The grid width has been set to 480mm and a grid 
size of 20mm. 

To wrap the grid pattern evenly around the cylinder with 500mm spacing, a 
scale of 0.00025, which is 1/4000 (the circumference), should be entered in 
the Scale Around Axis attribute. 

 

   
Scale along the axis The number of repeats along the cylinder.  

To double the number of grid lines, type a scale of 0.5 
to halve the number of grid lines, type a scale of 2.  
For wrapped images, type the height of the geometry 
for one repeat, and halve the value to double the 
number of repeats. 
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Centre point Type the X, Y, and Z coordinates to define the centre 
of the cylinder, relative to the object hook point.  

Axis direction The orientation of the bitmap on to the face of the 
cylinder. 

Origin Type the starting position of the wrapped texture 
around the cylinder. You will have to calculate the sine 
of the angle in the X point and the cosine of the angle 
in the Y point. 

 
The image on the left shows a plan view of a cylinder with the origin of the grid 
at 0 degrees. The image on the right shows the grid rotated by 22.5 degrees.  
 
A value of sine (22.5) and cosine (22.5) were entered as X and Y points in the 
dialog box. 
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9 Applying materials to Faces 

9.1 To add a material to a single face 
There are times when you need to apply a material to a single face of a 
clump. For example, a door may be painted one colour on the front and a 
different colour on the sides and back. 
 
MicroGDS offers commands to do this. These are found on the Set menu.  
 
1. Open the Training data file and the ‘Cuboid’ window definition. 
2. Ensuring no graphics are selected, select any material from the Material 

list on the status bar. 
3. On the Set menu, click Material, Per Face, and click one face of the 

cubiod. 
4. Select another material from the Material list and click another face of the 

cuboid. 
5. You can continue to click onto faces as required. 
6. You can change the material at any time by selecting from the Material list.  
7. Update the renderer and refresh your scene.  

 

 

9.2 To add a material to all faces on a clump 
If you add two clumps to form one clump the resulting clump will adopt the 
material of the workpiece. (Remember that the workpiece is the clump that 
you add to.). 
 
There are times when you may want to retain both materials, for example if 
you add the wooden legs of a sofa to the fabric covered base. You can retain 
the wooden material by selecting the legs and adding the wooden material to 
all faces. When you then add the legs to the sofa both materials are retained.    
 
 
1. In the Training data file, open the ‘Newel post and balusters’ window 

definition. 
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2. Select one of the balusters, and from the material list select a material.  
3. Select the handrail. 
4. On the Set menu, click Material, all Faces. 
5. At the prompt, type the material name Gold.  
6. With the handrail still selected, click Solid, Boolean, Add to workpiece and 

click the baluster that you selected in 2 above. 
7. Update the renderer and refresh the scene.  

 

 
 
Note that both materials have been retained. 
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Exercise 25 Add a plain material to the fascias of the Beach house 
 
In a previous exercise you created a roof tile material and assigned it to the 
Slate roofs.  
 
In this exercise you will create a new plain material to represent the fascias 
and underside of the roof. You will then assign the fascia material to the 
pitched roofs. Finally, you will reassign the top tiled areas of each roof the 
original material, Slate roof.   
 
1. Create a new plain black material called Fascia. 
2. Select all three pitched roofs and assign the material Fasica to the clumps.  
3. Deselect all graphics and from the Material list, select Slate roof. 
4. From the Set menu, click Material Per Face, and click onto each sloping 

face, swinging your model round as necessary.  
5. Update the renderer and refresh the scene.  
 

 
 

Note that any slopes are now tiled but the facias are now black. If you 
swing your model to see the underside of the tiled roofs, these are now 
also black, rather than tiled as previously. 

6. Save and close the Beach house file. 
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9.3 Smoothing a clump edge 
In the following exercises, you will revisit the cushion that you created earlier 
in the course. 
You can use the Solid Clump, Smooth Edge command to smooth the edge 
between specific faces of a clump. For example, between each quadrant of 
the cushion there are ridges which the Smooth Edge command can remove.  
1. Open the Training.MAN file and the ‘cushion’ window definition. 
2. To view the edges to smooth, on the View menu select Hide Mode, Hide, 

and from the Hide Options select Show Smooth Edges, Partial.  
 

 
 
 
 
 
 
 
To smooth an edge: 
3. On the Solid menu, click Clump, Smooth Edge. 
4. Click onto some of the edges that you want to smooth (you will have to 

zoom in to part of the cushion). 
5. Click Render Update All and refresh your scene. 

9.4 Removing non-planer surfaces 
When you use the Patch command, it can create non-planar faces. If you 
rendered the cushion in the quality mode Raytrace Full you will see that some 
of the non-planer faces protrude out of the surface. If you split each face of 
the clump into triangular faces, each face becomes a flat plane.    
 
 
 
 
 
 
 
 
 
 
 
To triangulate a clump: 
1. On the Solid menu, click Clump, Triangulate. 
2. Select the clumps to triangulate. 
3. On the Render menu, click Quality, Raytrace Full. 
4. Update the Renderer and refresh your scene. 
5. Save and close the Training data file. 

Hard ridges clearly visible if partial 
smooth edges are shown 

Click onto the line to smooth the edge 

The example above illustrates the 
protruding faces of the non-planer 
geometry rendered in Full Raytrace 
mode 

The clump is triangulated which corrects 
the facets and renders smoothly. 
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9 Working with lightstyles 
 
During this training course you have viewed your model in a number of ways, 
including Shaded view and in the Renderer. It has always been possible to 
see your geometry in the Renderer as the scene has been illuminated by a 
default light.  
 
In this section you will create and modify different types of lights and position 
them in your scene. You can represent lights and shadows by assigning a 
light to an object in a 3D view. 
 
Lightstyles are assigned to objects in the same way that you assign linestyles 
to primitives. A lightstyle of None is assigned to each object by default.  

The Default light 
If the Render, Default Light command is selected, the default light is used.  
The default light is not affected by other lights. You do not have to update the 
lighting parameters before you render even if you change the default light 
setting. 
 
The default light automatically calculates lightness and darkness of faces, but 
does not calculate shadow projection. Irrespective of where you stand in t he 
scene, the default light will always illuminate the area you are looking at. It is 
as if you are wearing a miner’s helmet with the light switched on. Since the 
effect seems rather flat, it is not suitable for representing high -quality images.  
 
There are six types of light:  
 
Ambient 
Creates background lighting. This light should be used with care as it tends to 
create a flat looking scene. 
 

 
Distant 
Creates a light source that emits parallel light, as if from a very distant source 
such as the sun.  
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Eye  
Creates a light source at the eye position. Eye lights can be a good alternative 
to ambient lights as they maintain highlights. This light is similar to the default 
light. 
 

 
 
Point  
Creates a light source that emits light from a point equally in all d irections. 
This light creates the sort of lighting effect you would see if a light bulb was 
suspended from a ceiling. 

 

 
Projector  
Creates a light source that projects an image across the scene, similar to a 
slide on a slide projector. 

 
Spot  
Creates a light source that emits a cone of light. This light is very useful for 
directing light to areas of interest in the scene. 
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Location and orientation of lights 
 
The six types of light are grouped into two categories, depending on:  
· whether or not the lighting is affected by the location and orientation of the 

light object 
· whether or not the light casts shadows 
 
Location and orientation Lights Description 
Affected by location Point 

Spot 
Projector 

The location of the light is at the light 
objects' hook point.  

Affected by orientation Spot 
Projector 
Distant 

The light is directed along the 
negative Z axis of the object to which 
the light is assigned. 

Not affected by location 
or orientation  

Ambient 
Eye 

The position and orientation of the 
object to which the light is assigned 
does not affect the lighting. 

 

Light objects 
The object hook position for Ambient and Eye lights is not important. For 
Distant, Point, Spot, and Projector light types the location and orientation of 
the light depends on the location and angle of the objects’ hook point. 

9.1 To add a light to the scene 
In the following example you will add a light to your scene and look at the 
various effects that can be accomplished using different light attributes.  
 
1. Open the file Lights and the ‘Lights’ window definition. 
2. Change the scale to 1:1. 
3. Select the layer lights, and make it editable.  

Note that it is good practice to place all your lights on their own layer(s) as 
it is much easier to manage them at a later date.  

4. Click the 2D view button. 
5. Create a new object called Light, and place the hook point, near to the 

bottom-left corner of the table. Use a face snap on to the floor. (The hook 
point will become the point of the light source.)  
You need to create some graphics to represent a light. This is usually a  
simple line, circle or rectangle. (The shape and size of the graphics is 
unimportant.) 

6. Create a Circle with a radius of 500, and position the centre of the circle at 
the object’s hook point. Type // to achieve this.  
 



106  MicroGDS  

 

Moving a light object 
The circle representing the light is currently sitting on the floor. Light objects 
are exactly the same as normal MicroGDS graphics, and you can use any of 
the edit commands on light objects. Moving the light object should always be 
done in Object mode. You will move the light from the ground (the XY plane 
0/0) to 2000mm in the Z direction. 
  
1. To select the light object, press CTRL+SHIFT and click onto the object. 

Type //2000. 
2. Reset the hook point on to the light object.  
3. Click the 3D view button. 
 
To position or copy directional lights such as spot, projector, and distant lights 
you can use the Object Reposition command. 

9.2 Changing the lightstyle to an Ambient light 
You have created graphics for your light and you have also moved the light. 
The light object currently has a lightstyle of NONE. To illustrate some of the 
properties of lights, you are now going to assign different light types to the 
light object and see the effect of each light in the renderer.  
 
1. Ensure that the Default light is turned off. 
2. In Object mode, select the light object. 
3. Select the DEFAULT lightstyle from the Light list on the status bar.  

Note that NONE means 'no lightstyle', and therefore you cannot create a 
lightstyle based on NONE. 

4. On the File menu, click Lightstyle Modify. 
The Lightstyle dialog box is displayed: 

 
 

The Lightstyle dialog box is also displayed when you create or modify a 
lightstyle from the Document Organizer. 

5. From the Light type list select Ambient. 
 
Attributes for Lights 
There are a number of different attributes for each light type. T wo of the 
attributes are common to all lights. 
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Intensity The Intensity attribute controls the intensity of the light. The higher 

the value, the more intense the light. 
Colour The Colour attribute controls the colour of the light. Select a colour 

from the list, or click … to display the Define Colour dialog box 
and specify a custom colour. 

 
6. Change the Intensity value from 0.1 to  0.6.  
7. Leave the default colour of white. 
8. Click Save As, and save your light as Ambient. 
9. Close the lightstyle dialog box. 

To see the effect of the light: 
10. Ensure that you have a 3D view and the window has not been maximized.  

As this is the first time you are viewing your scene in the renderer, you 
need to update all the model parameters.  

11. Select Render, Update All. 
12. Click Render, Refresh. 

 
 
Note: Ambient lights should be used with care as they tend to make the scene 
look flat and washed out. 

9.3 Changing the lightstyle to an Eye light 
You will now change the lightstyle to see the effect an Eye light has on the 
scene. 
 
1. In Object mode select the light object. You will notice that in the status 

menu the current lightstyle is Ambient. 
2. From the Lightstyle Modify list, select Eye. 
3. Leave all the parameters as default. 
4. Click Save As, and save the lightstyle as Eye. 
5. Close the Lightstyle dialog box. 

To see the updated light in the renderer you will need to update the data. 
However as you have only changed the lights in the scene you do not 
need to update all the other parameters.  
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8. Click Render, Update lights, and then click Render, Refresh.  
 

 
 

The following three attributes are common to Point, Projector, and Spot lights:  
 
Colour 
Temperature  

You can use the Colour Temperature attribute to specify the 
light colour via an exact description of the spectral distribution 
of the light. 

Fall Off  The Fall Off attribute controls the way in which the light 
intensity varies with the distance from the source. For the Fall 
Of attribute, select a value from the list: 

   
Constant no variation in intensity 
Inverse intensity decreases as the inverse of the 

distance from the source 
Inverse Squared intensity decreases as the square of the 

distance from the source 
Clamped Inverse intensity is fixed at the light source, and 

decreases as the inverse of the distance 
from the source 

Clamped Inverse  
Squared 

intensity is fixed at the light source, intensity 
decreases as the square of the distance from 
the source 

 
Range The Range attribute controls the distance from the light at 

which the specified intensity is shown, in millimetres. This 
attribute works in conjunction with the Fall Off attribute. 
For example, if you specify an intensity of 1, and a fall off for 
which the intensity decreases as the inverse of the distance 
from the source (Inverse fall off), a range of 1000 means the 
intensity: 
    at 1000 mm is 1 
    at 2000 mm is ½ 
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Changing the lightstyle to a Point light 
You will now change the lightstyle to a point light and see the effects of 
intensity, fall off, and range, to point lights: 
1. Select the Light object. 
2. On the Lightstyle dialog, edit the following parameters:  

· select Point from the list 
· type an intensity of 1.0 
· select Constant from the Fall Off list  

The range for Constant Fall Off has no effect. 
· leave all the other parameters as default  

3. Save the lightstyle as Point, and close the dialog box. 
4. Click Render, Update Lights, and then click Render, Refresh. 

Note that the intensity is constant throughout the scene.  

 
 

You will now edit the point light to see the effect of an inverse fall off.  
 
1. Select the light object. 
2. On the Lightstyle dialog box, edit the following parameters: 

· select Inverse from the Fall Off list 
· select a range of 1500mm 

3. Save the lightstyle to the same name. 
4. Click Render, Update lights, and then click Render, Refresh.  
 

 
Note that the corners of the building have become darker as they are 
further away from the light source. 

5. Save and close the Lights file. 
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9.4 Setting the light to an angle 
The following example takes you through the steps of adding a distant light to 
your scene. You can also use this method to position Spot lights.  
1. Open theTraining data file, and the ‘Block’ window definition.  
2. Change the view to 2D. 
3. Create a new layer called lights. 
4. Draw a short construction line using the Construct Line command, giving 

two Dot snaps, as illustrated: 

 
5. Move the end of the construction line 1500mm in the Z direction using the 

Vertex, Move command. 
6. Create a new object called light and place the hook point at 0/0.  
7. To create the light object, draw a circle with a radius of 100mm and place it 

at /. Press ESC. 
8. Switch to 3D view. 
9. To position the light, on the Object menu click Reposition. 
10. Pick up the circle with a Centre snapcode and place it at the end of the 

construction line using a Point snapcode. 
The prompt bar now requests the position for the X azis. However, since 
the light source of a distant light is directed along the negative Z axis, you 
will specify the –Z direction. 

11. Press SHIFT+ TAB, the prompt bar now requests the position of the –Z 
axis. 

12. To direct the light along the –Z, use a Line snap anywhere on the 
construction line. 

13. Press ESC to retain the current X and Y axes, and press ESC again to end 
the command. 
Your light object should now be roughly positioned as illustrated below:  

 

construction line 
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14. To set the render environment, open the Preferences dialog box, click the 
Render tab, and set the image size to Custom. Speci fy width/height 
500x500. 

15. On the Render menu, click Quality, Full. 
16. On the View menu, click Render Environment and set the Background to 

Plain. Change the colour to Light Blue. 
17. To create a lightstyle, switch your drawing to 2D. 
18. Select the light object and select DEFAULT from the Light list on the status 

toolbar. 
19. On the File menu, click Lightstyle Modify. 
20. From the Light list, select Distant, and ensure that Shadows are set to On.  
21. Click Save As, name your lightstyle Distant, and then click OK. Close the 

Lightstyle dialog box. 
22. To render your scene, on the Render menu click Update, All.  
23. On the Render menu, click Refresh. 
24. The rendered scene, lit by your distant light, should now appear similar to 

the following illustration: 

 
25. Save and close the Training data file. 

9.5 Shadows 
Distant, Point, Projector, and Spot lights cast shadows. To illustrate the 
properties of shadows you will use the data contained in the Lights file.  
 
1. Open the Lights file, and the ‘Lights’ window definition.  
2. On the Document Organizer select the Styles tab, click the Lights folder 

and from Lights.MAN select POINT. 
3. Change Shadows to On to cast shadows, or Off to ignore shadows.  

This controls whether or not the light casts shadows.  
4. Click Render Update All, and then Render Refresh. 
 

 
 

No shadows Casts shadows 
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Note that the illustrations above use a combination of eye and spot lights to 
achieve the effect. Your scene only has one light and therefore will appear 
much darker. 
 
Shadow Type  
The Shadow Type attribute controls whether the light casts hard shadows or 
soft shadows. Hard shadows have straight edges and support material 
transparency. Hard shadows ignore Shadow resolution, Shadow quality, 
Shadow softness, and Shadow tolerance attributes.  
 
1. Select the light object. 
2. Click Lightstyle Modify, and select the Shadow Type Hard to cast Hard 

shadows, or Soft to cast Soft Shadows.  
3. Update and refresh the Renderer.  

 

 
 

 

Shadow Resolution 
This controls the accuracy of the shadow map for casting soft shadows. The 
shadow map can be considered as a rectangular array of distances, as see n 
from the light. 
The default value of 256 is sufficient for most scenes; the higher the shadow 
resolution value the longer the image takes to update in the renderer.  
 
1. Select the light object. 
2. Click Lightstyle Modify, and select the Soft option from the Shadow list. 
3. Change the Shadow Resolution to 100. 
4. Save the lightstyle Point. 
5. Update and refresh the Renderer.  

Note how the shadow cast by the table on the left has a jagged edge.  
 

 
 

Hard shadows Soft shadows 

Shadow resolution of 100 Shadow resolution of 500 
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6. Select a Shadow resolution of 256 (back to the default setting).  
7. Save the lightstyle Point. 

Shadow Quality 
This controls how fine or coarse the shadow map detail is for soft shadows.  A 
low value, such as 1, produces coarse shadows; a higher value, such as 4, 
produces finer shadows. 
 
 

 
 
 

Shadow Softness  
This controls the softness of the shadow boundaries for soft shadows.  A low 
value, such as 1.0, produces hard edges to the boundaries; a higher value, 
such as 2.0, produces softer boundaries. 
 
To see the effect of Shadow quality and softness: 
1. Select the light object. 
2. Click Lightstyle Modify. 
3. Select a shadow quality of 1 and a softness of 1. 
4. Save the lightstyle as Point.  
5. Click Render, Update Lights, and Render Refresh. 
6. Select a Shadow quality of 9 and a softness of 10. 
7. Save the lightstyle as Point. Click Render Update Lights, and Render 

Refresh. 
Note that the shadow cast by the table on the right now has a soft edge.  

 

 
 

Shadow quality 1 Shadow quality 9 

Shadow softness 1 Shadow softness 4 
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Shadow Tolerance 
Shadow Tolerance controls the shadow map, sampling distance for soft 
shadows. It is used to manage self-shadowing artefacts that can be apparent 
with low resolution, high softness shadows. 
 
The value should be as small as possible. A value of 1.0 will cause all 
shadows to vanish. 
 

 
 
 
Scattering 
 
This attribute is for use with the Fog Light Foreground environment shader.  It 
controls whether the light is scattered through the fog effect.  
 
To scatter light in the fog, set this attribute to On. If you do not want the light to 
scatter in the fog, or if you do not intend to use the Fog Light shader, set this 
attribute to Off. 
 

 
 
To see the effect of light scattering on a spot light: 
 
1. Select the light object and from the Lightstyle Modify dialog box, select 

Spot. 
2. On the View menu, click Renderer, Environment. 
3. Select the Foreground tab, and click onto the Fog Light attribute. Change 

the Fog Desnsity value to 0.4 and close the Environment dialog box.  
4. Click Lightstyle Modify, and select Inverse from the Fall Off attribute list.  
5. Select the Scattering attribute and set scattering to On.  
6. Save the lightstyle as Spot, and close the Lightstyle dialog box. 
7. Update the lights and environment in the renderer and refresh the scene.  

Shadow tolerance 0 Shadow tolerance 0.14 
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Spot lights have 3 additional attributes to control the cone of light:  
 
Cone Angle 
Cone Angle defines the light cone being emitted from the source.  The apex of 
the angle is at the hook point of the object. 
 

 
 
 
 
To see the effect of changing the Cone Angle: 
1. Select the light object. 
2. Click Lightstyle Modify, and select a Cone Angle of 25. 
3. Save the lightstyle as Spot.  
4. Click Render, Update Lights and refresh the scene. 
 
Cone Delta Angle 
Within a Cone of Delta Angle, the intensity of light is full. At Delta Angle from 
the full Cone Angle, the intensity begins to diminish. At the full cone angle, the 
intensity is zero. See Help for full details. 
 
 

 
 

Scattering off Scattering on 
 

Cone Angle 60 
degrees (default) 

Cone Angle 15 
degrees 

 

Cone Delta Angle 0 
degrees 

Cone Delta Angle 15 
degrees 
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To see the effect of editing the cone delta angle: 
1. Select the light object. 
2. Click Lightstyle Modify, and reset the Cone Angle back to the default value 

60 Degrees. 
3. Set the Cone Delta Angle from the default value of 5 to 0.  
4. Save the lightstyle, and close the Lightstyle dialog box. 
5.  Click Render, Update Lights and refresh the scene. 
 
Beam Distribution 
Beam Distribution defines how the intensity of the light varies with the angle 
from the negative Z axis. 0.0 produces uniform intensity across the interior of 
the beam. A higher value produces a faster fall off in intensity. 
 

 
 
 

To see the effect of editing the Beam Distribution angle:  
 
1. Select the light object. 
2. Click Lightstyle Modify and reset the Cone Delta Angle back to its default 

value of 5. 
3. Set the Beam Distribution Angle to 30. 
4. Save the lightstyle, and close the lightstyle dialog box. 
5. Click Render, Update Lights and Refresh the scene. 
6. Save and close the Lights file. 

Beam Distribution 0 Beam Distribution 30 
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Exercise 24 Adding Lights to the Beach House 
 
In this exercise you will import a layer, representing sand, into your beach 
house scene. You will then add an eye light, and a distant light (the sun). 
Finally you will create a point light. 
 
1. Import Beach.man from the Training folder into your Beach House file.  
2. Drag the layer SAND into the beach house window. 
 
Creating an eye light 
 
1. View your model in 2D. 
2. Make the Sand and the Roof layers invisible. 
3. Create a new layer and name it LIGHTS. 
4. Set the axes angle to 50. 
5. Create a new object EYE:LIGHT, and place the hook point in the centre of 

your model. 
6. Create a circle using Circle, Centre Point. 
7. Change the lightstyle from NONE to DEFAULT. 
8. Click Lightstyle Modify and select Eye from the list. 
9. Save the light as EYE. 
10. View your model in 3D. 
11.  Click Render, Update All and refresh the scene. 
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Creating a distant light (Sun Light) 
 
1. Switch the view from 3D to 2D. 
2. Make the LIGHTS phase the current, editable phase. 
3. Create a new object called SUN:LIGHT and place the hook point 

anywhere on the drawing. 
4. Using the line command and dot snaps, place a line from the bottom left 

corner to a position in the centre of the Beach house. 
5. Click Alter, Vertex Move, and move the start of the line //6000 in the Z 

direction. 
6. Place the axes, with a point snap, at the start of the line and press 

SHIFT+TAB to position the negative Z axis down the line towards the 
Beach house. Press ESC to finish the command. 

7. Move the object hook point to 0/0/0. 
8. Change the lightstyle from NONE to DEFAULT. 
9. Click Lightstyle Modify, and select Distant from the list.  
10. Change the Shadows attribute from Off to On. 
11. Save the lightstyle as SUN. 
12. View your model in 3D. 
13. Make the phases Sand and Roof visible. 
14. Turn off the default light. 
15. Click Render, Update All and refresh the scene. 
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Creating a point light inside the beach house 
 
1. Set Axes Centre. 
2. Temporarily make the Roof and Sand phases invisible.  
3. Ensure the LIGHTS phase is current and editable. 
4. Go to 2D view. 
5. Open the View Parameters dialog box. 
6. From the list select 3D. 
7. Using the Pick button, click a point from the bottom right corner of the 

lounge inside the beach house and drag to a look at point towards  the 
bathroom. 

8. Edit the Z values for both the eye and look-at points to 1950.  
9. Create a new object POINT:LIGHT and place the hook point in the centre 

of the lounge. 
10. Click Construct, Circle, Radius Centre, and type 500 at the prompt. To 

place the circle at its hook point, type // 
11. In Object mode, move the point light up to a height of //2500 in the Z 

direction. 
12. Change the lightstyle from NONE to DEFAULT. 
13. Click Lightstyle Modify and select Point from the list. 
14. Edit the attributes as follows: 

· Leave all the point light attributes as default except for: 
· Intensity = 0.4 
· Fall Off = Inverse 
· Range = 45mm 
· Shadows = On 
· Shadow Type = Soft 

15. Save the light as POINT. 
16. As the image will be too bright with the SUN light turned on, select this 

light and from the Light list, select NONE.  
17. Click Render, Update All, and refresh the scene. 
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18. Save and close the Beach house file. 
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10 Environment shaders 
 
In a previous section you have changed the Plain colour Background attribute 
in the Environment shader from the default black to a much brighter powder 
blue, and you have also changed the parameters of the Fog light Foreground 
environment shader. This enabled you to see the effect of reflectance 
materials and the scatter option in point and spot lights.  
 
In this section you are going to look in more detail at some of the other 
environment settings. 
 
You can create an environment around your graphics in a rendered image. 
You can specify the foreground, background, and/or map a number of images 
around the scene.  

10.1 Creating an environment 
· on the View menu, click Renderer Environment, to display the 

Environment dialog box: 
 

 
 
The following Environment shaders are available: 
 
Foreground  
The Foreground shader modifies the colour of the surface of each pixel to 
produce an atmospheric scene.  For example, you can use these shaders to 
create a fog effect.  
  
Background 
The Background shaders define the colour of pixels in the image that are not 
covered by geometry.  For example, you can use the background shader to 
create a sky effect, or the backdrop to a scene.  
 
Environment 
The Environment shaders map images around the scene to represent the 
environment.  It creates an environment cube from six images around the 
entire 3D model.  
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10.2 Foreground environment shaders 
There are six Foreground environment shaders, including none if you do not 
want an environment shader. 
 
Depth Cue foreground shader 
Use the Depth Cue foreground shader to enhance the impression of depth of 
the geometry. Depth cueing uses the fact that distant objects appear dimmer 
than closer objects, especially if seen through a haze.  
 
The attributes for this shader are: 
 
Background Colour Select a colour for the depth cue effect 
Near Type the distance from the eye position at which the 

Depth Cue colour will begin 
Far Type the distance from the eye position at which only 

the Depth Cue colour will be visible 
 
For an example of the Depth Cue foreground shader: 
1. Open the Lights file, and the ‘Environment 1’ window definition.  
2. On the Environment Foreground tab, select Depth Cue.  
3. Select the colour white. 
4. Type 49000 in the Near box and 90000 in the Far box.  
5. Close the dialog box. 
6. Click Render, Update All, and refresh your scene. 

 

 
 
 
 
Fog foreground shader 
Creates a fog effect in your scene. The fog density increases with the 
distance from the eye position. 
 
The attributes for this shader are: 
 
Fog Colour Select a colour for the fog effect 
Distance Type a distance in millimetres. The larger the 

distance, the further the fog is from the eye position.  
Maximum Density Type a value (between 0.0 and 1.0) to indicate the 

maximum density of the fog. A value of 1.0 creates 
full fog near infinity. Lower values indicate less dense 
fog. 

No Depth Cue Depth Cue foreground 
Near = 49000mm 
Far = 90000mm  
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Ignore Background Select No to fog the background, or Yes if you do not 
want the background to be fogged. 

 
For an example of the Fog Foreground shader:  
1. With the ‘Environment 1’ window definition still open, on the Environment  

Foreground tab, select Fog. 
2. In the Distance box type 50000, and in the Maximum Density box type 

1.0. 
3. From Ignore Background select No. 
4. Close the dialog box and refresh your scene. 
 

 
 
 
 
 
Fog Light 
 
For the Fog Light shader to take effect, point and spot lights must have the 
Scattering attribute set to Yes. You are also recommended to set the Fall Off 
attribute to Inverse Squared when you use Fog Light.  
 
The attribute for Fog Light. 
Fog Density Type a value to define the scattering of the light at the light 

sources. A higher value indicates more scattering. 
 

 
 
 
See the Lights section Scattering for an example of this. 
 
Ground Fog Foreground shader 
 
The Ground Fog Foreground shader can simulate the effect of early morning 
mists. 

No Fog Fog settings 
Distance = 50000mm 
Maximum density = 1.0 
Ignore Background = No  

No Fog Fog Density = 0.001 
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Fog Distance Type a distance in millimetres. The larger the distance, 

the further the fog is from the eye position.  
Fog Height Type a height for the height at which the fog fades to 

nothing. 
Fog Colour Select the colour of the fog from the list, or specify a 

custom colour. 
Ground Point Type the X, Y, and Z coordinates in the Point dialog box 

to define the position of the 'ground' (at which the fog 
starts). 

Ground Normal Type the X, Y, and Z vectors in the Vector dialog box to 
define the direction in which the fog density will change. 
(This also defines the plane of the 'ground'.)  

Maximum Density Type a value (between 0.0 and 1.0) to indicate the 
maximum density of the fog. A value of 1.0 creates full 
fog near infinity. Lower values indicate less dense fog.  

Ignore Background Select No to fog the background, or Yes if you do not 
want the background to be fogged. 

 
For an example of the Ground Fog foreground shader:  
1. With ‘Environment 1’ window definition still open, on the Environment 

Foreground tab, select Ground Fog. 
2. In the Fog Distance box, type 4000, and in the Fog Height box, type 1500.  
3. Set the option Ignore Background to Yes. 
4. Leave all other settings at their default.  
5. Close the dialog box and refresh your scene. 
 

 
 
 
 
 

No Ground Fog Ground Fog setting 
Fog Distance = 4000 
Fog Height = 1500mm 
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Snow Foreground shader 
 
The Snow Foreground shader creates an effect of flakes of snow in your 
scene. For full details of the Snow Foreground shader see Help.  
 
The following illustration used the snow settings specified:  
 

 
 

10.3 Background environment shaders 
There are eight Background environment shaders i ncluding the default option 
of none if you do not want an environment shader.  
 
Clouds background shader 
 
Use the Clouds background shader to create a background cloud pattern.  
 
The attributes for clouds are: 
 
Scale Type a number to define the scale of the cloud pattern.  
Background Colour Select the colour for the 'sky'  
Clouds Colour Select the colour for the clouds. 
Detail Select the level of detail you require in the cloud 

pattern from the list. 
 
For an example of the Clouds background shader:  
1. With the Environment 1 window definition still open, on the Environment 

Background tab, select Clouds. 
2. In the Scale box type 5, and from Detail select Extremely High.  
3. Reset the Foreground Shader to None. 
4. Close the dialog box and refresh your scene. 
 

 
 

Snow settings : 
Near Scale = 0.08 
Far Scale = 0.04 
Flake Size = 0.5 
Flake Density = 0.6 
Noise Amplitude = 0.2 
Noise Scale = 0.03 
Random Seed = 9 
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Environment background shader 
Use the Environment background shader to display the selected Environment 
environment shader as the background (as well as the environment). This 
shader is used with the Fixed Distance Cube and Image Cube environment 
shaders only. 
 
The attributes for Environment background shader are:  
 
Intensity Type a value to define the brilliance of the reflection.  
Angle Type the angle over which the environment map is to be sampled 

for each pixel of background. The environment map can be 
blurred slightly in this way. 0 is no blurring 0.05 will blur the 
image. 

 

 
 
1. In the Lights file, open the ‘Environment 2’ window definition.  
2. On the Environment Background tab, select Environment and leave the 

attributes as default for the time being. 
3. Select the Environment tab and select Fixed Distance Cube from the list.  
4. Double-click the attribute Front(+x) and browse for the file 

3D\TrainingCourse\Training Manual\Training Textures\Environment 
images\Front. 

5. Repeat this option for the other attributes Back, Left,  Right, Top, Bottom. 
6. Type 10000 for the Size attribute. 
7. Close the dialog box and refresh your scene. 

To blur the image: 
8. On the Background tab, change the angle to 0.07.  
9. Close the dialog box. 
10. Update the renderer, and refresh your scene. 

 

Graduated background shader 
The Graduated background shader creates a background that is graduated 
between two colours. 
 
The attributes are: 
 
Top Colour   Select the colour for the top of the scene. 
Bottom Colour Select the colour for the bottom of the scene. 
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For example 

 
 

For an example of the Graduated background shader, open the Graduated 
window definition. 
 
Grid background shader 
 
The Grid background shader creates a background that is a grid.  
 
The attributes for the grid background shader are:  
 
Grid Width Type the horizontal distance between the grid lines in 

pixels. 
Grid Height Type the vertical distance between the grid lines in 

pixels. 
Grid Colour Select the colour for the grid. 
Background Colour Select the colour for the squares in the grid. 
 
For example: 

 
 

For an example of the Grid background shader, open the Grid window 
definition. 
 
Image background shader 
Use the Image background shader to display an image as the background.  
 
MicroGDS places the top left corner of the background image in the top left 
corner of the rendered view. The image is displayed on a 1:1 basis, and if 
necessary is repeated to fill the entire background.  
 
The attributes for the Image background shader are:  
 
File Name Specify the path of the image file to be used. 
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For example 

 
 
An image file pixel size of 336X250 was used in this example and rendered at 
a size of 250 X 250 in MicroGDS. The right hand edge (86 pixels) of the 
image was cropped. If the final MicroGDS render size was greater then 250 
pixels high, then the image would have been tiled. 
 
For an example of the Image background shader open the Image window 
definition. 
 
Plain background shader 
The Plain background shader displays a simple background of uniform 
colour. 
 
The attribute for Plain background shader is:  
 
Colour  Select the colour for the background. 
 
For example: 

 
 
For an example of the Plain background shader, open the Plain window 
definition. 
 
Scaled image background shader 
 
The Scaled Image background shader displays an image as the background. 
You can also rotate the image as required. 
 
MicroGDS scales the image to fit the view. If the height or width of the image 
is larger than the Render window, the image may appear distorted. If you 
zoom in on the view, the background image is scaled accordingly.  
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The attributes for the Scaled Image background shader are:  
 
File Name Specify the path of the image. 
Softness Type the degree of blurring for the image. A lower value 

sharpens the image; a higher value softens, or blurs, 
the image. 

Rotation Select the angle through which you want the image 
rotated. 

Keep Aspect Ratio Select On to maintain the aspect ratio of the original 
image in the background. The top-left pixel of the image 
is placed in the top-left of the Render window. If the 
aspect ratio of the image does not match the aspect 
ratio of the Render window, MicroGDS may crop the 
view when it creates the rendered image. 
Select Off to fit the image to the scene, distorting the 
image if necessary. 

 
 
 
For example 
 

 
 
 
 

 

Original image 1500 x 1100 
 

Aspect ratio Off: 
The image has 
compressed to fit 
the render width 
 
 

Aspect ratio On: 
The original image maintains its 
aspect ratio. But crops the view in 
the MicroGDS render 
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10.4 Environment environment shaders 
 
Environment environment shaders map images around the scene to 
represent the environment. For example, use these shaders to create a glass 
structure in which the reflections change depending upon the position of the 
eye. 
 
There are four Environment environment shaders i ncluding the default option 
of none if you do not want an environment shader.  
 
Fixed Distance Cube environment shader 
 
The attributes for the Fixed Distance Cube environment shader are:  
  
Front Specify the path of the image file to be reflected from the 

positive X direction in the normal axes. 
Back Specify the path of the image file to be reflected from the 

negative X direction in the normal axes. 
Left Specify the path of the image file to be reflected from the 

positive Y direction in the normal axes. 
Right Specify the path of the image file to be reflected from the 

negative Y direction in the normal axes. 
Top Specify the path of the image to be reflected from the positive Z 

direction in the normal axes 
Bottom Specify the path of the image to be reflected from the negative Z 

direction in the normal axes 
Centre 
Point 

Specify the X, Y, and Z coordinates in the Point dialog box to 
define the centre of the cube. 

Size Specify the size of the image cube, in millimetres. The cube 
should be larger than the scene. 

 

 
 
 
 
To see an example of a Fixed Distance Cube: 
1. In the Lights file, open the ‘Conservatory’ window definition  
2. On the Environment tab, select Fixed Distance Cube. 
3. Set the file 3D Training Course\Training Manual\Training 

Textures\Environment images\Front.bmp to the attribute Front. 

No environment 
 
 

Fixed distance cube environment 
Note the reflections in the glass 

 



3D Training Course  131 

 

4. Set the file 3D Training Course\Training Manual\ Training 
Textures\Environment images\Back.bmp to the attribute Back. 

5. Set the file 3D Training Course\Training Manual\ Training 
Textures\Environment images\Left.bmp to the attribute Left. 

6. Set the file 3D Training Course\Training Manual\ Training 
Textures\Environment images\Right.bmp to the attribute Right. 

7. Set the file 3D Training Course\Training Manual\ Training 
Textures\Environment images\Top.bmp to the attribute Top. 

8. Set the file 3D Training Course\Training Manual\ Training 
Textures\Environment images\Bottom.bmp to the attribute Bottom. 

9. In the Size box, type 100000. 
10. Update and refresh the renderer.  
 
 
Image Cube environment shader 
 
Use the Image Cube environment shader to create an environment map from 
six images arranged in a cube. 
 
Note that all objects are assumed to lie at or near the centre of the 
environment cube. This will be satisfactory if you have only one object that 
reflects the environment, or if the environment cube lies a long way away 
from the objects. However, if the model includes a number of objects in 
different positions that will reflect the environment, you may want to use the 
Fixed Distance Cube environment shader.  
 
The attributes for the Image Cube environment shader are: 
 
Front Specify the path of the image file to be reflected from the positive 

X direction in the normal axes. 
Back Specify the path of the image file to be reflected from the negative 

X direction in the normal axes. 
Left Specify the path of the image file to be reflected from the positive 

Y direction in the normal axes. 
Right Specify the path of the image file to be reflected from the negative 

Y direction in the normal axes. 
Top Specify the path of the image to be reflected from the positive Z 

direction in the normal axes 
Bottom Specify the path of the image to be reflected from the negative Z 

direction in the normal axes 
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To see an example of an Image Distance Cube: 
1. In Lights.man open the Image Cube window definition 
2. On the Environment tab, select Image Cube. 
3. Double-click the Front attribute, and browse to the file 

ENV_MAPS\new_york\FRONT.BMP. 
4. Repeat for each direction attribute, selecting the appropriate image file.  
5. Update and refresh the renderer.  
 
Render Cube environment shader 
 
The Render Cube environment shader is used to create an environment cube 
from the rendered geometry. This shader uses the Background environment 
shader to create environment reflections in geometry that has a reflectance 
shader setting of environment. 
 
The geometry that uses the Reflectance shader of environment is ignored 
when the render cube is calculated. 
 
The attribute for the Render Cube environment is:  
 
Resolution
  

Type the size, in pixels, of the environment map images. A 
larger value improves the quality of reflections, but requires 
more processing time and uses more memory  

 
The example below shows the reflections of the clouds (a Background 
environment shader of clouds) on the floor. The floor material has a 
reflectance shader of environment. 
 

 
 
 
To see the above example: 
 
1. In the Lights file, open the ‘Render Cube’ window definition.  
2. On the Environment tab, select Render Cube. 
3. Type 200 in the Resolution box. 
4. Refresh the renderer. 

Note the sharp reflections on the floor.  

Resolution 128 (default) Resolution 20 
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To produce soft reflections on the floor: 
5. On the Environment tab, select the Render Cube. 
6. Type 20 in the Resolution box. 
7. Update and refresh the renderer.  
8. Save and close the Lights file. 
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Exercise 25 Adding a background environment to the Beach house 
 
1. Open the Beach house file and the Beach House window definition. 
2. On the View menu click Renderer Environment. 
3. Click the Browse button and select Beach House\library\raster\Beach 

background 5.jpg. 
4. Click the Nudge back button two or three times. 
5. Update the renderer and refresh your scene.  
 

 
 
Congratulations, you have finished the MicroGDS 3D training course.  


