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Introducing the MicroGDS Advanced 
training course 

This course is intended for users who are familiar with the basics of 
MicroGDS and now wish to learn about some of the more advanced 
techniques. It is assumed that you have completed the MicroGDS 
Foundation Course and that you are familiar with the general layout and 
concepts of the system. 
 
During the course, you will experience how easy it is to work with large 
sets of graphical data, by creating and building up a multi-user project. 
For each task, we show the most common way to accomplish it. The 
course will guide you through each topic, with step-by-step instructions, 
to enable you to complete each section. 

Before you begin 
Ensure that MicroGDS version 8.0 Plus or Pro, has been installed on 
your computer. 
 
Copy the Advanced training data folder to your computer’s hard disk.  
 

MicroGDS documentation 
You will need a copy of the MicroGDS version 7.0, Using MicroGDS,  
Introducing MicroGDS version 7.1, and Introducing MicroGDS 8.0 user 
guides. 
 

Important 
One part of this course shows you how easy it is to change the 
MicroGDS user interface. It is recommended that you first check with 
other users before doing so, for example, if the computer on which you 
are running the course is not your usual workplace machine. 
 
If you wish to revert to the settings that were in place at the start of this 
course, ensure that you make a note of any configuration file locations 
that you are asked to change and reassign the paths appropriately. 
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1. Planning and setting up project 
environments  
Working with large sets of graphical data from different sources and 
disciplines could be a daunting task to manage. For example, in a large 
multi-disciplinary project, architects, engineers, landscape designers, 
service engineers, interior designers and other professions, may need to 
access data simultaneously. MicroGDS provides the multi-user project 
facility for this reason.  
 
Multi-user projects enable you to handle the data in a structured manner, 
keeping track of all the relevant drawing files that you need when 
working with large projects of this nature. 
 
In this section you will learn how to create a MicroGDS project database 
to manage the data for a large project. You will then create two 
MicroGDS project workspaces through which you access the drawings 
within the project. 
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1.1  Creating a project database 
1 Start MicroGDS and click New on the File menu. The Create a New 

File dialog box is displayed. 
 

2 Select the Project database option and click Next. The Create a New 
Project Database dialog box is displayed. You can select a template, 
a database type, and enter a short description of the project. 

 

 
 
3 At this point, you are not selecting a Template, and you will leave 

the Database Type at its default. Type a short description for the 
project database in the Description box. In this case type Health 
and Fitness Club.  
 

4 Click Next. The Set Project Database Details dialog box is 
displayed. 
 

 
 
5 To enter a project database name, click Browse and locate your C 

drive (or the drive on which you wish to hold the database). Click the 
Create New Folder button and rename the folder to Flints Health 
and Fitness Club  
 

6 You will use this folder to save your work throughout this course. 
Double-click the folder to open it. 
 

7 In the File name box, type the name of your project database Flints 
and click Open. The Set Project Database Details dialog box is again displayed, this time 
with the folder path and new database name. 

 
8 Click Next. 



4 MicroGDS  

 

Defining database aliases 
MicroGDS displays the Define Database Aliases dialog box. For 
example: 

 

 
 

Aliases are the names you associate with the folders available to the 
project. There are five alias types: 
 
• layer aliases specify the folders for new layers 
• window aliases specify the folders for new window definitions 
• raster aliases specify the folders for accessing raster images 
• library aliases specify the folders for accessing library files 
• reference aliases specify the folders for accessing MicroGDS 

documents whose windows can be used as photos.  
Note that reference aliases are optional. 

 
The default alias name for each alias type is shown on the left of the 
dialog box. The default folder name for each alias, which MicroGDS will 
automatically create, is shown on the right of the dialog box. Notice that 
the folder names are created immediately below the project database 
folder. Therefore only the relative paths of the alias locations are shown. 
This means that if the project is moved to another drive, the aliases will 
still be relative to the project and will not have to be reassigned. 
 
If you accept these details, MicroGDS creates subfolders in the project 
database with the names shown, and maps those locations to the default 
alias names. 
 
You are not going to accept all the default aliases offered. Instead you 
are going to define two separate aliases for layers and window 
definitions, one for the Club House and one for the Site. You are also 
going to define an additional alias for layers called Import. This will be 
used to import layer files from a DXF drawing. 
 
1 Select the ‘Layer files’ alias and click Edit. The Alias Editor is 

displayed: 
 

For more information, see Using 
aliases in Help. 

A layer file contains graphical 
data, including objects, attribute 
data, and text. 

A window definition provides a 
view onto the graphical data 
stored on the layers. 
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2 Change the Name to read Club House Layer files 

 
You are going to store all layer files relating to the Club House in a 
new folder ‘Club House\Layer files’. 
 

3 Edit the Location by adding at the start of the path Club House\. 
 
Your Alias Editor should now look like this: 
 

 
 

4 Click OK. You are returned to the Define Database Aliases dialog 
box. 

 
You are going to store all window files relating to the Club House in 
a new folder ‘Club House\Window Files’. 

 
5 Now click the ‘Window files’ alias and click Edit. 
 
6 Edit the Name in the Alias Editor to read Club House Window files  

 
7 Edit the Location to read Club House\Window files 

 
8 Ensure that the Expandable check box is selected. Your Alias Editor 

should now look like this:  
 

 
  

9 Click OK. You are returned to the Define Database Aliases dialog 
box. 
 
The raster and library files refer to the whole project, so these will 
remain in their locations above the Club House and Site folders. 

Selecting the expandable check 
box allows users of the 
workspace to expand an alias 
name to show any subfolders. 

A raster file is in one of the 
following formats: 
BMP, DIB, JPG, (or JPEG), TIF, 
(or TIFF), PNG or EPX. For more 
information, see Help. 
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The aliases should be as shown in the Define Database Aliases 
dialog box below. If you have made a mistake, use the Edit button to 
correct it. 
 

 
 
You are now going to define two new aliases for folder locations that 
will contain the data relating to the car park and surrounding area, 
for the Site project workspace. 

 
10 On the Define Database Aliases dialog box, click Add to display the 

Alias Editor. 
 
11 Make sure the alias Type is set to Layer. 

 
12 In the Name box, type Site Layer files. In the Location box, type 

Site\Layer files, and then click OK. 
 
13 Click Add to redisplay the Alias Editor. 
 
14 Change the alias Type to Window and ensure that the Expandable 

check box is selected. 
 

15 In the Name box, type Site Window files. In the Location box, type 
Site\Window files, and then click OK. 

 
You will now create the final layer alias within the Site folder to hold 
the imported layers.  
 

16 Repeat steps 10 to 12, typing in the Name box Import Layer files 
and typing in the Location box Site\Layer files\Import 
 
You have now finished defining your aliases. Your Define Database 
Aliases dialog box should now contain the following: 

 
Club House Layer files Layer  Club House\Layer files 
Club House Window files Window X Club House\Window files 
Raster files Raster X Raster files 
Library files Library X Library files 
Site Layer files Layer  Site\Layer files 
Site Window files Window X Site\Window files 
Import Layer files Layer  Site\Layer files\Import 

 
If your Define Database Aliases dialog box is different from the 
above, click Edit and make the necessary amendments. 
 
 

Note that the X in the Define 
Database Aliases dialog box 
indicates that the alias folder 
is expandable. 
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17 Click Next. 
 

18 Click ‘Yes’ to the prompt ‘The folder Club House\Layer files does not 
exist. Do you wish to create it and any other alias folders?’ 
 
MicroGDS has created the appropriate folders for you. You can see 
your file structure in Windows Explorer. Do not close down 
MicroGDS at this stage as you have not finished creating your 
project. 
 

19 To see your file structure, start Windows Explorer and go to the 
location of your Flints Health and Fitness Club folder. Open all the 
subfolders. Your project structure should look like this (you may 
need to refresh your screen – press F5): 
 

 
 

20 Close Windows Explorer and return to your MicroGDS session. 
 
The Define Database Style Search Path dialog box is displayed: 
 

 
 

Defining the database style search path 
MicroGDS uses the style search path to read and store style files such as 
linestyles and character styles (charstyles). A project must have at least 
one location in its search path for style files. You can change the default 
location, and add and remove folders from the style search path as 
applicable. 
 
The first location that you specify defines the folder in which styles are 
updated and saved as you work. The style files in this location are called 
local style files and contain the local styles for the project. 
 
You can reorder the locations in the style search path using the Move Up 
and Move Down buttons. 
 

Your company may have 
company standard styles which 
will be held in a separate location. 
They will not be editable locally. 

For more information, see  
Editing the style search path in 
Help. 
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1 To define the folder for your local style files, double-click the first 
location, labelled 1, remove the dot and type Styles, and then click 

 
 

You are now going to set up a second location in the style search 
path to enable you to use styles from other style files. These styles 
would normally be your company’s standard styles. However, for the 
purpose of this training course you will use some pre-created style 
files in the training data folder. 

 
2 On the Define Database Style Search Path dialog box, click Add. 
 
3 Click Browse, represented by three dots, and browse to the 

Advanced training data folder. Select the Company Styles folder, 
and then click OK. 

 
Your style search path should now show:  
 

 
 

4 Click Next, and click ‘Yes’ to the prompt ‘The folder Styles does not 
exist. Do you wish to create it?’. MicroGDS creates a new folder 
called Styles under the Flints Health and Fitness Club folder. 

 
The Finished Creating a New Project Database dialog box is 
displayed: 
  

 
 

You are now ready to create the first of the two project workspaces. 
 
5 Ensure that the ‘Create a workspace’ check box is selected, and 

then click Finish. 
 

The Create a New Project Workspace dialog box is displayed. 

If you do not select the Create a 
workspace check box, you can 
create a workspace later by 
selecting File New and selecting 
the Project workspace option. 
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1.2 Creating a project workspace 
A project database can have any number of workspaces so that access 
to the data can be allocated to different users or disciplines. You are 
going to create two project workspaces: 
• Flints Site.cpj   
• Club House.cpj 
 
A workspace contains information such as the project database to be 
used, the layers that are editable and the default locations in which to 
save new files. It is also the way that you access the data. 
 
As you had selected the Create a workspace check box, the Create a 
New Project Workspace dialog box is displayed. As you have just 
created a project database, the name of the project workspace and the 
database are entered automatically in the appropriate boxes, for 
example: 
 

 
 
You will first create the Site workspace. 

 
1 Edit the Name box to add ‘Site’ to the CPJ name. The box should 

now show drive:\Flints Health and Fitness Club\Flints Site.CPJ 
 
Do not change the project database name as this is the database 
you want the Flints Site workspace to reference. Leave the 
Connection String unchecked. Checking this enables you to identify 
existing data to connect to. 
 

2 In the Description box, type Site workspace for Flints Health and 
Fitness Club 
 

3 Click Next. 
 
MicroGDS displays the Select Workspace Aliases dialog box. This 
enables you to select the layer aliases for the layers that are to be 
editable by users of the Site workspace. 
 
Initially, the ‘All aliases refer to editable data’ check box is selected. 
This means that all the layers referenced by the following aliases are 
editable by all users. You can restrict users from editing specific 
layers, by clearing this check box, and then selecting the aliases that 
refer to the layer file locations to be made editable. 

 

Project databases can be saved 
as project templates on which 
new projects can then be based. 
For details, see Using MicroGDS. 

Project databases and 
workspaces can be created and 
managed using the Project 
Administrator utility. Refer to the  
Project Administrator Help.  
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4 Clear the ‘All aliases refer to editable data’ check box and select the 
‘Site Layer files’ and ‘Import Layer files’ check boxes.  
 

 
 
5 Click Next. 

 
The Select Default Aliases dialog box is displayed. For example: 
 

 
 
Default aliases are stored in each workspace that refers to the 
database. For example, a Site workspace would have default aliases 
to store site data. This ensures that new files are saved 
automatically in the appropriate locations. 
 

6 As one of your first tasks is to import a DXF file, select the Import 
Layer files as the default layer alias and the Site Window files, as 
the default window alias. 
 

 

Once the project has been 
created, the only way to 
permanently change the default 
aliases in a workspace is by using 
the Project Administrator. Refer to 
the Project Administrator Help for 
details. 
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7  Click Next. 
 

The Finished Creating a New Project Workspace dialog box is 
displayed: 

 

 
 
8 Select the Open the Workspace check box and then click Finish. 

 
MicroGDS creates Flints Site.CPJ (the workspace) and adds it to the 
Document Organizer: 
 

 
 
 
Note that the default window definition alias is bold and highlighted. 

 
MicroGDS also adds a placeholder window to the MicroGDS window 
to indicate that the workspace is open, but no window definitions are 
currently open: 
 

 
 
For the time being you will leave Flints Site.CPJ and, as a short 
exercise, create the second workspace for the Club House. 

If you select the Add to the 
Windows Start menu check box, 
the Site CPJ will be added to your 
Start menu and you will be able to 
click on it to open it without first 
starting MicroGDS. 
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Exercise 1: Creating the Club House workspace 
Create a second workspace for data relating to Flints Club House. The 
Club House workspace will refer to Flints project database. Follow the 
wizard from the File New menu. A brief description of the steps have 
been included below to help you. 
 
1 On the Create a New File dialog box, select the Project workspace 

option. 
 

2 Enter the name for the new workspace. 
Tip: Browse to drive:\Flints Health and Fitness Club and double-click 
the folder to open it. In the File name box, type Flints Club House 
 

3 Browse for and select Flints.cpd as the database. Leave Connection 
String unchecked. 
 

4 In the Description box, type Club House workspace for Flints 
Health and Fitness Club, and then click Next. 

 
People who work on the Club House drawings have no need to edit 
data relating to the site. Therefore the only editable layers necessary 
for the Club House project will be the Club House layer files. 

 
5 Clear the ‘All aliases…’ check box and select ‘Club House Layer 

files’, and then click Next. 
 
The following Select Default Aliases dialog box is displayed: 
 

 
 
 

6 Ensure your Select Default Aliases dialog box is identical to the 
above, and then click Next. 

 
7 Select the Open the Workspace check box and then click Finish. 
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8 Click the list arrow at the top of the Document Organizer and you will 
see that it now contains two workspaces: 
 

 
 
MicroGDS also adds a second placeholder window to the MicroGDS 
window. 
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2. Importing data 
In MicroGDS, you can import data into your project from external CAD 
systems. The data could, for example, consist of survey data drawings or 
structural steelwork drawings supplied by outside contractors. 
 
However, because drawing methods and styles differ from office to 
office, and from project to project, the source data might not be 
organized in the way you would like, or might not conform to the drawing 
standards of your company. To help solve these types of problem, 
MicroGDS allows you to customize elements from the source drawings, 
such as the layer names and linestyles, before you import the external 
data. 
 
In this section you will import external data into your project. You will also 
populate the project with additional data by importing drawings 
previously created in MicroGDS. 
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2.1 Setting up library data 
If you were working in a disciplined office environment, you would 
probably have library files of standard objects for each particular type of 
project. For the purpose of this course, a number of library files have 
been created for you. You will now replace your empty, newly created 
library folder in Flints Health and Fitness Club folder. 
 
1 Do not close your projects, but minimize MicroGDS. 
 
2 Open Windows Explorer and locate your Advanced training data 

folder. Select the Library files folder and press CTRL + C to copy the 
folder and all the files. 

 
3 Move to drive:\Flints Health and Fitness Club and press CTRL + V to 

paste the folder and files. 
 

4 At the prompt ‘…do you want to replace the existing files?’ click ‘Yes 
to All’. 

 
The original Library files folder has been replaced by the new folder 
and its contents, from the Advanced training data folder. 

 
5 Restore the MicroGDS window, and on the Document Organizer, 

click the Library Files tab. 
 

6 To see the list of library files that are now available to the project, 
click the Library files alias. 
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2.2 Importing a DXF file 
You can change layer and object naming conventions, and line and 
character style names in DXF/DWG files to suit your company’s 
standards prior to importing the files into MicroGDS. This is done by 
using mapping tables. 
 
Two mapping tables are supplied in the Advanced training data folder. 
You will make some final edits to these mapping tables before you 
import the data. 
 
However, before you edit the mapping tables, you will use the DXFScan 
utility supplied with MicroGDS to list the element names used in the DXF 
file you will be importing. 

Listing the element names 
1 To start DXFScan, from Programs on your Start menu, click 

MicroGDS 8.0, and click DXFScan. 
 
2 On the DXF/DWG Scanner window, click Open file. 

 
3 From the Files of type list, select DXF files and browse to \Advanced 

training data\Import data\Site\Survey data.DXF, and click Open. 
 
• click the Styles tab, and note two character styles are listed; 

GRID_TEXT and STANDARD_TEXT 
 
• click the Ltypes tab; there are five linestyles listed 
 
• click the Layers tab and note that the layer names begin with G 

followed by 7 numbers 
 

4 To close the DXFScan utility, click Close.  

Setting up mapping tables 
You are going to use an entity mapping table to change all the existing 
layer names starting with a G to meaningful names. The entity mapping 
table supplied with the training data is a short example of such a table 
and maps only layers. For a more comprehensive entity mapping table, 
see the sample mapping table (entmap.emt) in \Program 
Files\Informatix\MicroGDS 8.0\Programs. 

 
1 Start a text editor such as Microsoft Notepad, and on the File menu, 

click Open. 
 
2 Change the Files of type box to All Files, and then browse to 

drive\Advanced training data and double-click Entmap.emt to open 
it. 
 

3 Add the following line at the top of the layer mapping: 
 
G8030001=Building outline 

 
Note: It is very important that you ensure throughout this section 
that your typing is accurate and that your capitalization is exactly as 
specified, otherwise your mapping tables may not work correctly. 

4 On the File menu, click Save. 
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You will now look at the Style mapping table that has been supplied 
with this course, make some amendments, and map it to the DXF 
data. Style mapping tables have the extension .smt. 

 
Style mapping tables define which linestyles and charstyles are used 
when you import and export MicroGDS files. 

 
5 From the Notepad File menu, click Open. 
 
6 Browse to drive\Advanced training data and double-click Styles.smt 

to open it. 
 

You will now amend the file so that MicroGDS substitutes, for 
example, the linestyle DASHDOT2 for Chain line. When you import 
the DXF file, MicroGDS will use the linestyles you have specified. 

 
7 Add the following: 

• under the heading [DXFLinesin] add the lines: 
DASHDOT2=Chain line 
FILLED=Fill 10% 

• under the heading [DXFCharsin] add the lines: 
GRID_TEXT=TNR7000 
STANDARD_TEXT=TNR3000 
 

8 Save your file and quit Notepad. 
 

You now have a customized style mapping table, an entity mapping 
table, and have defined the styles you wish to use in your project 
workspace. You will now map the location of your style and entity 
mapping tables to your project. 

 
9 In MicroGDS, open your Preferences dialog box and map your 

styles mapping table, using the File Locations tab. Click the Browse 
button next to Style mapping and browse to \Advanced training 
data\Styles.smt. Select the file and click Open.  

 
10 To map your entity mapping table, click the Browse button next to 

Entity mapping and browse for \Advanced training data\Entmap.emt. 
Select the file and click Open. Select the Save preferences check 
box, and then click OK. 

 
11 To load the tables, on the File menu click: 

• Mapping Tables, Styles 
• Mapping Tables, Entities 

 
When the tables are loaded, the commands are ticked. 
 

 

For more details, see Style mapping 
tables in Help. 

The linestyles Chain line and Fill 
10% have been predefined in the 
Company styles lines.sty. 

The charstyles TNR3000 and 
TNR7000 have been predefined in 
the Company styles char.sty using 
Windows font Times New Roman. 

The style mapping table supplied is a 
short example, for a more 
comprehensive one, see the sample 
mapping table in Program 
Files\Informatix\MicroGDS 
7.1\Programs. 
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Importing your data 
1 From the Document Organizer list, select Flints Site.cpj. 

 
2 On the File menu, click Import File, browse to \Advanced training 

data\Import data\Site\Survey data.DXF and then click Open. 
 

The following changes to the DXF data have been made by 
MicroGDS reading your mapping tables: 
• the grid is a dotted linestyle (Chain line) 
• the fill is transparent (10% fill) 
• the text styles are TNR3000 and TNR7000 
• the layers are named instead of numbered  

 
3 On the File menu, click Save Window & Layers and name the 

window definition Site plan. 
 
Note that MicroGDS automatically displays the default window alias 
for the location in which to save the window definition. 

 
You have now created the site plan. You will now import the data for 
the car park. 



20 MicroGDS  

 

2.3 Importing a MAN file 
When you imported DXF data in section 2.2, the layer alias was set to 
Import Layer files. This is because you were importing data from an 
external source and you would normally want to check this data before 
moving it into your main project alias (in this case Site). 
 
In this section you will be importing a MicroGDS MAN file which is part of 
your main project, so you will override your default layer alias to Site 
Layer files. The MAN file contains the data for the site car park layout. 
You will then copy the car parking layers into the Site plan window 
definition. 

Changing the default layer alias 
1 On the File menu, click Alias Overrides. 

The Alias Overrides dialog box is displayed: 
 

 
 

2 From the Layer alias list, select Site Layer files and then click OK. 
Any data you now import will be created on layers in the location 
defined by the Site Layer files alias. 

Importing the car park data 
1 On the File menu, click Import File. 

 
2 From the Files of type list, select ‘MicroGDS Files (*.MAN,*XML …)’. 

 
3 MicroGDS defaults to the last folder visited, so select 

Carparking.MAN and click Open. 
 
The Carparking.MAN file is imported into a new window definition 
called Parking & landscaping.wnd. Note that the name is derived 
from the principal window in the MAN file that you imported. The 
layers are created in the location defined by the Site Layer files 
alias. 
 

For more information, see Setting up 
Alias Overrides in Help. 
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4 On the Document Organizer, click the Layers tab. 
 

5 Now, double-click on the Import Layer files alias to open it. Double-
click on the Site Layer files alias to open it. Your Layers tab should 
look as illustrated: 
 

 
 

6 On the File menu, click Save Window & Layers. 

Adding the car parking data to the Site plan window 
definition 
You will now add the car parking data to the Site plan window definition 
so that all of your graphics can be viewed in the same window. 
 
1 On the Document Organizer, double-click the Site plan window 

definition to ensure that it is displayed and current. 
 

2 On the Document Organizer, click the Layers tab, open the Site 
Layer files alias and select all layers (four). 
 

3 Using the left mouse button, drag the layers from the Document 
Organizer to the bottom of the Mini Window Editor. 
 
The graphics on the layers are now visible as phases in your Site 
plan window definition. 
 

4 On the File menu, click Close Project and on the Save Drawing 
dialog box, click Save All. 

 
Note that at this point no data has been duplicated. You are viewing the 
same data in two window definitions: 
• Site plan, and 
• Parking & landscaping 
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Exercise 2: Importing the Club House MAN file 
You are now going to import a MicroGDS MAN file into your Flints Club 
House workspace. 
 
1 From the Document Organizer list, check that Flints Club House.cpj 

is current. 
 
You can now import the MAN file. 

 
2 On the File menu, click Import File. 
 
3 Ensure the Files of type is ‘MicroGDS Files (*.MAN,*.XML…)’. 
 

4 Click  to go to Advanced training data\Import data\Club House 
and then double-click on Flints club house.MAN to open it. 
 
The data is copied into your Flints Club House.cpj in a window 
definition called ‘Flints Club House.wnd’. 
 

5 On the File menu, click Save Window & Layers. 
 
Note that Flints Club House is shown under the default window alias 
(Club House Window files) on the Document Organizer. 
 
Later on in this training course, you will combine the Club House 
layers, with the Site layers. 
 
You will notice that if you are using the MicroGDS default colours, 
phase 1 uses a very pale colour. In the next section you will redefine 
the colours.  
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3. Colours 
In MicroGDS you can create as many colours as you require. You can 
assign colours to phases, objects, individual primitives, linestyle strokes, 
background, and selected graphics. In 3D drawings you can also assign 
colours to materials and lights. 
 
When you first start MicroGDS, a set of default colours is stored in your 
computer’s registry. In a single-user environment, colours are stored in 
each individual MAN file, and in a multi-user environment colours are 
stored in each project workspace. 
 
You can define new colours, or edit existing colours, using the Colours 
tab on the Preferences dialog box. The Colours tab also enables you to 
copy colours from your current document to the registry, and to copy 
colours from the registry into your current document. 
 
In the next section you will replace the default colours with a set of 
colours predefined for this training course.  
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3.1 Copying colours to the registry 
1 Using Windows Explorer, go to the folder Advanced training data, 

and double-click Colour Palette.man to open it in MicroGDS. 
 
2 On the File menu in MicroGDS, click Preferences, and click the 

Colours tab. 
 

 
 

3 To overwrite the colours in the registration database with the current 
colours, click ‘To registry’ and then click Yes at the prompt. 

 
The colours are copied from the Colour Pallete.man file to your 
computer’s registry. 

 
4 Close Colour Pallete.man. 
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3.2 Copying colours from the registry 
1 On the File menu, click Preferences, and click the Colours tab. 

 
2 Click From registry, and at the prompt ‘This will overwrite the colours 

in the current project with those from the registration database. Do 
you wish to continue?’ click Yes. 
 

3 Close the Preferences dialog box. 
 
The colours are updated in the Club House window definition, and 
the RGB (colour) values are now saved in the Flints Club House 
workspace. 
 

When you create a new project workspace, MicroGDS uses the colours 
from the registration database. If you edit a colour or copy the colours 
from the registry, MicroGDS writes the RGB values of each colour to the 
project workspace file. From that point the project workspace will ignore 
the registry colours and use its own colour definitions. 

Viewing your workspace to see the colour values 
Using a text editor, you can view Flints Club House project workspace 
and see how the RGB values have been assigned. 
 
1 Using Windows Explorer, go to drive:\Flints Health and Fitness Club 

and click on Flints Club House.cpj.  
 

2 Press SHIFT and with a right-button mouse click, select Open 
With… 
 

3 Select Notepad from the Open With dialog box. Ensure that the 
‘Always use this program to open this type of file’ is NOT selected, 
and then click OK. 
 

4 Scroll down to [MGDS Colours]; the Red, Green, and Blue values 
are then listed. 
 

5 Exit from Notepad without saving. 
 

6 Open Flints Site.cpj as described in 1 above. 
 

Note that at this stage there are no colours written in the project 
workspace as no colours have been edited or copied from the 
registry.  

 
7 In the next exercise you will copy the colours from the registry to the 

Flints Site project workspace. 
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Exercise 3: Copying colours from the registry to 
Flints Site workspace 

 
In this exercise, you will save the colours from the registry to Flints Site 
workspace. 
 
• Open Flints Site workspace and the Site plan window definition, and 

follow the steps in 3.2. 
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4. Customizing the user interface 
Although MicroGDS provides a default set of commands and toolbars, 
each MicroGDS user will have their own set of features that they 
commonly use, or they may prefer to place elements, such as toolbars, 
at different positions around their screen. Each screen configuration will 
vary from user to user.  
 
MicroGDS provides a set of tools that you can use to customize your 
user interface. For example, you can create new toolbars, add items to 
toolbars and edit status toolbars. In addition, you can attach a command 
that takes effect when you click the right mouse button, and add 
commands to run other applications from MicroGDS. 
 
In this section you will customize toolbars, add your own right mouse 
button menu (a shortcut menu), and assign shortcut keys to MicroGDS 
menu commands. 
 
If you intend to revert to the settings that were in place at the start of the 
course, ensure that you keep a note of the current MicroGDS settings. 
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4.1 Customizing toolbars 
You will create a new toolbar (a user toolbar), name it ‘My toolbar’, and 
add a number of buttons to it. The buttons you add give access to a 
number of commands that you will be using later in the course. 

Creating a new toolbar 
1 To open the Toolbars dialog box, press CTRL + T. 
 
2 On the Toolbars tab, click New, and in the New Toolbar name box, 

type: My toolbar and press ENTER. 
 

A new toolbar is displayed for you to add buttons to: 
 

 
 
3 On the Toolbars dialog box, click the Customize tab, and select 

Axes from the Categories list. 
 
4 Select Axes Move from the Commands list, and drag it onto your 

new toolbar. Repeat for Axes Reset. 
 

5 Add the following buttons: 
• Object Replace  (Objects category) 
• Object Sequence (Objects category) 
• Cut   (Selection category) 
• Paste   (Selection category 
 
Your new toolbar will now look like this (don’t worry if the order of 
buttons is different): 
 

 
 
6 Move ‘My toolbar’ to a convenient place in your toolbar area. 
 

In order to save duplicating commands, you will now remove two of 
the commands you have added to My toolbar from their default 
toolbars. 

 
7 With the Customize tab still active, drag the Cut button on the 

Selection toolbar (in the MicroGDS toolbar area) to the graphic 
screen area and then release the button - it disappears from the 
toolbar. 

 
8 Repeat step 7 for the Paste button, and then click OK to close the 

Toolbars dialog box. 
 

9 To save your toolbar changes immediately, select Save preferences 
on the Preferences dialog box and then click OK.  
 

For more information, see 
toolbars in Help. 
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Adding a status item to a toolbar 
You will now add the status item Char to My toolbar and then edit it. 
 
1 Open the Toolbars dialog box, and then click the Status bars tab. 

 
2 From the Status items list, drag Charstyle to the end of My toolbar. 

 

 
 
You will now change the status item label from Char to ‘current 
charstyle’ and increase the width of the charstyle display box. 

Changing the status item label 
1 On the Status bars tab on the Toolbars dialog box, click Edit. 

The Edit Status Item dialog box is displayed: 
 

 
 

2 On My toolbar, click the word Char. 
The Edit Status Item dialog box is updated to reflect your selection: 
 

 
 
3 In the Label text box, type current charstyle followed by a space. 

Note that the width box increments automatically. 

Adjusting the charstyle display box width 
1 On My toolbar, click the Charstyle display box and increase the 

width to 180. 
 

2 Click Done, and then click OK. 
My toolbar is now as shown below: 
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4.2 Creating a flyout toolbar 
Displaying a large number of toolbars can reduce the available working 
area. To make a number of commands available without using so much 
screen space, you can use ‘flyout toolbars’. Flyout toolbars display only 
the first button, the rest ‘fly out’ from this button. Flyout toolbars have a 
small triangle on the bottom right of the button: 
 

 
To create a flyout toolbar: 
 
1 Open the Toolbars dialog box, click the Flyouts tab and select Text 

(System) from the toolbar names. Drag the name onto the end of My 
toolbar. 

 
2 On the Toolbars dialog box, click OK. 
 
3 Press the mouse button on the flyout toolbar button to display the list 

of commands: 

 
4 If you already have the Text toolbar displayed, to save space, drag it 

on to the graphic screen, and then click the cross in the corner to 
close it. 

 
You can return all system and status toolbars to their original settings at 
a later time, using Reset All on the Toolbars dialog box. 
 
Note that toolbars you create can also be used as flyouts. You can also 
add flyouts to system toolbars and remove flyouts as required. For full 
details, see Help. 

For more details see, Using 
toolbars in Help. 

flyout
toolbar
button



Advanced Training Course  31 

4.3 Customizing keyboard shortcuts 
MicroGDS provides many shortcut keys such as F2 to open the Window 
Editor and F7 to select all graphics. It is possible to create your own 
shortcut keys, and in the following steps you will create a shortcut key to 
save the current view. 
 
1 Open the Preferences dialog box and click the Shortcuts tab. 
 
2 In the Command box, click File to close the File menu commands, 

and then click View to open the View menu commands. 
 
3 Select the Save View command. 
 
4 In the ‘Type new shortcut key’ box, press F11. 
 

 
 
5 Click Add and then click OK. 
 

Note that you can use any combination of SHIFT, ALT, and CTRL 
keys. F11 is used in this exercise. 

 
6 Zoom in to any area in your current window definition and save the 

view using F11, change the view and then click Restore View on the 
View menu. 

For a full list of default shortcut 
keys, see Keyboard shortcuts in 
Help. 
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4.4  Customizing menus 
When you start MicroGDS and open a new document, MicroGDS 
provides the following menus.  
 

 

 
 
You can customize the menus to suit your particular requirements. For 
example, you can add, remove, and move commands between menus. 
You can also create a new menu, and add commands to it. 
 
To understand how to customize MicroGDS menus, you will add a menu 
called My Menu, which will provide the following facilities: 
 
• start the Windows Notepad 
• run the sample application Bonus tools 
 
To customize a MicroGDS menu, you create a text file in Windows 
Notepad or similar, and save it with a .cfg extension. You then specify 
the location of the .cfg file in your Preferences.  
 
In the MicroGDS 8.0 Programs folder there is a sample cfg file called 
sample automenu.cfg. It contains an example of changes to the Help 
menu, a new Tools menu, and an example of a right-click popup menu. 

For more details, see 
Customizing menus in Help. 

Note that MicroGDS Plus does 
not contain the Render menu. 
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4.5 Creating a new main menu 
You will now create the following new main menu: 
 

 
 
1 Open Notepad from your Accessories menu, and on the first line 

type: 
 

[Menu] 
 
This line enables MicroGDS to identify that the following entries are 
intended as menu items. 

 
2 On the next line, type: 

; My Menu 
 
The semicolon ‘;’ at the beginning of the line signifies that this line is 
a comment and will be ignored by MicroGDS. 

 
3 On the next line, for the menu name that will appear on the menu 

bar type: 
M&y Menu 
 
The ampersand (&) indicates that the next letter will be underlined to 
provide an access key for the menu (see the illustration of My Menu 
above). This will enable you to press ALT + Y to access the menu. 
 

4 On the next line, type: 
M&y Menu\&Notepad=notepad.exe 

 
• My Menu is the name of the menu to which the following item 

will be added 
• The forward slash separates the main menu title from the menu 

item 
• Notepad is the command that will appear on the menu 
• The ‘=’ character separates the command from the program 

name  
• notepad.exe is the name of the program file 
 

5 To create a separator bar, on the next line type  
{/mmw} M&y Menu\---=X 

 
• {/mmw} indicates what sort of window must be open in 

MicroGDS for the separator to appear on My Menu: 
first m = menu flag 
second m = the menu will be available in a single user 
document 
w = the menu will be available in a multi-user window 
 

• M&y Menu is the menu to which the item will be added 
• --- (three dashes) indicates a separator bar will be added  

For more details on flags, see API 
Help, menu function 
CadAddMenuCommand. 

MicroGDS looks for the word 
[Menu] and anything after that in 
the correct format will be 
displayed on the menu bar. 
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• =X this must be included (X can be any single character) 
 
You will now add the Bonus tools sample application. For the 
purpose of this exercise a copy of Bonustools.exe has been placed 
in the Advanced training data folder. 
 

6 Add the following line: 
{/mmw} M&y Menu\B&onus tools=drive:\Advanced training 
data\Bonustools.exe 
 

7 Save your file as My Menu.cfg in your Flints Health and Fitness 
Club folder. 
 
Your file should now look similar to this: 
 

 

Assigning the menu file to MicroGDS 
1 In your Preferences, click the File Locations tab, and click the Menu 

configuration Browse button. Browse to your project folder and 
double-click your .cfg file to open it. 

 
2 Click Save preferences, and then click OK. 

 
This file is loaded and will be read the next time you start MicroGDS. 
 

3 To see My Menu, leave MicroGDS and click Save All, then restart 
MicroGDS. 

 
4 Click My Menu (or press ALT + Y) and you will see one item, 

Notepad. 
 
5 Open your Flints Club House workspace and then open the Flints 

Club House window definition. 
 
6 Click My Menu. You will now see an additional item (Bonus tools) 

and one separator. These were not visible before because you 
specified they would only be visible when a multi-user window was 
open. 
 
The bonus tools program mounts a toolbar offering a cloud 
generation command, a draw arc command, a command to check 
the number of vertices in a primitive, and a parabola command. 

 

Note that if your company uses a 
specific cfg file, remember to set 
your preferences back to the 
company configuration file after 
this training course. 

Note that you cannot change the 
order of the menus on the menu 
bar. This is determined by 
MicroGDS. 
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4.6 Creating a right-click, popup menu 
You will now create a right-click, popup menu for the right mouse button 
that will provide the following MicroGDS commands.  
 

 
 
Note that in the MicroGDS user interface, and in the rest of this training 
course, a right-click, popup menu is referred to as a shortcut menu. 
 
1 Go to My Menu.cfg in Notepad. 
 

You will now add the following lines to your cfg file. Note that menu 
items added to MicroGDS can be flagged to specify the type of 
menu to which they apply. These flags must be placed in braces {}. 
In the following example, the flags mp indicate that the following is a 
right click shortcut menu. 
 

2 At the bottom of the file, type the following comment: 
; right click shortcut menu entries 
 

3 On the next line, type the following right mouse click command: 
{/c5145 /mp}Cut=X 
 
where: 

the braces enclose the flags 
/c is the flag indicating that the following command 

(specified by its command identifier) is a built-in 
MicroGDS menu command 

5145 is the command identifier (in this case Cut) 
/mp is a shortcut menu available when a document is 

open 
Cut is the command name that will appear on the menu 
=X must appear, (X can be any single character) 

 
4 On the next two lines type: 

{/c5143 /mp}Copy=X 
{/c5151 /mp}Paste=X 

 
5 On the next line type: 

 
{/mp}---=X 
where: 
--- (three dashes) indicate a separator bar will be added 
 

6 On the next line type: 
 
{/c5155 /mp}Undo=X 
 

7 On the File menu, click Save. 
 

For a full description of flags, see 
the API help topic 
CadAddMenuCommand. 

For a full list of program 
identifiers, see mgdsmenu.txt in 
your MicroGDS Custom folder. 
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My Menu.cfg should now look like this: 
 

 
 

8 This file will be read the next time you start MicroGDS. 
 

9 To see your changes, leave MicroGDS and then restart it.  
 

10 Open Flints Club House workspace and open the Flints Club House 
window definition. To see the shortcut menu, click your right mouse 
button in the window definition.  
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Exercise 4: Customizing the user interface 

Toolbars 
1 Create a new toolbar ‘My toolbar 2’. 

 
2 Add the following commands: 

• Save View (View category) 
• Restore View (View category) 
• Clone Window (File category) 
• Update Thumbnail (View category) 
• Align to Set XY Axes (View category) 

 

     

Main menu 
You will now add the MicroGDS Help Synchronize program to My 
Menu.cfg. 
 
1 In Notepad, open My Menu.cfg. 
 
2 Insert the following at the bottom of My Menu: 

 
{/mmw} M&y Menu\&Help Synchronize=drive:\Advanced 
training data\HelpSync.exe  
{/mmw /s} M&y Menu\&Edit text and spell 
checker=drive:\Advanced training data\edittext.exe 
(The /s flag enables the menu command when you have graphics 
selected.) 
 

3 Save My Menu.cfg. 
 

4 Exit MicroGDS and save your settings on exit. Then restart 
MicroGDS. 
 

First you will use the edit text program you have added to My Menu: 
 

1 Open the Flints Club House workspace and the Flints Club House 
window definition. 
 

2 In the Mini Window Editor, double-click the Walls phase to make it 
current and editable. Make all other phases hittable. 
 

3 Press F7 to select all graphics. 
 

4 Click My Menu, Edit text and spell checker. 
 

5 In the Edit Text dialog box, click Spell Check, and accept the 
correction of Beaxtician to Beautician. Ignore the spelling of 
‘Comms’. 
 

6 Reset all phases to editable. 
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You will now use the Help Synchronize program you have added to My 
menu: 
 
1 On My Menu, click Help Synchronize. The Help Sync toolbar is 

started. 
 

2 Select all three Help Sync buttons (with question marks). 
 

3 Click a number of toolbar buttons, the appropriate Help topic is 
launched. 
 

4 To close Help Synchronize, click  on the HelpSync toolbar. 

Shortcut menu 
1 Add the following commands to the bottom of your shortcut menu: 

• a separator bar 
• Display Query = 5225 
• Draw to Selection = 5440 

 
2 Save My Menu.cfg. 

 
3 In MicroGDS, exit and click Save All at the prompt. 

 
4 Restart MicroGDS and open the Flints Club House workspace and 

Flints Club House window definition to see your new shortcut menu 
commands. 
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5. Viewing your data 
When you work with large amounts of data over vast distances, viewing 
the extent of the graphics on a drawing could be very difficult and time 
consuming.  
 
For example, imagine trying to zoom in to some detailed, intricate work 
and then zooming out to the broader picture. Locating a useable view 
extent with which to work could be difficult. Using the Navigate window in 
MicroGDS, you can create a thumbnail view of your graphics that you 
can then use to navigate around your drawing more easily and quickly.  
 
MicroGDS also provides tools so that you can rotate views, personalise 
the view controls, and also save and restore views for future use. 
 
In this section, you will learn how to work more easily with views, such as 
how to set up, save, and create new and rotated views. 
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5.1 Choosing your view controls 
To help you see the effect of the various view controls, ensure that the 
Flints Club House window definition, in your Flints Club House 
workspace, is open. 

View buttons 
MicroGDS offers a large number of view control buttons. Each one can 
be displayed: 
• on an open window definition 
• on the Navigate window 
 
They are also all available on the View toolbar. You can selectively 
switch each one on and off by using the View Controls tab on the 
Preferences dialog box. 
 

 
 
The view controls can be displayed on a 2D view, a 3D view, or both. 
You can choose whether they are displayed vertically down the left-hand 
side of a window definition, or horizontally along the bottom of a window 
definition. Note that the view controls are always displayed horizontally, 
along the bottom of the Navigate window. 
 
You can also add view buttons to your own toolbars as described earlier. 
 

For a full list of Viewing buttons, 
see Help. 
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Customizing view controls 
 
1 On the File menu, click Preferences, and select the View Controls 

tab. 
 
2 Under the Window 2D column: 

• select Zoom In and Zoom Out  

• scroll down the list and clear the Zoom bar  
• click OK to see the results 

Using the Navigate window 
An additional aid to navigation is the Navigate window. The Navigate 
window can be displayed and hidden using the Window menu. The 
Navigate window can be docked as required. 
 
1 If the Navigate window is not currently displayed, on the Window 

menu, click Navigate. 
 

The Navigate window is opened with the default viewing buttons as 
illustrated below: 
 

 
 
The standard buttons on the Navigate window are, from left to right: 
• Previous View 
• Next View 
• Update Thumbnail 
• Nudge Left 
• Nudge Right 
• Nudge Up  
• Nudge Down 

 
 

2 Click the Update Thumbnail button on the Navigate window. The 
Flints Club House window definition is displayed in the Navigate 
window, and also (if you have Flints Club House selected on the 
Windows tab and the Preview button selected) in the preview area 
on the Document Organizer. 
 
You will now use the thumbnail to move around your view. When 
you draw new graphics or change the view of a window definition, 
you see the changes in the thumbnail only after you update the 
thumbnail. 

 

For more details, see Navigating 
the view in Help. 

A thumbnail enables you to 
preview the window on the window 
definitions tab in the Document 
Organizer, and to move around the 
view using the Navigate window. 
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3 In the window definition, use the Zoom In button to enlarge the 
Restaurant area.  
 

4 To change the zoomed in area, point to the highlighted area in the 
Navigate window and drag it around. The corresponding area is 
moved in your window definition. 
 

5 To move the zoom in area in an orthogonal direction, click the 
Nudge Up, Nudge Down, Nudge Left, and Nudge Right buttons a few 
times to see the effect. 

 
6 To change the zoom in extent, press your right mouse button over 

the Navigate window and drag the mouse to define the view extent. 
 
You can change the view buttons that are displayed on the Navigate 
window, using your Preferences. 

 
7 Open the Preferences dialog box, and click the View Controls tab. 
 
8 Under the 2D Navigate column, select the following check boxes: 

• Save View 
• Restore View 

Using a mouse wheel 
If you have a wheel mouse, you can also use the wheel to navigate the 
view (in both the window definition and the Navigate window). Rotating 
the wheel up zooms in, and rotating the wheel down zooms out. 
 
When you press the wheel, the pointer changes to a hand.  The point at 
which the hand appears is attached to the graphics, so that as you move 
the hand around, the graphics are panned under the hand. 

Draw to selection 
The Draw Selection viewing button allows you to zoom in to show all 
graphics that are currently selected. This can be particularly useful when 
you are editing a number of objects dispersed around the drawing. The 
Draw Selection command allows you to zoom in quickly. 
 
Note that you have added the Draw to Selection command to the 
shortcut menu. 
 

The nudged amount can be 
adjusted in the View Parameters 
dialog box. 
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5.2 Saving views 
When you are working on a large project you can create any number of 
window definitions, each one of which can have a saved view for a 
particular area of graphics. 
 
You will now create some views, and save them as new window 
definitions. 
 
1 Open the project Flints Site.cpj, and double-click the Parking & 

landscaping window definition. Double-click the title bar to maximize 
the window. 

 
2 Zoom in to the area illustrated below. 
 
3 Press F11 (Save View), and in the Navigate window, click Update 

Thumbnail. 
 
4 On the File menu, click Save Window As and name your window 

definition Building footprint  
 

 
 

You now have a new window definition called Building footprint that 
will open with the view you saved. The thumbnail in the Navigate 
window will also reflect the saved view. 
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5 In the Document Organizer, double-click the Parking & landscaping 
window definition. 

 
6 Zoom in to the area illustrated below. 
 
7 Press F11, and on the Navigate window, click Update Thumbnail. 
 
8 On the File menu, click Save Window As and name your window 

definition Car park island 
 

 
 
9 Move between your views using CTRL + TAB. 
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5.3 Rotating views 
You can align the graphics in a window with the set XY axes. This 
enables you to view your graphics from any angle you wish. 
 
To illustrate the Align to Set XY Axes command: 
 
1 Double-click the Parking & landscaping window definition to open it. 
 

You will orientate your view so that it is orthogonal to the long line of 
parking bays.  

 
2 On My toolbar, click Axes, Move. 
 
3 To place your axes, click on your graphics as illustrated below; 

ensure that your Y axis is pointing in the direction shown, and then 
press ESC. 

 

 
 
4 On My toolbar 2, click Align to Set XY Axes. 
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The graphics are rotated to align with the XY axes: 

 
 
 

5 Zoom in to an area that just encloses all the Parking bays: 
 

 
 
6 Press F11, and in the Navigate window, click Update Thumbnail. 
 
7 On the File menu, click Save Window As and name your window 

definition Parking bays rotated 
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Exercise 5: Saving views 
You will save a rotated view of five car parking spaces, which you will 
designate the visitors parking area. 
 
1 Open the Parking & landscaping window definition. 
 
2 Zoom in to the area illustrated below: 
 

 
 
3 Set your axes along the line as illustrated. 
 
4 On the View menu, click Align to Set XY Axes. 
 

 
 
5 Press F11, and in the Navigate window, click Update Thumbnail. 
 
6 On the File menu, click Save Window As and name your window 

definition Visitors parking 
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6. Managing objects 
In the MicroGDS Foundation Course, you learned how to create new 
objects and also how to edit and rename existing objects. 
 
In this section you will learn how to produce a list of object names used 
in your drawing. Next, you will rename a range of objects in a sequence 
and then use the object name and its sequence as annotation on the 
drawing. 
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6.1 Listing objects 
MicroGDS provides two methods of producing reports about objects: 
 
• Object, List which is covered in this section 
• Object, Schedule which is covered in section 9 
 
Object list scans the active window definition and produces a list of all 
the objects (and instance objects) included in each visible phase, and the 
number of times they occur. 
 
To list all objects in the Parking & landscaping window definition: 
 
1 Ensure that the Parking & landscaping window definition is the 

active window. 
 
2 On the Object menu, click List. 
 
3 MicroGDS generates a text file, listing the objects as follows: 

 

 
 
 
4 Close the file. 

For full details, see Listing objects 
in Help. 
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6.2  Sequential numbering 
The 35 car parking bays along the bottom of the car park in the Parking 
& landscaping window definition are each to be painted with a sequential 
bay number, starting from the left. 
 
The bay numbers will be displayed as individual objects and text blocks 
using secondary annotation. Each object will be renamed with the Object 
Rename Sequence command, so that each object will have the same 
root name, with an incremental number as its last facet. 

Attaching a text block to the current bay 
1 In the Document Organizer, double-click the Parking bays rotated 

window definition to open it. 
 
2 In the Mini Window Editor, ensure the Car park phase is set to 

editable and is the current phase. Set all other phases to hittable. 
 
3 Zoom in to the first parking bay on the left of as illustrated below. 

 
4 On the Object menu, click Rename, Object.  

 
5 Click the parking bay with an Inside snap (the object to rename). 

 

 
 

6 In the Rename Object dialog box, type ‘Parking Bay:1’, and click 
OK. 
 

7 Press ESC. 
 
You have added a second facet to the object name, this being ‘1’. 
 

8 Click on to Parking bay:1 to select it, and on My toolbar click Axes, 
Reset and click on to Parking Bay 1 with an Inside snap. 

Setting the font 
To set the font for the bay number text, you will change the current 
charstyle. 

 
1 From the Styles tab on the Document Organizer, open the 

Charstyles category, open the Flints Health and Fitness 
Centre\Styles\CHARS.STY and select Arial Narrow 2000 High.  
 

2 From the shortcut menu, select Set as current. 

For full details, see Secondary 
annotation in Help. 
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Adding secondary annotation to your object  
1 From the flyout toolbar on My toolbar, click Construct Text.  

 
2 In the text box, type ^(facet 2). Select the top right justification 

button, and then click OK. 
 
^(facet 2) means that the second facet of the object name will be 
added to the object and displayed as text – in this case the number 
1. 

 
3 Place your text with a point snap in the top right-hand corner of the 

parking bay. 
 

The number 1 is inserted as illustrated: 
 

 

Replacing objects with another object 
In MicroGDS you can replace a number of objects with copies of another 
object. You will now copy the first bay (with its number) and replace the 
rest of the parking bays with it. 

 
1 Click Restore View to view the whole line of parking bays. 

 
2 Press F10 and select the first parking bay (the bay and the number 1 

should both be selected). 
 

3 Use the shortcut menu, and click Copy. 
A copy of the first bay is placed on the Clipboard. 
 

4 Press F6 (Fence) and draw a line as illustrated below, ending the 
line with a dot snap. Press ENTER to select the objects which the 
line crosses. 

 

 
 
All the parking bays except the first bay should now be selected. 
 

The commands Replace and 
Superimpose use graphics from 
the Clipboard. 
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5 On My toolbar, click Object Replace. 
All the bays are replaced with the Clipboard copy of the first bay, 
and all are currently numbered 1. 
 

 

Renaming the objects in a numeric sequence 
1 On My toolbar, click Object Sequence, and click OK on the Rename 

Object dialog box to accept the first object name. Click onto each of 
the parking bays in turn, with an Inside snap, starting with bay 1. 
 

2 On the Edit menu, click Select All. 
 
3 To see the result, on My toolbar, use your flyout button to select 

Regen Text. 
 
The text is regenerated and the numbers are updated sequentially 
from 1 to 35 as illustrated below: 
 

 
 

4 Press F11 to save your view, and then, on the File menu, click Save 
Window As, and name your window definition Parking bays 
numbered. 
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Exercise 6:Sequential numbering 
You are now going to use Object Sequence to number the 5 parking bays 
as illustrated below. 
 
All 5 bays have secondary text added to the second facet of the object, 
but as the object name consists of only 1 facet, the secondary annotation 
is invisible. 
 
1 In the Document Organizer, double-click the Visitors parking window 

definition to open it. 
 
2 Ensure the Car park phase is editable and all other phases are 

hittable. 
 
3 In Object mode, select the first bay. On My toolbar, click Object 

Sequence and add 36 as the second facet. 
 

4 Click on the five bays starting from the left. 
 
5 Press F7 to select all. 
 
6 On My toolbar, click Regen Text. The parking bays are numbered 36 

to 40 as shown below. 
 

 
 
7 On the File menu, click Save Window & Layers. 
 
8 Close your Flints Site workspace. 
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7. Working with layers and phases 
 
Layers contain the data in a project and are used to maintain a 
manageable amount of graphics. If all the data in a drawing were on one 
layer, you can imagine how difficult it would be to control how the data 
are viewed and how time consuming it would be to refresh the screen. 
 
In this section you will learn about the relationship between layers and 
phases, how layers are viewed in windows, how to copy a layer, and how 
to filter the data on one layer to view it in different phases. 
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7.1 Creating new phases to reference an 
existing layer 

You will use the Furniture layer data provided in the Flints Club House 
workspace for this exercise. 
 
In this first exercise, you will filter the furniture into three phases. The 
first phase will reference all the furniture except for the internal and 
external dining furniture. The second phase will reference the internal 
dining furniture and the third phase will reference the external furniture.  
 
Note that although the data appears in three phases, the graphics have 
not been moved or copied but simply filtered to display them in their 
respective phases. 

Copying phases 
1 Open Flints Club House.cpj and double-click the Flints Club House 

window definition to open it. 
 

In the Mini Window Editor, note the phases that are included in the 
current window definition. 

 
2 Double-click the Furniture phase to make it current.  

 
3 Click the right mouse button over the Linked layer column in the 

Mini Window Editor and select Invert Selection. Under the Status 
column select Hittable. 
 

4 Make a copy of the furniture phase by selecting it, pressing CTRL 
and dragging it to the bottom of the list. Repeat again to make a 
second copy of the furniture phase. 
 

 
 
You now have three phases looking at the same layer data 
(furniture)−notice that the layer link numbers are the same. You 
have not made three copies of the data. Currently, all three phases 
reference the same data, so you will now use inclusion lists to filter 
the data in a particular phase. 
 

5 Change the phase colours by changing phase 6 to Red (colour 1) 
and phase 7 to Blue (colour 3). 

Note that the furniture in the Flints 
Club House includes the exercise 
equipment. 
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Filtering the contents of a phase 
1 To filter the furniture using an inclusion list, you will need to use the 

full Window Editor, so press F2.  
 
2 Select your first furniture phase (phase 5) and click the Include 

button, and then in the Inclusion List box type: 
 
NOT MGDS:FURN:** 
** 
 
This will include all furniture except any furniture with object names 
starting with ‘MGDS:FURN:’ 
 

3 Click OK. 
 
4 Select your second furniture phase (phase 6) and repeat steps 2 and 

3 typing in the following: 
 

**:DINING 
 
This will include any furniture with object names ending with the 
facet ‘DINING:’ and exclude all other objects in this phase. 
 

5 Select your third furniture phase (phase 7), click Include and then 
type: 
 
**:EXTERNAL** 
 
This will include any furniture with object names containing 
‘EXTERNAL’ and exclude all other objects in this phase. 
 

6 On the Window Editor, edit the Phase labels to reflect the content of 
each phase. 

 
The furniture data has now been filtered into three phases, to 
illustrate the different types of furniture in Flints Club House. 

 
7 Close the Window Editor, and then save your window and layers. 
 
 

You can use the asterisk as a 
wildcard character. * means match 
this single facet; ** means match the 
remainder of the object name. For  
full details of wildcards, see Using 
wildcards in Help. 
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7.2 Creating a new layer and duplicating its data 
In MicroGDS you can copy a layer together with its data, so that you 
have a duplicate set of data. This is known as cloning in MicroGDS. This 
can be useful if you want to try various schemes, but you want to keep 
the original layer data unchanged. 
 
In this section you will first copy a window definition and rename it. When 
you copy a window definition you are copying only the view onto the 
graphics, and not the actual graphics. So, at this stage, you have not 
created duplicate data. 
 
You will then clone the external furniture layer, and the graphics it 
contains, so that you have a duplicate set of the external furniture. 
Finally to illustrate that the data has been duplicated, you will display 
both window definitions side-by-side and move the external furniture into 
a new layout.  

Copying Flints Club House window definition 
1 On the Document Organizer, select the Flints Club House window 

definition, and then select Copy from the shortcut menu. 
 

2 Select the Club House window files alias and choose Paste from the 
shortcut menu. 
A copy of the Club House window definition is inserted. Remember, 
this is a duplicate view, not duplicate data. 
 

 
 

3 Rename the copy of the window definition External furniture 
scheme 2 and double-click on it to open it. 

Duplicating the data 
1 Press F2 to open the Window Editor. 

 
2 Select the furniture phase with the **:EXTERNAL** inclusion list, and 

click the Clone Layer(s) button. 
 
The Clone Layers dialog box is displayed. 

 
3 Ensure that ‘Change Existing phases to refer to cloned layers’ is 

selected and click OK. 
 

For more details, see Cloning 
layers in Help. 
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Note that phase 7 no longer has the same linked layer number as 
phases 5 and 6. This means that you have created a duplicate set of 
all furniture, but with only external furniture visible, because of the 
inclusion list filter. 
 

4 To dismiss the Window Editor, click Close. 
 

5 Close all window definitions except Flints Club House and External 
furniture scheme 2. 
 

6 On the Window menu, click Tile Vertically. 
 

7 Press F10 to select Object mode. Rearrange the external tables in 
the ‘External furniture scheme 2’ window definition. Note that they 
have not moved in the Flints Club House window definition as they 
are on a different layer. 
 

8 Select and move a table and chairs in the restaurant and notice that 
they move in both windows. 
 

 
 
9 Save and close the Flints Club House workspace. 
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7.3 Moving layers 
In this section you will move layers from one alias to another. You will 
move the layers from the Import alias to the Site alias. The Import alias 
was a temporary alias used to import the DXF file to. You will now move 
these layers into their permanent alias location (the Site alias). 
 
Note that you can only move layers when they are not being referenced 
by a window definition. This means you must open the Flints Site 
workspace, and move the layers before opening the Site plan window 
definition. 
 
1 Open the Flints Site workspace. 
 
2 DO NOT open any of the window definitions. 
 
3 On the Document Organizer, click the Layers tab, and select all the 

layers in the Import Layer files alias. 
 
4 Using the right mouse button, drag the layers from the Import Layer 

alias to the Site Layer alias. 
 
5 Release the mouse button, and from the displayed shortcut menu, 

select Move Here. 
 

The layers are moved into the Site Layer files alias. 
 
6  Close the project. 
 

When you move layers between layer aliases, the layers are 
immediately moved in the filing system. Therefore you do not need 
to save the project before you close it. 
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7.4 Setting style overrides 
In MicroGDS you can set overrides for a phase to define the linestyle in 
which all lines are drawn, and the charstyle in which all text is drawn. 
 
In this section you will select a masked linestyle, copy a phase and use 
the masked linestyle as a style override. This will mask the paving slabs 
and prevent them from showing through the table and chairs. 
 
1 Open the Flints Club House workspace. 
 
2 Open the Flints Club House window definition. 
 
3 Zoom in to the patio area on the left side of your window definition. 
 
4 Display the Window Editor; the Furniture phase (phase 7) with the 

inclusion list **:EXTERNAL** should be at the bottom of the phase 
list. 

Copying phases 
1 To copy phase 7, select it and holding down CTRL, drag it to the 

bottom of the list.  
 
You now have phase 8 with the same layer link number as phases 7, 
6 and 5. 
 

2 Your Window Editor and the table and chairs will look like this: 
 

 

For more details, see Setting 
phase overrides in Help. 
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Using the Overriding linestyle 
1 Select phase 7 **:EXTERNAL** 

 
2 From the Linestyle Override list, select the MASK linestyle. (The 

Overrides Linestyle is two-thirds down the Window Editor.) 
 
Your table and chairs now have a mask linestyle, so the paving 
bricks are now obscured. 
 
Your Window Editor and table and chairs will now look like this: 

 

 
 

3 Close the Window Editor. 
 

4 Save and close the Flints Club House window definition. 
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7.5 Copying phases and superimposing objects 
In this section you will combine the data from the Club House and Site 
plan window definitions and save the data in a new window definition. 
You will then copy tables and chairs to an area around the pond and add 
a parasol to them. 

Creating a new window definition combining the Site and 
Club House data 
1 Open the Flints Site workspace, and then open the Site plan window 

definition. 
 
2 Open the Flints Club House workspace, and the Flints Club House 

window definition. 
 
3 On the Window menu, click Tile Vertically. 
 
4 Select the Site plan window definition and open the Window Editor. 
 
5 Select all the phases, except the footprint phase, and drag them into 

the Club House window definition. 
 
6 Close the Site plan window definition. 
 
7 Maximize the Club House window definition. 

 
Notice that all the phases from the Site plan window definition are 
hittable. This is because you do not have direct access to the Site 
data via the Club House workspace. 

 
8  Save the window definition as Overall site plan 

Copying the tables and chairs around the pond  
1 Zoom in to an area around the Pond: 
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2 In object mode, select an external table and holding down CTRL, 
place 4 copies around the pond as illustrated below: 

 

 
 
 
3 Zoom in to one of the tables you have just placed. 

Adding a parasol to one of the tables 
1 On the Document Organizer, click the Library Files tab and expand 

the Furniture library file. 
 
2 Now expand the Furniture layer to display the objects it contains.  
 
3 Select the MGDS:FURN:EXTERNAL:PARASOL object and from the 

shortcut menu, select Insert Instance. 
 

4 Move the mouse to position the parasol over the top of the table. 
Use an I snapcode to place the parasol.  

 
The parasol is placed, centred on the table: 
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Copying the parasol to all the external tables  
1 In the Mini Window Editor make phase 7 (the Furniture phase which 

includes the External furniture) editable. Make all other phases 
hittable. Remember to use Invert Selection. 
 

2 On My toolbar, click Axes Reset, and click onto the centre of the 
parasol. 
 

3 Select the parasol in Object mode (F10), and cut the parasol to the 
Clipboard. (Make sure only the parasol is selected.) 
 

4 Zoom out to the area illustrated below. 
 

5 On the Edit menu, click Select All (only the external tables and 
chairs are selected). 
 

6 On the Object menu, click Superimp. 
 
The parasol is added to the rest of the external tables and chairs. 

 

 
 
 

7 Save both your project workspaces. 
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Exercise 7:Superimposing objects 
In this exercise you will copy a dining chair to the end of one of the 
tables in the restaurant, and then superimpose the chair on to all the 
tables in the dining area. 
 
1 Check you have the Flints Club House workspace and the Overall 

site plan window definition open. 
 
2 Zoom in to Bar & Joggers restaurant. 
 
3 Make phase 6 (the phase which includes the dining furniture) 

editable, and make all other phases hittable. 
 
4 From the Document Organizer Library tab, expand Furniture.MAN. 

Select the MGDS:FURN:CHAIR:DINING object and from your 
shortcut menu, select Insert Instance. 

 
5 Place the chair down with an I snap at the table illustrated. 
 

 
 
6 On My toolbar, click Axes Reset and click on to the middle of the 

table using an Inside snap. 
 
Note that the Angle in the status bar changes to 90 degrees as this is 
the object axes of the dining table. 

 
7 In object mode (F10), cut the chair to the Clipboard. 
 
8 Select all the tables (six). 
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9 From the Object menu, select Superimp. 
 

The chair is copied to the other tables as illustrated below: 
 

10 On the status toolbar, reset the Angle back to 0. 
 
 

 
 

11 Save the Club House workspace, and then close both project 
workspaces. 
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8. Creating symbols, linestyles, and 
character styles 
The graphics and text that you produce on the screen are exactly what 
you get when you plot or print your drawing. Using MicroGDS, you can 
enhance the look of a drawing in a number of ways including varying the 
thickness of lines, and including symbols within lines to denote particular 
requirements. You can also make use of colour with filled linestyles, and 
create fills with symbols to mark out areas of interest on your plans. 
Furthermore, you can create your own typeface (or font) to use when you 
add text to your drawing. 
 
In this section you will learn how to create your own font and use it to 
annotate your drawing. You will also create a number of linestyles 
including filled linestyles, using both symbols and raster images. 
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8.1 Creating fonts 
In this next section you are going to modify some predefined characters 
and use them in a text block. 
 
To save time, an alphabet has been partially created for you. 
 
• Open My text.MAN from the Advanced training data folder. 
 

 
 

You will notice that the letters A to F are different to the rest of the 
alphabet, and that the letter L is missing. You will first create the 
letter L using an existing font, and then edit it (together with letters A 
to F) to match the other letters. 
 
For MicroGDS to recognize a text or symbol character, you must 
give it an appropriate name. The last facet of this name must be the 
valid Unicode or ASCII character specification that represents that 
particular character. For example, if you query the character G, the 
object name is text:71, 71 being the ASCII code for ‘G’. 

Creating the character ‘L’ 
1 On the Object menu, click New.  

 
2 In the New Object dialog box change the name offered to text:76, 

(76 is the ASCII code for L), and place the hook point at the bottom 
left of the empty grid box.  
 

3 From the current charstyle list on My toolbar, select ARIAL94. 
 

4 On your flyout toolbar, click Construct Text. In the New Text dialog 
box type L and select the middle justification button. Place your 
letter in the empty grid box with an Inside snap. 

 
To modify the shape of your text, you need to convert the existing 
letters A to F and L from text to line primitives. 

For a full list of ASCII codes, see 
Decimal ASCII codes in Help. 
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Converting text to line primitives 
1 On the Mini Window Editor, set the Construction lines phase to 

Visible. 
 
This will enable you to select your letters easily without inadvertently 
selecting the construction lines. 

 
2 Select the first letter to convert, using a Box snap as illustrated, and 

then from your flyout toolbar, select Graphics from Text. 
 

 
 
3 Repeat step 2 for each letter to convert, ensuring that you select 

only one object at a time. Otherwise, MicroGDS would combine the 
objects into one single object. 
 
You will now change the style of the letters to match the rest of the 
alphabet. To speed up the selection of the letters, you will use the 
Fence command. 

Matching your fonts to the rest of the alphabet  
1 Press F10, object mode, and F6 (Fence select) and draw a line as 

illustrated below; press ENTER to finish. 
 

 
 
2 On the Alter menu, click Smooth, Midpoints. 

 
3 With each letter still selected, from the Line list on the status toolbar, 

select Fill30%143T. 
 

4 Press ESC to deselect the Fence command. 
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Your finished alphabet will look as shown: 
 

 
 

 
You have created the graphics for the capital letters of a new font. 
To enable MicroGDS to recognize font graphics you need to save 
the file as a CV7 file. 

 
5 Save the MAN file as My new font.CV7 in drive:\Advanced training 

data\Company Styles. 
 
6 Close the CV7 file. 
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8.2 Using your new font 
In this section you will use the font you created in the previous section in 
a new charstyle. 
 
1 Open the Flints Site workspace and the Building footprint window 

definition. 
 

2 Double-click the Footprint phase to make it current and editable, and 
create a new object called Text: 

 
3 Place the hook point in the middle of the building footprint, using an 

Inside snap. 
 
You will now define a new charstyle based on your My new font.CV7 
file. 
 

4 From your flyout toolbar, select Charstyle Modify and select 
MicroGDS Font. From the MicroGDS Font dialog box, select My 
new font and click OK. In the Height box, type 10000 and save your 
charstyle as My text. 

 
5 Using the Construct Text command, place the word FLINTS as 

illustrated below. 
 

Note that you have to use uppercase characters as these are the 
only set you created. Any lowercase characters you use will display 
as DEFAULT style. 
 

 
 

6 Save and close your window definition. 
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8.3 Creating a linestyle using a symbol 
In MicroGDS you can incorporate MicroGDS fonts and symbols in a 
linestyle. This is useful, for example, on architectural plans where you 
may want to use patterned filled linestyles for paved areas, roof tiling, 
brick coursing, etc. 
  
You are going to create a filled linestyle, using a conifer tree symbol, to 
donate a field used for Christmas tree farming. 

Creating a CV7 file 
1 Open the file drive:\Advanced training data\Tree Symbols.man. 

This file contains two symbols representing trees: 
 

 
 
2 Query the objects and check that the last facet of each object is a 

number. 
 
3 Save the file as My symbols.CV7 in your Company Styles folder, 

and then close the file. 

Preparing your graphics 
1 Open the Site plan window definition in Flints Site workspace. 
 
2 Click on to the land boundary as illustrated below: 

 

Click
here

 

For more details, see Creating 
and modifying linestyles in Help. 
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Creating a filled linestyle using a tree symbol  
1 On the Status toolbar, ensure that your units are set to mm. 

 
2 Open the Linestyle dialog box. 
 
3 For the Stroke type, select Fill. 
 
4 For Fill type, select Symbol. 
 
5 From the Font list, select My symbols and in the Symbol box select 

the symbol representing a conifer tree (Symbol 1). 
 
The tree symbol was originally created at a scale of 1:1 and is 
approximately one metre high. Your fill area in the site plan is 
covering a very large area, (approximately 19000 square metres). A 
one metre tree will be so small that you will not be able to see it on 
the drawing. The symbol therefore needs to be scaled. For this 
example you will scale the tree 10 times. 

 
6 Type 10 in the Scale box. This will make the tree 10 metres high. 
 

You now need to set the spacing around each tree symbol. For this, 
use the Grid section of the linestyle dialog box. 

 
7 To set the vertical gap, type 20000 in the Gap box, and to set the 

horizontal spacing, type 20000 in the Spacing box. 
 

Your Linestyle dialog box should now look as illustrated below: 
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Creating a thin boundary line 
1 Click the New Stroke button and then, for the Stroke type, select 

Pattern.  
  
2 Click Save As, and name your linestyle Tree fill. 

 
The selected land parcel will adopt the Tree fill linestyle as 
illustrated below: 

 

 
 

3 Close the Linestyle dialog box, and then press F8 to deselect your 
graphics. 
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8.4 Creating a linestyle with a raster image 
You can also use a raster image in a linestyle. To illustrate this, you will 
show paving around the Club House. 
 
Creating a filled linestyle using a raster image 
1 Open Flints Club House workspace and open the External furniture 

scheme 2 window definition. 
 

2 Open the Linestyle dialog box. 
 
3 For the Stroke type, select Fill. 
 
4 For Fill type, select Raster. 
 
5 To enter the file name, click Browse and select drive:\Advanced 

training data\Raster files\Mpv0732.bmp. Click Open. 
 
6 In the Height and Width boxes, type 1600. 
 
7 Save the linestyle as Paving 
 

 
 
8 Close the Linestyle dialog box. 
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8.5 Using your filled linestyle 
1 In the Mini Window Editor, make the Paving phase editable and 

current. 
 

2 In object mode, click on the unpaved area around the restaurant as 
illustrated below: 

 
 

click
here

 
 
3 On the status toolbar, change the linestyle to Paving. 

 
The area is filled with paving as illustrated: 
 
 

 
 
4 Save and close your Flints Club House workspace. 
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8.6 Creating a nested linestyle 
You will now create a dashed linestyle that will be used as a boundary 
line around the Health Club Site. 
 
The dashed line shown below will be constructed using three strokes: 

Stroke 1

Stroke 3

Stroke 2
 

Preparing your data 
• From the Document Organizer list, select Flints Site workspace, and 

open the Site plan window definition.  

Creating the first stroke 
The first stroke is a dashed line, 1mm thick. 
 
1 Open the Linestyle dialog box. 
 
2 From the Document style list, select DEFAULT. 
 
3 Complete the dialog box as follows: 

• Stroke type: Pattern 
• Offset: 0.500 
• Co-ord space: Output  

Output space means that your linestyle graphics will be a fixed 
visual size on screen and on printed paper. For example, if a 
stroke uses a 5mm dash, it will always measure 5mm whether 
you zoom in or out.  

• Thickness: 1.000 
The physical thickness of the line. 

• Phasing: Line 
Line phasing means that the start of the End pattern 
corresponds with the end of a Middle pattern repetition. Variable 
components are stretched as necessary. 
 

You define the pattern in three parts: the start and end parts are 
drawn once, at the start and end of the line, respectively. The middle 
part is repeated along the length of the line. If necessary, the middle 
is stretched to fit the line with a whole number of repetitions. 
 
The following components are available: 

  fixed length line 
   

  fixed length space 
   

  Symbol 
   

  variable length line (Middle only) 
  

  variable length space (Middle only) 

For more information on Co-ord 
space, see Help. 

For more information on Phasing, 
see Help. 
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Lines and spaces of variable lengths are called elastic components. 
You can specify the length for elastic components, but they can be 
stretched to fit the line if necessary. 
 

4 Complete the Pattern section of the dialog box as follows: 

• drag  into the Start pane 

• drag  into the Start pane, double-click the component, type 

1.5 and click  

• drag  into the Middle pane, double-click the component, type 

1.5 and click  

• drag  into the Middle pane 

• drag  into the Middle pane, double-click the component, type 

1.5 and click  

• drag  into the End pane, double-click the component, type 

1.5 and click  

• drag  into the End pane 
 

 
 

You delete components by 
dragging them out of the pane. 
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Creating the second stroke 
The second stroke is a continuous line. 
 
1 On the Linestyle dialog box, click New Stroke and complete the 

dialog box as follows: 
• Stroke type: Pattern  
• Offset:0 
• Co-ord space: Output 
• Thickness: 0 
• Phasing: Line 
• Pattern: To clear the Start, Middle, and End panes click Clear 

All 
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Creating the third stroke 
 
The third stroke is a continuous line the same as the second stroke, but 
is offset from the first line by one millimetre. 
 
1 Click New Stroke 

• Stroke type: Pattern 
• Offset: 1.000 
• Coord space: Output 
• Phasing: Line 
• Thickness: 0 

 

 
 

2 Save your linestyle as Border, and close the Linestyle dialog box. 
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8.7 Using your nested linestyle 
1 Make the General line phase the current editable phase. 

 
2 Select the General line as illustrated below. 

 
3 From the Line list, select Border. 

 
4 The line is changed as illustrated below: 

 
 

 

 
 
 

 
5 Save the site plan window definition. 
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Exercise 8: Creating linestyles 
1 Open a new window definition. Set the view parameters to 

5000/5000, -5000/-5000. 
 

2 On the View menu, click Save View. 
 
3 Create the following patterned linestyle. (The linestyle definition is 

given on the following page.) 
 

 
 
 

4 Delete your graphics but keep your window definition open for the 
next section. 
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Solution to Patterned linestyle 
First stroke: 
• Stroke type  Pattern 
• Offset  64 
• Colour  67 
• Co-ord space Drawing 
• Thickness   128 
• Phasing  Angle 
• Middle pattern pane: 

• Elastic line 400 
• Elastic space  400 
• Elastic line 400 
• Elastic space 400 

 
Second Stroke: 
• Stroke type  Pattern 
• Offset  -64 
• Colour  1 
• Co-ord space Drawing 
• Thickness   128 
• Phasing  Angle 
• Middle pattern pane: 

• Elastic space  400 
• Elastic line 400 
• Elastic space 400 
• Elastic line 400 

 
Third Stroke:  
• Stroke type  Pattern 
• Offset  128 
• Colour  30 
• Co-ord space Drawing 
• Thickness  0 
• Phasing  Line 
 
Fourth stroke: 
• Stroke type  Pattern 
• Offset  -128 
• Colour  30 
• Co-ord space Drawing 
• Thickness  0 
• Phasing  Line 
 
Note: Remember to clear all pattern components from the third stroke as 
they are automatically inherited from the previous stroke. 
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9. Overlapping closed line primitives 
In MicroGDS you can choose how to fill multiple, overlapping closed line 
primitives. You can specify that ‘holes’ are created where primitives 
overlap, or that these areas should be filled in. This applies only to 
primitives in the same object, linestyle and colour. 
 
1 In the window open from the last exercise, delete your graphics if 

you have not already done so. 
 

2 Using the Rule X and Rule Y commands create a grid 500 x 5. 
 

3 On the Object menu, click Insert. Go to the MGDS Generic library 
and from furniture.man, select MGDS:FURN:SIMPLE:SINGLE BED. 
Click Inset link, and place it on top of your grid. 
 

4 On the Construct menu, click Graphics from instance. 
 

5 Open the linestyle dialog box, and set up the linestyle properties as 
shown below: 
 

 
 
 

6 On the Linestyle dialog box, click Save. 
 
Note that on the bed the closed line primitive representing the pillow 
is a ‘hole’ and you can see the underlying grid as illustrated below: 
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7 On the linestyle dialog box, from the Rules for multiple loops, select 
Use loop sense, and click Save. 
 
The graphics for the bed are changed as illustrated below: 
 

 
 
The pillow is no longer a ‘hole’ as with ‘Use loop sense’ overlapping 
primitives that are drawn in the same direction are simply overlaid.  
 
Note that holes can be created with ‘Use Loop sense’ if overlapping 
primitives are drawn in opposite directions. 
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10. Attaching alphanumeric text to 
objects 
Sometimes, you might want to include additional information with an 
object that cannot be graphically represented. Using a plan view of a 
door as an example, you cannot see the height of the door, or whether 
the door has a fan light or a vision panel, its colour, the manufacturer’s 
details and so on. Attribute data provides a method of attaching non-
graphical data to an object. When you have attached attribute data to 
objects, you can create reports and schedules using the attached data. 
 
In this section you will attach attribute data reporting the manufacturer, 
the maintenance date, the asset manager, the asset manager’s 
telephone number, and the cost of the equipment in the gym. 
 
You will then use attribute data in a phase inclusion list to filter the 
maintenance dates of the Treadmills. 
 
Finally you will create an object format definition file and use it to create 
an object schedule. 
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10.1 Setting up your window definition 
In this section you will prepare your graphics before creating and 
assigning attribute data. 
 
To enable you to access the data quickly you will create a new window 
definition displaying a zoomed in extent of the Club House gymnasium, 
and delete all unwanted phases. 
 
1 Open Flints Club House workspace, and the Flints Club House 

window definition. 
 

2 Zoom in to the Gym area and press F11 (Save View). 
 

3 Save the window as Gym 
 

4 Press F2 to open the Window Editor and remove all phases except 
Walls, and Furniture with the inclusion list NOT MGDS:FURN:** 

 
Your Gym window definition should now look as illustrated below: 
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10.2 Creating mnemonic definitions 
To define the behaviour of attribute data when assigning information to 
an object you must set a mnemonic definition. A mnemonic definition 
has the following parameters: 
 
Applicability 
 
There are three applicability levels you can apply attribute data to in 
MicroGDS – Reference, Object, and Layer: 
 
• Reference level: applies the information to the selected object only 

For example, imagine the treadmills in the gymnasium were 
purchased at different times and you wanted to track their 
maintenance dates. The dates would vary for each treadmill, so you 
would need to attach a maintenance date to each individual 
treadmill. 
 

• Object: applies the information to all objects of the same name 
For example, imagine you wanted to know the name and address of 
the company who manufactures the treadmill. In this example only 
one company manufactures treadmills, so you could assign this data 
to one treadmill and all the other treadmills (with the same object 
name) will adopt the same data. 
 

• Layer: applies the information to all objects on the same layer 
For example, imagine you wanted to know the telephone number of 
the person responsible for the upkeep of all the furniture, including 
the gymnasium equipment. As all the furniture in the Club House is 
on one layer, you need only assign the data to one piece of furniture; 
all the other furniture will inherit the same data. 

 
Attribute data type 
 
The following types of attribute data can be attached to objects: 
• Text: this is free text, such as a name or an address  
• Enumeration: you select from a list of pre-defined words 
• Double: use double precision when the data is numerical and 

requires up to ten significant digits in total 
• Single: use single precision when the data is numerical and requires 

up to six significant digits in total 
• Integer: use this when you want to set a range for a whole number 
• Area, Length, Volume: for a number in the specified units 
• Date: for a date in a specified format 
 
There also are four computed mnemonics which perform different 
calculations. For details of computed mnemonics see Help. 
 
To illustrate attribute data and how the different types of mnemonic 
definition control the way data is applied, you will set up mnemonic 
definitions and apply data as follows: 
• the manufacturer of the gym equipment 
• the asset manager of the furniture 
• the asset manager’s telephone number 
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• the cost of the treadmills  
 

Defining the manufacturer of the gym equipment  
1 On the Document Organizer, click the Styles tab and then click  

(the New Mnemonic toolbar button). 
 

The Mnemonic Definition dialog box is displayed: 
 

 
 

2 From the Applicability list, select Object. 
This means all objects with the same name will be assigned the 
same manufacturer. 

 
Each mnemonic definition has its own identification name. This is 
typed in the Name box. 
 

3 To define the name for the mnemonic for the manufacturer of the 
gym equipment, type Manufacturer 
 

4 In the Prompt box type a description for the attribute Manufacturer 
of the gym equipment. This description is used for the title of the 
Edit Attribute Data dialog box, when you add or edit the attribute 
data associated with the mnemonic. 

 
5 From the Storage list, select the Local check box. 

 
You are now going to define the definition for the name and address 
of the manufacturer. The manufacturer’s details will be on four lines. 
 

6 From the Type list, select Text. 

For more information, see The 
Mnemonic Definition dialog box  
in Help. 
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7 Select the Limited check box. 

 
8 In the Maximum number of lines box type 4. Leave the Minimum 

number of characters as 0 and the Maximum number of characters 
as 132. 
 

9 To save the mnemonic definition, click Save and then click Close. 
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Viewing the parameters for the manufacturer of the gym 
equipment mnemonic definition 
1 On the Document Organizer Styles tab, click Preview, then open the 

Mnemonics folder and the C…\styles file, and then click on 
Manufacturer. 
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Defining the asset manager of the furniture 
1 To define the asset manager of the furniture, on the Document 

Organizer Styles tab, click  
 

2 All the furniture, including the gym equipment, is on one layer, 
therefore the name of the asset manager can be set at Layer level; 
so select Layer from the Applicability list. 
 

3 To define the name for the mnemonic, type Asset Manager 
 

4 In the prompt box, type Who is responsible for this asset? 
 

5 Ensure the Local check box is selected. 
 

6 In this example, the asset manager is one person from four 
candidates. To ensure that the asset manager is chosen from a list, 
select the Enumeration option and type 1 in the Maximum list box.  

 
7 In the Word list box type, Jenny Applegate,Terry Taylor,John 

Goody,Jane Fairbanks. Note that each name must be separated 
by a comma. 
 

 
 

8 Click Save. 
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Defining the asset manager’s telephone number  
1 The asset manager’s telephone extension number can also be set at 

Layer level, so select Layer from the Applicability list. 
 

2 To define the name for the mnemonic, type Asset Manager’s 
extension number 
 

3 In the prompt box, type What is the Asset Manager’s extension 
number? 
 

4 Ensure the Local check box is selected. 
 

5 The extension number will be a whole number so select Integer from 
the Type list, and type 1 in the Maximum list box. 

 
6 The extension numbers range from 200 to 300, so in the Minimum 

box type 200, and in the Maximum box type 300. 
 

 
 

7 Click Save. 
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Defining the cost of the gym equipment 
1 The cost of the gym equipment will apply to individual objects, so 

select Object from the Applicability list. 
 

2 In the Name box, type Cost. 
 

3 In the Prompt box, type How much does this equipment cost? 
 

4 From the Type list, select Single, and in the Maximum list box, type 
1 
 

5 In the Leading digits box type 4 and in the Trailing digits box type 2 
 
This means that you can assign 4 digits before the decimal point and 
two after, for example, 7500.00 
 

6 Check the Show trailing zeros box. 
 

 
 

7 Click Save, and then click Close. 
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10.3 Assigning attributes 
Now that you have created your mnemonic definitions, you can use them 
to assign attribute data to the gym equipment. 

Assigning the manufacturer 
1 In object mode (F10), select one of each of the following objects: 

 
• stepper 
• treadmill 
• multi-gym 
 

 
2 On the Object menu, click Attrib. 

 
The Attribute Data dialog box is displayed showing details of your 
mnemonic definitions, and the selected objects with the layer name 
in brackets. 
 

 
 
3 To assign the manufacturer’s name and address to the Stepper, 

drag the Manufacturer mnemonic from the top list onto 
Gym:Stepper:2D (Furniture) in the bottom list.  
 
Notice that a plus sign has appeared to the left of the object name.  
 

You can click Flash Object on the  
dialog box to check you have the 
correct objects selected. 
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4 To define the name and address of the manufacturer: 
• click the plus signs to display the applicability of the 

Manufacturer mnemonic definition. In this case it is Object level 
• click the plus sign adjacent to Object and double-click the 

mnemonic definition (Manufacturer) 
 

The Manufacturer of the gym equipment dialog box is displayed: 
 

 
 

5 Double-click each line in turn and type the address on each line as 
follows: 
 
Gym World 
57 Cedar Court 
Oakfield 
Suffolk SU3 5CP 
 

6 Click OK. 
 
As this attribute is Object level, it has been added to all the objects 
with the name Gym:Stepper:2D. 
 

7 The treadmill and the multi-gym are also manufactured by Gym 
World. To assign the same name and address to these two objects, 
drag the stepper data onto the treadmill and multi-gym. 
 

8 Click Close. 
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Assigning the furniture asset manager 
You will now assign the asset manager to the gym equipment. As the 
asset manager is at Layer level Applicability, you only need to assign the 
manager’s name to one object. It will automatically be added to all other 
items on the Furniture layer. 
 
1 Select a single Stepper in the window definition, and on the Object 

menu, click Attrib. 
 
2 To assign the asset manager to the Stepper, drag the Asset 

Manager mnemonic from the top list onto Gym:Stepper:2D 
(Furniture) in the bottom list. 
 

3 To define the asset manager: 
• click the plus signs to display the applicability of the Asset 

Manager mnemonic definition. In this case it is Layer level 
• click the plus sign adjacent to Layer and double-click the 

mnemonic definition (Asset Manager) 
 

4 Double-click the first line (Jenny Applegate), and from the list select 

Terry Taylor. Click  and then click OK. 
 
5 Close the Attribute Data dialog box. 
 
6 Query any other piece of gym equipment. Check that Terry Taylor 

has been added as the asset manager. 
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Assigning the cost of the gym equipment 
You will now assign the cost to the Treadmill. The cost is at Object level 
Applicability, so when you assign cost to one object, it is automatically 
assigned to all other objects with the same name. 
 
1 Select one Treadmill and on the Object menu, click Attrib. 
 
2 To assign the Cost to the Treadmill, drag the Cost mnemonic from 

the top list onto Gym:Treadmill (Furniture) in the bottom list. 
 

3 To define the cost 
• click the plus signs to reveal the applicability of the Cost 

mnemonic definition. In this case it is Object level 
• click the plus sign adjacent to Object and double-click the 

mnemonic definition (Cost) 
 

4 Double-click the first line, and type 250.00, and then click  
 
5 Click OK and then click Close. 
 
6 Click on another Treadmill and on the Object menu, click Attrib. 

 
It will have the same Cost mnemonic definition, as it has the same 
object name. 
 

7 Click Close. 
 

8 Click on the Stepper and on the Object menu, click Attrib. 
 
This does not have a Cost mnemonic definition as it does not have 
the same object name. 

 
9 Close the Attribute Data dialog box. 
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10.4 Using attribute data to filter objects in a 
phase 

In the next three sections you will define the maintenance date for the 
gym equipment; you will then assign maintenance dates to the 
Treadmills, and then use attribute data in inclusion lists to filter the 
objects in phases. 

Defining the maintenance date of equipment in the gym 
1 Open the Mnemonic Definition dialog box. 

 
2 As the maintenance date for each piece of equipment will be unique, 

select Reference from the Applicability options. 
 

3 To define the name for the mnemonic, type Maintenance 
 

4 In the prompt box, type Maintenance date: for example 30 August 
2003 
 

5 Select Date from the mnemonic definition Type list. 
 

6 Type 1 in the Maximum list. 
 

7 Select (GMT) in the Time zone list. 
 

8 From the Date format options, select Long date and from the Time 
format options, select Omitted. (We will not include the time in this 
exercise.) 

 

 
 

9 Click Save and then click Close. 
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Assigning the maintenance date 
You will now assign a maintenance date to the four Treadmills. As the 
maintenance date is at Reference level, you will assign them 
individually. 

 
1 Select the four Treadmills in the window definition and on the Object 

menu, click Attrib. 
 
2 To assign the maintenance date to the Treadmills, drag the 

Maintenance mnemonic definition from the top list onto the first Gym 
Treadmill:2D (Furniture) in the bottom list. 
 
• click the plus signs to display the applicability of the 

Maintenance mnemonic definition. In this case it is Reference 
level 

• click the plus sign adjacent to Reference and double-click the 
mnemonic definition (Maintenance) 

 
The Maintenance date dialog box is displayed: 
 

 
 

3 Double-click on the line numbered 1 (which contains today’s date) A 
calendar is displayed: 
 

 
 

4 Use the two arrows either side of August 2002, to select February 
2004, click on 16 and then click OK to close Calendar dialog box, 
and OK to close the Maintenance Date dialog box. 

 
5 Repeat steps 2 to 4 for the other three Treadmills, assigning the 

following dates in turn: 
 

14 April 2004 
09 July 2004 
16 November 2004 
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6 Click Close, to close the Attribute Data dialog box. 
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Filtering objects by attribute data  
In your gym window definition, you have a layer on which all the gym 
equipment is drawn. You will create a new phase and use attribute data 
filtering to show only Treadmills that have a maintenance date on or 
before 30 June 2004. You will then create another phase to show only 
Treadmills that have a maintenance date after 30 June 2004. The 
graphics referenced in each phase will be drawn in different colours. 

Creating two new furniture phases 
1 Press F2 to open the Window Editor. 
 
2 Select the Furniture phase, press CTRL, and drag a copy of the 

Furniture phase to the bottom of the phase list. 
 
3 Repeat step 2 so that you have 2 duplicates of the Furniture phase. 
 

 
 

4 Change the colour of phase 3 to red (1) and phase 4 to green (2). 

Using attribute data in a phase inclusion list  
You will now use attribute data to filter the maintenance dates for the 
Treadmill in a phase inclusion list. 
 
First you must specify the mnemonic applicability. These are: 
 

P. for primitive level 
R. for reference level 
O. for object level 
L. for layer level 
 

The applicability prefixes are not case sensitive. The maintenance date 
is at Reference level. 
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You then specify the mnemonic name. 
Type the name of the mnemonic definition exactly as it is stored. Names 
are case sensitive. The mnemonic name in this instance is Maintenance. 
 
You then specify the Operator, which can be any of the following: 
 

<   less than 
<=   less than or equal to 
=   equal to 
<>   not equal to 
>=   greater than or equal to 
>   greater than 
matches  matches a string 

 
You must insert a space either side of the operator. You will use the less 
than and greater than operators.  
 
Lastly you will specify the attribute_value. The attribute value is case 
sensitive. For a full list of attribute values, refer to the online Help. 
 
You are specifying a date attribute value, and there is a special 
'datetime' string to specify a specific date. 
 

The syntax of the 'datetime' string is: 
datetime [yyyy-mm-dd] 
 

When the attribute date value includes text and numbers you must 
enclose the attribute data value in double-quotes, for example: 
 

datetime [“2004-12-31”] 
 

In the next steps, you must ensure that you type the characters exactly 
as specified. 
 
1 Select one of the two new furniture phases you have created and 

click the Include button. 
 
2 In the Inclusion List dialog box, type:  
 

 
 
Note that the ‘brackets’ are parenthesis, not square brackets. 
 

3 Select the other new furniture phase you have created and click the 
Include button. 

 
 

 



104 MicroGDS  

 

4 In the inclusion List dialog box, type: 
 

 
 
5 Click OK and then close the Window Editor. 
 
6 Make sure all your graphics are deselected. 
 
Two of the Treadmills are now displayed in green, and two in red. All 
other gym equipment is displayed in the original grey. 
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10.5 Creating an object format definition file 
You can create a report of the objects in a window definition. However, 
you first need to create an object format definition file to specify what 
information is to be displayed in the report and how it will be laid out. You 
must load this file before you generate your report. 
 
A format definition file is a text file, which you can create in any text 
editor. It must be saved with the extension .FRM. 
 
There are a number of format definitions that you can use to extract 
object information. In this exercise you will use the title and column 
definitions: 
 
• Title inserts the name of each mnemonic listed in each column, at 

the top of the report 
• Column inserts the attribute data of the named mnemonic, between 

the specified column numbers 
 
1 Open Notepad and type the following: 

 

 
 
The above file will generate the following information: 
 
• between columns 1 and 35 the object name 
• between columns 38 and 90 the name of the manufacturer of 

that object as set by your attribute data  
• between columns 92 and 104 the Maintenance date for that 

object as set by your attribute data 
• between columns 106 and 126 the cost of the object as set by 

your attribute data 
 
2 Save your file as Flints format file.frm in your Flints Health and 

Fitness project folder. 
 

For full information see Creating 
an object format file in Help. 
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10.6 Creating an object schedule 
When you have created your object format file, you first load the file, and 
then you create your object schedule. 

 
1 On the Object menu, click Format. 

 
2 Browse to your format file.frm and click Open to load the format file. 

 
Before you create your report, you will specify the objects to be 
included in the report. 
 

3 On the Information bar at the bottom of the MicroGDS window, click 
the SETEDIT button. 
 

4 In the Objects box on the Set Edit dialog box, type Gym**, and click 
OK. Notice that the text on the SETEDIT button changes to red 
when editing restrictions are active. 
 
This will restrict the following selection to objects with Gym as the 
first facet of their object name. 
 

5 On the Edit menu, click Select All. Note that only the Gym objects 
are selected. 
 

6 On the Object menu, click Schedule. 
 

7 Click Yes at the prompt ‘…do you wish to schedule the selection 
list?’ 
 
A report is produced in the following format: 
 

 
 

 
8 To clear your editing restrictions before proceeding, double-click the 

SETEDIT button to open the Set Edit dialog box, click Clear, and 
then click OK. 
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10.7 Querying objects with attribute data 
When you query an object with attribute data, attribute name and details 
are displayed in the Query window. 
 
1 Press CTRL + Q. 

The Query window is displayed  with the following message: 
“Hit the primitive you wish to query. 
Details will appear in this window.” 
 

2 Select one of the Treadmills. The Query window is updated as 
follows: 
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Exercise 9: Assigning the asset manager’s 
telephone number 

1 Assign the asset manager’s extension number (256) to the gym 
equipment.  
 
As the asset manager’s telephone number is at Layer level 
applicability, you will only have to assign the manager’s extension 
number to one object. It will automatically be added to all other 
items on the Furniture layer. 

 
For further assistance, follow the steps in Assigning the furniture 
asset manager earlier in this section. 
 

2 Check that the extension number is shown in the Query window. 
 

3 Save and close the Gym window definition and the Flints Clubhouse 
workspace. 
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11. Linking to and inserting documents 

Dynamic Data Exchange 
Dynamic Data Exchange is a windows convention for linking data 
between programs. Links between the source and the destination 
program are set up, so that when the data is modified in one program it 
is automatically updated in the other.  
 
You can create DDE data in MicroGDS using some of the measure 
commands. 
 

Object Linking and Embedding 
You can use Object Linking and Embedding (OLE) to share information 
between Windows programs. 
 
You can, for example, embed or link MicroGDS MAN files in other 
applications, and similarly, you can embed or link data from other 
applications in MicroGDS. 
 
When you link data, it is stored in the source file: the destination file 
stores only the location of the source file and displays a representation of 
the linked data. When the source file is updated, the linked data is also 
updated. It is therefore important not to move or rename the source data, 
otherwise the link will be broken. 
 
 
 
In this section you will count all the Car parking spaces and display this 
as linked data. You will then delete some of the parking bays. When you 
regenerate the linked data it is automatically updated to reflect the new 
number of parking bays. 

For full details see Object linking 
and embedding in Help. 
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11.1 Dynamic data linking 
In this section, you will use the Measure Number command to find out 
how many parking bays there are, and then paste this information back 
into your window definition.  
 
1 Open Flints Site workspace. 
 
2 Open the Parking & landscaping window definition. 
 
3 Zoom in to the car park area. 
 
4 In the Mini Window Editor, double-click the Car park phase to make 

it current. 
 
5 On My toolbar, click Axes Move, and place your axes in the area 

just above the island as illustrated below: 
 

 
 

6 Create a new object and name it Number of bays:  Place the hook 
point as illustrated above. 

 
7 From the Char list, select Arial Narrow 2000 High. 

 
8 On the Query menu, click Number, and at the prompt bar type 

Parking** (the objects we wish to count are named Parking Bay) and 

click  
 

The following message is displayed showing the count as 70. 
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9 Click Copy Link, and from the Edit menu, click Paste Special. 
 
10 On the Paste Special dialog box, select Paste Link, and click OK. 
 
11 In reply to the question ‘Do you wish to drop the overhead of the 

DDE link’, click Yes. 
70 is placed at the Object hook point. 

 
12 Select the text you have just placed, and on the Alter menu, click 

Edit Text.  
The following text, shown as a formula, is displayed in the text box: 
 
^(NUMBER(16,Parking**)) 
 

13 Edit the text to read: 
There are ^(NUMBER(16,Parking**)) parking spaces in this car 
park 
 

14 Click the Centre Justification button, and click OK. 
 

 
 
15 In object mode, delete three of the parking bays on the left side, 

select the text and, from your flyout toolbar, click Regen Text. 
 
16 The linked data is updated as illustrated below: 
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17 Save and close your project workspace. 
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11.2 Linking MicroGDS to Microsoft Word 

Preparing your graphics 
1 Open Flints Club House workspace and double-click the Overall site 

plan window definition to open it. 
 

2 Zoom in to the lake area and joggers restaurant. Press F11 to save 
your view. 
 

3 On the File menu click Save Window As, and name your window 
Picnic table layout 

Opening the Word document 
• Use Windows Explorer to go to your Advanced training data folder 

and double-click Garden Furniture Quote.doc to open it: 

 

Creating a dynamic link to the number of tables and chairs  
1 In MicroGDS, on the Query menu, click Number. 

 
2 In the Objects to count prompt box, type **EXTERNAL* and click 

 
The number of Objects counted is displayed in a Message box as 
follows: 
 

 
 

3 Click Copy Link. 
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4 Go to your Word document, and place the cursor between the words 

‘quote for’ and ‘picnic chairs’. On the Edit menu, click Paste Special. 
On the Paste Special dialog box, click Paste link and then click OK. 

 
The number of tables and chairs is inserted in your letter. 

Creating a dynamic link to the table and chairs graphics 
The picnic tables and chairs are instances referenced from the Furniture 
MAN file. You will insert the man file into your word document. 
 
1 Place the cursor in your Word document on the next line after the 

words ‘as illustrated below:’ 
 

2 On the Insert menu, click Object. 
 
The Object dialog box is displayed: 
 

 
 

3 Click the Create from File tab, and Browse to drive:\Flints Health 
and Fitness Club\Library files\Furniture.MAN. 
 

4 Select the Link to file check box, and then click OK. 
 
A dynamic linked copy of the picnic table and chairs is inserted into 
your Word document. 
 

5 Select the object, and then drag one of the box corners to 
approximately half its original size. 
 

6 Ensure that you only have MicroGDS and Word application windows 
open on your screen. Click on an empty space on the taskbar, and 
from the shortcut menu, select Tile Windows Vertically. 
 
MicroGDS and Word are tiled next to each other, but you may have 
to make fine adjustments to make the two windows display 
appropriately. 
 

7 In Word, double-click the picnic table and chairs to open the linked 
MAN file in MicroGDS. You now have the Picnic table layout window 
definition and the Furniture.MAN file open. 
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8 In MicroGDS, from the Window menu, select Tile Horizontally. 
 

 
 

9 Click on ‘Picnic table set’ window definition to make it current. In 
primitive mode, individually select and delete three chairs, leaving 
only the top chair as illustrated below: 

 

 
 

 
10 Select the remaining chair, and on the Construct menu, click Array, 

Polar. In the Number of copies box, type 3 and then click OK. 
 

11 Place your copies with two Inside snaps in the middle of the table. 
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12 Save the Furniture.MAN file. MicroGDS and Word will update 

automatically. 
 

13 In the Picnic table layout window definition, select a picnic table and 
chairs and click Delete. The number of picnic sets in the Word 
document will update automatically. 

 
14 In Word, save and close Garden Furniture Quote.doc. 

 
15 In MicroGDS close ‘Picnic table set’. 

 
16 Save and close Flints Club House workspace. 

 
17 Exit MicroGDS 

 
Congratulations you have finished the MicroGDS Advanced 
Training Course 
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12. Project and man file templates 
MicroGDS has many time saving commands and features, one of which 
is the ability to create template files. This will not only save you time 
when setting up new projects and drawings, but can also help to maintain 
company standards. 
 

This final section of the course gives an overview of the template files 
that you can create and use. The information given here is purely 
reference, and no exercises are included. For full details on creating and 
using templates, refer to the MicroGDS Help. 

Project templates 
You create a MicroGDS project template from an existing project. Project 
templates create: 
• project databases (.cpd)  
• project workspaces (.cpj)  
• alias locations 
• style search paths 
 
All files and folders that lie below the project database file (.cpd) in the 
project template structure are copied to the new project database. Any 
aliases and style search path locations that reference folders outside of 
this structure are created in the new database. 
 
You specify project templates using the Multi-user tab on your 
preferences. To add a template, browse to the location of the project 
database file (.cpd) that is to be used as the template, and then specify a 
name for the template. This is the name that MicroGDS displays in the 
Template list when you create a new project database. 

Single user template files 
You can also use a template when you create a single-user document. 
 
Templates can create graphics and styles in new documents. For 
example, you could set up a template that has: 
• a drawing frame 
• your company logo 
• a standard set of styles for a particular type of drawing 
 
Template files are standard MicroGDS files that you save with the 
extension .mtf. 
 
You specify the location of single-user document templates using the File 
Locations tab on your preferences. MicroGDS defaults to this location 
when you select the ‘From template’ option when you create a new file. 
 
 
Congratulations, you have now completed the MicroGDS Advanced 
training course. 
 
 


