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Introduction

About MicroGDS
Welcome to MicroGDS ™ 2010.

MicroGDS is a powerful, computer-aided design and draughting system
that makes it easy to transfer your creative and imaginative ideas into
two-dimensional and three-dimensional drawings and models.

MicroGDS is a registered trademark of Informatix Inc.

Informatix offer two MicroGDS products: MicroGDS Collaboration
and MicroGDS Entry Level. Both products share a comprehensive set
of features for meeting the needs of today’s CAD users, including:

the ability to draw to any scale using real-world measurements

an extensive set of styles and drawing effects to make your drawings
clear and attractive

easy to use methods for creating and modifying data

flexible and powerful tools for moving, editing, and deleting objects
3D geometry generation from 2D drawings

the ability to work in multi-user mode so that a number of users can
access the same project data simultaneously
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e simple and effective techniques for exchanging data with other
Windows software

o the ability to read and write data in other formats, including XML,
DXF and DWG

o the ability to publish to numerous other formats, including PDF,
PNG, and DWF

e extensive customization facilities

You can also use MicroGDS modelling with Piranesi™ to produce
exhibition-quality drawings. Piranesi is a unique three-dimensional
paint package that offers sophisticated painting techniques enabling you
to express your ideas using a whole range of artistic effects.

Piranesi is a product of Informatix Inc. You can find the Piranesi
homepage at www.piranesi.co.uk

It is recommended that you periodically check the Informatix website
for new product information, updates, and free downloads. You can find
the MicroGDS homepage at www.microgds.co.uk

MicroGDS Collaboration

MicroGDS Collaboration offers a full complement of features,
including the capability to work in a multi-user environment.
MicroGDS Collaboration also provides full 3D solid and surface
modelling, plus a sophisticated, photo-realistic renderer.

This product is ideal for users who wish to generate high quality
visualizations of 3D models, and work in both multi-user and
single-user environments.
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MicroGDS Entry Level

MicroGDS Entry Level offers similar features to MicroGDS
Collaboration, but has a reduced set of 3D functions and rendering
capabilities. This product is tailored for users who wish to work in both
multi-user and single-user environments, but require only basic
visualization capabilities.

The MicroGDS website

The MicroGDS website is your online technical resource centre. You
can read the latest MicroGDS reviews, access all the product
information, download applications and tools, and access the
MicroGDS Gallery and User Forum. Visit the MicroGDS Gallery to
view a range of example images created using MicroGDS. The User
Forum lets you get in touch with other MicroGDS users around the
world. Use it to share your thoughts, ask questions, provide answers,
share images, and exchange tips and techniques. You can find the
official MicroGDS website at www.microgds.co.uk

You can also access the website directly from MicroGDS by clicking
MicroGDS Homepage on the MicroGDS Help menu.

It is recommended that you periodically check the MicroGDS website
for new product information, updates, and free downloads.

Checking for updates

The MicroGDS version number is shown on the MicroGDS title bar.
You can check the MicroGDS website online to see if there are updates
to your copy of MicroGDS.

When an update or new version becomes available on the website, you
can choose to download and install it.

To check for updates, click Check for Updates on the MicroGDS Help
menu, then follow the instructions on the screen.
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About this guide

This user guide presents selected concepts and procedures to enable you
to begin working with MicroGDS. The guide includes information
about creating and placing graphics, working with styles, working with
other file formats, and customizing MicroGDS.

It also contains information on working in a multi-user environment and
the advanced solid and rendering features in MicroGDS Collaboration.

Organization of this guide

The guide is arranged in two parts:

e Part One: Working with MicroGDS 2010
Explains the concepts and features that are applicable to both
MicroGDS products. It also describes how to work in a multi-user
environment.

e Part Two: Advanced 3D and rendering

Describes the advanced solid and rendering features available in
MicroGDS Collaboration.

Resources for learning MicroGDS

Informatix provides documentation and services for learning how to use
MicroGDS and for solving problems.

MicroGDS documentation

The MicroGDS documentation consists of a user guide and a
comprehensive online Help system. The user guide is provided in PDF
format. You can also purchase a printed copy of the guide from
Informatix Software International. Please contact Informatix for more
information.

o What’s new in MicroGDS 2010
This document provides information on new and enhanced features
in MicroGDS 2010. The document is provided in PDF format which
you can find on the MicroGDS website at www.microgds.co.uk

e Using MicroGDS
The user guide describes the fundamental concepts and how to use
the features in MicroGDS.
For full details of all the commands available in MicroGDS, refer to
the online Help.
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e  MicroGDS Help

MicroGDS provides extensive online Help. Details of every
command and dialog box are included, along with procedures for
completing each task.

Accessing online Help

To access the MicroGDS online Help system and use the full facilities
of Microsoft HTML Help, Microsoft Internet Explorer must be installed
on your computer.

To use the online Help system

1 On the MicroGDS Help menu, click Help Topics.

The main Help window is displayed, showing the topic Overview of
MicroGDS.

2 Click the Contents, Index, Search, or Favorites tab to choose how
you would like to navigate to the required help topic.

3 To display help on a topic, double-click the topic name.

To display context-sensitive help

1 Press Shift+F1, or on the MicroGDS Help menu, click What’s This?
A question mark is attached to the mouse pointer.

2 Click the command or toolbar button you want help on.

To display help on the current command
e press F1, or click the Help button on a dialog box

Training courses

Informatix provides training courses that are designed to teach you how
to plan and draw in MicroGDS. The courses are structured to cover
basic foundation training, 3D, and advanced use. Please contact
Informatix for more information.
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Part One

Working with
MicroGDS 2010






Exploring MicroGDS

Starting MicroGDS
To start MicroGDS

>

1 On the taskbar, click the Start button and point to Programs.

2 Point to the folder that contains MicroGDS, then click MicroGDS.

You can also start MicroGDS by double-clicking a MicroGDS desktop
shortcut, or double-clicking one of the following MicroGDS file types:

[ )

.MAN single-user document
.MTF single-user template
STY style file

.CV7 font file

.CPJ multi-user project
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The MicroGDS window

— Status toolbars Menu bar Toolbars

& MicroGDS 2010 Collaborat’an

Properties window ——
— 1 Document Organizer
Phase Status Colur  Lin
——— Mini Window Editor
For Help, press F1 Foston Z:0 1] 4
I
Prompt bar Information bar

The layout of your window may be shown differently to the illustration,
depending on the MicroGDS product and version you are using.

Not all menus and toolbar buttons are available until you create or open
a document.

When you first use MicroGDS, the MicroGDS window displays:
e amenu bar

e anumber of system toolbars

o the two status toolbars

e Document Organizer

e Mini Window Editor

e Properties window

e prompt bar

e information bar
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You can switch toolbars and windows on and off using commands on
the Window menu. The menu bar, prompt bar, and information bar are
always displayed.

Profiles

As you work with MicroGDS, you will set up the MicroGDS window to
best suit you. You can move windows around, dock and resize
windows, customize toolbars and menus and so on. MicroGDS
remembers all these settings and stores them in a profile. This means
that when you next use MicroGDS, the layout will be exactly as you left
it. By default, you use the ‘current’ profile. However, you can create
additional profiles and choose which one to use from a list. For
example, you might set up your toolbars to suit specific work
environments, such as having separate 2D drawing and 3D design
profiles and then switch between them.

When you exit MicroGDS, the window layout is always saved to the
current profile. You can also save the layout to the loaded profile or to a
new profile using the Profile commands available from the Window
menu.

For more details about saving and loading profiles, see Chapter 17,
Customizing MicroGDS.

Docking and resizing windows

In the illustration the Properties window is undocked, but the other
items are docked. Docked items are placed in a side bar, at the top,
bottom, left, or right of the window. To dock a window or toolbar, drag
it to any side of the MicroGDS window, or double-click its border or
title bar. To undock an item, drag it away from the side bar or
double-click its border.

To move a window or toolbar to one side of the MicroGDS window
without docking it, press Ctrl when you drag.

When any resizable windows, such as the Document Organizer or Mini
Window Editor, are docked to the side of the MicroGDS window, a split
bar appears which you can use to resize the docking area. In addition,
when two of these windows are docked one above the other, a split bar
appears which you can use to resize the windows.

The window positions and sizes are saved in the current profile.
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Menu bar
At the top of the window is a standard Windows menu bar. The menu
bar provides commands to create and edit documents in MicroGDS.
A number of right-click shortcut menus are also available with
MicroGDS. Shortcut menus provide commands that apply specifically
to the area in which you are working.
You can change a current key assignment or assign a new shortcut key
to any MicroGDS menu command. For details, see Chapter 17,
Customizing MicroGDS.
Toolbars
Toolbars contain buttons that give you quick access to menu commands
and features.
You can use the status toolbars to change the settings for the current
session and the selected graphics.

p  Toshow and hide toolbars

1 Press Ctrl+T, or on the Window menu, click Profile, Customize.

The Customize dialog box is displayed:

Customize [5_<|
View Controls Shortcuts Menu
Toobars | Customize Flyouts Status bars
[JAdvanced Solids (System) ~ Mew. ..

[Jaxes (System)

[¥]Curves (System)

[Jcurves 2 (System)
[Jpimensions (System)
[JFace MaterialMesh (System)
[¥]File (System)

[¥]Lines (System)
[CJobjects (System)
[CPaths (System)
[CJQuery (System)

| Resetal |

[CJrenderer (System) Button size
[[]5ection (System)
[[]5egments (System)

[Hl Calartinn fCuctam’

[ oK ][ Cancel ][ Help ]
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The Toolbars tab is the first tab on the dialog box and so is
automatically displayed.

2 For each toolbar that you want to show, select the corresponding
check box. For each toolbar that you want to hide, clear the check
box.

By default, toolbars are displayed horizontally. You can move the
toolbars to different positions on your screen and you can change their
orientation. Toolbars are saved in the current profile.

To move a toolbar

e drag the toolbar by its gripper bar or by its border:

AA AR X
}

gripper bar
To change the orientation of a toolbar
e press Shift when you drag the toolbar
Note that you cannot change the orientation of a status toolbar.

When you drag a toolbar away from the toolbar area or change its
orientation, it is undocked and its title bar is shown. For example:

|APQ&LEI A:’l

If you dock a toolbar to one side of the MicroGDS window, its
orientation automatically changes to vertical or horizontal, as
appropriate.

You can customize toolbars by adding or removing items. You can also
create new toolbars and change the size of the buttons. In addition, you
can create flyout toolbars that enable you to access all the commands on
a toolbar, from a single button.
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Flyout toolbars show a small triangle on the bottom right of the button,
for example:

24O

flyout toolbar button

x [ > F P

To select the command that the flyout button represents, click the
button. To select a different command, press the mouse button on the
flyout toolbar button, then drag to the appropriate command. The
selected command becomes the flyout button on the toolbar.

Flyout toolbars provide a useful way of making many commands
available, without using too much screen space. For details on how to
create flyout toolbars, see Chapter 17, Customizing MicroGDS.
Status toolbars

The two status toolbars show information about the active window and
about any currently selected graphics.

The default information displayed on Status bar 1 is:

Colour the current colour; the default is ByPhase

Line the current linestyle; the default is DEFAULT
Char the current charstyle; the default is DEFAULT
Light the current lightstyle; the default is NONE

Mat the current material; the default is DEFAULT
File name the path of the current document if the document

has been saved, otherwise this is Documentn
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Justification the justification buttons used for text; the default
is left justification

xyz the pressed buttons fix the corresponding
coordinates

The x, y, and z buttons are described in
Chapter 5, Entering positions.

The default information displayed on Status bar 2 is:

Scale the scale at which you are currently working; the
default is 1:1

Angle the set axes angle; the default is 0

Units the units of measurement in which you are
working; the default is millimetres (mm)

Places the number of decimals places displayed; the
default is 0

Profile the name of the profile in use; the default is
current

Layer the name of the current layer

Object, instance, or  the name of the current object, instance, or

assembly assembly
Selected graphics the total number of selected graphics: objects or
primitives

The appropriate settings shown on the status toolbars are used when you
next create new graphics.

When you select graphics, the appropriate settings on the status toolbars
are updated to reflect the properties of the selected graphics. For
example, if you select a line primitive, the linestyle assigned to the
primitive is displayed in the Line box.

If the selected graphics are all different, their status is not displayed and
the appropriate box is blank. For example, if you select several line
primitives which have different linestyles, the Line box is blank. When
you deselect the graphics, the status returns to the previous value.
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A box is also blank if its information is not appropriate. For example, if
you select a line primitive, the Char box is blank since a line does not
have a charstyle.

You can change a characteristic of the selected graphics by choosing the
required value from the appropriate list, or in some cases, by typing the
required value.

You can add and remove status toolbar items, but you cannot create
flyout status toolbars with their contents. See Chapter 17, Customizing
MicroGDS for details about customizing your toolbars.

Document Organizer

The Document Organizer provides a central point from where you can
work with the data in your documents. It displays a series of tabs, each
providing access to a specific type of data. For example, you can open
and rename window definitions (and views) from the Window
Definitions tab, and create and modify styles from the Styles tab.

The Document Organizer provides shortcuts to the equivalent menu
commands. Although you can use the menus and toolbars for most
operations in MicroGDS, it is expected that you will use the Document
Organizer for all your document management tasks.

More details are given in Using the Document Organizer on page 29.

Mini Window Editor

The Mini Window Editor enables you to work with phases in the active
window definition. The Mini Window Editor is a cut-down version of
the full Window Editor, providing quick access to some of the
frequently-used phase commands. You can, for example, use the Mini
Window Editor to create a new layer or change the colour in which
graphics in a phase are displayed.

The window editors are described in Chapter 4, Using layers and
phases.
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The Properties window

A particularly useful facility in MicroGDS is the Properties window.
You can use the Properties window to view extensive details about the
graphics currently selected. For example:

b
EL 1l
= Document
S Lavers (1)
1 Obects (1)

= Plain obiject

FEE file: cabtall:ivamy
Scale 1:1

Axes angle -a0

Hook point 100mm. 1 00mmeOram
Lightstyle HOME

Link numbers 8.6

2 Mumnber of primitives | 33

B Manufacturer Greenstone

You can use the Properties window, for example, to see the colour and
linestyle of a line primitive, the name of the object in which the
primitive is stored, and the layer on which the object resides. You can
also change the value of any editable property (properties that are
read-only are shown shaded in the window).

The buttons at the top of the window enable you view the information
in different ways. You can also switch to query mode to view low-level
primitive details, such as the radius of an arc, the length of a line, and
the area of a circle.

The Properties window provides a central location from which to
change the properties of your drawing elements. Although you can use
the menu and toolbar equivalents to view and change the properties of
the selection, it is expected that you will work with the Properties
window active.

For more details, see Chapter 13, Getting information.
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Hints, prompts, status, and positions

Many commands require you to enter positions. To help you,
MicroGDS displays hints, prompts, the status of specific items, and
coordinate positions at the bottom of the MicroGDS window. For
example:

|P0int ko trace around Position 7E2mmi431mm/E7omm M | Z=0 SETEDIT “Z== ++ WUM |8y

Information is shown from left-to-right about:
e the current command

Shows a summary of the command under the mouse pointer or the
action required to complete the next step in the command.

e the pointer position
Shows the current pointer position—in the current units and decimal
places—together with the nearest snapcode. This information is
dynamically updated as you move the mouse pointer across a
drawing. You can set your preferences to show only the last hit
position if you prefer. For details about setting preferences, see
page 22. For information about each individual preference, refer to
Help.

o the status of the Z=0 facility
The Z=0 button enables you to force graphics to be drawn on the
XY plane. For details about using the Z=0 facility, refer to Help.

o the status of the SETEDIT facility
The SETEDIT button enables you to set editing restrictions to
temporarily exclude graphics from being edited. For more details,
see Chapter 3, Working with primitives and objects.

o the status of hover highlighting
The Hover Highlight button provides feedback about the graphics
directly beneath the mouse pointer. Details are given in Chapter 3,
Working with primitives and objects.

e an animation when drawing is in progress

e the status of the grid
A grid can assist you when you are drawing and placing graphics.
When a grid is defined, you can switch it on and off using the Grid
button.
More details about the grid are given in Chapter 5, Entering
positions.
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o the status of dynamic snap guides

The Snap Guides button enables you to display dynamic snap guides
when constructing or editing graphics. Details are given in
Chapter 5, Entering positions.

e CAP if Caps Lock is on
e NUM if Num Lock is on
e whether there are any problems associated with an open document

If there are problems associated with any open document, an
exclamation mark on a yellow background is shown. You can use
the exclamation mark button to display a Problems dialog box which
you use to view and correct errors in open documents.

More details about warnings and errors are given in the later section
Opening a document on page 35 and also in relevant sections
throughout the guide.

The prompt bar

For some MicroGDS commands, MicroGDS displays a prompt bar at
the bottom-left of the window. The prompt bar is displayed, for example
for you to enter the radius for a circle:

R adius: _ﬂﬂ _?J |

Whenever you are required to specify a position, you can display the
prompt bar by typing coordinates instead of clicking in the window. The
prompt bar appears as soon as you start typing.

By default, the prompt bar is fixed at the bottom of the MicroGDS
window. You can choose to have a floating prompt bar which you can
move to a convenient position on your screen.

To float the prompt bar
1 On the File menu, click Preferences.

2 On the General tab, select the Floating prompt bar check box.
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Using commands

In MicroGDS, you use commands to draw, view, and modify graphics.
There are a number of ways you can access commands:

e you can access all commands from the menus
Note that some commands are available only from the Document
Organizer.

e you can access many commonly-used commands using the toolbars

e you can access some commands using buttons on the information
bar

e you can access some commands using shortcut keys

You can change the default shortcut assignments, and add or remove
a shortcut for any MicroGDS command. For details, see Chapter 17,
Customizing MicroGDS.

For example, to display the Window Editor, you can press F2, or on the
File menu, click Window, Edit, or on the File toolbar, click the Window
Editor button.

Command feedback

When you select a command, you often see a graphical representation
of that command attached to the mouse pointer. For example, if you are
measuring the distance between two points in a window, the following
is shown:

>

il |

For other commands, MicroGDS may require information from you.
For example, when you construct a polygon, you are prompted to enter
the number of sides.

Sometimes, you might need to undo a position during a command. For
example, if you are drawing a series of lines and you make a mistake
when specifying one of the points, you can undo the position. To undo a
position, press Backspace.

When you use a command, it either:

e remains active ready for you to use again

e or ends automatically once you have completed the task
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Where a command remains active, you can often change the command
parameters before re-using the command. For example, if you construct
an arc which has an angle of 45° and you now want to draw a second
arc which has an angle of 90°, you can press Enter to redisplay the
prompt bar and specify the new angle.

Note that some commands can be used while using another command.
For example, you can start the Line command and begin drawing a line,
use the Zoom Rectangle command to zoom to another area, and when
the zoom completes you are back to the Line command.

To end an active command when you have finished, press Esc.

Repeating commands

For many commands, you can repeat the last command. For example, if
you use Construct, Text to create and place a text primitive, you can use
the repeat command facility to immediately create another text
primitive.

To repeat the last command

e press Enter

Undoing and redoing commands

You can undo commands that created, deleted, or modified graphics.
MicroGDS undoes the most-recent first and works back. Similarly, you
can reverse an undo.

To undo a command

e press Ctrl+Z, or on the Edit menu, click Undo
To redo a command
e press Ctrl+Y, or on the Edit menu, click Redo

You can undo and redo up to the undo buffer size set in your
preferences. Note that you cannot undo commands you made before
saving a document.
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Setting preferences

You can customize MicroGDS by setting up a number of personal
preferences. Initially, all preferences are preset to the default MicroGDS
settings. You can modify settings using either the Preferences dialog
box or the Preference Files Editor. The Preferences dialog box gives
access only to your personal settings whereas the Preference Files
Editor may let you modify settings at other levels. For example, you
may be able to modify settings for all MicroGDS documents contained
in a specified folder (if you have the relevant access permissions to the
folder).

Note that any change to your personal settings is reflected in both
editors.

All settings are saved to xml files, stored in the appropriate locations.
You can see the location of a settings file in the Preference Files Editor.
For more details about the Preference Files Editor, see Chapter 17,
Customizing MicroGDS.

To set your preferences

e on the File menu, click Preferences

You may find that not all your personal preferences are available to you.
This is because a preference may be set as a policy a higher level.
Where a policy is in place, it cannot be overridden at any lower level.

Changes to your preferences are saved only in memory. To save
changes permanently, save your settings when you exit MicroGDS or
save the settings file using the Preference Files Editor. Note that if you
have any unsaved modified settings when you exit MicroGDS, you will
be prompted to save the changes.

The preferences that you can set up are described in the relevant
sections throughout this guide, and in the Help. Refer also to
Chapter 17, Customizing MicroGDS.
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MicroGDS documents

MicroGDS drawings are stored in documents. A document
encompasses all the data for a drawing, that is, document windows,
layers, graphics, and so on.

In MicroGDS, you can work in single-user mode or in multi-user
projects. In single-user mode, each time you open or start a new
document, a new window is opened in which you can store the graphics
and related information (such as primitives, objects, and layers).
Single-user documents are stored in .MAN files.

In a multi-user project, the graphical data is stored in separate files
enabling several users to work on the data. For details, see Chapter 16,
Multi-user projects.

In MicroGDS, graphical data is stored on a series of layers. Each layer
can be considered as a transparent overlay. You can use layers to group
related graphics together. If you do not create any layers, all the
graphical data is held on a single default layer. The default layer, and
any layers that you create, are automatically allocated a phase. A phase
is a view onto the layer data, and enables you to choose the graphics
that are to be included, the colour in which they are displayed, and the
order in which they are to be printed. For more details, see Chapter 4,
Using layers and phases.

To access the layer data in a document, you use a window definition.
This provides a view onto the graphical data. In a single-user document,
the first window created in a document is initially the principal window.
This is the window that opens whenever you open the document. You
can create as many window definitions as you require, and set any other
window to be the principal window. Each window definition defines
which layers are to be referenced in the view, which graphics are
editable, visible, invisible, and hittable, the view extents, and the
projection.

Every window definition has at least one view associated with it. One of
these views is designated the default view for the window. Whenever
you create a new window definition, a default view (named View1) is
also created. You can create as many views onto a window definition as
you require and, similar to a window definition, set any other view to be
the default view of the window.
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For more details, see Working with window definitions on page 38 and
Working with multiple views on page 53.

Most graphics in a MicroGDS document have a style assigned. A style
defines the appearance of a graphic. For example, a line primitive has a
linestyle and a text primitives has a charstyle. Some graphics, such as
inserted raster images, do not have a style assigned. Styles that you
create in a document are saved in the MAN file. However, you can also
share standard or common styles by using style files. For details about
style files, see page 25.

You can also use graphics from other files in your documents. For
example, you can insert a raster image from a raster file or link an
object from another single-user document. In MicroGDS, you can set
up aliases to reference the physical locations of files that you want to
use in a document. For more details about aliases, see page 27.

Templates

A template is a document with custom-designed properties and content
which you can use to create other documents. A template can contain
anything that can be stored in a MAN file, such as graphics, styles, and
window definitions. For example, you might create a template to define
a drawing frame or one that includes a company’s logo. Templates are
simply single-user documents that you save with the extension .MTF.
MicroGDS provides ready-made templates (a0.MTF through to
a4.MTF) that you can use.

You may also find it useful to set up a template to reference style files
(described next), or aliases which reference additional files that you can
access.

When you base a new file on a template, the template’s content is
copied to the new document. Templates are used only when you create a
new file; if the template is subsequently updated, existing documents
based on the template are not updated.

If you want to make changes to a template (a .MTF file), you must open
the file using the Open command on the MicroGDS File menu, or drag
the template file into the MicroGDS window. If you double-click the
file in Windows Explorer, a new document based on the template will
be created.
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If you often want the same graphics and styles to be available in new
documents, you can set a default template to be used for all new, blank
files.

You specify the location of your templates on the File Locations tab in

your preferences. Then, when you choose to use a template, MicroGDS
lists any templates that exist in the specified location. For details about
setting your preferences, see Chapter 17, Customizing MicroGDS.

For more details about creating and using templates, refer to Help.

Style files

Documents can share styles by using style files. You can create and
access the following types of style file:

Style file name Style type

LINES.STY linestyle
CHARS.STY charstyle
LIGHTS.STY lightstyle
MATLS.STY material

ATTRS.STY mnemonic definition
SCHEMAS.STY schema definition

Only style definitions are saved in a style file. If you create graphics to
help you define the styles, they are discarded when you save and close
the style file.

For single-user documents, you can access style files by specifying their
location on the style search path. For more details, see the following
section Styles and single-user documents.

For multi-user projects, the location of style files is set in the project
database. For more details, see Styles and multi-user projects on
page 27.

You can also access any style files that exist in the location for styles
and fonts, defined in your file location preferences. Any style files that
exist in the specified location are made available to all your documents
(single-user documents and projects). Note that although the style files
in this location are made available, it is the location in which any are
installed with MicroGDS. If you wish to place your own style files in
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this location, first ensure that a style file of its type does not already
exist. If you do store files in this location, be sure to move them before
your MicroGDS installation is updated or repaired, otherwise they may
be lost.

To specify style files in your file location preferences

1 On the File menu, click Preferences.

2 Click the File Locations tab.

3 In the Styles & Fonts box, specify the location in which global style

files (and MicroGDS font files) are located.

By default, the location is set to the Fonts folder in your MicroGDS
installation directory.

Note that your CAD manager can set policies to restrict any of your
preference settings. If the Styles & Fonts box is greyed out, this
indicates that a policy is in place and you cannot change the set
location.

Any changes to your preferences are saved only in memory. To save
changes permanently, save your settings when you exit MicroGDS.

Styles and single-user documents

When you create or modify a style in a single-user document, the style
is saved in the MAN file. These styles are called local styles. However,
you can also access styles in external style files. To do this, you specify
the folder in which the STY files are located on the style search path.

To set the locations of style files on the style search path

1 On the File menu, click Style Search Path.

2 In the Edit Search Path dialog box, define the locations of the styles
files (.STY) that are to be referenced by the current document.

The order in which the search paths are listed is important because if
a style name of the same type appears in more than one style file,
MicroGDS uses the first style that it finds.

If changes are later made to any of the styles in a style file, those
changes are reflected in all documents that reference the file.
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If you modify a style from a style file, it becomes a local style in the
current document and is saved in the MAN file. Styles saved in a
document take precedence over styles of the same name in a style file.

For more details about creating and using style files, refer to Help.

Styles and multi-user projects

In multi-user projects, all styles are stored in external style files which
are defined in the project database.

If you modify a style from a style file, it becomes a local style and is
saved in the first location on the project’s style search path. For details
about creating multi-user projects, see Chapter 16, Multi-user projects.

Aliases

An alias is a name given to a folder so that the path to that folder does
not have to be specified in full. This is similar to using Windows
shortcuts. Mapping a location to an alias is useful when files are moved
in the filing system.

In a single-user document, aliases can be used to reference the locations
of:

e object libraries

Object libraries are MicroGDS MAN files that contain objects you
can insert or link to the current document. For details about objects,
see Chapter 3, Working with primitives and objects.

e raster images
Raster images are image files that you can insert into the current

document. For details about raster files, see Chapter 15, Working
with different file formats.

e reference documents
Reference documents are MicroGDS documents that contain
window definitions that can be used in photos in the current

document. For details about photos, see Chapter 3, Working with
primitives and objects.

e renderer files

Renderer files can be used by materials, lights, and rendering
environments in MicroGDS Collaboration. For details about
rendering, see Part Two: Advanced 3D and rendering.
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Aliases are defined using the Aliases command on the File menu and
are stored in the current document.

Aliases are also used to define the locations for layer and window
definition files, and are set up in the project database. For details, see
Chapter 16, Multi-user projects.

To set up aliases (in a single-user document)

1
2

On the File menu, click Aliases.

In the Aliases dialog box, define the alias definitions for the current
document:

e to add a new alias, click Add

e to change an existing alias, click Edit
e to remove an alias, click Remove

When you add or change an alias, the Alias Editor is displayed.

In the Name box, type the alias name you want to use.

In the Location box, specify the physical location to which the alias
refers.

Note that if you map an alias to a network drive, the assignments
will only work for all users who use the same standardised mapping
of drive letters to disks. If you do not use a standardised network
mapping system, you should specify the full network pathname
when you set up alias names.

From the Type list, select the alias type you require.

For example:

Alias Editor 3

Mame Electrical Objects

Location Ci\Instances\Electrical obje

Type

Expandable

l (04 ] [ Cancel ] [ Help ]

To allow an alias name to be expanded which will give access to any
subfolders below, select the Expandable check box.

Click OK to close the Alias Editor, and again to close the Aliases
dialog box.



Chapter 2: Exploring MicroGDS 29

When you have set up aliases for object libraries and raster images, you
can access the data from the Document Organizer (described next).

You can view the contents of raster and library alias locations in
Windows Explorer by right-clicking over the folder and clicking
‘Explore folder’ on the shortcut menu.

More details about setting up and using aliases are given in Help.

Using the Document Organizer

Use the Document Organizer to work with the data relating to
documents that you have open. For example, you can open and rename
window definitions in a document, create and modify styles, and copy
and rename layers. The Document Organizer also provides access to
files in any aliased file locations.

> To open and close the Document Organizer

e press F4, or on the Window menu, click Document Organizer

current document

Gate House. MAN + #—— document list
1 & | # |3 +— tabbed pages
14 A& | [@ —f— toolbar

__;] 30 wiew

tab-specific data
(in this case, window definitions)

_|j] Ceiling view —
0] Plan view
_|j] Print layout

0] Section A-4

When you open a document, it becomes the current document in the
Document Organizer and its name is displayed in the document list.

If you open more than one document, you can switch between them
using the document list. This enables you to view, share, and work with
data in any number of documents.
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The first time you open the Document Organizer in the current session,
the Window Definitions tab is displayed. This shows a list of the
window definitions in the document. In a single-user document, the
name of the principal window is shown in bold. (This is the window
that MicroGDS opens each time you open the document.)

In a multi-user project, the name of the default window alias is shown
in bold. This is the default location in which new window definitions in
the project are saved. For details, see Chapter 16, Multi-user projects.

The Document Organizer has five tabs. Each tab provides a toolbar and

a shortcut menu for commands specific to the type of data:

e the Window Definitions tab
Includes commands to work with window definitions and saved
views. For example, you can open, rename, find, and export window
definitions and show, copy, rename, and delete views. For details,
see Working with window definitions on page 38 and Working with
multiple views on page 53.

o the Layers tab

Includes commands to copy, rename, find, and export layers. For
details, see Chapter 4, Using layers and phases.

o the Styles tab

Includes commands to create, modify, and change styles. For details,
see the individual styles chapters (Chapters 7 and 8, and Chapters 10
and 11).

o the Library Files tab
Includes commands to preview and insert objects from aliased MAN
file libraries. For details about objects, see Chapter 3, Working with
primitives and objects.

o the Raster Files tab

Includes commands to preview and insert raster images from aliased
raster files. For details about raster images, see Chapter 15, Working
with different file formats.

The Window Definitions and Layers tabs list the windows and layers
currently available in the document, in alphabetical order.

The Styles tab shows the style categories; there is one category for each
style. When you open a style category, a list of locations in which style
files exist is displayed. The first location is the current MAN file; all
new styles are saved in the MAN file. The path for each location
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defined in the style search path is then displayed. At the end of the list,
the path set for styles and fonts (in your file location preferences) is
shown, provided that a style file for the displayed category exists.
Setting up the style search path is described on page 25.

If you have set up aliases for object libraries and raster files, the Library
Files tab and the Raster Files tab list each aliased location.

To display the items available in a style category, or from a library or

raster alias, you must open it.

> To open a style category or alias location
e double-click the name, or click the plus sign (+) to its left

Whenever a list of items is displayed in the Document Organizer, you
can preview an item.

> To preview an item in the Document Organizer
1 Click the appropriate tab.

2 Select an item.

To close the preview area, select the command again.

Remember that you can also view the contents of raster and library alias
locations by right-clicking over the alias folder and clicking ‘Explore
folder’ on the shortcut menu.

The facilities available from the Document Organizer are described in
the relevant sections in this guide. For more details, refer to Help.

Using name assistants

Your system administrator may set up special naming standards for
layers and objects at your site, using name assistants. Name assistants
define the naming standards for layers and objects and can be set up to
suggest or enforce the names.

If you begin to draw immediately, MicroGDS usually creates an object
and a layer using the default names. However, if the name assistants are
in force, and the default object and layer names do not conform to the
naming standards, the following message appears:
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The layer name
default

daoes hot confarm to the naming standard.

MicroGDS then opens the Layer Name or New Object dialog box as
appropriate, for you to specify a name that conforms to the naming
standards. The dialog box shows a tree-like structure of naming
conventions.

For example:

Layer, Name rz|

- |
gl ==
Architect ~
Civil Engineering

Contractor) Shop Drawings

Electrical

Equipment Consultants

Fire Protection

GIS {Geographic Information Systems)
Inkerior Design

Landscape Architecture

Mechanical

Other Consultants

Flumbing

Sheviboe sl

Mame

L e 3 e 3 e 2 e )

The layer name
default
does not conform ko the naming standard,

Note that when you create a layer in a multi-user project, an additional
box is displayed at the bottom of the Layer Name dialog box. For
details, see Chapter 16, Multi-user projects.

If you are using name assistants and the tree structure is not shown,
either the appropriate configuration file has not been set up or the name
of the layer on which you are creating the new object does not conform
to the naming standards.

To expand a name category, double-click the name. Each time you
select a name, MicroGDS adds a component to the displayed name in
the Name box.
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For example:

Layer Name Pz|
Mame | IPFLR-DIMS I o« ]
Label |Dimensi0ns |

[=- Floor Plan ~
Border
Cross-hatching & Poche
Dimensions
General Motes & Specifications
A orduElues o

The listed descriptions and the corresponding layer names are defined
in the configuration file.

You specify the names and locations of the configuration files and their
applicability on the Name Assistants tab in your preferences. Details on
how a system administrator can set up the name assistants is given in
Chapter 17, Customizing MicroGDS.

Working with documents

This section describes how to create, open, save, and close a single-user
document.

For details about how to work with multi-user project files, see
Chapter 16, Multi-user projects.

Creating a new document

> To create a new document

1 On the File menu, click New.

MicroGDS displays the Create a New File dialog box:

Create a New File &l

Select the tvpe of file you wish to create. Single-user files store
all data in a single file, Multi-user Files are part of a mulki-user
project used to share data between users.

Single-user File Multi-user files
() Blark (%) Project database
() From template () Project workspace

Click Mext ko specify Further options,

[ Mext = ][ Cancel
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2 Do one of the following:

e to create a new blank document, or a document based on a
default template, select Blank and click OK

e to create a document based on a template, select From template,
then click Next

Use the displayed dialog box to locate the template (a .MTF
file), and click Open.
The initial location that MicroGDS should look for template files
can be set in your File Locations preferences.
You can also create a new document based on a template by
double-clicking a template file in Windows Explorer. (Do not drag a
template file into the MicroGDS window unless you want to open
the template file.)
A new window opens in the MicroGDS window. Each new window
is numbered sequentially from 1 within the current document (and in
the current session).
For example:
Viewing buttons

!.‘2. Document1 - Window1 - View1

View extent

FoeoOuD

Axes

= U S0 PAMOG

W
3 o E

Zoom bar Scroll bars
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The window items are described in Working with windows on page 41.

When you create a single-user document, MicroGDS creates a window
definition (the principal window) and a default view onto the window.
The principal window opens and the default view is shown each time
you open the document. You can create additional window definitions
and saved views as required. For details, see Working with window
definitions on page 38 and Working with multiple views on page 53.

Opening a document

To open a document

o on the File menu, click Open, and select the document to open

e or, double-click the .MAN file in Windows Explorer

e or, drag the .MAN file from Windows Explorer into the MicroGDS
window

When the document has loaded, the default view in the principal
window definition opens.

For example:

2 The Gate House.MAN - 2D view - Entrance (A=
a

=l
-
=]
2
@
[«]
5
v
'y
.‘g
i

v

< |1

You can open other MicroGDS documents, such as style files, in the
same way.

You can also open files of other formats, for example, DXF files. For
details, see Chapter 15, Working with different file formats.



36

Using MicroGDS 2010

By default, if MicroGDS detects any errors with the document, a
Problems dialog box opens giving details about the error. For example,
an error might indicate that the document contains a link to another
document or file for which MicroGDS cannot find the source or that
fonts used in the document are not installed on the current machine. The
Problems dialog box provides facilities to view and correct the detected
errors. More details are given in the section relevant to the type of data
to which a problem has been found.

Whenever there are unsolved problems in an open document, a yellow

warning triangle ¥, is shown on the information bar. You can
double-click the button to open the Problems dialog box.

Lock files and backup files

When you open a .MAN file, MicroGDS creates a parallel lock file in
the filing system. The lock file has the extension .MA#. Lock files
ensure that only one person can edit the document at one time. The lock
file is removed when the document is closed enabling another person to
open it for editing. While a document is locked, other users can open
the document as read-only.

If you have the Backup option set, on the General tab of your
preferences, and you have made changes to the document since it was
last saved, MicroGDS creates a backup file with the extension .MAS.
When the document is next saved, the backup file is removed.

If a document is not closed correctly, for example, if MicroGDS stops
responding, the lock file and the backup file (if it exists) remain in the
filing system. When you next open the document, MicroGDS prompts
you to first unlock the file. If you unlock the file and a backup file
exists that is more recent than the file at the time it was closed,
MicroGDS displays a second message prompting you to save the file.

If you close the backup file and then open the original file, you cannot
re-open the backup file.

Template files and style files are locked and backed up in the same way.

If the Backup option is not set, a backup file does not exist and any
unsaved changes to a file are lost.
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Saving a document

As you work on a document, you can save the document using either
the same name, or a different name.

To save your document
e press Ctrl+S, or on the File menu, click Save MAN File

This command reflects the type of document you are saving. For
example, if you are saving a STY file, the command shows Save
STY File.

If you have not yet saved the document, a Windows Save As dialog
box is displayed. In the Save As dialog box:
a) ensure that the Save as type box shows MicroGDS File (*.MAN)

b) specify the name and location for the document

If you do not include the .MAN extension, MicroGDS adds it
automatically.

c¢) Click Save.

To save a document to another MicroGDS format, select the appropriate
file type in the Save as type box. You can also export window
definitions to other formats, for example, DXF. For details, see

Chapter 15, Working with different file formats.

Closing a document

To close your document
e on the File menu, click Close MAN File

This command reflects the type of document you are closing. For
example, if you are closing a STY file, the command shows Close
STY File.

If the document has not yet been saved, you are prompted to save or
discard it. If you choose to save the document, MicroGDS displays a
Windows Save As dialog box. Save the document as described in the
previous section.

If the document has unsaved changes, you are prompted to save or
discard them.
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Working with window definitions

Each window definition you open or create is opened in a new window.
You can store multiple window definitions in a single document. This
enables you to work with different parts of a document, and also share
data throughout a document.

For each window definition that you create, MicroGDS also creates an
initial, default view. You can create additional views and move easily
from one to another. For more details, see Working with multiple views
on page 53.

This section describes some of the basic, window definition tasks. For
full details, refer to the appropriate chapters in this guide and also refer
to Help.

Creating window definitions

> To create a window definition
1 On the Document Organizer, click the Window Definitions tab:

Window Definitions tab —s= [ | & | = | i1 | &

2 Click the New Window toolbar button —
Alternatively, use the Window, New command on the File menu.

The window definition opens in a new window. The window title shows
Windown — Viewn, where:

e Windown is the next sequential window definition number within
the current document

e Viewn is the next sequential view number within for the current
window definition

If you do not change the names, MicroGDS stores the window
definition and view with the generated names when you save the
document. Details about renaming window definitions and views are
given later.

When you create a window definition in a multi-user project, you must
save the window to a file. For details, see Chapter 16, Multi-user
projects.
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Opening window definitions

| 2 To open a window definition

e in the Document Organizer, double-click the name of the window
definition to open

The default view of the window definition opens in the MicroGDS
window.

If a window definition has multiple saved views, you can open a
different view by clicking the plus sign to the left of the window
definition name and then double-clicking one of the displayed view
names.

For example:

O\l |« |@ | &

o W AR
click here to = ﬂ Electrical circuit
expand views ™3 point perspective view
] Lavout double-click view to open

T Plan view
+ ﬂ Fire Protection
+ g'] Plurnbing

Note that the view icons depict the type of view they store. For more
details, see Working with views on page 45.

You can use the Find facility in the Document Organizer to search the
document for specific window definitions. You can use wildcards to
find window definitions that have similar names. For details, refer to
Help.

You can also open the default view in a window definition from the File
menu:

1 On the File menu, click Window, Open.
MicroGDS displays the Open Windows dialog box.

2 Double-click the name of the window definition to open.
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Changing the principal window
To change the principal window in a single-user document

1 In the Document Organizer, select the name of the window
definition that you want to set as the principal window.

2 Right-click to display the shortcut menu, and select Set as Principal.
The name of the window definition is shown in bold, to indicate that
it is now the principal window.

This command is not applicable with multi-user projects.

Renaming window definitions

To rename a window definition

1 Inthe Document Organizer, select the window definition you want
to rename and press F2.

2 Enter the new name and press Enter.

You can group window definitions in a MAN file into categories, by
typing the name in a particular format. This will show the windows in a
document in a tree structure in the Document Organizer. For details,
refer to Help.

Closing window definitions

To close a window definition
e on the File menu, click Window, Close
If you have unsaved changes in the window definition, you are not

prompted to save them. The changes will be saved when you save
the document.

If the window definition is the last view onto the document, the window
is closed but the document remains open. MicroGDS creates a
placeholder window for the document, which appears minimized at the
bottom of the MicroGDS window. This enables you to work with the
document later in the current session.

The name of the document represented by the placeholder window is
shown in its title bar. For example:

document menu

£ The Gate Hous... @
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You can reopen recently-used windows in the document, using the

window’s document menu. You can close the document by clicking
on the placeholder window or using the Close MAN File command on
the File menu.

Note that if you close a window definition in a multi-user project to
which you have unsaved changes, you are prompted to save the
changes. This is because window definitions in a project are saved in
separate files.

Working with windows

When you create or open a document, MicroGDS opens a new window.
The rectangle inside a window is where you produce your drawing.
This rectangle is the view extent and is a view onto the drawing sheet.
By default, the axes are shown in the centre of the window. MicroGDS
uses the axes to draw and place graphics. Further details about the axes,
the view extent, and the drawing sheet are given in the next section.

When you have drawn graphics, as you move the mouse pointer around
the view extent you will notice the following:

o if you have hover highlighting switched on, any editable primitive
or object beneath the mouse pointer is highlighted, and information
relating to the graphics is shown in an InfoTip

For more details about hover highlighting, see Chapter 3, Working
with primitives and objects.

o if you have snap guides switched on, MicroGDS creates temporary
construction lines that you can use to help position and align
graphics precisely
For more details about snap guides, see Chapter 5, Entering
positions.

o the pointer constantly changes to identify the type and location of
the nearest snap point (if you have the ‘Dynamic pointer position’
check box selected in your preferences)

MicroGDS provides snapcodes to enable you to snap exactly to any
given point in a window. This ensures accuracy in drawing,
selecting, moving, and placing graphics. For details about the
snapcodes, see Chapter 5, Entering positions.
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You can create multiple windows, each showing a different view of the
same window definition or showing different window definitions. To
the left of each window are the viewing buttons for moving around the
view, and the zoom bar. These are described later in Working with views
on page 45.

The drawing sheet

The current view extent is simply a view onto the drawing sheet. You
can think of the drawing sheet as a sheet of paper on a drawing board.
You can draw on any part of the sheet—you do not have to use the
entire drawing sheet.

You can change the view extent to see different parts of a drawing, and
you can enlarge or reduce the extent. For more details, see Working with
views on page 45.

When you start to draw, you choose a scale. You do not have to print at
this scale—you can choose to make your graphics fill as much or as
little of whatever size paper you have in your printer or plotter. When
you print a 2D or 3D view, MicroGDS prints only what is in view in the
view extent, so if you want to print the entire contents of the window,
you must ensure that it is completely in view. For a print-layout view,
MicroGDS always prints the whole of the paper.

Note that the sheet has a fixed-paper size of 100,000 km square, at a
scale of 1:1.

About the axes

By default, in the centre of the view extent are the axes. The axes
provide a powerful drawing aid when you draw and place graphics.

X

If the axes are within the view extent, by default the axes are always
displayed on the screen, but they are never printed. Each window has its
own set of axes but only the axes in the current view of a window are
shown.



Chapter 2: Exploring MicroGDS 43

Positions on the sheet are measured in relation to the origin of the
current axes—using the X, Y, and Z coordinates. Coordinates are
shown, and given, in the order X, Y, Z. The coordinates are shown to
the right of the prompt bar. MicroGDS shows either the coordinates the
dynamic pointer position or the last point input, depending on your
preferences.

You can change the position of the axes and their rotation as you work.
You can save a window’s axes so that you can restore it at any time.
You can also choose to hide or show the axes on your screen.

For more details, see Chapter 6, Using the axes.

The drawing origin

By default, the position at the centre of the drawing sheet is called the
drawing origin. The point is 0 on the X, Y, and Z axes and is the
position on your drawing sheet that you use as a point of reference.

When you create a new, blank document, the normal axes’ position has
the axes’ origin at the drawing origin. If you create a document from a
template in which the drawing origin has been changed, the axes are set
at the centre of the drawing sheet and not at the position set by the
drawing origin.

You can change the location of the drawing origin, using the Document
Properties command. You might want to do this, for example, to
measure positions from the bottom, left-hand corner of a plan, rather
than from the centre. You can then move the axes’ origin to the drawing
origin using the Axes Normal command.

Note that the Axes Centre command always resets the axes to the centre
of the drawing sheet.

In the following example, the drawing origin in the first illustration is
set at the default position, that is at the centre of the drawing sheet at
coordinates 0/0/0. This is currently the centre axes’ and the normal
axes’ position. In the second illustration, the drawing origin has been
moved in a negative X direction. The drawing origin coordinates are
measured from the centre axes position, relative to the new drawing
origin. Therefore, the drawing origin is set to 50/0/0.
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centre axes position, normal axes
normal axes position
™ ’ N osit>ifm 50/0/0
drawing origin 0/0/0 p ) -
drawing origin 0/0/0
> To change the drawing origin

1 On the Set menu, click Axes, Centre to set the axes to the centre of
the drawing sheet.

The drawing origin is specified as the position from the centre of the
drawing sheet relative to the new drawing origin.

2 On the File menu, click Document Properties.

3 Inthe Document Properties dialog box, enter the X, Y, and Z
coordinates for the new drawing origin, relative to the centre axes,
then click OK.

Coordinates are always displayed relative to the current axes and its

origin, even if you change the drawing origin.

p  To position the axes at the drawing origin

e on the Set menu, click Axes, Normal

For more details about coordinates and axes, refer to Chapter 5,

Entering positions and Chapter 6, Using the axes respectively.

The scale and size of graphics

You can draw at any scale you like and in any measurement units; both

scale and units can be set on the status toolbar or by using commands

on the Set menu.
> To set the axes scale

o in the Scale box on the status toolbar, type or select the scale you
require

e or, on the Set menu, click Axes, Scale and enter the scale you
require in the prompt bar
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When you specify a scale, MicroGDS uses a scales file to determine the
scales that are available. You specify the scales file to be used in your
preferences. If you type a scale that corresponds to a value in the list,
then that element is selected. For details about creating a scales file, see
Chapter 17, Customizing MicroGDS.

When you have set the scale, all new graphics are drawn at this scale
until you change it. The scale of existing graphics is not changed.

> To set the units of measurement

o in the Units box on the status toolbar, select the units you require; in
the Places box, type the number of decimal places

e or, on the Set menu, click Units, enter the units you require in the
prompt bar and then enter the number of decimal places you require

The number of decimal places does not affect the accuracy to which you
draw, only the precision to which dimensions and numbers are
displayed in MicroGDS.

For more details about inputting positions, see Chapter 5, Entering
positions.

Working with views

A view comprises a number of settings including the extent of the
window definition that is visible and the window quality settings used
to display the graphics.

The window quality settings determine how graphics are to be
displayed. You can set the window quality using the Quality command
on the View menu. For details, refer to Help.

In MicroGDS, there are three view types that you can switch between:
e 2D view

2D is the default view of a window definition. The extent of the
view is in the XY plane.

e 3D view

A 3D view extent is defined by the eye position and the look-at
point. This determines the (pyramid-shaped) cone of view, with the
apex of the cone at the eye position. For more details, see Chapter 9,
Working in 3D.
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e print layout view

Print layout view is specifically for setting up how the physical page
will be printed. A print layout view stores the paper size, orientation,
and margins. The extent of the view is in the XY plane.

In general, a print layout view behaves similar to a 2D view.

To switch between views

e on the View menu or on the View toolbar, click the view type you
require:

1| 2D view

w| 3D view

[0  print layout view
You can also switch between views using the viewing buttons which are
on the left of each window. These are described later in this chapter.
Switching to 3D view

When you switch to 3D for the first time, a default 3D perspective view
is shown.

When you subsequently switch to 3D, a view with the previous 3D
parameters is shown.
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Switching to print layout view

When you switch to print layout for the first time, MicroGDS displays
the Page Setup dialog box for you to set your paper size requirements.
For example:

Page Setup E|

) Partrait

(®) Landscape

Size: Margins: Top

P Left |10 Right
10 @ mm

v s 10 Onches

ok | [ cancel | [ Hep

The name of the paper displayed in the Paper box defines the
orientation, paper size, and margins of the current paper. MicroGDS
uses a paper sizes file to determine the paper definitions available to
you. A sample file called ‘paper sizes.csv’ is installed to your
MicroGDS Programs folder and is automatically referenced in your File
Location preferences. For details about editing or creating a paper sizes
file, see Chapter 17, Customizing MicroGDS.

You can select any paper available to you. You can also change any of
the displayed settings, for example, you can increase the margins to add
more white space around your graphics.

When you subsequently select print layout, MicroGDS uses the paper
definition that you set up. The paper definition is saved with the
window when you save the document. To change the assigned paper
size at a later date, use the Window, Page Setup command on the File
menu, or click the Page Setup button on the Window Editor. The
Window Editor is described in Chapter 4, Using layers and phases.
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Changing the view extent

When you work with a document, you will constantly need to change
the extent to see different parts of the view in the window definition. In
MicroGDS, you can move around a view, and you can zoom in and out
to enlarge or reduce the extent.

Each time you change a view, MicroGDS records the new parameters
and updates the view parameters.

There are a number of ways in which you can view different parts of a
window definition. For example, you can use:

e the zoom commands and the zoom bar

e the scroll bars

e the viewing buttons

o the Navigate window

e commands on the View menu

You can also view and manually change the parameters using the View

Parameters command on the Window menu. More details about the
view parameters are given in Chapter 9, Working in 3D.

If you are using a wheel mouse, you can zoom in and zoom out of the
current window by rotating the wheel, and pan the window by pressing
the wheel whilst moving the mouse.

The zoom bar, scroll bars, and the viewing buttons are known
collectively as the view controls. You can choose which view controls
you want to be made available on your windows. For details, see Setting
the view controls on page 53.
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Using the zoom bar

Use the zoom bar to zoom in and out of the window about the current
view centre. By default, the zoom bar is situated on the left side of the
window, below the viewing buttons.

| -—— slider

<—— thermometer

To zoom out, click above the slider; to zoom in, click below the slider.
Or drag the slider in the required direction.

e ina2D view

Dragging the slider to the top of the zoom bar zooms out 100 times,
and dragging it to the bottom zooms in 100 times. The slider
automatically returns to the centre of the zoom bar when you release
it.

e in a print layout view

The zoom bar behaves in an absolute manner, relative to the selected
paper size. Note that you cannot zoom out beyond the selected paper
size.

You can also zoom in and out using the viewing buttons, and the Zoom
commands on the View menu.

Using the scroll bars

You can pan around a window definition using the scroll bars. The
vertical scroll bar is on the right of the window and the horizontal scroll
bar is at the bottom.

The scroll box indicates the extent of the graphics shown in the window
as a proportion of the total extent of all graphics. When all graphics are
shown, the scroll box fills the entire scrolling area; no background is
visible.
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In a 2D view, you can scroll the view almost without limit; in a print
layout view, you can scroll only to the extent of the selected paper.

For details about navigating in 3D views, see Chapter 9, Working in 3D.

Using the viewing buttons

You can use the viewing buttons, at the left of each window, to change
the view. You can select different viewing buttons to display on 2D
(including print layout) and 3D views using the View Controls tab on
the Customize dialog box. To open the Customize dialog box, click
Profile, Customize on the Window menu.

The default buttons on a 2D window are:

O switches to 2D view
& | switches to 3D view
! switches to print layout view

> expands the view extent to fill the window (not available with a print
layout view)

Q, zooms in to a rectangular area that you specify

Q, zooms to show the selected graphics as large as possible

@ zooms to show all the graphics as large as possible.
In print layout view, shows only graphics that are within the paper
extent.

Qo switches back to the previous view

(5] switches forward to the next view

=) creates a new window with a view extent that you specify
aligns the view with the current XY axes (not available with a print
layout view)

=] creates a new window with a view extent that you specify

'y advances to and retreats from a point

By sets the drawing style in which to draw intelligent objects

These and other commands, such as changing the graphical quality of
the window, are also available through the View menu. All commands
to change the view in a window are also available from the View
toolbar.
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The default buttons on a 3D window are described in Chapter 9,
Working in 3D. More details about choosing view controls are given in
Setting the view controls on page 53.

When you change the view, you can use the Next View and Previous
View commands to move forwards and backwards between views. This
enables you, for example, to concentrate on a specific part of the
window and to see the results instantly by returning to the previous
view.

Using the Navigate window

When you have a 2D or print layout view, the Navigate window enables
you to zoom, nudge, pan, and move around using a thumbnail view. A
thumbnail shows a small picture that you can use to navigate the default
view in the associated window definition. A thumbnail is not available
in a 3D view.

For example:

If the view is zoomed in on a specific part of the default view, the view
extent is highlighted in the thumbnail and the area outside is shaded in
the Navigate window.

view extent —

mﬁ

__M“LMH

4
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p  Todisplay the Navigate window

1 Ensure that the window whose contents you want to view in the
Navigate window is the active window.

2 On the Window menu, click Navigate.

When the Navigate window is open, the thumbnail is immediately
updated whenever you make a different window definition active.

You can select the viewing buttons to display on the Navigate window
on the View Controls tab of the Customize dialog box. For more details,
see the next section Setting the view controls.

p  To specify the view extent

e using the right mouse button, drag the mouse pointer across the
required extent

As you drag, a rectangular outline is drawn to indicate the new view
extent.

For example:

o0

When you release the mouse button, the view extent is updated.

The view extent of a print layout view cannot be larger than the
paper extent.

p  To pan the view extent

e using the left mouse button, drag the rectangle in the thumbnail to
move the position of the view extent

Or, click at the new centre of the view.
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Setting the view controls

You can show and hide the zoom bar, the individual viewing buttons,
and the scroll bars. By default, a subset of viewing buttons are visible
on each graphics window and on each Navigate window. You can also
choose a different set of buttons for 2D (including print layout) and 3D
views, and change the orientation of the view controls.

> To set the view controls
1 On the Window menu, click Profile, Customize.
2 On the Customize dialog box, click the View Controls tab.

3 Switch the zoom control options on and off by selecting the check
boxes.

4 To set the orientation of the controls, select Horizontal or Vertical.

5 Click OK.

Working with multiple views

Each window definition has a default view. This is created
automatically whenever a new window definition is created. You can
create additional new views, rename a saved view, and change the
default view. You can also save and recall views.

Creating new views

You can view different parts of the same window definition at the same
time. For example, you may want to create a new view from a view
which has a rotated axes. Or, you may want to have two views zoomed
into different parts of a window—one shown in 2D and the other shown
in 3D. You do this by creating a new view of the window.

When you create a new view, it is not a new window definition but
simply another view onto the active window. Any changes you make to
the graphics in one view are reflected in any other views.

> To create a saved view
1 Open the window definition in which to create a new saved view.
2 Set up the view extent that you want to save.

3 On the View menu, click Save View As.
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4 1In the View Name dialog box, specify the name for the view and
click OK

The view is added to the list of views, beneath the appropriate
window definition on the Document Organizer.

Note that you can also use the View Parameters dialog box to create
new saved views.

Showing saved views

To show a saved view

1 In the Document Organizer, click the plus sign to the left of the
window definition whose views you want to list.

2 Double-click the name of the view to show.

Changing the default view

To change the default view of a window definition

1 Inthe Document Organizer, expand the window definition whose
views you want to modify.

2 Right-click over the name of the view to set as the default view, and
select Set as Default.

The name of the view is shown in bold, to indicate that it is now the
default view.

Renaming saved views

To rename a saved view

1 Inthe Document Organizer, expand the window definition whose
views you want to modify.

2 Select the view you want to rename and press F2.

3 Enter the new name and press Enter.

Saving and recalling views

When you open an existing document, by default MicroGDS displays a
default 2D view of the principal window based on your current printer
settings. For example, if your printer is set to A4 portrait, the view of
the window is displayed in portrait view. Note that the size of the view
is slightly smaller than the paper size to allow for the margins.



Chapter 2: Exploring MicroGDS 55

If you are working on a specific part of a drawing that contains many
graphics, you may find it useful to save the view so that you can quickly
return to it later. Then, when you next open the window definition for
which you have a view saved, MicroGDS displays the saved view
instead of the default view. You can also recall the saved view at any
time.

Note that saving a document does not save the current view; you must
explicitly save the view you require.

Saving views can also be useful if you embed a MicroGDS document in
another application such as Word. You can save the view at the same
extent as the embedded document. Then, when you double-click the
embedded document, it is opened in MicroGDS at the same extent as it
appears in the application. For details about embedding and linking
data, see Chapter 15, Working with different file formats.

> To save the current view
e on the View menu, click Save viewname

Once you have saved a view, you can restore it later. You might want to
do this, for example, if you change the extent of the view.

| 2 To restore a saved view

e on the View menu, click Restore viewname

Exiting MicroGDS
p  To exit MicroGDS

1 On the File menu, click Exit.
If you have made changes to your preferences, you are prompted to
save your personal settings.

2 Click Yes or No to save or abandon the changes, as required.

If you have any unsaved changes to your documents, MicroGDS
prompts you to save them before exiting.
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Working with primitives and
objects

Primitives and objects

All the graphics you see in a drawing consist of primitives and objects.
A primitive is a basic graphic item, such as a line or a block of text. An
object is a collection of graphics, which can be primitives or objects.

Primitives
A primitive is a graphical element drawn using a single command.
Primitives are the building blocks of a drawing. There are several types
of primitive:
e line primitives
Line primitives include multi-segments lines, arcs, circles,
rectangles and so on. Details on line primitives are given in Line
primitives described next.
e text primitives
Text primitives can be created in MicroGDS or can be imported text.
Details on text primitives are given in Chapter 8, Working with text.
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e OLE photo primitives
OLE primitives (Object Linking and Embedding) include Adobe
Acrobat and Microsoft Office documents and graphic images saved
as bitmaps. Details on OLE primitives are given in Chapter 15,
Working with different file formats.

e window photo primitives
A window photo primitive is a snapshot of the graphics in one
window that is displayed in another window. Details on photo
primitives are given on page 59.

e raster primitives
Raster primitives are images inserted into a drawing. Details on
raster primitives are given in Chapter 15, Working with different file
formats.

e clump primitives
Clump primitives are made of a material, and can also have a
different material allocated to each face. Details on clump primitives
are given in Chapter 9, Working in 3D.

Primitives are grouped together into objects; one primitive can be part
of only one object.

Line primitives

Line primitives are made up of vertices and segments:

e avertex is a point where two line segments join (for example, a
corner), or the point at the start and the end of a line

e asegment is a line between two vertices; it can be straight or curved

A number of MicroGDS commands work on paths. A path is a distance

along a line primitive between any two selected points (these do not

need to be vertex points). For example, you can delete a path or change
the linestyle of a path.
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For example:

path

segment

vertices / =

All line primitives have at least two vertices, one at the start and one at
the end. A line primitive that consists of a single segment has two
vertices, and a line primitive that consists of two segments has three
vertices. The start and end vertices of a closed primitive are at the same
position. A rectangle, for example, has five vertices, one on each corner,
and an end vertex at the same position as the start vertex.

When you draw a line primitive, MicroGDS adds vertices between
segments on the line. You can also add a new vertex to an existing line.
For example, the following rectangle (a closed-line primitive) has five
vertices. By adding another vertex, you can change the shape of the
graphic as shown in the example below:

new vertex

For details about adding, moving, and deleting vertices, refer to Help.

Window photo primitives

A window photo primitive is a snapshot of the graphics in one window
definition (the source window), that is displayed in another window
definition (the destination window). The photo can reference a window
in the same document or in a different document.
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Window photo primitives are useful for composing plot compositions.
For example, if window definition A contains a frame, and window
definition B a building plan, you can construct photos of them both and
combine them in window definition C.

Window A Window B Window C

£l

Typically, you would use a print layout view for plot compositions. In a
print layout view, the size of the view corresponds to the size of chosen
paper. For details about print layout views, see Chapter 2, Exploring
MicroGDS.

Note that the contents of a window photo primitive are not shown in 3D
views.

When you insert a photo into a window definition, the location of the
original window from which it was taken is saved with it. Whenever the
original window definition is updated, MicroGDS updates the contents
of the photo. If the source window and target windows are in different
documents, you can set up a reference alias to point to the source
document’s location. Then, if the source document is moved to a
different location, you need only change the path of the alias. For
details about setting up aliases, see Chapter 2, Exploring MicroGDS.

If you open a document in which the source of a referenced photo
cannot be found, MicroGDS reports the error condition to the Problems
dialog box.

To re-establish the link, you must correct the name and location of the
document and/or window that contains the original graphics:
o if the location of the source file is aliased, you can edit the alias path

You can edit the alias path using the Problems dialog box or the
Aliases command on the File menu.

Note that you can only edit the path of an alias in a single-user
document. Reference aliases in a multi-user project are set up in the
project database. For details, see Chapter 16, Multi-user projects.
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o if the location of the file is not aliased, or you do not want to change
the alias path, you can edit the photo path

You can edit the photo path using the Problems dialog box, the
Properties window, or the Photo, Edit Path command on the Alter
menu.

Note that you can use the Many Paths command on the Edit menu to
update the paths of multiple missing linked graphics.

You can move, scale, and rotate a window photo primitive by
manipulating the photo border. You can also also assign a linestyle to
the photo border or change its shape using many of the primitive editing
commands. For example, you can move vertices to make an oblique
shape or use the Fillet command to round-off the photo corners. You
can even swap the border with that of another line primitive.

You can also snap onto the individual graphics within a photo primitive.
For example, you might want to align a specific item in the photo with
an existing graphic in the window, or measure the distance between two
points in a photo.

If you want to edit any of the graphics in a window photo primitive,
without changing the original graphics, you can burn in the photo. This
converts the photo primitive to graphics in your document which you
can then edit locally.

Full details on working with window photos are given in Help.

Objects

An object is a collection of graphics. In MicroGDS, there are several
types of object:

e aplain object stores a collection of primitives

e an instance object does not contain graphics of its own, but has a
link to the original object in the document in which it is stored

e an intelligent object is created from graphics and attribute data or
just attribute data

An attribute is non-graphical information that can be attached to
graphics, such as height, colour, or cost.

e an assembly object contains only other objects; assembly objects can
contain plain objects, instance objects, intelligent objects, and other
assembly objects
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Each object has a name and can be treated as a single item that you can
edit, move, and so on. The commands that you can use, however,
depend on the type of object with which you are working.

When you construct primitives, they are automatically included in the
current plain object. By default, the current object is called no:name
until you create a new object. The name of the current object is shown
on the status toolbar.

You can change the default object name to something more meaningful
using your preferences, if you prefer. For details, see Chapter 17,
Customizing MicroGDS.

Selecting primitives and objects

Many MicroGDS commands require you to select graphics. For
example, if you want to move, copy, or alter an item, you must first
select it.

Before you select graphics, you must choose to select them as
primitives or as objects. If you select the graphics as primitives, you can
edit the individual primitives or a number of primitives from different
objects. If you select the graphics as objects, you edit all the primitives
within the whole object.

When you select a primitive or an object, the graphics change colour.
You can choose the colour in which to show selected graphics in your
preferences.

You can use the Set Edit command to define a filter to restrict editing to
particular primitives. For details, see Restricting editing on page 91.

To set primitive selection mode
e press F9, or on the Edit menu, click Select Primitives

To set object selection mode
e press F10, or on the Edit menu, click Select Objects

The way in which you select items depends on the ‘Explorer-like
selection and drag-and-drop’ option in your preferences. If this option is
selected, then the Windows behaviour is used; if the option is cleared,
then the default MicroGDS behaviour is used.

The following assumes that you are using the default MicroGDS
behaviour; if you are using the Explorer-like behaviour, refer to Help
for the equivalent details.
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> To select graphics
1 Click the item using the appropriate snapcode:

e if you are selecting primitives, only the primitive you click is
selected

e if you are selecting objects, the primitive you click and all other
primitives within the same object are selected

If you select an assembly object, all objects within the assembly
are selected.

In MicroGDS, you use snapcodes to snap exactly to points on
existing graphics. As you move the pointer around, you see
snapcodes displayed beneath the mouse pointer. For more details,
see Chapter 5, Entering positions.

If multiple items lie within the snap radius of the mouse pointer, you
can cycle through the graphics by pressing Spacebar. When the item
you want to select is highlighted, click the mouse button or type the

displayed snapcode.

Note that you can change the key that is assigned to cycle through,
using your preferences.

2 To add to the selection, press Shift and click each item.
To deselect an item, press Shift and click the item.

You can select and deselect all graphics in a window. If you are
selecting primitives, all primitives will be selected, and if you are
selecting objects, all objects will be selected.

> To select all graphics
e press F7, or on the Edit menu, click Select All

> To deselect all graphics
e press F8, or on the Edit menu, click Deselect All
When in selection mode, you can select adjacent items by enclosing
them in a box.

> To define the box

e click at the start of the box and then click at the opposite corner of
the box

You can deselect items and add to the selection by pressing Shift when
you define the box.
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To include all graphics that cross the boundary of the enclosing
rectangle, press Tab before giving the second position. When you press
Tab, the bounding rectangle changes to a dotted line. For example:

L i

Dok

enclosing box, Tab one primitive selected
not pressed

[ N

enclosing box, Tab two primitives selected
not pressed

Another way to select graphics is to use the Fence command on the Edit
menu to draw a fence. The graphics that are selected by the fence
depend upon the selection mode, that is, whether you are selecting
primitives or objects.

For more details on the select commands, refer to Help.

Highlighting primitives and objects

By default, as you move the mouse over a drawing, graphics are
automatically highlighted. This provides constant feedback on your
drawing, and gives a clear indication of complex structures. Graphics
are highlighted only if the command you are using is able to operate on
them.

In select primitive mode, the primitive beneath the mouse pointer is
highlighted. In select object mode, the primitives within the object and
the extent of the object beneath the pointer are highlighted. The object
hook point is also shown (as a butterfly shape) if it is within the view
extent. The hook point can be thought of as the ‘handle’ of the object,
and is described further on page 68.
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Select primitive mode Select object mode

If you continue to hover over a graphic, an InfoTip is shown giving
details about the highlighted primitive or object:

Linestyle: 54

Phase: 1

Colour: Custom

Arear 143199mm?

Ohject: Furniture:chair ibwo

=
F
“| [obiect: Furniture:chairbwo
Phase: 1

Select primitive mode Select object mode

The details in the InfoTip depend on the type of graphic that is
highlighted. For details about the type of information displayed, refer to
Help.

When a command is in progress, the graphic feedback reflects what is
required and highlights only items on which the command can operate.
For example, if you are moving a line segment, only the line segment
currently beneath the mouse pointer is highlighted:

I ]
When MicroGDS highlights an item, you can press Spacebar to move
through any other items that are within the snap radius. For example, if
you want to alter a line primitive but the primitive is obscured by other

primitives, use Spacebar to cycle through the graphics until the
primitive you want to alter is highlighted.

You can choose the level of hover highlighting you require using the
Hover Highlight button on the information bar, at the bottom-right of
the MicroGDS window:

" z=0 sereon PEETTRET WM

Hover Highlight button
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You can choose from:

o highlight graphics and show InfoTips

o highlight graphics only

e do not highlight graphics or show InfoTips
e show InfoTips only

Note that you can customize InfoTips using your Snapping preferences.

When the mouse pointer is over an object or primitive in selection
mode, to which a URL attribute has been assigned a link icon is shown
to the left of the mouse pointer:

&2, Foint

®

This indicates that a hyperlink exists which you can open. For details
about assigning attributes, see Chapter 14, Working with attributes and
schemas.

Viewing properties for graphics
You can use the Properties window to see details about selected
graphics. The information available depends on whether you select
graphics as primitives or as objects. For example, in primitive mode, the
details include the number of vertices, the colour, and the linestyle
assigned to the primitive.

p  To see details about a graphic

1 In primitive or object mode, select the graphic whose details you
want to view.

2 If the Properties window is not currently displayed, press Ctrl+Q, or
on the Window menu, click Properties.

The first time you open the Properties window, the ‘Details display’ is
shown. This gives details about the document, layer, object, and
primitive (if in primitive mode) for the selection.
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For example:

3]
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Properties

El Document
Drocument
Document label

= Layer

Mame Foof Structure
Label Roof detail
Status Modified
Phazes 9

= Plain object

Mame Calurmn

Scale 1:1

Axes angle 0

Hook. point 1011 /17 497 mmB00mm
Lightstyle MOME
Objectstyle shutomatics
= Cloged line

Colour By Phase
Lirestyle DEFAULT
Yertices &5

Area AE03mn?
Length 2FFTmm

E:\Gate.. \The Gate House MAN
Drraft drawings for CUST:1234

You can use the buttons at the top of the window to view details for the
selection in different ways. If you save your settings when you exit
MicroGDS, MicroGDS remembers the last view selected in the
Properties window.

For more details about viewing the properties of graphics, see
Chapter 13, Getting information.

Drawing primitives

As soon as you start to draw a primitive, it is included in the current
object and placed on the current layer.

To draw a primitive, you select the type of primitive you want to create
using the toolbars or menu commands, and then draw the graphic. For
example, to draw a line, you select the Construct Line command and
then specify the start and end points of the line.

Line primitives are drawn using the current linestyle. Linestyles define
the appearance of a line and are made up of one or more strokes. A
stroke can define the line thickness, the fill, or the pattern in which lines
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are drawn. The name of the current linestyle is shown in the Line box
on the status toolbar. For more details, see Chapter 7, Working with
linestyles.

Text primitives are drawn using the current charstyle. Charstyles define
the font, size, and style in which text is drawn. A charstyle also defines
any spacing around the text. The name of the current charstyle is shown
in the Char box on the status toolbar. For more details, see Chapter 8,
Working with text.

The commands for drawing graphics are on the Construct menu. Full
details on constructing graphics are given in Help.

Creating objects

To group primitives into a new object, you usually create the object
before you draw the primitives. However, you can also move existing
graphics into a new object.

When you create a new object, you are prompted for the object’s name
and its ook point. The hook point can be thought of as the ‘handle’ of
the object and can be used, for example, to pick up and place the object
at an exact point in the window. It is also used in other commands that

work on objects.

Note that new objects are created on the current layer, therefore you
should first set the layer on which you want to create the object. For
details, see Chapter 4, Using layers and phases.

To create an object

1 If you want to move existing graphics into a new object, select the
graphics.

2 Do one of the following:
e to create a new empty object, on the Object menu, click New

e to create a new object from the selected graphics, on the Object
menu, click New from Selection
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The New Object dialog box is displayed. For example:

New Object X

Mame

Cross-hatching & Poche
Cimensions

Elevation

Elevations

General Motes & Specifications
Identification Tags

Key Motes

Legends & Schedules

Morplot Info. & Constr, Lines
Motes, Call-outs & Key Motes
Plokting Targets & Windows
Redine

Symbols, Bubbles & Targets
Title Black Sheet Mame & MNurmber

[ Caricel ] [ Help ]

3 In the Name box, type the name of the object.
MicroGDS provides the current object name as the default.

The name must conform to the standard naming rules, described in
the next section.

If you are using a name assistant, you can select the object name
from the Object list. If you are not using the name assistant, the list
is empty.

You are now required to enter a position for the object’s hook point.

4 To set the hook point at the origin of the current axes, press Esc.
Otherwise, click a point in the window.

The new object is created on the current layer.

Note that you can change the location of the hook point using the Hook
command on the Object menu. For details, refer to Help.

You can also check that you have positioned the hook point correctly,
by hovering over the object (in select object mode), where you will see
the hook point. Alternatively, you can use the Axes, Reset command on
the Set menu. For details about the axes and objects, see Chapter 6,
Using the axes.
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Object scale and axes

When you create an object, the current scale and current axes rotation
are saved with it. In this way, an object has its own internal scale and its
own axes, whose origin is located at the object’s hook point.

Note that you can move an object and change its axes rotation using the
Object Reposition command. For details, refer to Help.

Take care when placing objects that have a different scale from that of
the set axes scale. For example, if you copy an object with a scale of
1:50 from a window, and paste it into a window where the current scale
is 1:100, it would appear at half the size.

Note that you can change the scale of an object at any time using the
Scale command on the Object menu. For details about axes and scales,
see Chapter 6, Using the axes.

Rules for naming objects

You should structure object names in a meaningful way so that you can
use filters. Filters enable you to manipulate graphics in different ways.
For example, they enable you to restrict editing to only those objects
whose names contain certain characters. For more details, see Filtering
object names on page 72.

Rules for naming objects are:

e an object name can contain up to 256 characters and can include
spaces and certain punctuation marks

For a list of all valid characters that you can use in an object name,
refer to Help.

e object names can be separated into up to six facets (sections)
For example, the object name no:name has two facets: ‘no’ is one
facet, and ‘name’ is the other.
If you are creating an intelligent object using the predefined BIM
components provided with MicroGDS, the first facet of the object

name must conform to one of the predefined names. For more
details, see Using BIM intelligent objects on page 81.
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e cach facet is separated by a colon (:)

You can use semicolons instead of colons. For example, if it is
easier, you can type internal;wall;plaster rather than
internal:wall:plaster. MicroGDS automatically converts the
semi-colons to colons.

Invalid characters are converted to colons.

e object names with only one facet can have between one and 255
characters, and must end with a colon

e object names are case sensitive, so ‘rad:1000” and ‘RAD:1000’ are
two different objects

When you name objects, try to give them clear, descriptive names. For
example, the following object is a gas cooker:

The name for this object might be:
I:Kitchen:Cooker:Gas:Free

where:

I indicates that the object is part of the interior detail
Kitchen indicates that the object is located in the kitchen
Cooker indicates that the object is a cooker

Gas indicates that the cooker is gas sourced

Free indicates that the cooker is freestanding

If your system administrator has set up special naming standards for
layers and objects for your site and these are enforced, when you create
an object or a layer, MicroGDS displays a dialog box showing a
tree-like structure of naming conventions. This enables you to create
names by selecting facets from the list. For more details about name
assistants, see Chapter 2, Exploring MicroGDS.

Note that the object naming conventions are not displayed unless the
current layer name conforms to the layer naming conventions.
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You may want to rename existing objects from time to time. For
example, you may want to change the name of an object that you have
copied from another document. MicroGDS provides commands for
renaming a single object or a number of objects. These are described in
MicroGDS Help.

Filtering object names

Using a comprehensive naming structure for objects makes it easy to set
filters (using wildcards) when you set up an inclusion list. You use an
inclusion list when you want to define the graphics which:

e can or cannot be edited in a document, using the Set Edit command

For details about using the Set Edit command, see Restricting
editing on page 91.

e are to be displayed in a phase, using an inclusion list in the Window
Editor

For details about setting up an inclusion list in the Window Editor,
see Chapter 4, Using layers and phases.

You use the asterisk as the wildcard character to match facets in object
names, as follows:

* means match this single facet

wE means match the remainder of the object name

You can also use the question-mark (?) to match any single character of
an object name.

For example:

kerb:paving:dropped
kerb: kerb:*:dropped
kerb:dropped

Object name Wildcard Match
kerb: kerb:** v
kerb:paving v
kerb:paving:dropped v
external:kerb X
kerb: kerb:* v
kerb:paving v

X

X

X
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Object name Wildcard Match
kerb:paving:dropped v
kerb: **:paving
kerb:paving

kerb:paving:dropped

kerb: kerb:?
kerb:A

kerb:B

kerb:paving

X NS X X (X

You can also reverse the sense of the action using an Exclude rule. For
example:

Exclude kerb:**
will match everything except objects with kerb as their first facet.

You can also use advanced filters to specify which primitives and
objects can or cannot be edited, and will or will not be displayed, using
attributes. For details, see Chapter 14, Working with attributes and
schemas.

Inserting objects

You can insert objects from one single-user document into another
document. This enables you to build up libraries of objects that you can
re-use at any time.

You can also link objects from other single-user documents to your
current document. A linked object is known as an instance object. An
instance object does not contain graphics of its own in the current
document, instead, it has a link to the original object in the document in
which it is stored. You can create libraries of standard objects, and these
objects can then be linked to a number of different documents as
instance objects, to ensure that the objects in the documents are all the
same.

Note that you can insert or link only to top-level objects, you cannot
insert an object that is part of an assembly object.
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If you are inserting or linking several objects in a document, you can set
up aliases to map the physical location of the files containing the
objects to an arbitrary name. If the files are later moved to a different
location, you need only change the pathname in the aliases table.

Note that if you want to use aliases, you should define the aliases before
you insert or link the objects to the document. For details about setting
up aliases, see Chapter 2, Exploring MicroGDS.

When you insert an object or an instance object, styles may be copied to
the target document if they are needed. If style names of the same type
already exist in the document, those are used instead.

Inserting objects using the Document Organizer

When you set up aliases for object libraries, the library aliases are
shown on the Library tab in the Document Organizer. This enables you
to insert library objects directly from the aliased locations.

You can also insert objects from aliased and non-aliased libraries, using
the Object menu. For details, see MicroGDS Help.

p  Toinsert an object from an aliased library

1 If the Document Organizer is not displayed, press F4, or on the
Window menu, click Document Organizer.

2 Ensure that the appropriate document is the current document in the
Document Organizer.

3 Click the Library Files tab:
Library Files tab

Ole|[+&=
A list of each aliased object library file is displayed.
If you have not defined any aliases for object libraries, you can
either define the alias before you continue, or you can insert an
object using the Object menu.

4  Double-click the library MAN file that contains the object to insert.
The layers in the library are listed.
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5 Double-click the layer that contains the object to insert.
The objects in the library are listed.

You can preview an object by selecting its name. If the preview is

not currently visible, click 4

6 To insert the selected object into the active window:
e to copy the object directly into the window, on the shortcut
menu, click Insert Object

e to create an instance object, on the shortcut menu, click Insert
Instance

MicroGDS prompts you to specify the position for the library
object, or to press Enter if you want to change the object size or
orientation.

For details about transforming objects, refer to Help.
For details about specifying positions, see Chapter 5, Entering
positions.

Note that you can also insert an object by dragging it into the window
definition. You can then move it to the required position and, if
necessary, use the Transform commands on the Alter menu to rotate,
enlarge or reduce, mirror, and stretch the graphics.

You can also use the shortcut menu in the Document Organizer on a
library file or a layer to open the Object Insert dialog box, with the
selected item as a filter. For more details about inserting objects, refer to
Help.

Working with instance objects

When you insert an instance object into a document, you can view the
physical file location of the object in the Properties window.

p  Todisplay the file location of an instance object
1 Press Ctrl+Q, or on the Window menu, click Properties.
2 Select the instance object to query.

The Properties window displays details about the library object,
including the name and location of the file in which the object is stored
and the name of the object.
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For example:
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You can see more details about the instance object in an InfoTip, by
hovering over the Library object property.

If you selected the instance object in primitive mode, the Properties
window also shows the names of any styles, for example, the linestyle
or charstyle assigned to the primitive you clicked on in the instance
object. Note that the original styles may be copied to the target
document if they did not already exist.

Instance objects are read-only. You can change the size and the scale,
and move, copy, paste, and delete an instance object, but you cannot
change any of its individual primitives or add new primitives to the
object. Note that you must be in select object mode (F10) to manipulate
an instance object. If you delete an instance object, only the instance in
the current document is deleted.

If you open a document that contains an instance object that cannot be
found, for example, because the file has been moved to a different
location, MicroGDS displays the following symbol in its place:

I7
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To re-establish the link, you must correct the name and/or location of
the MAN file that contains the original object:

o if the location of the file is aliased, you can edit the alias path

You can edit the alias path using the Problems dialog box or the
Aliases command on the File menu.
Note that you can only edit the path of an alias in a single-user
document. Library aliases in a multi-user project are set up in the
project database. For details, see Chapter 16, Multi-user projects.

o if the location of the file is not aliased, or you do not want to change
the alias path, you can edit the instance object path
You can edit the instance object path using the Problems dialog box,
the Properties window, or the Instance, Edit Path command on the
Object menu.

Note that you can use the Many Paths command on the Edit menu to
update the paths of multiple missing instance objects.

For more details on these commands, refer to Help.

If you want to make changes to the original object, for example, to alter
a primitive, you can open the file that contains the original object.

To edit the original object
1 On the Object menu, click Instance, Open.
2 Click the instance object whose MAN file you want to open.

Alternatively, double-click the instance object to open the MAN file to
which the object is linked.

The window definition of the document containing the original object
opens in a new window. The extent of the window is set to the extent of
the original object.

If changes are made to the original object, all instances of that object
are also changed. However, if the original object is changed and saved
while you are working with a document that references it, you will need
to update the document to see the changes.

To update instance objects
e on the Object menu, click Instance, Update

If you want to edit an instance object, without changing the original
object, you can burn in the object. You can then modify the object, or
any of its primitives.
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> To burn in an instance object
1 Press F10, or on the Edit menu, click Select Objects.
2 Select the instance object to burn in.
3 On the Object menu, click Instance, Burn In.

Any changes made to the original object will no longer be reflected in
the converted object.

Using assembly objects

An assembly object is a collection of objects that can be used and
manipulated as a group. You can insert, scale, and rotate an assembly
object in a drawing. You can open an assembly object to access its
individual objects, modify them, and then close the assembly to work
with it once again as a group.

For example, suppose you are designing a dining room layout, you
might arrange table and chair objects into an assembly, which you could
then move about as a group.

Assembly objects can contain plain objects, instance objects, intelligent
objects, and other assembly objects. An assembly object can also be
instanced.

You can create libraries of standard assembly objects, which can then be
referenced by a number of different documents as instance assembly
objects. This will ensure that the graphics in the documents are all the
same. If the source assembly is edited, the instance assembly objects
can all be updated to make the changes visible.

Note that when you insert an object from a library, you can insert only
top-level objects, you cannot insert an object that is part of an assembly
object. As a consequence, if you insert an object as an instance object
and you later move the object into an assembly, the link will be broken.

Each assembly object has a name, hook point, scale, and rotation
associated with it. An assembly object, and all objects it contains, exist
on a single layer.
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Creating assembly objects

To group objects into a new assembly object, you can either:

e create the assembly object and then create the objects it will store
e or, move existing objects into a new assembly object

The procedure for creating new assembly objects is similar to creating

new objects, described on page 68. This procedure is summarised
below; for full details refer to Help.

To create an assembly object

1 If you want to move existing graphics into a new object, select the
graphics.

2 Do one of the following:

e to create a new empty assembly object, on the Object menu,
click Assembly, New

e to create a new assembly object from the selected objects, on the
Object menu, click Assembly, New from Selection

The New Assembly dialog box is displayed. This dialog box is the
same as the New Object box, except for its title.

3 Inthe Name box, type the name of the assembly object.

The name must conform to the standard naming rules. For details,
see Rules for naming objects on page 70.

If you are using a name assistant, you can select the assembly object
name from the Object list. If you are not using the name assistant,
the list is empty.

You are now required to enter a position for the assembly object’s
hook point.

4 To set the hook point at the origin of the current axes, press Esc.
Otherwise, click a point in the window.

The new assembly object is created on the current layer and is
opened for editing.

If the assembly object is empty, its extents are initially set to the
view extent; any visible graphics outside the extent are shown faded
to indicate that they cannot currently be edited. If the assembly
object contains graphics, its extent is set to the boundaries of the
objects it contains.



80

Using MicroGDS 2010

For example:

gy
i

You can now create new objects which will be stored in the
assembly object. If you immediately begin drawing without creating
a new object, the primitives are automatically included in a new
plain object.

When you have finished working with an assembly object, you can
close it.

To close an assembly object
e double-click outside the boundary of the assembly object
e or, on the Object menu, click Assembly, Close

To open an assembly object
e in Select Object mode (F10), double-click the assembly object
e or, on the Object menu, click Assembly, Open

Dissolving an assembly object

Sometimes, you might want to move the contents of an assembly object
up one level to its parent assembly or layer. You can do this easily, by
dissolving the assembly.

To dissolve an assembly object

1 Press F10, or on the Edit menu, click Select Objects.

2 Select the assembly object that you want to dissolve.

3 On the Object menu, click Assembly, Dissolve.

Any selected assemblies are moved to their parent assembly, or to
the layer if no parent assembly exists. The empty assembly objects
are deleted.
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Using BIM intelligent objects

In MicroGDS, a BIM (Building Information Modelling) intelligent
object is modelled parametrically from MicroGDS data. This is
typically achieved from line primitives and attribute data, or just
attribute data. The attributes are referenced in Object-level schemas.
The schema defines which objects a set of attributes are intended to be
used with. Each schema defines an objectstyle which describes the
properties of an intelligent object.

For example, a wall can be modelled as plan linework which defines its
centreline, together with a height, and a style which defines the layers
of the wall (for example, brick, cavity, and plaster). Individual
properties of the wall style, such as the thickness of the layers, can then
be overridden on an individual basis using the Properties window.

MicroGDS provides a set of predefined BIM (Building Information
Modelling) components, such as walls, doors, and windows. New
components will become available. It is recommended that you
periodically check the Informatix website for updates.

The basic procedure for creating an intelligent drawing is:

1 Set the style search path of your document to reference the
components that make the intelligent objects and drawings
available.

2 Set the drawing style to one of the BIM drawing styles.

3 Create a new object and name it using one of the predefined BIM
object names.

4 Set the objectstyle to the name of the schema that defines the
behaviour of the object.

5 For walls and slabs, draw ordinary line graphics to represent the
reference line of the wall or slab.

6 Modify the attribute values to tailor the objects to your drawing.
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You can customize the BIM environment in various ways, such as by
creating your own objectstyles or changing the mnemonic definitions
that describe the behaviour of a particular intelligent object. You can
also define your own BIM components. For more details, see
Chapter 17, Customizing MicroGDS.

Setting the document intelligence

To enable the construction and drawing of BIM intelligent objects, you
must tell the MicroGDS document that you are going to be using
intelligent objects in your drawing. You can immediately tell if a
document can use intelligent objects by looking at the drawing style. If
the only entry shows <<Automatic>> then the document is not enabled
for intelligent objects. To enable the document, you add an entry to the
Style Search Path that points to the location of the BIM application
data:

<*MICROGDS_COMMON_APPDATA>BIM

This is the default location set up during the MicroGDS installation.
Note that by using this system format, you will not need to update the
path for each of your MicroGDS documents if the installation procedure
changes the location of the data in a future release; it will be done
automatically.

If you define your own intelligent objects, you need to reference the
relevant path to your own files on the style search path. For details, see
Chapter 17, Customizing MicroGDS.

Now several new entries appear on the drawing styles list. These
determine the the level of detail to show for the graphics in the current
view.

Setting the drawing style

When you work with a document that contains intelligent objects, you
choose a drawing style. Each drawing style is defined by a
Window-level schema. The schema contains attributes and a reference
to a predefined .NET assembly that determine the appearance of the
view. (The .NET assembly is responsible for the display of MicroGDS
BIM objects in the current view, in the selected drawing style.)



Chapter 3: Working with primitives and objects 83

p  To set the drawing style

1 On the viewing buttons or on the View toolbar, click ="

2 Select the drawing style to set from the list.
MicroGDS provides the following drawing styles:

e Ceiling: shows a mirrored orthographic, bottom view of the solid
model of the building. Similar to ‘Detail’, this drawing type
using a clip plane and section styles to generate the required
drawing.

Note that clip planes and section styles are described in
Chapter 9, Working in 3D.

e Detail: shows an orthographic, top view of the solid model of the
building; this drawing type uses a clip plane and section styles to
generate the required drawing.

e Elevation: shows a horizontal, orthographic view of the solid
model of the building.

e GA (General Arrangement): shows a 2D view which draws the
building using linestyle and masking techniques. For large
buildings, you will probably want to use this drawing style for
most interaction as it is the fastest to draw.

e Perspective: shows a general purpose 3D view of the solid model
of the building.

In the 3D viewing styles, the reference line is not normally visible,
but becomes visible when the object (and no other object) is
selected.

In documents that are not enabled for intelligent objects, the
drawing style is set to «Automatic»

Note that additional drawing styles may be created by application
developers.

In addition to setting the appropriate type of view, the drawing style
also selects a suitable representation of certain building components.
For example, doors are shown open in a Detail view but closed in an
Elevation view.

Tip: To view the graphics in an intelligent drawing in different
drawing styles, create additional saved views for any other drawing
types and switch between them. For details about saving views, see
Chapter 2, Exploring MicroGDS.
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Creating a BIM intelligent object

The process for creating a MicroGDS BIM intelligent object is identical
to that for creating a plain MicroGDS object (described on page 68).
However, the first facet of the object name must be defined in the
intelligent object style that you want to use.

To use a style that is provided with MicroGDS, the first facet must be
one of the following:

For a wall object: IfcWallStandardCase
For a door object: IfcDoor

For a window object: IfcWindow

For a slab object: IfcSlab

The case and name must be identical to that shown.

Additional facets may be used to distinguish between different objects
of the same type. For example:

New Object

Mame | IFcDoor:ExternaliuPyC

It is this first facet that tells MicroGDS which properties will apply to
the object.

After you place the new object’s hook point, the Properties window is
populated with all the parameters for the object type.

You now define the objectstyle which will set the default attribute
values for the type of construction you choose.

Defining the objectstyle for a BIM intelligent object

Each objectstyle of a BIM intelligent object is defined by an
Object-level schema. The schemas contain attributes appropriate to the
type of intelligent object. A BIM wall object, for example, currently has
two objectstyles: Block and Brick-Cavity-Block. The two wall
objectstyles each have a subset of the wall properties. These schemas
are automatically associated with an object which has a corresponding
object name. The association is then made using an Objectstyle property
in the Properties window.
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For example:

Properties

Iiew aliStandardCase External
Scale 8
Axes angle 0
Hook poirt 0.0rmen/0.Oenen /0L Orrn
Lightsiyle NONE Lightstyle NONE
¥ Height «Hones ¥ Height «Hones
R Reference line Inestyle | «Nones R Reference line nestyle | Brick-Cavity Block
A Refetence line offset aNones A Refetence line offset A27.500
R Layer 1 thickness «Hores W Layes 1 thickness 102500
¥ Layer 1 matenal «Mones ¥ Layer 1 matenal Brick
W Layer 1 secton inestyle | <Nones A Layer 1 sechon nestyle | SecbonBrick
FLayer 1 is ventilated «Hones W Laper 1is ventilsted FALSE
¥ Layer 2 thickness «Hones ¥ Layer 2 thickness 50000
W Layer 2 matenal «Hones W Layer 2 matenal Cavily
Default attributes and initial values for all Default values for Brick-Cavity-Block
IfcWallStandardCase objects obijectstyles
To set the Objectstyle

o click the the Objectstyle value, then click ¥ and select from the list

Drawing the reference line for an intelligent object

For MicroGDS BIM wall and slab objects, you need to draw the
graphics to define the reference line of the object.

o for a slab object, draw the outline of the slab

This must be a closed-line polygon, for example, to represent a floor
slab.

o for a wall object, draw the centreline of the wall

This could be a single line for a garden wall or a closed-line polygon
for a building.

Note that when MicroGDS draws an intelligent object, curved surfaces
are facetted when they are extruded. You specify the number of facets to
use. The higher the number, the smoother the surface. For more details,
see Chapter 9, Working in 3D.

Tip: You can use the Z=0 button to force graphics to be drawn on the
XY plane, for example, if you are creating a floor slab. For details about
using the Z=0 facility, refer to Help.
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When you have drawn the primitive, the graphics are drawn in the
selected drawing style. For example:

wall in Perspective drawing style wall section in Detail drawing style

You do not draw any graphics for window and door objects. These are
drawn intelligently according the attribute data values. However, when
you create a window or door, set the object hook point at the position on
the drawing at which to place the bottom left corner of the window or
door. Then, to associate the window or door with an existing intelligent
wall object, move the window onto the wall.

wall object and floating door wall object and associated door

The depth of the window or door automatically adjusts to match the
wall thickness and a hole is made in the wall to accommodate it.

Note that snapping onto the wall when you initially create the window
or door object will not establish the connection between the two objects.
This is because the window or door only becomes intelligent when its
objectstyle has been set.

Modifying the properties of a BIM intelligent object

When you add a BIM intelligent object to a drawing, its attributes and
values (defined by its objectstyle) are added to the Properties window.
You can modify the default values to suit your drawing’s environment.
For example, you can change the operation type of a door, that is,
whether it is a single or double swing door or whether it opens to the
left or right. You might also want to change the overall door width and
height and change the panel thicknesses. You do this by editing the
attribute values in the Properties window.
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Depending on the type of attribute, you can:

e type the new value in the box

o select a value from a list of predefined choices
e or edit the value in a dialog box

Any entry that you modify is shown in bold in the Properties window.

If you find that you are frequently using a particular set of attribute
values, you can set these up as a new objectstyle. For details, see see
Chapter 17, Customizing MicroGDS.

For full details about editing attribute values, see Chapter 14, Working
with attributes and schemas.

Note that you can use the standard editing commands to modify the
reference line of a BIM intelligent object. For example, you can use the
Move Line Segment command to extend a wall area.

Moving and copying graphics
You can move or copy selected graphics:
e from their current positions to new positions in the same document

o from one object to another within the same document or to another
document

e from one layer to another within the same document or to another
document

You can move and copy graphics as primitives or as objects. If you
want to move or copy objects from an assembly object or paste objects
into an assembly, you must first open it for editing. For details, see
page 80.

Note also that you can move and copy instance objects as a whole, but
you cannot move or copy individual items within the instance.

You can also move an object and change its axes rotation using the
Object Reposition command. For details, refer to Help.

The way in which you move and copy items depends on the
‘Explorer-like selection and drag-and-drop’ option in your preferences.
The following assumes that you are using the default MicroGDS
behaviour; if you are using the Explorer-like behaviour, refer to Help
for the equivalent details. (Note that if you are using Explorer-like



88

Using MicroGDS 2010

behaviour, a shortcut menu is available which provides Cut, Copy,
Paste, and Delete commands.)

The procedures given describe just some of the moving and copying
operations. For more details on these, and all other move and copy
operations, refer to Help.

Moving and copying primitives and objects

You can move or copy selected primitives or objects from one position
to another.

To move or copy primitives or objects

1 On the Edit menu, click Select Primitives or Select Objects, as
required.

2 Click the first graphic to move or copy.
3 Press Shift and click each subsequent graphic to move or copy.

4 Do one of the following:

o to move the selected graphics, press Shift+Ctrl and drag the
graphics outline to the new location

e to copy the selected graphics, press Ctrl and drag the graphics
outline to the new location

As soon as you have dragged the graphics away from their original
position, you can release the keys and mouse buttons.

5 To place the graphics at the new position, click the mouse button.

You can also use the Alter Move command and the Construct Repeat
command to move and copy selected graphics. For details, refer to
Help.

Moving and copying primitives between objects

You can move or copy primitives from one object to another. You can
also move or copy a primitive to an object that is on another layer or
even another document.

Below are just two methods you can use to move or copy graphics. For
full details, refer to Help.
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p  To move primitives from one object to another
1 Press F9, or on the Edit menu, click Select Primitives.
2 Select the primitive to move.
3 On the Object menu, click Get.
4

Select the object in which to move the primitive.

To retain the original primitives, press Ctrl when you click the
object to which to move the item.

p  To copy primitives into a new object
1 Press F9, or on the Edit menu, click Select Primitives.
2 Select the primitives to copy to the object.
3 Press Ctrl+C, or on the Edit menu, click Copy.
4

On the Object menu, click New, then create the new object.
For details, refer to Creating objects on page 68.

)}

Press Ctrl+V, or on the Edit menu, click Paste.
6 To test that all of the primitives are now one object:
a) Press F10, or on the Edit menu, click Select Objects.

b) Click one of the primitives in the new object.

When you snap onto one of the primitives, all of the primitives in
the object change colour, which means that they are all one object.

You can use the New from Selection command on the Object menu to
move primitives (or objects) into a new object.

Cutting and deleting graphics

You can cut and delete graphics from your current document. Cut
graphics are copied to the Clipboard. You can retrieve a cut graphic by
pasting from the Clipboard or by undoing the Cut command. Deleted
graphics are not copied to the Clipboard and can only be retrieved by
undoing the command.

You can cut and delete graphics as primitives or as objects. If you want
to cut or delete objects from an assembly object or paste objects into an
assembly, you must first open it for editing. For details, see page 80.

Note also that you can cut or delete an instance object as a whole, but
you cannot cut or delete any of its individual primitives.
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When you cut or copy graphics to the Clipboard, MicroGDS stores the
location of the graphics relative to the current axes’ origin, and this is
used when you paste a graphic back into a window. If you move the
axes before you paste graphics back into the window, the graphics are
pasted back at the position, scale, and rotation relative to the current
axes origin.

To cut selected graphics to the Clipboard
e press Ctrl+X, or on the Edit menu, click Cut

To paste graphics that have been cut or copied

e press Ctrl+V, or on the Edit menu, click Paste

To delete selected graphics

e press Delete, or on the Edit menu, click Delete
To retrieve deleted graphics
e press Ctrl+Z, or on the Edit menu, click Undo

Note that if you are using Explorer-like behaviour, a shortcut menu is
available which provides Cut, Copy, Paste, and Delete commands.

Replacing objects globally

Another way in which you might want to edit objects is to globally
replace all occurrences of one object in a window for another.

For example, you might have started a floor layout with a simple object
representing a door, which you later change to one showing more detail.

To replace all occurrences of one object with another one
1 Ensure that the replacement object’s hook point, and the hook point
of each object being replaced, are in the appropriate positions.

The replacement object will be placed by its hook point at the hook
point of each replaced object.

For details on moving an object’s hook point, refer to Help.
2 Press F10, or on the Edit menu, click Select Objects.

3 Select the replacement object with which you will replace the
existing objects.
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4 On the Set menu, click Axes, Reset, then click the replacement
object.

The axes origin is moved to the hook point of this object.

5 With the replacement object selected, on the Edit menu, click Copy
(or Cut) to copy the replacement object to the Clipboard.

6 Select the objects to be replaced.

If there are a lot of different objects in the window, use Set Edit to
limit editing to just the objects that are to be replaced, and use the
Select All command on the Edit menu. For details about using Set
Edit, see Restricting editing on page 91.

7 On the Object menu, click Replace.

All the selected objects in the window definition are replaced with the
object on the Clipboard.

You can also replace primitives within objects, and superimpose objects
and primitives. For details, refer to Help.

Altering graphics

MicroGDS provides many commands for altering graphics. For
example, you can move a vertex, delete or move a line segment, alter a
path, and so on. Most of the commands that you use to change the
appearance of graphics are on the Alter menu.

An instance object does not contain any graphics of its own in the
current document, therefore you cannot alter the appearance of any
primitives it contains. However, you can use the Transform commands
to rotate, enlarge, mirror, and stretch an instance object as a whole. For
further details, refer to Help.

For details on all the commands that you can use to alter selected
graphics, refer to Help.

Restricting editing

The Set Edit command allows you to temporarily exclude primitives
and objects from being edited, or to restrict editing to specific
primitives or objects. It also enables you to restrict editing to graphics
that use particular linestyles, charstyles, materials, and colours.
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Note that style editing restrictions apply to primitives. Consequently,
you can select an object only if all its primitives are individually
selectable.

You can restrict editing to:

specifically-named objects or all objects except those of a specified
name

line primitives that use (or do not use) a certain linestyle

For details, see Chapter 7, Working with linestyles.

text primitives that use (or do not use) a certain charstyle

For details, see Chapter 8, Working with text.

3D clumps that use (or do not use) a certain material

For details, see Chapter 11, Working with materials.

primitives that are assigned or are not assigned a certain colour
For details, see Changing the colour of graphics on page 94.

Furthermore, you can combine these options, making the Set Edit
command an extremely powerful facility.

To restrict editing of objects

1

Press F3, or on the Set menu, click Edit.

You can also use the SETEDIT button on the information bar (at the
bottom right of the MicroGDS window) to set restrictions:

o if SETEDIT is not currently enabled, click the button

If SETEDIT is enabled, a single click of the button toggles the
current editing restrictions on and off.

o if SETEDIT is currently enabled, double-click the button
The Set Edit Filter Editor is displayed.

To define your object restrictions, do one or more of the following:

o click the New button to add a new rule, then type the object
name in the Wildcard/Schema box

o click the Pick button and click an item (object or primitive,
depending on the selection mode) in the window definition

e click the List button to browse to the object name using a list
For details on object naming conventions and use of wildcards, see
Rules for naming objects on page 70.

To specify the action of a rule, select Include or Exclude from the
Action list.
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4  Select the types of objects to which the rule applies from the Match
list.

For example, to restrict editing to objects whose names begins with
kerb, but to exclude objects with kerb as any facet other than the
first, you would specify the following:

Set Edit Filter Editor

Linestyls |Is v| |«nll>a V| [ Pick. ]
Charskyle |15 v| |«AII» v| [ Pick. ]
Waterial  [1s v | [l v [k ]
Colour Is w zhlls v| Pick.

Active wildeard / Schema Advanced MEw
¥  Exclude #* kerh Ohject

Object

(o)

Ensure that you enter Exclude rules at the start of the list, before any
inclusion rules.

You can toggle rules on and off using the check box under the
Active column.

You can also apply advanced filters to specify which primitives and
objects can or cannot be edited, using attributes. A brief
introduction to attributes is given later in this chapter. For details
about assigning attributes to graphics, and filtering graphics using
attribute values, see Chapter 14, Working with attributes and
schemas. You can also refer to Help.

5 To only allow editing of primitives using a specific linestyle,
charstyle, material, or colour, select the style or colour from the
appropriate list.
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e select «All» to apply the rule to all graphics of the corresponding
type

e select «Undefined» to apply the rule to graphics whose style is
missing
For example, styles may be missing from files imported from
other modelling systems.

Alternatively, click Pick and click a primitive to which the style or
colour is assigned.

To allow editing of all primitives, except those drawn in the
specified style or colour, select ‘Is not” from the appropriate list.
Note that, when primitive colour is set to «All», you cannot set
Colour ‘Is not’ (as this would exclude all primitives from editing).

As you set up the filter rules, you can test the result at any time by
clicking Preview. Only objects that meet the criteria are highlighted.
6 Click Close.

When you have set up your restrictions, the SETEDIT button on the
information bar is pressed in and the text changes colour:

Z-0| SETEDIT | =8 ++ L R

You can toggle the editing restrictions on and off by clicking the
button.

MicroGDS will not let you select any primitives which do not comply
to the restrictions you have set.

Remember to clear the edit restriction when you have made the changes
you require.

Changing the colour of graphics

By default, graphics are drawn using the colour defined for the phase in
which they are referenced. The default colours for phases are set in your
document properties (available from the File menu). You can change
the default colour for any phase to one of your choice, using the Mini
Window Editor or the full Window Editor. For details, see Chapter 4,
Using layers and phases.

You can override the phase colour for individual graphics using the Set
Colour command.
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> To change the colour of existing graphics
1 Select the graphics whose colour you want to change.

2 From the Colour list on a status toolbar, select an existing colour or
choose a new colour.

If you want to assign a colour that is not available in the list, click
the ‘Select colour’ entry.

MicroGDS displays the Select Colour dialog box. For example:

Select Colour P?l

Colour Table | True Calour

Meutral

I N 4, B P

]

R T

Lo J|

i1
o
]
fa]
L

You can choose a colour from the document’s colour table or define
a new, custom colour.

If you are defining a custom colour on the True Colour tab, you can
specify a level of transparency using the Alpha slider. For details

about specifying a custom colour using the True Colour spectrum,
refer to Help.

3 Specify the colour you require and click OK.

The colour assigned to the selected primitive is shown in the Colour
box on the status toolbar.

e When you select a primitive for which no explicit colour is assigned,
the Colour box shows ByPhase:

| Colaur IB_-,-F'hase 'I

e  When you select a primitive that has an explicit colour, the colour
and colour number are displayed in the Colour box:

| Calaur I_ vI
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If the primitive has a custom colour assigned (specified by using the
True Colour tab on the Select Colour dialog box), the colour and the
red, green, blue, and alpha values are displayed in the Colour box:

| Calour I255.-"229.-"229.-"255 vl

o If the selected graphics have different colours assigned, the Colour
box is blank:

| Calour I vl

The colour assigned to selected primitives is also shown in the
Properties window. Note that primitives of different colours show
«Mixed» in the Colour property line.

You can also set colours for individual linestyle strokes and charstyles.
For example, you might have a linestyle that has a red border, and a
green fill, or a charstyle that uses a blue font.

To use the colours set in the linestyles and charstyles of the graphics
used in a phase, select the ‘Use style colours’ check box in the Window
Editor. Otherwise, MicroGDS draws the graphics using the phase
colour.

For details about creating and modifying linestyles, see Chapter 7,
Working with linestyles. For details about creating and modifying
charstyles, see Chapter 8, Working with text.

To reset all graphics to their phase colours
1 On the Edit menu, click Select All.
2 From the Colour list on the status toolbar, select ByPhase.

Any explicit colours set in the styles are honoured, provided that the
‘Use style colours’ check box is selected in the Window Editor.
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Using attributes

You can assign attributes to graphics. Attributes are non-graphical
information about the item. For example, an attribute might provide
information about the cost of an object, its colour, details of its supplier,
and so on. You can then export this information to other Windows
applications such as spreadsheets and databases, where it can be used to
produce reports such as parts lists, costings, and maintenance reports.

In addition to assigning attribute values, you can also:
e calculate attributes for primitives and objects

e retrieve information from external databases

You do not assign attributes to calculated and external attributes, the
values are calculated on request.

You can use an attribute as a filter in an inclusion list. For example, you
could define a filter to show only those objects which have a floor area
greater than 20 metres in one phase, and only those objects which have
a lesser floor space in another phase.

You can also use attributes in text primitives, as secondary annotation.
For example, if you were refurbishing an office, you could reference an
external attribute to retrieve employees names and telephone numbers
and assign them to the office desks.

For details about assigning attributes and filtering graphics using
attributes, see Chapter 14, Working with attributes and schemas.

Details about secondary annotation are given in Chapter 8, Working
with text.

Producing object reports

MicroGDS provides two facilities for producing reports about objects:

e Object List: produces a list of all the objects in the active window
definition, together with the number of times they appear in each
phase

e Object Schedule: generates a report that lists all the objects in the
active window definition, together with other information requested
such as any associated attributes

For details about the Object List and Object Schedule facilities, see
Chapter 13, Getting information. For complete details, refer to Help.
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Using layers and phases

Layers

MicroGDS enables you to divide your drawings into logical and
manageable portions by using layers. All the graphical data (primitives
and objects) in a document are drawn on layers. You can regard layers
as transparent overlays, with different parts of the drawing produced on
each overlay.

For example, if you were producing an cinema complex, you might
structure the drawing on the following layers:

e layers 1—10: the architectural detail

e layers 11 —25: seating arena and foyer

e layers 26 —30: wiring detail

e layers 31 —34: lighting and projection

o layers 35—-36: sprinkler system

If you create a new document and immediately begin drawing,

MicroGDS creates a layer for you, with the name ‘default’. You can
rename this layer or create a new layer to use.

You can also change the default layer name that is used for each new
window definition if you do not explicitly create a layer, in your
preferences.
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In a single-user document, layers are stored in the MAN file. There is
virtually no limit to the number of layers you can create.

In a multi-user project, the graphics on each layer are stored in separate
files (LYR files). For details about multi-user projects, see Layers and
phases in multi-user projects on page 120.

Phases

When you create a new layer, MicroGDS automatically creates a phase.
A phase determines which graphics from the layer are drawn and how
they are drawn.

The phase defines:

o whether the graphics are editable, hittable, visible, or invisible
(known as the editing status)

e which graphics on the layer are to be included in the phase

e the colour in which graphics are shown

e any overrides, such as a specific linestyle or a fading value to dim
down graphics

o the name of the layer to which the phase is linked

To specify which graphics stored on the layer are to be displayed in
each phase, you can use an inclusion list.

For example:
Phase 1

OFFICE 1 \|

Layer 1
=
OFFICE 1 ’.f
O il -
a B
b
IE] 0 3 Phase 2
u “d o
‘a |0
a D
O

You can use phases in this way to make editing easier. For example, you
can show different graphics on the same layer in different colours. Or,
you can choose which graphics in a phase are editable and which are
hittable.
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The current layer

All new graphics are drawn on the current layer. If you open an existing
window definition and immediately select a construct command,
MicroGDS automatically makes the layer referenced by the last editable
phase the current layer, and draws the graphics on that layer. If the
window definition does not reference any layers, MicroGDS usually
creates a layer using the default name. If the name assistants are in
force, you may be prompted to specify a valid layer name. The new
layer is made the current layer.

For details about using the layer name assistant, see Chapter 2,
Exploring MicroGDS.

By default, the name of the current layer is shown on a status toolbar.
For example:

Laver Roof Structure

You can customize your status toolbars to hide layer names. For details,
see Chapter 17, Customizing MicroGDS.

All editable phases that reference the current layer are shown checked
in the Mini Window Editor. For example:

Status  Caolour | Linked laver Phase label

1 E External door £3)  Fire door
el E Roof structure (1) Flak roof
3 W 15 Roof structure (1) Flak roof
4 E Z walls (23
*5 E Roof structure (1) Flak roof

In the above example, phases 2, 3, and 5 all reference the current layer

‘Roof structure’. This is indicated by each phase having the same layer
link number, in this case (1). However, because only phases 2 and 5 are
editable, only these phases are checked.

For details about layer link numbers, see Phases list on page 104. For
details about the editing status, see the section Changing the editing
status of a phase on page 106.
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To help you identify which graphics are included in a phase, MicroGDS
assigns a default drawing colour to each phase. You can change the
colour of individual primitives and objects on any layer, or change the
default phase colour to one of your choice. For details, see Changing
the colour of a phase on page 107.

You will often want to work on different layers to add, delete, and
modify graphics held on other layers. To do this, you need to switch to a
different layer.

p  To switch between different layers
e in the Mini Window Editor, double-click a phase that is linked to the
layer you want to make current
If the phase was not editable, MicroGDS automatically changes its
editing status to Editable.
e or, in the window definition click a graphic which is in an editable
phase that is linked to the layer you want to make current

You can also switch between layers using the full Window Editor,
described next.

Working with layers and phases

Although you can perform many tasks with the Mini Window Editor,
you can also use the main Window Editor to manage the layers and
phases in a window. For example, you can use either the Mini Window
Editor or the Window Editor to create layers and phases. But if you also
want to add a description to a layer, define style overrides for a phase,
or set a phase to be screen only, you can perform all these tasks with the
Window Editor.

> To display the Window Editor
1 Select the window definition whose layers and phases you want to
modify.
2 Press F2, or on the File menu, click Window, Edit.
The Window Editor is displayed.

To display the layer and phase properties for more than one window
definition, select the next required window definition and then
press F2.

MicroGDS opens a new Window Editor for each subsequent
window definition.
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You can reposition or resize the Window Editor as required. When you
next display the Window Editor, MicroGDS remembers its last position
and size.

A number of shortcut menus are available when you work with the
Window Editor. To see a shortcut menu, click the appropriate item with
the right mouse button.

Using the Window Editor

indow Editor - Structural [Manor hotel. MAN] g@

Status | Colour | Linked layer  Mod | Linestwle  Charstyle  Material  Fading  Sc
E o
.z E 1 Roof st... u
3 Y 18 Roof st... u phases list
4 E 2 Walls (23 M Arial ..
*c E Roofst., U
< »
window label | Lean To Canservatory |
Paper: Page Setup...
Phase | Layer | ATHbES layer properties
Phase 1
Status (®Editable  OHittable  Owisible (O Invisible .
phase properties
Colour [¥]use primitive colours [#] Use style colours  [] Screen anly
Label | Fire door |
[ Filter. .. ] | «lnrestricteds |
Cwverrides Linestyle| LS | Charstyle | LS | Material| v
Fading % El
Copy Phase(s) Remave Phase(s)

The name of the window definition (and document) to which the
Window Editor refers is shown in the title bar.

The Window Editor has three main areas: a phases list, window and
paper details area, and three tabs: Phase, Layer, and Attributes.
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Phases list

The phases list is at the top of the Window Editor. It shows all phases
that are referenced in the window definition. A bullet to the left of a
phase means that the layer it references is the current layer. If no layer is
current, no phases are marked.

The information shown for each phase is:

o the number of the phase; phases are numbered sequentially starting
from 1
The phase number determines the order in which the graphics are
drawn and printed.

o the editing status of the phase (E, H, V, or I)

o the colour and colour number (or colour value, for a user-defined
colour) of the phase

o the name and the link number of the layer to which the phase is
linked
The link number can be used to distinguish between layers that have
the same name.

Each layer in a multi-user project is stored in a separate layer file.
The link number is used to link the appropriate layer file to the
window definition.

o the modification status of the layer (shows M if modifications have
been made to the layer but not yet saved, or U if the layer is
unmodified)

If you are working on a multi-user project, there are two additional
statuses. For details, see Changing ownership of a layer on
page 123.

o the names of any overriding linestyle, charstyle, and material set for
the phase

o the percentage of any fading used to dim down the graphics on a
phase

e whether or not the phase is shown only on the screen, and not
printed

o the phase label (not visible in the above illustration), if one exists
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Phases can be sorted by different columns by clicking the required
column header. Clicking the column a second time will reverse the
order. The column on which phases are sorted shows an up or down
pointing arrow, depending on the sort direction.

The Window label box below the phases list enables you to add a
description of the associated window definition.

If you have set up a paper definition for use with a print layout view, the
paper size is shown below the Window label box. If you want to assign
or change the paper size, click the Page Setup button and define the
paper definition using the Page Setup dialog box. For details about
assigning a paper size for a print layout view, see Chapter 2, Exploring
MicroGDS.

Phases, layers, and attributes

The Phase and Layer tabs enable you to work with the phases and labels
used in the related window definition. The Attributes tab enables you to
set up window-level attributes which apply to the entire window
definition.

Working with phases

To work with the phases in the Window Editor, click the Phase tab.

Remember that many of the actions described in this section can also be
performed using shortcut menus in the Mini Window Editor.

Selecting phases

To change the properties of a phase, such as its editing status, the
colour, or description, you first select the phase.

> To select a phase

o in the phases list, select the phase whose properties you want to
change

You can use the Windows multi-select facilities to select multiple
phases.
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To select all phases
e in the phases list, on the shortcut menu, click Select All

When you select multiple phases, the values for one or more properties
may become blank or appear unavailable. This indicates that the phases
have different values for those properties. If you change one of these
values, all selected phases assume the new value.

Reordering phases

The order in which the phases are numbered determine which graphics
are drawn over the top of other graphics (phase 1 is drawn first). You
can change the position of a phase in the sequence, thereby changing
the order in which graphics are overlaid.

To reorder the phases
e in the phases list, drag the phase up or down the list

To move a phase to the top or bottom

e select the phase to move and, on the shortcut menu, click Move to
Top or Move to Bottom

Note that if you have changed the sort order, for example, to sort by the
‘Linked layer’ name, this changes only the sort order in the phases list;
phases are always drawn in numeric order.

If you are using mask (or opaque) linestyles, take care when reordering
phases. Unless the phases are correctly ordered, you might not be able
to see graphics which are referenced in different phases. For details
about creating and using mask linestyles, see Chapter 7, Working with
linestyles.

Changing the editing status of a phase

Each phase determines the editing status of the graphics on the layer
with which it is associated. The editing status can be one of the
following:

o Editable (E)
You can edit and hit existing graphics, and create new graphics.
o Hittable (H)

You can hit existing graphics, but you cannot edit them or create
new graphics.
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e Visible (V)
You can see existing graphics, but you cannot hit or edit them, or
create new graphics.

o Invisible (I)
You cannot see, edit, or hit existing graphics, or create new graphics.

To change the editing status of a phase

1 In the phases list, point to the phase whose status you want to
change.

2 On the shortcut menu under the Status column, click the editing
status you require.

Alternatively, click the Status button you require on the Phase tab.

Tip: to change the editing status of a phase to Editable and make its
layer current, double-click the phase in the list.

Changing the colour of a phase

MicroGDS automatically assigns a colour for the graphics in each
phase. The default colours for phases are set in the document properties.
The colour allocations are saved when you save a document, therefore,
you can have different colour allocations for each document. You can
also copy the colour allocations of a document to and from the
document defaults, which are used for all new documents. For details
about changing the default colour allocations, see Chapter 17,
Customizing MicroGDS.

If you have the Colour list on a status toolbar, the colour assigned to the
graphics in the current phase is shown in the box. Unless you change
the colour of individual graphics, the Colour box shows ByPhase. This
indicates that MicroGDS is using the phase colour for new graphics.

All graphics in the phase are drawn in the phase colour (unless you
change the colour of individual items using the Colour list). If you
change the colour of an individual graphic, the colour (and its number
or value) is shown in place of ByPhase.
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To change the colour of a phase

1 In the phases list, point to the phase whose colour you want to
change.

2 On the shortcut menu under the Colour column, select an existing
colour or choose a new colour in which you want the graphics to be
displayed.

To assign a colour that is not available from the list, click the ‘Select
colour’ entry. Then, select your colour using the Select Colour
dialog box. For details about using the Select Colour dialog box, see
Chapter 3, Working with primitives and objects.

Alternatively, select the Colour you require on the Phase tab.

Respecting primitive colours

You can set colours for individual graphics. By default, graphics are
shown in their set colours. Graphics that have not been set explicit
colours are shown in their phase colours.

To use the colours set for individual graphics

1 In the phases list, select the phase that uses set colours for individual
graphics.
2 On the Phase tab, select the Use primitive colours check box.

The graphics are drawn in their set colours, and not in the phase
colour.

Respecting style colours

You can set colours for individual linestyle strokes and charstyles. For
example, you might have a linestyle that has a red border, and a green
fill, or a charstyle that uses a blue font.

To use the colours set in the linestyle or charstyle

1 In the phases list, select the phase that uses styles with the embedded
colours you want to retain.
2 On the Phase tab, select the Use style colours check box.

The styles are drawn in their embedded colours, and not in the phase
colour.
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For details about creating and modifying linestyles, see Chapter 7,
Working with linestyles. For details about creating and modifying
charstyles, see Chapter 8, Working with text.

Note that if you select both ‘Use style colours’ and ‘Use primitive
colours’, any set colours for individual primitives are used.

Showing a phase on screen only

Occasionally, you may want to show the graphics in a phase only on the
screen. MicroGDS enables you to display graphics on screen, but will
hide them when you:

e print a window definition in which the phase is referenced

e include a photo of a window definition in which the phase is
referenced in another window definition

e publish a window definition in which the phase is referenced

Details about each of these procedures is given in the corresponding
chapters in this guide. Refer also to Help.

To mark a phase for screen display only

1 In the phases list, select the phase whose graphics you want to
display only on screen.

2 On the Phase tab, select the Screen only check box.

Note that graphics are also not shown in the thumbnail picture in the
Navigate window (for 2D views) or the window preview in the
Document Organizer.

Filtering graphics in a phase

By default, all graphics on a layer are included in all phases that are
linked to the layer. This is indicated by «Unrestricted» shown on the
Phase tab of the Window Editor.

You can use a phase filter to include and exclude specific graphics on a
layer. For example, you might want to include the electrical circuits in a
phase, but do not want to show the actual wiring detail.
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p  Toset up a phase filter

1 In the phases list, select the phase whose phase filter you want to
edit.

2 On the Phase tab, click Filter.
The Phase Filter Editor is displayed, for example:

% Phase Filter Editor 3]

Ackive Wildcard | Schema Advanced Mew

~ Exclude ** Extatiar Chiject
~ Include Framewoark: 412:doard Ohiject -
W Include Framework: 415:%* Object

[ oK. ] ’ Cancel ] [ Clear ] ’ Preview ]

The default phase filter is simply ** (under the Wildcard/Schema
column). This means, include all graphics stored on the layer linked
to this phase.

3 Edit the phase filter as appropriate and click OK.

You set up a phase filter in much the same way as when restricting
graphics from editing. This is described in Chapter 3, Working with
primitives and objects.

It is important to remember however that you must specify any
Exclude rules at the start of the list, before any Include rules.
For example, if you specify:

Exclude A:DR

ks

all objects are included except A:DR.

However, if you want to exclude all objects that match a particular
wildcard EXCEPT for some specific objects, you must specify the
exceptions before the Exclude statement.
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For example:

Include ARCH:DOOR**

Include ARCH:WINDOW**

Exclude ARCH**

Kk

excludes all objects with the first facet ARCH, except for objects
with the first facets ARCH:DOOR and ARCH:WINDOW.

You can also use advanced filters to specify which primitives and
objects will or will not be included in a phase, using attributes. For
details about assigning attributes to graphics, and filtering graphics
using attribute values, see Chapter 14, Working with attributes and
schemas. You can also refer to Help.

Once you have set up a phase filter, you can copy it to other phases if
required.

To copy a phase filter

1 In the phases list, select the phase whose filter you want to copy.
2 On the Phase tab, click Copy Phase(s).

3 In the phases list, select the phase in which to copy the filter rules.
4 On the shortcut menu, click Paste Phase Filter.

Note that this command copies a phase filter from a single phase. If you
copy multiple phases, the command is unavailable.

Setting global overrides for a phase

Usually, graphics are drawn and printed using the style definitions that
are assigned to the graphics. For example, a line primitive uses a
linestyle definition and a text primitive uses a charstyle definition.

You can specify a series of overrides to temporarily display or print the
graphics in a different way.

Setting linestyle, charstyle, and material overrides

Normally you choose a style per primitive, so that graphics in a phase
may be drawn using a mixture of linestyles, charstyles, and materials.
However, you can override this and display all line primitives in a phase
in a single linestyle, all text in a single charstyle, and all clumps in a
single material.
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You might want to do this, for example, if you are printing an early
draft of a drawing using a printer that does not have all of the fonts that
are used in the drawing.

To override the linestyle, charstyle, or material for a phase

1 In the phases list, select the phase for which you want to set the
overrides.

2 On the Phase tab, select the styles you want the phase to use from
the linestyle, charstyle, or material lists.

For details about linestyles, charstyles, and materials, see chapters 7, 8,
and 11 respectively.
Setting fading overrides

You can use a fading override to dim down the graphics on a phase. You
might want to fade the graphics on one phase to help emphasize the
graphics on another phase.

A fading value affects all graphics in the phase, including raster files
and graphics that are assigned a primitive colour, using the Set Colour
command.

To override the fading value for a phase

1 In the phases list, select the phase for which you want to set the fade
override.

2 On the Phase tab, specify the fading percentage for the strength in
which you want the graphics to be drawn and printed.

100% draws the graphics in full colour; 0% makes the graphics
invisible. Intermediate values will be semi-transparent.

Copying phases

You can create more than one phase to link to a layer. You can then
specify which objects on the layer you want to be included in each
phase.

To copy a phase
1 In the phases list, select the phase to copy.
2 On the Phase tab, click Copy Phase(s).
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3 Click the position in the phases list at which to paste the phase, then
click Paste Phase(s).

The new phase is assigned the next phase number, but it has the
same link number as the original phase. This indicates that both
phases are linked to the same referenced layer.

You can also copy a phase from one window definition to another by
copying the phase from one Window Editor and pasting it into another.
Removing a phase

Removing a phase from a document does not delete the layer graphics.
It simply removes the link to the layer, in the window definition.

p  Toremove a phase
1 In the phases list, select the phase to remove.
2 On the Phase tab, click Remove Phase(s).

If you remove all phases that are linked to a layer, you can create a new
phase that references the layer’s data by copying the layer in the
Document Organizer into the Window Editor. For details, see Adding
layer graphics to a window definition on page 117.

Adding a description to a phase

You can add a description to a phase. You could, for example, make a
note about the objects you have included in the phase.

> To create or change the current phase’s label

1 In the phases list, select the phase for which you want to add a
description.

2 On the Phase tab, type the description in the Label box.

Working with layers and phases
To work with the layers in the Window Editor, click the Layer tab.

Remember that many of the actions described in this section can also be
performed using shortcut menus in the Mini Window Editor.
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Creating layers and phases
To divide your drawing into layers, you must first create the new layers
and phases.

> To create a new layer and phase

In the phases list, click the phase above which the new phase will be
positioned.

On the Layer tab, click New Layer & Phase.
The Layer Name dialog box is displayed.

If you are using a layer name assistant, a list of layer categories is
displayed in the box. If you are not using the name assistant, the box
is empty. For details about using the layer name assistant, see
Chapter 2, Exploring MicroGDS.

In the Name box, specify the name for the new layer, following the
rules described in the next section Naming layers.

If you want to add a description of the layer, in the Label box, type a
description (using up to 127 characters), and then click OK.

Note that if you are transferring data to a system using DXF/DWG
files, layer names will be converted to a format required by
DXF/DWG. You can force the exported layer name to a preferred
name by entering it in a special format in the Label box. For details,
refer to Help.

When you create a new layer, the associated phase is given the next
phase number in the sequence (from 1), and is added to the phases
list in the Window Editor. The phase is also assigned the next phase
colour.

If you want to change the editing status, or the colour in which the
graphics will be shown in the phase, make your changes as required.

A phase can have one of four editing restrictions. These are
described earlier in Changing the editing status of a phase on
page 106.

Changing the colour of a phase is described in Changing the colour
of a phase on page 107.

You can also create new layers and phases using a shortcut menu in the
Window Editor and the Mini Window Editor.
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You can rename an existing layer description using:
o the Rename Layer button on the Window Editor
e the Document Organizer

e and the Properties window

For details about the Properties window, see Chapter 13, Getting
information.

If you are using a layer name assistant, a layer description may have
been added to the layer name assistant configuration file. If a label does
exist, it is automatically displayed in the Label box. For more details,
see Chapter 17, Customizing MicroGDS.

Naming layers

When you create or rename a layer, you should use a descriptive name.
For example, ‘architecture details’ is far more meaningful than
something like ‘top layer’.

Rules for naming layers are:

e alayer name can contain up to 256 characters

e names can include spaces, except at the beginning or end of the
name

e layer names are case sensitive, so ‘lighting’ and ‘LIGHTING’ are
two different layers

By default, layer names in a document do not have to be unique. You
can, however, force names to be unique, or request a warning if you
name a layer using the same name as one that already exists. You set the
applicability of unique names in your preferences. For details, refer to
Help.

Previewing layers

Every layer that is created is saved in the document. You can list all the
layers in a document by clicking the Layers tab on the Document
Organizer.

You can also preview the graphics stored on any individual layer.
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> To preview a layer

1 If the Document Organizer is not currently displayed, press F4, or
on the Window menu, click Document Organizer.

2 On the Document Organizer, click the Layers tab:
Layers tab

[aje|s]|e|aE|

3 Select a layer to preview.

shortcut menu, click Toggle Preview.
All graphics are shown as two-dimensional images.

When the preview area is visible, the Preview button appears pressed in.
To close the preview area, click the button again.

Finding layers
The Document Organizer can help you to locate layers that you cannot

find because, for example, the window definition that referenced the
layers has been deleted.

| 2 To find layers in a document
1 On the Document Organizer, click the Layers tab.

2 On the Layers tab, click 4
MicroGDS displays the Find Layers dialog box. For example:

ﬂ Find Layers

Mame & Location | advanced
Mamed: | *
Look in:

Mame Skatus
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If you are working with a project the dialog box displays an
additional field called Location to display the path of any layers
found.

Specify your search requirements and click Find Now:

e in the Named box on the Name & Location tab, specify the name
of the layer

You can use wildcards to match characters in the name. Layer
names are not case sensitive. For example, S* matches all layers
with names that begin with ‘S’ or ‘s’, followed by any number of
characters, including none.

Note that the Look in box can be used only to search for layers
in specific aliases, in a multi-user project.

e to find layers by the assigned layer label, click the Advanced tab
and specify the layer label

You can also search for only those layers that are not referenced
by any window definitions, by selecting the ‘Unreferenced layers
only’ check box.

MicroGDS searches the document and lists any layers that match
your search criteria in the Results box. For more details about
finding layers, refer to Help.

Adding layer graphics to a window definition

You can add the graphics on an existing layer to any window definition
in the same document. To do this, you create a new phase from the
layer, and then reference that phase in the required window.

> To add layer graphics to a window

1

In the Document Organizer, ensure that the document from which
you want to copy a layer is the current document.

Click the Layers tab and then select the layers whose data you want
to copy to a window definition.

On the shortcut menu, click Copy.
MicroGDS copies the selected layers.
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4  Ensure that the window definition in which you want to create the

phase is the active window.
Under the Linked layer column in the Window Editor (or in the
Mini Window Editor), on the shortcut menu, click Paste Phases.

MicroGDS pastes a phase for each layer that you copied into the
window editor.

You can also create a new phase from a layer, by dragging the layer
from the Document Organizer into either of the window editors. For
more details, refer to Help.

Duplicating a layer

You can duplicate the data of an existing layer by cloning it. This may
be useful if you want to try changing the graphics, but you want to keep
the original layer graphics unchanged.

To clone an existing layer

1 From the phases list in the Window Editor, select the phase that

references the layer you want to clone.

2 Click Clone Layer(s).

The Clone Layers dialog box is displayed.

Do one of the following, and then click OK:

e to add a new phase to refer to the cloned layer, select this option

o to change the existing phase to refer to the cloned layer, select
this option

If you are using a name assistant, MicroGDS displays the Layer
Name dialog box for you to specify the name. The name must
comply with the MicroGDS naming rules.

If you added a new phase to reference the cloned layer, MicroGDS
adds a new phase to the Window Editor.

If you changed the existing phase to refer to the cloned layer,
MicroGDS replaces the existing phase by the new phase in the
Window Editor.
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Deleting a layer

When you delete layers in a single-user drawing, the graphics on that
layer are deleted from disk when you save the file. All phases that
reference the layer are also deleted.

Note that if you want to delete layers from multi-user projects, you must
use the MicroGDS Project Administrator utility. For more information,
refer to the online Help for the Project Administrator (if the Project
Administrator utility is available to you).

p  Todelete a layer

1 Inthe Document Organizer, ensure that the document from which
you want to delete the layer is the current document.

2 Click the Layers tab and then select the layers that you want to
delete.

3 Press Delete, or on the shortcut menu, click Delete.

4 To confirm the deletion, click Yes at the prompt.

Moving and copying objects between layers

Although objects are created on the current layer, you can move and
copy selected graphics from one layer to another—within the same
document or to another document.

> To move objects to another layer
1 Press F10, or on the Edit menu, click Select Objects.
2 Select the objects to move.
3 On the Object menu, click Get.
4

Select the layer to move the objects to by clicking an object already
on that layer.

> To copy objects to a layer in a different MAN file

1 In the source MAN file, press F10, or on the Edit menu, click Select
Objects.

To copy all objects on a layer, make all other layers not editable and
then press F7 or click Select All on the Edit menu.

2 To copy the objects to the Clipboard, press Ctrl+C, or on the Edit
menu, click Copy.
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3 In the destination MAN file, make the layer you want the objects to
be copied to, the current layer.

Ensure that a phase that is linked to the layer is editable.

4 To paste the objects onto the layer, press Ctrl+V, or on the Edit
menu, click Paste.

Layers and phases in multi-user projects

Each layer in a multi-user project is stored in a separate layer file (a
.LYR file) and is referenced by the window definitions. When you open
a window definition, MicroGDS reads the list of layer names and looks
for the graphics that appear on those layers in the layer files. A window
definition can best be described as a set of filters on the graphical data
held in the .LYR files.

In the same way that each layer in a single-user document has a unique
link number, each layer file in a project also has a unique layer link
number. In a project, the layer link number is also used for the file name
of the layer. For example, if you create a new layer called
‘Foundations’, MicroGDS assigns it the next available layer link
number, for example, link number 78. Consequently, the file name on
disk is 78.LYR. It is important that you do not change the name of the
layer file (.LLYR) in the Windows Explorer. If you do change the name
and you open a window definition that references the layer, an error
message is displayed.

The layer link numbers in a project can be used when multi-user project
files are shared over remote sites. The project manager can allocate
layer link number ranges to each site, using the Project Administrator.
The Project Administrator is available from the MicroGDS Program
menu. For details on how to use the Project Administrator, refer to the
utility’s online Help.

Each time a new layer is created, it is added to the project database.
Details about all the layers in the project database are recorded in the
Document Organizer. Other users can access the layers using the
Document Organizer and can copy or link a layer directly to a window
definition.

Because a layer can be referenced by more than one window definition,
more than one user can open a layer at one time. To prevent more than
one user editing the same layer at the same time, when a user opens a
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layer or creates a new one, they take ownership of that layer and
MicroGDS locks the file. This means that one user can edit the file and
other users can open it and snap onto the graphics, but cannot edit it at
that time. When the owner has finished editing a layer, they can disown
the layer which then enables another user to take ownership. This is
described further in the later section Changing ownership of a layer on
page 123.

Note that there is virtually no limit to the number of layers you can
create in a multi-user project.

The layer name assistant in multi-user projects

The name assistants enable you to create layers and objects whose
names conform to the naming standards in use at your site. Layers and
objects have separate configuration files. For information on using
object name assistants see Chapter 2, Exploring MicroGDS.

The layer name configuration file determines the names to be used for
new layers. For multi-user projects, this file can also define the location
in which a layer of a particular name should be located.

Any rule in the layer name assistant configuration file can have an alias
added to it. When an entry is selected from the top-level names in the
Layer Name dialog box, if there is a relevant alias attached and that
alias is defined in the project, that alias is selected in the alias location
of the dialog box.

To attach an alias to a rule in the file, add the alias in parentheses to the
end of the expansion text. For example:

ELEC—(Lighting)|Electrical
specifies that the alias name Lighting will be selected in the Layer
Name dialog box when a new layer starts with ELEC-.

You can also override a previously specified alias for a specific
expansion only. For example:
ELEC—|ALARM~(Security)|Alarm installation

overrides the alias set for the top-level entry for this specific expansion
only.
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Creating new layers

When you create a new layer in a multi-user project, you can select the
layer alias in which to save the new layer.

Note that aliases are defined in the project database. For details about
creating a project database, see Chapter 16, Multi-user projects.

1 Press F2, or on the File menu, or click Window, Edit.

2 In the Window Editor, click the Layer tab and then click New Phase

& Layer.

The Layer Name dialog box is displayed, for example:

Layer Hame

Mame |

Label

architect

Civil Engineering
Contractorf Shop Drawings
Electrical

Equipment Consultants
Fire Pratection

IS (Geographic Information Systems)
Interior Design

Landscape Architecture
Mechanical

Cther Consulkants
Plurnbing

il Sk ksl

Common layers
- Interior layers
Electrical data

Layer files

Invalid layer name

To create a new layer in a multi-user project

L

o] %

B
Lo ]

Help

If you are using a layer name assistant, a list of layer categories is
displayed in the top list box. If you are not using the name assistant,

this box is empty.
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3

5

Specify the name for the new layer.

By default, all new layers are saved in the location defined by the
default layer alias set for the workspace. However, if you are using a
layer name assistant the layer name configuration file may define
the preferred location to which a layer of a particular name should
be created. For more details, see the previous section, The layer
name assistant in multi-user projects.

Select the alias that defines the location in which you want to save
the layer from the list at the bottom of the dialog box.

Note that you can override the default alias for new layers for the
current work session using the Alias Overrides command. For
details about overriding the default aliases, see Chapter 16,
Multi-user projects.

Click OK.

Creating a new layer automatically creates a phase to refer to the newly
created layer.

Changing ownership of a layer

You can edit layers only if you ‘own’ them. When you create a new
layer, or when you are the first person to open a layer for editing (an
editing status of Editable), you are given ownership of the layer. Other
users can open the layer as Hittable or Visible, but cannot edit it.

When you save changes to a layer that you are editing, other users can
update to see the changes.

> To see recent changes made by the owner

1

The current owner must first save the window definition that
references the layer.

Once the window definition has been saved, in the Phases list in the
Window Editor, select a phase that references the layer whose
changes you want to see.
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3 On the Layer tab, click Update Layer(s):

Layer E-CCTW (1)

Status  Loaded [ owned
Location <Electrical data=
Label Electrical circuitry

“ew Laver & Phase, ., [ Clone Laver(s),., ] [ Update Layer(s) ]

The most up-to-date version of the layer is now available. Any edits that
have been saved by other users are displayed.

> To change the ownership of a layer
1 The current owner must disown the layer by:
a) selecting a phase that references the layer, and then

b) clearing the Owned check box on the Layer tab

If changes have been made to the layer that have not yet been
saved, MicroGDS prompts whether to save the changes or
discard them.

2 Another user can then take ownership of the layer by:
a) selecting a phase that references the layer, and then

b) selecting the Owned check box

The ownership of other phases that reference the layer is also
changed.

You can also own and disown a layer using the shortcut menu in the
Mini Window Editor.

When you disown a layer, the editing status of any editable phases that
reference the layer is changed to hittable. Another user can then take
ownership of the layer for editing.

Note that when you close a project workspace, all layers are
automatically disowned.
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Deleting a layer
You cannot delete layers from a multi-user project using MicroGDS.
The project manager can delete duplicate and unused layers using the
Project Administrator.

The Project Administrator is available from the MicroGDS Program
menu. For details on how to use the Project Administrator, refer to the
utility’s online Help.
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Entering positions

Specifying positions
Many commands in MicroGDS require you to enter a position. You can

specify the position by using a snapcode to snap to existing graphics or
snap in free space, or by typing coordinates.

If you make a mistake when specifying a position, you can often use
Backspace to cancel the position.

MicroGDS provides the following drawing aids which you will find
useful when locating a position.

e snap guides which are drawn automatically for you to snap to

e a grid which you can use to help lay out your drawing

e the x, y, z buttons which you can use to fix a coordinate

e acurrent position from which you can measure relative coordinates
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By default, the position of the mouse pointer is shown in the Position
box at the bottom of the MicroGDS window.

| | Passition G54 /853mrn/Ornm O

This shows that the current position is 664mm along the X axis, 859mm
along the Y axis, and Omm along the Z axis. The D represents the Dot
snapcode. The coordinates and snapcode are dynamically updated as
you move the mouse.

You can change your preferences to show the last hit position instead.
For details about changing your preferences, see Chapter 17,
Customizing MicroGDS.

Note that unless you snap to a graphic that has a Z coordinate, or you
explicitly type a Z coordinate, the previous Z coordinate is used. If no
graphics in the window have a Z coordinate, you can omit the Z value
as it will always be 0.

Using snapcodes

Snapcodes enable you to snap exactly to points on the graphics. This
ensures accuracy in drawing, selecting, moving, and placing primitives
and objects.

As you move the pointer around, you see snapcodes displayed at their
appropriate positions as the pointer passes over them. For example:

Faint

tre

and
4

MicroGDS tries to anticipate what you are trying to snap to based on
the command you are using and the position of the mouse pointer. You
can accept the suggested snapcode by clicking the mouse button or
choose a different one by typing an explicit snapcode.

When MicroGDS looks for a snapcode to show, a default distance is
used which determines how far away from the mouse pointer to look.
Usually, this distance will be suitable. You can, however, specify your
own hit-radius value, using your preferences.
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When there are no graphics to snap to at the pointer position, the Dot
snapcode is shown. The coordinates of a Dot snapcode will have an X
coordinate, a Y coordinate, and a Z value of 0. If you draw graphics
using a Dot snapcode, the graphics will always have a Z value of 0.
This is because the Dot snapcode always snaps to the XY plane. The XY
plane is the default view—Ilooking across the XY plane, with the X axis
running left-to-right, and the Y axis running bottom-to-top.

To use a snapcode
e click the mouse button when you see the snapcode displayed
e or, type the initial letter for the snapcode you want

If multiple items lie within the snap radius of the mouse pointer, you
can cycle through the graphics by pressing Spacebar. When the item
you want to select is highlighted, click the mouse button or type the

displayed snapcode.

By default, snapcodes are displayed using the whole word. You can set
your preferences to have snapcodes shown using just their single letter
reference.

The table below shows the snapcodes with their single-letter reference,
highlighted in bold:

Axes parallel to the current X or Y axes

Box one of nine justification points around a text box (corners,
midpoints, and centre)

Centre centre of curvature of arc or circle

Dot position of mouse pointer (when there are no underlying
editable or hittable graphics)

End end of a line

Face surface of a clump

Grid points on a grid

Inside centre of gravity of a 2D shape or centre of the 3D clump
face

Line nearest point on a line

Middle middle of the nearest line segment

Normal position on the nearest line to create a ninety degree angle

Origin origin (hook point) of the nearest object

Point vertex of a line, or the intersection of two lines

Tangent position on the nearest line to create a tangent

Vertex vertex of a line
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Note that snapcodes A, O, T, and V are never shown at the mouse
pointer; you must always type the initial letter to use them. Note also
that G is shown only when the grid is enabled, but is always available
when a grid has been defined by typing the initial letter.

Snapcodes are displayed with an initial uppercase letter. When you type
a snapcode, you can type it in uppercase or lowercase.

If you type a snapcode that is not applicable to the current graphics,
MicroGDS displays a warning. For example, if you hover over a line
segment of a rectangle and you use the Centre snapcode, instead of the
Inside snapcode to snap to the centre of the rectangle, MicroGDS
displays the message: ‘Cannot get centre of straight line’. You can
choose to switch off snapcode error messages in your preferences.

Using coordinates

To give exact positions when you are drawing or moving graphics, you
can use coordinates.

The principle of coordinates is the same as that used for map references,
where a point is represented by two numbers indicating its position
along an X axis and a Y axis. The following grid shows this principle.

10

b ®m e oW

Y axis

=R

DD 1 b 3 4 5 & 7 -3 = 10

X axis

Horizontal measurements are along the X axis, and vertical
measurements are along the Y axis. In this case, measurements along
both axes start from the bottom left of the grid and are incremented in
the positive directions (that is, right along the X axis, and up along the
Y axis). The bottom left-hand corner is therefore 0/0/0, known as the
origin. The last position of the coordinate (that is, /0) is the Z position.
The Z axis runs vertically through the XY plane at the origin.
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The spot shown in the example above, is 5 units along the X axis, 6
units along the Y axis, and 0 along the Z axis. In MicroGDS, this point
is referred to as 5/6/0 or 5,6,0 (depending on your list separator setting).
These are the coordinates of this position.

When you draw and place graphics, it is often useful to move or rotate
the axes. You can change the position, scale, and orientation of the axes
as required, For details, see Chapter 6, Using the axes.

The current position

MicroGDS marks the last hit position in the document window by a
small circle. This is called the current position. For example:

LM

current position
indicator

It is from this position that relative coordinates are measured. Each time
you specify a new position, the current position and circle marker move
accordingly.

You can change the current position without specifying a position
simply by hovering over a point where one of the following snapcodes
is shown:

Centre
End
Inside
Middle
Box
Point

e o o o o o

Then, when you use a relative coordinate, the position is interpreted as
an offset from the current position. For more details, refer to MicroGDS
Help.
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Setting the units of measurement

When you type in coordinates, if you do not specity units of
measurement MicroGDS uses the current set units as shown on the
status toolbar. For example:

Urits | mm Evs

If you want to enter the coordinates in different units from the set units,
you simply enter the correct symbol for the units when you type in the
numbers. MicroGDS automatically converts the coordinates to the
current set units to draw the item accurately.

For example, you may be drawing an office work area in metres and
you want to add a desktop for which you only have the imperial
measurements. You could type the desktop’s imperial dimensions,
followed by the feet symbol () and MicroGDS would convert the

dimensions for you.

The types of units you can use, with examples, are:

mm (for millimetres) 1.2mm
cm (for centimetres) 1.2cm
Inches 1.2"

m (for metres) 0.23m
km (for kilometres) 1.34km
Feet 2.3
Feet+Inch 2'6.5"
Imperial 2'6 1/2"
Miles 0.23miles
Ken 3.4ken
Shaku 15shaku
Sun 1.4sun
Bu 15bu
Nautical Miles 1.5nmi

You can combine different units, for example 5”/2" specifies the X
coordinate in inches and the Y coordinate in feet.
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In addition to setting the type of units you want to work in, you also set
the number of decimal places used for measurements. This does not
affect the accuracy to which you draw, only the precision to which
dimensions are displayed. If you are working in Imperial units, this is
the fractional unit. For example, if you want measurements to be
displayed to an accuracy of sixteenths of an inch, set decimal places

to 16.

Note that each type of measurement unit has a maximum number of
decimal places that you can set. The maximum number of decimal
places you can set per measurement is given in a table in Help.

If you save the axes for a window definition, the current units and
decimal places are also saved. When you open a window definition, its
axes are loaded from the window’s stored values. You can recall a
window’s axes which will also restore the units and decimal places. For
details about saving and recalling a window’s axes, see Chapter 6,
Using the axes.

MicroGDS stores the coordinates of graphics as double-precision,
floating-point numbers. The accuracy of this storage is 1/10,000mm
over a space of £50,000km. So, if you set the scale to 1:1 and are using
mm as the set units, the smallest value that you can enter (and that
MicroGDS can display) accurately, is 0.0001mm. If you set a scale of
1:50 and are using miles as the set units, the smallest value is
0.000000001 miles.

You can specify the type of units and number of decimal places on the
status toolbar or by using the Units command on the Set menu.

To set the units of measurement and decimal places

1 On the Set menu, click Units.

2 At the prompt bar, type the units you require.

3 At the prompt bar, type the number of decimal places you require.

When you set the units, those units are also used, by default, for new
dimensions, measurements, lengths, and coordinate positions, unless
you change them.

Note that the number of decimal places specified does not affect the
number of decimal places for angles. The decimal places for angles are
set on the General tab of your preferences. For more details, refer to
Help.
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Entering coordinates

You can use coordinates whenever MicroGDS requires you to give a
position. To enter the position, just start typing the coordinates. As soon
as you begin typing, MicroGDS displays the Position prompt bar for
you to enter the coordinates.

For example:

Faozitiaon: ﬂ)ﬂ_’d EDa’dﬂ

When you have typed the coordinates, press Enter or click v/

There are two types of coordinates you can use:
e Cartesian coordinates

e Polar coordinates

Both Cartesian and Polar coordinates can be absolute or relative:
e absolute coordinates are measured relative to the current axes

By default, the set axes have their origin at the centre of the drawing
sheet. You can move the axes, and therefore the origin for measuring
absolute coordinates, to anywhere on the drawing sheet.

e relative coordinates are measured relative to the current position

The current position is marked by a small circle. This position is the
base point from which relative coordinates are measured.

You enter coordinates in the order X, Y, Z. If you omit a coordinate,
MicroGDS uses the last value specified for that coordinate. If you omit
the Z coordinate and no Z coordinate has been specified, the Z
coordinate is 0.

In MicroGDS, you can use in-line equations when you enter
coordinates. MicroGDS solves the equation to calculate the required
position. When you enter in-line equations, you must enclose the
equation in brackets. Note that there must be no spaces between an
arithmetic operator and the coordinate.

For example, to draw a line which has a total length of two existing
graphics, you could add the two X dimensions of the graphics together
by typing:

(42.5+65.23)/20

MicroGDS solves the equation to calculate the precise length for the
line. For a summary of the in-line equations you can use, refer to Help.
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Cartesian coordinates

Cartesian coordinates are defined by a distance horizontally and a
distance vertically.

Absolute and relative Cartesian coordinates must be separated by a
slash (/) or by the list-separator character (often a comma) specified in
your Windows Regional Settings.

Any point can be given in absolute coordinates, relative coordinates, or
a mixture of both.
Absolute Cartesian coordinates

Absolute Cartesian coordinates are measured from the set axes’ origin.
For example, a line drawn from 25mm/40mm to 90mm/—15mm appears
as:

Y

25 horizontally
40 vertically

Origin
90 horizontally
-15 vertically

Type absolute coordinates in the format:
o X/Y/ZorX)Y,Z
For example, 120/20/20 or 120,20,20

Relative Cartesian coordinates

Relative Cartesian coordinates are measured relative to the current
position. For example, if you were to draw a line from x=500, y=1000
to x=4500, y=—1500, you might give the first position in absolute
coordinates, at 500/1000. Then, to specify the other end of the line, you
could enter the position relative to the current position (indicated by the
small circle), 14000/r—2500:
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point A
500mm horizontally relative to the origin
1000mm vertically relative to the origin

\ X
Origin )
point B
4000mm horizontally relative to point A

-1500mm vertically relative to point A

Type relative coordinates in the format:
o 1X/rY/rZ or rX,rY,xZ
For example, r120/20/20 or r120,20,20

or:
o @X/Y/Z or @X,Y,Z
For example, @120/20/20 or @120,20,20

Polar coordinates

Polar coordinates are defined by a distance and an angle. An angle is
either an angle value or a bearing (a direction). Angles are measured
from the X axis, where normal X has a rotation of 0° (with a bearing of
East). Angular units are described in detail in Help.

Absolute Polar coordinates

Absolute Polar coordinates are measured from the set axes’ origin. For
example, to copy a circle 600mm along a construction line where the
angle of the construction line is 8° to the X axis, you could enter 600<8:

Y

600mm length at
. . . an angle of 8°
circle copied using

an Inside snapcode 6 _
— %
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Type absolute Polar coordinates in the format:
o distance<angle/Z
For example, 850<45/0

Relative Polar coordinates

Relative Polar coordinates are measured relative to the last position. For
example, you could draw a line of length 800 at an angle of 35° to the X
axis:

Y
800mm radius at 35°
/ x
Origin o«
x first point

Type relative Polar coordinates in the format:
o rdistance<angle/xZ
For example, r330<90/r0

or:
o (@distance<angle/Z
For example, @330<90/0

Constraining distances

You can specify the next position to be measured from the current
position, by typing the distance.

When you type a distance, the next position is constrained in all
directions from the current position. As you move the mouse pointer
outside the radius of the distance, a ghost chain line is drawn to the
current mouse position.
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For example, you may want to draw a line 1000 units from the centre of
a rectangle, at an angle which intersects the centre of a second
rectangle. To do this, start the line command and click in the centre of
the first rectangle, then type a distance of 1000 and click in the centre of
the second rectangle:

=

Insice
e

,’A\?

/

G

Using shortcuts

If you want to use the same value for X, Y or Z as the previous position,
you can omit that coordinate when you specify the new position. For
example, /50 means use the same X and Y values as the previous
position, and a value of 50 for Z.

If you enter an X and Y coordinate, the previous Z position (or zero if
no Z position has been specified) is used. So, /20 means use the same X
value as the previous position, a value of 20 for Y, and the same Z value
as the previous position. A single slash (/) character means use the same
X, Y, and Z values as the previous position.

Note that you must use ‘/° (not “,”) to specify the same value as a
previous position.

Combining snapcodes with coordinates

You can combine a snapcode with a coordinate. This enables you to
specify a coordinate (or an approximate coordinate) and use a snapcode
to snap exactly to a given point on the graphics.

To combine a coordinate and a snapcode, you simply type the
single-letter snapcode reference. MicroGDS finds the nearest graphic
component to the given coordinate. You can use any snapcode that is
appropriate to the graphic with which you are working.
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For example, to place a 50mm radius circle in the centre of a 100mm by
100mm rectangle, you can use an I (Inside) snapcode:

'/ coordinate 100/100/0

r 100mm
Inside snapcode

100mm

Type the coordinate and snapcode in the format:
e coordinate snapcode

For example, 100/100/0 i

You must leave a space between the number and the snapcode.

Examples of valid coordinates

50m/75m absolute Cartesian coordinates in metres

r50/r50/r100 relative Cartesian coordinates in the current set units

r50/100 relative Cartesian coordinates in X, absolute in Y in
the current set units

10/5/8 absolute Cartesian coordinates in the current set units

@75,60 relative Cartesian coordinates in the current set units

35m<30,15 absolute Polar coordinates, distance in metres, height
in current set units

@250<30 relative Polar coordinates in the current set units

550,225,100 absolute Cartesian coordinates in the current set units

5"2" absolute Cartesian coordinates, X in inches, Y in feet
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Using snap guides

Snap guides are temporary construction lines that are automatically
created for you by MicroGDS. You can use snap guides to help position
and align graphics more precisely. Snap guides are displayed whenever
you are prompted for a position in a command.

For example:

-

A set of default snap guides is created at the point of the last snap. They
are shown whenever the mouse pointer is within the snap radius. A
label indicating the origin of the snap guide is also shown.

You can remove the default angles or define additional angles, using
your Snapping preferences. You can also choose whether or not to show
snap guides in the Z direction.

Note that the angles are measured relative to the current axes.

By default, the snap guides are drawn as thin, black dashes. You can
change the colour, width, and pattern in which snap guides are
displayed in your preferences.

MicroGDS also creates snap guides at the angles and intersections of
existing graphics, simply by hovering the mouse pointer over an
appropriate position. For example, if you hover over a point, the default
set of snap guides are shown. If you hover over a line, Extension or
Parallel snap guides are shown through the current position.
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If you hover over a snap guide, MicroGDS shows details of its origin in

an label. This shows:

e an angle, if the snap guide was generated from an angle in your
preferences

o Extension, if the snap guide is the infinite extension of an existing
line

e or Parallel, if the guide was created parallel to an existing line

l ieﬁ_“\&" . parate
| 41 ..

Note that if snap guides are coincident (for example, an extension and
45° angle), a label is given only for the first guide to be added.

You can switch snap guides on and off, using the Snap Guides button on
the Information bar:

Z-0 SETEDIT | "== T NUM

Snap Guides button
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Using a grid
You can use a grid to help you draw and align graphics. You can display
the grid or set it to invisible, using the Grid command on the Set menu.

When visible, you can choose the spacing of the grid, and specify
whether to display it as dots or as graph paper.

When the grid is visible as graph paper, you can choose a colour for the
lines, and also vary the thicknesses of the lines by specifying a change
in boldness at set line intervals.

When a grid is defined, the grid is always active, even when invisible.
This means that you can always snap to it using the Grid snapcode. You
can choose to automatically snap to the grid point nearest the mouse
pointer when drawing in free space or only snap to the grid using a G
snapcode.

When a grid is defined, you can also show and hide the grid by clicking
the Grid button on the information bar:

T L

?

Grid button

Note that if you save a window’s axes and you have a grid defined, the
x and y grid spacing is also saved. For details about saving and
restoring a window’s axes, see see Chapter 6, Using the axes.

For more details about using a grid, refer to MicroGDS Help.

Fixing a position
You can fix the X, Y, or Z (or a combination of them) coordinates so

that the next point you pick uses the fixed X, Y, or Z position. You can
do this using the x y z status toolbar buttons:
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You can use these buttons when you are prompted to give a position.
When you click on a status toolbar button, it remains pressed until you
specify the corresponding coordinate. When you specify the position,
the status toolbar button changes colour to show that the coordinate is
fixed. When you specify the next position, the button reverts to its
normal state and the coordinate is no longer fixed.

Note that, as an alternative, you can press the X, Y, and Z keys on your
keyboard.

The following example shows how you can position the centre of a
circle at the intersecting coordinates of an existing graphic, where the
intersecting coordinates are not known.

1 Click

2 To fix the X coordinate, click anywhere on the far right line:
Y

point at which to fix
X coordinate

x
The button changes colour to show that it is fixed.

As you move the mouse pointer away from the fixed X coordinate, a
ghost chain line is drawn from the centre of the attached circle to the
intersection of the current mouse position. For example:

SO

Line

3 To indicate the Y and Z coordinates, click the appropriate point on
the top line.

You can fix any combination of coordinates you require.

You can also force all graphics to be drawn on the XY plane, using the
7Z=0 button on the information bar. When the button is switched on,
MicroGDS also switches on the fix Z button (on the status toolbar) and
then switches it off again when you end Z=0 mode. For details about
using the Z=0 facility, refer to Help.
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About the axes

MicroGDS uses axes to draw and place graphics. Coordinates are
measured from the origin of the axes, that is, 0,0,0. Some commands
use the rotation of the axis (also called the angle) to place graphics.

Each window definition has its own set of axes; these are used for all
views within the corresponding window definition. You can save a
window’s axes so that you can restore them at any time. For details, see
the later section Saving and restoring a window’s axes.

By default, the axes are set with:

o the origin at the centre of the drawing space

o the X axis horizontal in 2D view (a rotation of 0°), the Y axis
vertical, (and the Z axis coming out the screen)

e ascaleof1:1
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For example:

A i

.

MicroGDS does not show the Z axis in a 2D view if it points directly up
the world Z axis, out of the paper.

If you have moved or rotated the axes, or changed the axes’ scale, you
can reset them to their ‘normal’ position. For details, see the later
section Repositioning the axes.

You can choose to hide the axes, but note that the axes are never printed
even when they are shown.

You can draw lines that will always be parallel to either the X, Y, or Z
axis by using the Construct Oline command (orthogonal). This is the
same as using the A (Axes) snapcode with the Construct Line
command.

Where any part of a graphic lies on the same coordinate as the axes, the
associated part of the axes may change colour.

Note that you can also display a grid, for which you specify the grid
spacing, to further assist you when drawing and placing graphics. For
details, refer to Help.

Showing and hiding the axes

The axes are often useful to have on screen as they can help you when
you are drawing and placing graphics. At times, however, you may
prefer to work with the axes switched off.

p  To hide or show the axes

e on the Set menu, click Axes, Show
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Moving and rotating the axes

It is often useful to move or rotate the axes. For example, you may want
to carry out a series of constructions and measurements at a specific
angle to the horizontal.

Y Y Y
X
Normal axes Axes moved and Graphic placed with X
snapped to line (L snapcode) rotated axes

Text is always drawn parallel to the X axis. You can change the
alignment of existing text using the Alter Align command. For details,
refer to Help.

p  To move and rotate the axes

1 On the Set menu, click Axes, Move.
A set of axes are attached to the pointer.

2 To specity the new origin:
e click on the drawing at the required position

e or, type the coordinates of the position, relative to the existing
axes

e or, if you are working in 3D you can press Tab to use the
orientation of a 3D clump face, and then click on the face at the
required position
For details about working in 3D, see Chapter 9, Working in 3D.

MicroGDS now prompts you to specify the position of the X, Y, and
Z axes, in turn. In each case, you can:

e cycle through the possible axes, in the order X, Y, Z, -X, —Y, and
—Z by pressing Tab

e cycle through the possible axes in reverse order, by pressing
Shift+Tab

e retain the current rotations, by pressing Esc

3 Specify the position of the axes.

The axes are moved and the rotation is shown in the Angle box on
the status toolbar.
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If you know the exact angle you require, a quicker way to rotate the
axes is to specify the angle of the X axis (relative to its normal position)
using the Angle box on the status toolbar:

Angle |45 w

This is the angle through which the X axis will be rotated from the
normal position (horizontal on the screen). A positive angle usually
indicates an anti-clockwise rotation. However, you can change this on
the General tab of the Preferences dialog box. For details about
changing your preferences, see Chapter 17, Customizing MicroGDS.

When you rotate the axes, MicroGDS uses an angles file to determine
the strings and corresponding angles. You specify the angles file to be
used in your preferences. For details about creating an angles file, see
Chapter 17, Customizing MicroGDS.

You can also use the Axes Spin commands to rotate the axes. Using
Axes Spin Z is similar to typing in the Angle box—the axes are rotated
in the XY plane, about the Z axis. However, when you use the spin
commands, the angle you specify is measured from the current position.
Note that if you spin the axes about the X or Y axis, the Angle box
displays Skew to indicate the rotation in three dimensions.

For more details, refer to the Axes commands in Help.

Note that when you are working in 3D, it is often useful to rotate the
axes to a particular orientation before you construct 3D graphics (or
before you copy a 3D graphic to the Clipboard). For details about
working in 3D, see Chapter 9, Working in 3D.

Repositioning the axes

In addition to simply moving the axes as described above, you can
reposition the axes in a number of ways. This section describes how to
reset the axes to normal, and how to centre the axes.

For details on the commands you can use to change the position, the
origin, and the rotation of the axes, refer to Help.

Note that you can also move an object and change its axes rotation
using the Object Reposition command. For details, refer to Help.
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> To set the axes and scale to normal
e on the Set menu, click Axes, Normal
This resets the axes to the drawing origin and sets the scale to 1:1.

If you have not moved the drawing origin, the axes are set to their
normal position. For more details about the drawing origin, see
Chapter 2, Exploring MicroGDS.

> To centre the axes on the drawing sheet
e on the Set menu, click Axes, Centre

This resets the axes to the centre of the drawing sheet, but leaves the
scale as you have set it.

Rotating the view

You can rotate the view to align all the graphics in the window to the
XY plane. This enables you, for example, to work more easily with
graphics drawn at different angles. This is the equivalent of actually
turning the paper around to look at a different angle of the drawing.

When you have finished, you can revert the view to its real-world
orientation. For example:

Y Y Y

\ 4

X
original view rotated axes * view aligned to XY axes

> To rotate the view

1 Set the angle at which to rotate the view.
The angle of the XY axes define the orientation for the view.

2 On the View menu, click Align to Set XY Axes.
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Axes scale

In MicroGDS, you can draw at full size (that is, 1:1), or you can use
different scales for different objects just as you would if you were
drawing on a piece of paper. For example, you may want to draw an
office cubicle at a scale of 1:50 on one layer, and then draw a particular
work area, for example, the desk space at 1:10 on another layer. You
simply set the scale before drawing the first object and then change the
scale before drawing the next object.

Changing the scale

New graphics are drawn at the current scale. The current axes’ scale is
shown on the status toolbar:

Scale (1:50 v

You can change the current scale at any time. When you change the
scale, any new objects are drawn at that scale until you change it again.
Existing graphics are left unchanged. This means that you can have
different objects, at different scales, together in one document.

p  Tochange the scale of the axes

o in the Scale box on the status toolbar, type or select the scale from
the list

Or:
1 On the Set menu, click Axes, Scale.
2 Enter the scale you require at the Axes scale prompt.

When you specify a scale, MicroGDS uses a scales file to determine the
strings and corresponding scales. You specify the scales file to be used
in your preferences. For details about creating a scales file, see

Chapter 17, Customizing MicroGDS.

When you are drawing, you input real-world dimensions. MicroGDS
converts the dimensions and draws to the set scale. For example, to
draw a desk of 1800mm x 800mm, you would construct a rectangle,
giving its dimensions as 1800 and 800, no matter what the current set
scale is.

More information about objects and their scale and rotation is provided
in the following section.
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Saving and restoring a window’s axes

Each window definition in a document has its own set of axes. By
default, this is the normal axes. If you move, rotate or change the axes’
scale, you can save the axes for the window. You can then restore the
window’s saved axes later.

p  Tosave a window’s axes

e on the View menu, click Save Window Axes

Note that a window definition stores the following values:
o the axes origin, rotation and scale
o the units and decimal places

e the x and y grid spacing

The axes are saved in memory. To save the window axes in the window
definition, you must save the document.

> To restore a window’s saved axes

e on the View menu, click Restore Window Axes

If you are using a grid, the grid location and orientation are reset to
align to the restored axes.

Axes and objects

Each object has its own internal axes’ scale and rotation. When you
create an object, you set the hook point for that individual object. The
hook point is the ‘handle’ of the object which you can use to pick up
and place the object. It also defines the origin of the object’s internal
axes.

When you create an object, the current scale and rotation of the axes are
saved along with the new object. If you subsequently rotate or scale the
object, its internal axes are also rotated and scaled. The current axes are
unaffected.

The following drawing of an articulated lorry consists of two objects:
one object is the cab, and the other object is the trailer. The objects were
drawn as shown in Figure 1, and then the cab was rotated as shown in
Figure 2. The cab will have its axes saved as shown in the second
figure.
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Figure 2

Figure 1

If you later want to modify an object, you may want to set the current
axes to be the same as the object’s axes.

You can use the Query window to obtain the scale of an object’s axes
and its angle. For details, see Chapter 13, Getting information.

> To set the current axes to the object axes
1 On the Set menu, click Axes, Reset.
2 Click on the object to set the axes to.

MicroGDS aligns the current axes rotation with the selected object, puts
the origin of the axes at the object’s hook point, and sets the scale to be
that of the object.

If the object was the current object, it remains the current object. If the
object was not the current object, this does not make it current.

Scale with measurements

MicroGDS provides commands for you to measure graphics. For
example, you can measure:

o the distance between any two points

o the angle between two lines

o the radius of an arc or a circle

For some measure commands, such as measuring the angle between two
lines, the scale is not important. An angle of 90° will be 90° at any
scale.

For other commands, for example, when you measure the area of a
graphic, the scale can be important. When you measure the area of a
graphic, MicroGDS calculates and reports the area of the graphic at the
set scale and at the object scale.
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Note that when you measure graphics, MicroGDS displays the results in
a Query Measurements dialog box if the Query dialogues check box is
selected in your preferences. For details about setting your preferences,
see Chapter 17, Customizing MicroGDS.

More details about the measure commands, and other facilities that you
can use to access information about the graphics in your document, are
given in Chapter 13, Getting information.

Using the axes with cut and copy

When you cut or copy graphics to the Clipboard, MicroGDS stores the
location of the graphics relative to the current axes’ origin, and this is
used when you paste a graphic back into a window. This is important
when you replace one object with another using the Object Replace
command, or place one object on top of another using the Object
Superimp command.

You can replace multiple copies of one object with another, and
superimpose one object on top of multiple objects.

If you move the axes before you paste graphics back into the window,
the graphics are pasted back at the position, scale, and rotation relative
to the current axes origin.

> The basic steps for replacing objects are
1 Select the new object.
2 Copy it to the Clipboard (using the Edit Copy command).
3 Select the range of objects to be replaced.
4 Replace the objects with the new object (using Object Replace).

When you replace the old object, the new object is positioned so that
the origin of the axes when it was copied to the Clipboard is placed at
the point of the old object’s hook point. To avoid having objects
displaced, use the Set Axes, Reset command to reset the axes onto the
new object before copying it to the Clipboard.

Replacing objects is described in Help and an example is also given in
Chapter 3, Working with primitives and objects. For details about
superimposing objects, refer to Help.
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Linestyles

All line primitives have a linestyle, which defines what the line looks
like. A linestyle is made up of one or more strokes. Each stroke defines
specific characteristics of the linestyle. For example, one stroke can
define the line thickness, another can define the fill properties, and a
third stroke could define an offset pattern.

For example:

L i
oy
i
£ F _&4 it
¥
Bt Ry L= |
one stroke linestyle  two stroke linestyle multi-stroke linestyle, multi-stroke linestyle,
with a symbol fill with a hatch fill

MicroGDS provides a variety of built-in linestyles for you to use or
modify. When you create a new document, two linestyles are always
available: DEFAULT and BLANK.
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e DEFAULT is a basic, standard linestyle which draws with a
single-stroke line. It is shown as one pixel wide on the screen, and it
will print in the thinnest line available to your printer (unless you
select a different pen width when you print).

¢ BLANK s an invisible linestyle used by MicroGDS, for example,
for the borders of raster images. You might use it, for example, to
hide construction lines.

The DEFAULT and BLANK linestyles are stored separately from any
linestyles and cannot be saved, deleted, or replaced.

The thickness of lines shown in the graphics window will vary
according to how much the view is zoomed. Note that the thickness of
lines is dependent on the co-ordinate space setting for the linestyle
stroke, as described in Defining strokes on page 167.

You can add a style to a document by selecting a built-in MicroGDS
style or by creating your own.

MicroGDS linestyles
MicroGDS provides a number of built-in linestyles, for example:
DEFAULT
- LR SCISSOR
_____________ DASHA
14M

When you select a linestyle, MicroGDS shows you a sample of the
selected linestyle. You can use a linestyle as it is, or you can modify it
and save it for future use within the document.

Although MicroGDS linestyles are stored separately from your own and
cannot be overwritten, you can, however, accidentally overwrite
amended versions if you use the same name as that of a built-in
linestyle. For example, if you select SCISSOR, change the symbol size
and save it with the same name, your version of SCISSOR takes effect.
If you later reselect SCISSOR from the built-in styles and save it to the
same name, your version is overwritten and all graphics using this
linestyle now use the characteristics defined in the MicroGDS version.
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Accessing linestyles

For single-user documents, new linestyles are stored in the document.
They are saved when you save the document.

You can also access linestyles from external style files (called
LINES.STY). To do this, you specify the folders in which the
LINES.STY files are located using the Style Search Path command on
the File menu. You can add more than one folder to the style search
path, but only one LINES.STY file can be stored in each location. If
you modify and save a style from an external style file, it is saved in the
document. For more details about style files, see Chapter 2, Exploring
MicroGDS.

For multi-user projects, all linestyles are stored in external style files
(LINES.STY). New linestyles are saved in the first LINES.STY
location on the style search path. A linestyle is saved in the style file as
soon as you save the style, even if you do not save the project.

You can access linestyles available to a document from the Document
Organizer and also from the status toolbar.

> To access linestyles using the Document Organizer

1 On the Document Organizer, click the Styles tab:
Styles tab

EFREEIE

2 Double-click the Linestyles category, or click the plus sign (+) to the
left.

A list of all locations from where you can access linestyles is shown:

o for a single-user document, the name of the document with
which you are working is shown first, followed by the path of
each style file defined in the style search path if any

o for a multi-user project, the name of the first style file defined in
the style search path for the project is shown first, followed by
the path of each subsequent location defined in the project

If a LINES.STY file exists in the location defined for styles and

fonts in your file location preferences, this location is shown last in
the list. This enables you to reference a set of global style files that
are available to all your documents. For more details, refer to Help.
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3 To display a list of linestyles in a location, double-click the location
or click the plus sign (+) to the left.

For example:

=I-| Linestyles
=g kitchen,MAN
-+~ 10MM SOLID LINE
== 114
=-= GMM SOLID LINE
=+= 9MM SOLID LINE
=== FILLS0
= Qﬁ{ . \Mew projects
-+~ 10MM DASH
-+~ 10MM SOLID LINE
== 1MM DASH
== 3MM
=== FILLS0
=== Qutling
Linestyles are prefixed by an icon. The colour of the icon

determines the availability of the style:

e linestyles that can be used in the document are prefixed by a red
icon

o linestyles that are not currently available to the document are
prefixed by a grey icon
(A linestyle is unavailable if a linestyle of the same name already
exists in a location higher in the style search path.)

4 To preview a linestyle, select the style and then, on the shortcut
menu, click Toggle Preview.

> To access linestyles from the status toolbar

e on the Line box on the status toolbar, click the arrow
All styles available to the current document are listed.

Adding a linestyle

You can add a new linestyle to a document by saving one from those
available with MicroGDS or by creating your own.

When you add a linestyle, it immediately becomes current and any
selected graphics are assigned that linestyle. Any new graphics you
draw are also assigned the current linestyle.
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Note that if you open a document in which there are missing linestyles,
for example, if they have been deleted, MicroGDS reports the error
conditions to the Problems dialog box. You can use the dialog box to
correct the errors by:

o changing the styles and fonts folder

e editing the style search path

e adding new linestyles

This section describes how to add a new linestyle to your document. For

details about the characteristics that make up a stroke, see Defining
strokes on page 167.

To add a linestyle using the Document Organizer

1 Click the Styles tab on the Document Organizer, and then
double-click the Linestyles category.

2 Do one of the following:

e to create a new linestyle based on DEFAULT, select the
Linestyles category and then, on the shortcut menu, click New

e to create a new linestyle based on an existing style, select the
linestyle on which to base the new style from the required
location and then, on the shortcut menu, click New based upon

MicroGDS displays the Linestyle dialog box.

The dialog box shows you a sample of the linestyle, and the
characteristics of the first stroke in the linestyle. Each stroke is
represented by a separate tab.

3 If you want to use or amend a linestyle other than the current one,
do one of the following:

e to base the linestyle on an existing style in the document, click
‘Document style’, and then select the linestyle on which to base
the new style from the list

e to base the linestyle on a built-in style, select ‘MicroGDS style’,
and then select the linestyle on which to base the new style from
the list

You can use a built-in linestyle as it is, or you can modify it and save

it with a different name.

If you select a style from a list, all settings in the Linestyle dialog

box are reset to those stored with the selected linestyle.
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Specify the settings in the Linestyle dialog box, as required.
Check that the linestyle is what you require in the Sample box.

Save the linestyle:

e to save the linestyle with the existing name, as shown on the title
bar, click Save

e to save the linestyle with a new name, click Save As, type the
name in the Style Name dialog box and click OK

The name must comply with the MicroGDS naming rules, as

described later in this section. You cannot use the name DEFAULT
or BLANK.

The named linestyle is made current and its name is shown in the Line
box on the status toolbar.

To add a linestyle using commands

1
2

3
4
5
6

Deselect all graphics.

From the Line list on the status toolbar, select the linestyle on which
you want to base your new linestyle.

On the Styles menu, click Linestyle Modify
Specify the settings in the Linestyle dialog box, as required.
Check that the linestyle is what you require in the Sample box.

Save the linestyle as described in step 6 in the previous procedure.

Rules for naming linestyles

L[]

a linestyle name can contain up to 256 characters

names can include spaces, except at the beginning or end of the
name

linestyle names are case sensitive, so ‘fill 100’ and ‘FILL 100’ are
two different linestyles

you cannot save to the name DEFAULT or BLANK



Chapter 7: Working with linestyles 161

Changing the linestyle

When you add a linestyle, it immediately becomes current. To use
another linestyle, you select it from those available with the document.
When you change the linestyle, you can:

e change the current linestyle

e change the linestyle of selected graphics

e change the linestyle of all graphics using a specific linestyle

o override the linestyle of all graphics for a particular phase

You can also change the linestyle of part of an existing primitive, using
the Path, Linestyle command on the Alter menu. For details, see Help.

When you change to another linestyle or change the linestyle of an
existing graphic, MicroGDS automatically refreshes the window so that
you can see its effect.

If you are working with a complex drawing, redraws may take some
time. You can speed up redraws by changing the view quality options.
These determine how linestyles, text, and selected graphics are to be
displayed. Note that the quality settings also affect the printed drawing.
For details on setting the window quality, refer to Help.

Changing the current linestyle

The current linestyle is assigned to new line primitives that you draw.
The name of the current linestyle is shown in the Line box on the status
toolbar.

Line | bt SOLID LINE v

If you have selected several graphics that have different linestyles
assigned, the Line box is blank.

Note that each time you click a line primitive, the current linestyle
changes to that primitive’s linestyle.
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> To change the current linestyle

1 Select any graphics for which you want to change the linestyle.

2 Do one of the following:

from the Linestyle list on the Properties window, select the
linestyle

from the Styles tab on the Document Organizer, select the
linestyle and then click Set as current on the shortcut menu
from the Line list on the status toolbar, select the linestyle

on the Set menu, click Linestyle, type the name of the linestyle
in the prompt bar and press Enter

The linestyle name must match a linestyle that you have already
added to the document.

Changing the linestyle of existing graphics

> To change the linestyle of existing graphics

1 Select any graphics for which you want to change the linestyle.

2 Select the replacement linestyle, as described in the previous
section.

Changing the linestyle globally

MicroGDS makes it very easy to change the linestyle of a number of
graphics drawn using one linestyle to another linestyle. You simply
restrict editing to a specific linestyle.

> To change the linestyle globally

1 Press F3, or on the Set menu, click Edit.

You can also use the SETEDIT button on the information bar (at the
bottom-right of the MicroGDS window) to set restrictions:

if SETEDIT is not currently enabled, click the button

If SETEDIT is enabled, a single click of the button toggles the
current editing restrictions on and off

if SETEDIT is currently enabled, double-click the button

The Set Edit Filter Editor is displayed.

2 From the Linestyle list, select the linestyle to which you wish to
restrict editing.
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Alternatively, click the Linestyle Pick button and click a line
primitive to which the style is assigned.

Set Edit Filter Editor

lrestyle |15 | v [ rick ]
charstyle (15 v | [l v [ ek |
Makerial |Is v| |«F\II» vl[ Pick. ]
Colour I= ||l v| Fick.

ctive ‘Wildcard | Schema Advanced

Pick.

- |12
]
II E

Lisk...

Preview ] ’ Close ] [ Help

3 Click Close.

When you have set up your restrictions, the SETEDIT button on the
information bar is pressed in and the text changes colour. You can
toggle the editing restrictions on and off by clicking the button.

4 Ensure that you are in Select Primitives mode by pressing F9, or on
the Edit menu, click Select Primitives.

5 In your graphics window, select the relevant primitives; the status
toolbar shows you the number of primitives selected and that they
all use the same linestyle.

You cannot select any primitives that do not use the specified
linestyle.

To select all primitives drawn in the linestyle, press F7, or on the
Edit menu, click Select All.

6 Select the replacement linestyle as described in Changing the
current linestyle on page 161.

Remember to clear the editing restriction when you have changed the
linestyle.
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Overriding the linestyles for a phase

Usually, you assign linestyles to individual primitives. This means that a
phase can show primitives in many different linestyles. You can,
however, force all line primitives within one phase to be displayed and
printed in a single linestyle.

To override the linestyle for all graphics in a phase
1 Press F2, or on the File menu, click Window, Edit.

2 From the phases list in the Window Editor, select the phase whose
linestyles you want to override.

3 From the Linestyle Overrides list on the Phase tab, select the
linestyle you wish the graphics in the phase to use.

All line primitives within the selected phase are now drawn using
the chosen linestyle. Note that although they appear on screen and
print using the linestyle override, their original linestyles are
unchanged and still appear in the Line box on the status toolbar.

You can also see the name of the linestyle assigned to a line
primitive in the InfoTip, if you have hover highlighting on the
Information bar switched on. For details about hover highlighting,
see Chapter 3, Working with primitives and objects.

If you later remove the override, the primitives are drawn using their
original assigned styles.

You would probably use this feature as a temporary override. To change
the linestyle permanently, you would make the phase the only phase
editable, then select all the graphics, and change the linestyle.

Using strokes

Linestyles are made up of one or more strokes. There are three types of
stroke: pattern, fill, and vertex. Each linestyle can have up to 20 strokes.

For example, you might define two pattern strokes, each with a different
line thickness and a different colour, to create an overlay effect.

You can use symbols in linestyles, for example, to fill the area of a
closed-line primitive with a pattern. When you use symbols in
linestyles, you select the symbol from a font. You can also create new
fonts to define your own symbols. For more details, see Using symbols
in strokes on page 166.
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You use the Linestyle dialog box to add, delete, and reorder strokes in a

linestyle. For example:

Load dialog with: Sample
(%) Document style () MicraGDS style

| ]

Display

Units |mm v|
[ newstoke | [ Delete Stroke |

1-Pattern | 2-Fil |

Stroke type
v | ome
@ Fil
Co-ord space [use for snapping
O vertex
Fill
Fill Rule for multiple loops
[etoo o 7
Gradient fil details
Type of gradient fil
@ Linear  ()Radial Fit to primitive(s)
Direction 45 v
Calours
D Mirror
Blend
O Linear (@) Bell () Cosine
[ Save As ] ’ Close ] ’ Help

Creating new strokes

When you create a new stroke in a linestyle MicroGDS adds a new tab
to the Linestyle dialog box for you to define the characteristics of the
stroke. Each stroke tab is assigned the next sequential number; this

number defines the order of the strokes in the linestyle.
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p  Tocreate a new stroke in a linestyle

1 On the Linestyle dialog box, click the appropriate tab for the stroke
on which to base the new stroke.

MicroGDS creates a new stroke that is a copy of the currently
selected stroke.

2 Click New Stroke.
A new tab to define the stroke is added to the dialog box.

From the Stroke type box, select the type of stroke to define.

4  Define the characteristics for the stroke, as described in Defining
strokes on page 167.

Reordering strokes

The order in which strokes are drawn may be important. For example, if
one stroke defines a black fill and another stroke defines a white
criss-cross hatch, you would need to place the black fill before the white
hatch so that the hatch pattern is visible.

> To reorder the strokes in a linestyle
1 On the Linestyle dialog box, click the tab of the stroke to reorder.

2 Click << Move Up or Move Down >>, as required.

Deleting strokes

p  Todelete a stroke from a linestyle
1 On the Linestyle dialog box, click the tab of the stroke to delete.
2 Click Delete Stroke.

Using symbols in strokes

When you use symbols in a stroke, the set of symbols that is available
depends on the selected font. MicroGDS supplies a large variety of
fonts that you can use in your linestyles and charstyles. The folder in
which MicroGDS looks for fonts is set in your File Location
preferences. For details about setting your file location preferences,
refer to Help.

If you want to use special characters or symbols in a linestyle that are
not available in the supplied MicroGDS fonts, you can create your own
fonts from graphics.
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In MicroGDS, there are two types of font files: CV7 and CV6:

e (CV7 fonts save many types of primitive as part of the font graphics.
All linestyle properties, such as filled strokes, multiple colours, and
thickened offsets are retained. Other graphics, such as text
primitives, and raster primitives, are also saved.

e (CV6 fonts save only line primitives as part of the font graphics. All
linestyle properties and other graphics, such as text primitives are
ignored.

A CV6 symbol is presented in a linestyle as having a font and a size.

A CV7 symbol is presented in a linestyle as having a font and a scale,
however, it can also have a size. To specify a size, you assign the
special MGDS_SymbolSize attribute to the symbol objects. For
example, if you have a church symbol that has a base width (and
MGDS_SymbolSize attribute) of Smm, and you specity a size of 10mm
in the Linestyle dialog box, the symbol is enlarged by a factor of 2.

For more details on fonts and creating MicroGDS CV6 and CV7 font
files, refer to Help.

Defining strokes

When you add or modify a linestyle, MicroGDS displays the Linestyle
dialog box (shown on page 165). The name of the current linestyle is
shown in the title bar of the Linestyle dialog box. If you are creating a
new linestyle or if there are no linestyles saved in the current document,
the title bar does not show a linestyle name.

The top part of the dialog box contains:

e Document style and MicroGDS style options

o the linestyle name if you are basing the linestyle on an existing
document style or on a MicroGDS linestyle

o the units in which to display and interpret measurements in the
dialog box

o an example of the linestyle in the Sample box
e Dbuttons to create, delete, and reorder strokes
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Common stroke properties

Each type of stroke (Fill, Pattern, and Symbol) has a number of
common properties. These define:

e an offset

e acolour

e aco-ord space

o whether to resolve snaps for this stroke
Stroke offset

When you draw a line, the line goes through the given positions. You
can offset the drawn line to the left or right.

Use the Offset box to specify an offset to the left or right of the drawn
line, in the display units. Enter a positive value to offset the stroke to the
left, a negative value to offset the stroke to the right.

For example, the stroke for the line below has a positive offset and so is
offset to the left of the line:

1st point 2nd point

\ o

right

course of line

With offset lines, left and right is determined by the direction in which
you draw the line.

When you use the Rectangle, Ellipse, or Circle commands, the graphics
are drawn anti-clockwise. This means that a stroke with a negative
offset is offset outside a rectangle or circle, and a stroke with a positive
offset is offset inside.

For example:
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Stroke colour

Note that the Colour option is not available with Raster and Gradient
fill strokes. The colours for a Raster fill are defined in the raster image;
the colours for a Gradient fill are defined by two colours which are
specified in the Gradient area. For more details, see Creating filled
strokes on page 176.

By default, MicroGDS draws graphics using the colour defined for the
current phase.

You can use the colour list to specify the colour of a stroke:
e to use any colours defined in the stroke’s components, select Neutral

If you select Neutral, MicroGDS uses the colours embedded in the
components that make up the stroke, if any. For example, if you use
a symbol for a filled stroke and the symbol primitives were created
in green, the fill symbol is drawn in green. However, if you select
red in the Colour box, the fill symbol is drawn in red.

e to use an explicit colour for the stroke, select an existing colour
from the list

If you want to assign a colour that is not available in the list, click
the ‘Select colour’ entry. Then, select your colour using the Select
Colour dialog box. For details about using the Select Colour dialog
box, see Chapter 3, Working with primitives and objects.

To use the colours in a linestyle, ensure that the Use style colours check
box is selected in the Window Editor for the phase that uses the
specified linestyle.

Note that if the primitive has an explicit colour set (using the Set Colour
command), by default the primitive is drawn in the set colour and any
stroke colours are ignored. To use the stroke colours in a linestyle, clear
the Use primitive colours check box in the Window Editor.

For details about changing the colour of the graphics in a phase, see
Chapter 4, Using layers and phases.

The co-ordinate space of a stroke

Use the Co-ord space options to control the way in which the stroke is
drawn. Select the type of co-ordinate space to use:

e Object

Use Object space if you want the linestyle graphics to move, rotate,
and scale along with their object.
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e Drawing

Use Drawing space if you want the linestyle graphics to stay in
proportion when you zoom in and out; the graphics are not tied to
the object scale.

e Output

Use Output space if you want the linestyle graphics to always be the
same size, irrespective of scale and zoom.

In a print layout view, any graphics that have linestyles assigned that
use output space are drawn so that they are a scaled version of what
will appear on the paper. For details about print layout views, see
Chapter 2, Exploring MicroGDS.

e Version 6

Use Version 6 only if you want the same results as in earlier
MicroGDS releases.

For further details about co-ordinate space, and tips for choosing the
right co-ordinate space, refer to Help.

Stroke snapping

Use the Use for snapping option to specify whether to resolve snaps for
this stroke. When selected, snaps for patterned strokes are resolved at
each edge of the thickened stroke. For other strokes types, snaps are
resolved along their offset. All lines can be snapped along their base
line (at offset zero). Note that the setting of this option is ignored for
Output space styles, which are never snapped to.

Creating patterned strokes

Use a pattern stroke to create complex linestyles using combinations of
dots, dashes, and symbols embedded in the line. You can also change
the line thickness and specify the phasing for the pattern.

Stroke thickness

Use the Thickness box to specify the thickness of the stroke, in the
display units. The stroke can also be offset (to the right or left) as
specified in the Offset box.
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Note that you can increase the width for unthickened lines when you
print. For example, if you are using a high-resolution printer or if you
intend to photocopy a drawing, this may help to ensure that the lines are
visible. For details about printing a view, see Chapter 12, Printing and
plotting.

When you specify a thickness, the value you give is a real-world value.
When it is printed, the line will be drawn according to the type of
co-ordinate space selected, as described earlier.

Patterns

You define your pattern, using the pattern buttons, in three parts: the
start, middle and end. The start and end are drawn once per line
primitive, and the middle pattern is repeated in between. If necessary,
the middle can be stretched to fit the line.

Use the pattern buttons to build up your pattern:

draws a line of a specified fixed length
draws a space of a specified fixed length
draws the specified character or symbol from the selected font

draws a line of a variable length (Middle only)

I E G

> draws a space of a variable length (Middle only)

Lines and spaces of variable lengths are called elastic components. You
can specify the length for elastic components, but they can be stretched
to fit the line if necessary. The elastic components are varied according
to the phasing of the linestyle, described in the following section.

To define the start, middle, and end components
e drag the required pattern buttons into the appropriate list

MicroGDS calculates the line using the start and end components of
the pattern. Therefore, elastic lines and spaces can be used only in
the middle of the pattern.



172

Using MicroGDS 2010

For example:
Pattern
Thickness Ornm w Phasing Line v

Skart: Middle End
— 2.500mm <+ 3.000mmm H 2.500mm

= (=
43 10.000mm

HLIEE]

You can set the length for fixed and elastic length lines and spaces; the
length of a symbol is regarded as zero. If you want to leave a gap in the
pattern for the symbol, add spaces to either side of the symbol.

To change the length for lines and spaces

1

2

Double-click the component and then select or type the length you
require.

For elastic components, the value you enter defines the “unstretched’
length.

If you type the length in different units from the display units shown
at the top of the dialog box, MicroGDS automatically converts the
measurements to the display units to draw the line. For details on the
types of units you can use, see Chapter 5, Entering positions.

To accept the new value, click v/

Alternatively

1

Click the line or space component whose length you want to change.

The Linestyle dialog box displays options for changing the
properties of the component. For example:

HOEE)E]
Line details

3 v Elastic

To change the length, select from the list or type the length you
require.
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3 To change a fixed component to an elastic component, select the
Elastic check box.

To change an elastic component to a fixed component, clear the
Elastic check box.

| 2 To change a symbol character
1 Double-click the symbol component and then select the character
you require.

The characters available from the list are determined by the current
font. If the symbol you require is not available in the current font,
you can choose another font.

2 If the symbol you require is available in the current font, accept the
new value by clicking v/

p  Alternatively

1 Click the symbol component whose details you want to change.

The Linestyle dialog box displays options for changing the
properties of the symbol. For example:

HLEEE)

Symbol details
= W Font | symbol v
Size Scale Crientation
Smm - 0053 o w Relative to line

2 To change the character, font, size, and orientation for the selected
symbol, select the value you require from each of the boxes.

Note that the fonts that you can choose from depend on the font files

available in your font path set in your File Location preferences.

e If you are editing the details of a MicroGDS CV6 font, type the
size for the symbol or select from the list.

e If you are editing the details of a MicroGDS CV7 font, type the
scale for the symbol or select from the list instead.
Note that if a symbol size attribute is assigned to the symbol, a
Size box is also shown, displaying the specified symbol size.
(The Size and Scale boxes are interlinked, that is, if you change
one value, the other changes accordingly.)
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3 To draw the symbols at the specified orientation, relative to the line,
select the Relative to line check box.

To draw the symbols at the specified orientation, relative to the
chosen co-ordinate space, clear this check box. For details about the
co-ordinate space settings, see Defining strokes on page 167.

For more information about the symbol details, refer to Help.

> To remove an individual component

e press Delete or drag the component out of the list

p  Toremove all components in a list
e drag into the appropriate list
| 2 To remove all components in all lists
e click Clear All

The following example shows how you would define a linestyle that
repeats a pattern of fixed-length lines and fixed-length spaces
throughout the line, and ends each line primitive with a scissors symbol:

Pattern

Thickness 0.5mm Phasing Line v
Start Middle End
= Gmm T Tl
< 2.800mm

HLEE)

Symbol details
>§ w Font | syrmbol v
Size Stcale Orientation
3.5mm w 0,055 w 1] “ Relative ta line
L 1

If you draw an ellipse using this linestyle pattern, it appears as:

—————

2

— — —
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Phasing

Stroke patterns can include variable length, or elastic, components. You
can specify the length for elastic components, but they can be stretched
to fit the line if necessary. The elastic components are varied according
to the phasing of the pattern. Phasing is commonly used to ensure that
the vertices of a line primitive appear at a line, and not at a space in the
pattern.

Note that elastic components are only applicable to the middle
components in a pattern. Components that make up the pattern are
described in the previous section.

There are five phasing options; select the phasing you require from the

list:

e Select None for no phasing. The pattern starts at the start vertex of
the line, and repeats to the end vertex. Elastic components are drawn
at their defined lengths. The end of the line does not necessarily
correspond with the end of a pattern repetition.

e Select Angle to restart the middle pattern at each angular vertex
(where the two line segments that meet at the vertex are not
tangential). Elastic components are stretched as necessary.

e Select Line to ensure that the start of the End pattern corresponds
with the end of a Middle pattern repetition. Elastic components are
stretched as necessary.

Note that if the Middle pattern ends with a space, the last pattern
repetition is forced to end at the last line or symbol in the pattern.

e Select Grid to line up the components of the pattern when they occur
on parallel lines. You can use this option to line up the hatch pattern
when you use the Construct Hatch command to create hatch lines.

e Select Vertex to restart the middle pattern at each vertex, where each
segment is separately phased. Elastic components are stretched as
necessary.



176  Using MicroGDS 2010

Creating filled strokes

Use a fill stroke to flood fill closed primitives. Fill has no effect on open
primitives.

There are several fill types from which you can select:

e Brush

e Gradient
e Hatch

e Raster

e Symbol

MicroGDS provides options for you to choose how to fill multiple,
overlapping closed line primitives. You can specify that ‘holes’ are
created where the primitives overlap, or that those areas should be filled
in. These options apply only to primitives which are in the same object,
and use the same filled linestyle and primitive colour.

You choose how to fill the primitives using the ‘Rule for multiple loops’
option on the Fill tab:

e Use loop depth
Creates a hole wherever primitives overlap:

]
L]

If another primitive with the same fill attributes is overlaid, any part
of the hole that it overlaps is filled, and any fill that it overlaps
creates a hole:

D
u

If you explicitly change the colour of one of the primitives, any
holes in the primitive are filled:
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Furthermore, if strokes in a linestyle use offsets, each closed line
primitive is offset independently before all the primitives are
combined.

o Use loop sense

Select this option to take account of the direction in which each line
primitive is drawn. Overlapping primitives that are drawn in the
same direction are simply overlaid. Holes are created only where
overlapping primitives are drawn in opposite directions.

[ D

L] L]

all lines are drawn in the circle direction now reversed
same direction

For details about the direction in which primitives are drawn and
how to reverse the direction, refer to Help.

e Independent loops
This option draws each primitive independently, ignoring the
direction in which the primitive was drawn. No holes are created.

The following illustration shows part of a floor plan, with a sofa placed
on a tiled floor. The sofa uses an opaque, brush filled linestyle. Initially,
the style is set to ‘Use loop depth’, which means that a hole is created
wherever the sofa line primitives overlap:
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Notice that the floor tiles are visible wherever the cushions overlap.
One way to correct this is to use different linestyles for the sofa and
cushions. A more efficient way is to simply change the rule for multiple
loops option to ‘Independent loops’:

[ )

Il

The Fill tab has options to control the ways in which colours are mixed
at each pixel, to obtain the final result.

In this particular example, you could achieve the same result by
reversing the line direction of overlapping primitives and using ‘Loop
sense’.

‘Loop sense’ creates holes only where overlapping primitives are drawn
in opposite directions. This gives you more control over the appearance
of each nested primitive. To create a hole, make sure that the outer and
inner primitives are drawn in different directions. When you reverse the
direction of a primitive, the area of the primitive is reported as negative.
This enables you to calculate areas based on the positive and negative
line directions.

For all fills except Gradient, you can choose to make a fill transparent
or opaque (the default). To make the fill transparent, clear the Opaque
check box. Gradient fills are always opaque (unless a colour includes an
alpha value).

Transparent means that you will see any graphics that are drawn
underneath, and opaque means that you will not:

N\ N\

»
transparent fill opaque fill

Brush fills also provide a ‘true transparency’ option, where the colour
builds up where primitives overlap. You will see this in the next section.

Note that some output devices do not support transparent fills.



Chapter 7: Working with linestyles 179

For more details on the transparency options and the formulae for
colour mixing, refer to Help.

To define a fill type for the stroke
e from the Fill list, select the fill type you require

Brush fill

Select Brush to create a fill using a brush or pattern.

e select Percent fill and select the percentage fill from the list

e or, select Brush pattern and select the brush pattern from the list
The listed brush patterns are compatible with all versions of
MicroGDS.

e or, select Extended brush pattern and select the brush pattern from
the list
The listed brush patterns are compatible with MicroGDS version 8.0
and later.

For percentage fills, you can specify to use true transparency. True
transparency ‘builds up’ the colour where primitives overlap:

This option is not available if the Opaque check box is selected.

Brush patterns always use Output co-ordinate space, and are never
rotated or scaled. If you change the co-ordinate space, it has no effect
on the pattern.

Note that some output devices cannot print solid fills and overlapping
fills, therefore test your device before you use this feature.

Gradient fill

Select Gradient to create a fill that gradually changes from one colour to
another.

You can define linear and radial Gradient fills:

.
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e From the ‘Type of gradient fill’ options, select Linear to blend the
fill linearly, or Radial to blend the fill radially.

o To fit the fill to the primitives to which the gradient linestyle is
assigned, select the ‘Fit to primitive(s)’ check box. To fill a
primitive by specifying the coordinate positions, clear this check
box.

e Click the Colours boxes and select the colours you want for the
graduated fill.

Note that the colours you select are not affected by the phase colour
or the current colour.

o Use the Blend options to define the fall-off:
— Linear creates an even fall-off
— Bell creates a fairly steep fall-off, based on a bell-shaped curve
— Cosine creates a steep fall-off, using a cosine blend shape

The remaining options reflect the type of gradient fill, and whether or
not you have selected the ‘Fit to primitive(s)’ option.

Linear fill

If you select ‘Fit to primitive(s)’:

o Specify the angle for the graduated fill, by selecting from the
Direction list or typing in the box.

e To mirror the gradient fill, from the mid-point of the extent of the
primitive, select the Mirror check box.
You might do this, for example, to create a shading effect for
cylindrical columns:
| el
h |

=

If you do not select the Mirror check box, the extent of the primitive
is filled with a single instance of the fill.
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If you did not select ‘Fit to primitive(s)’:

e In the From and To boxes, type the coordinates for the start and end
of the fill, in the display units.
If you want a vertical fill, set the X coordinates to be the same, or
the Y coordinates for a horizontal fill.

e If you want to mirror repeat the gradient fill, select the ‘Mirror
repeat’ check box.
The first example below uses a mirror-repeat gradient fill to

simulate profiled roof sheeting; the second example uses gradient
fill without a mirror repeat to represent louvered window shutters:

]

mirror repeat fill no mirror repeat

If you select ‘Fit to primitive(s)’” with a radial fade, there are no

additional options to those described earlier.

If you did not select ‘Fit to primitive(s)’:

e In the From and To boxes, type the coordinates for the start and end
of the fill, in the display units

The From point is the centre of the fill and the To point is a point on
the circumference.

Hatch fill

Select Hatch to create a fill using a hatch pattern.

e to create a cross—hatch pattern, select the Cross hatch check box
By default, the hatching is drawn in the DEFAULT linestyle. You can
use any linestyle that exists in the document.

e to use a different linestyle, select the linestyle from the list

Note that only middle pattern strokes in the specified linestyle are used
for the hatching. Fill and vertex strokes are ignored. The pattern is

drawn as if its phasing were set to Grid. For details about phasing, see
page 175.
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Note also that there can be a conflict of co-ordinate spaces between the
pattern stroke, and the strokes of the hatch linestyle. In these cases, the
hatch style will be drawn in the ‘lower’ space, where the spaces rank in
the order Object, Drawing, Output (from high to low). Consequentially,
if you are designing a linestyle for use in hatching strokes in different
spaces, Object space is the most likely to give the desired results.

Use the Grid settings to define the grid along which the hatching lines
will be drawn:
gap specifies the gap between the rows of hatching

shear specifies the distance by which the hatched rows are to be
offset from one another

This affects the way in which any pattern elements line up.

slope specifies the angle at which the hatched lines are to be
drawn

origin specifies the coordinates for the origin of the hatched grid;
the coordinates are interpreted in the selected co-ordinate
space

For example:

Hatch fill details
Cpaque |:|
Use linestyle “ | Cross hatch
Grid
Gap Shear
10mm w Qrnrn A
Slope Origin
i} L Ornmn/Ommmf0mm

If you draw a rectangle using this hatch fill, it appears as:
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Raster fill

Select Raster to create a fill using a raster image. You might use a raster
fill, for example, to show wall textures or flooring. For example:

e In the File name box, type the full path of the raster file or click the
Browse button to select the file.

You can use any type of raster file that can be imported into
MicroGDS. For details, see Chapter 15, Working with different file
formats.

o To maintain the aspect ratio of the raster file, select the ‘Preserve
file aspect ratio’ check box.

Clear the check box to draw the raster image at the size specified by
the Height (Y size) and Width (X size) boxes.

o To retain the specified Height and Width settings if a different raster
file is later selected, select the ‘Keep grid if file changed’ check box.

Use the Grid settings to define the grid for placing the raster image:

height specifies the height of the raster image tile

shear specifies the distance by which the rows of raster images
are to be offset from one another

width specifies the width of the raster image tile

slope specifies the angle at which the raster image is to be drawn

origin specifies the coordinates for the origin of the grid; the

coordinates are interpreted in the selected co-ordinate space
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For example:

Raster Fill details

Opanue
File name
F:\TexturesiMetallic\Bronze kile.bmp
Preserve file aspect ratio [keep grid if file changed
Grid
Height Shear Width
150mm w Qrnrm A 150mm w
Slope Crigin
30 w Z200mmy L 7emm/Omm

where a single instance of the raster image is:

=T
==

T
I

I
L

If you draw a rectangle using this raster image with the above settings,
it appears as:

Symbol fill

Select Symbol to create a fill using symbols from a MicroGDS font.
e From the Symbol list, select the symbol you require. The set of
symbols that is available depends on the selected font. To change the
font, select the font you require from the Font list.
e To specity the size for the symbol:
— if you are editing the details of a MicroGDS CV6 font, type
the size for the symbol or select from the list
— if you are editing the details of a MicroGDS CV7 font, type
the scale for the symbol or select from the list
Note that if a symbol size attribute is assigned to the symbol, a Size
box is also shown, displaying the specified symbol size. (The Size
and Scale boxes are interlinked, that is, if you change one value, the
other changes accordingly.)
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e To draw the symbols at a specified angle, in the Orientation box,
type the angle for the symbol or select it from the list.

e To draw the symbols at the given orientation, relative to the line of
symbols as defined by the grid slope, select the Relative to line
check box.

Clear the check box to draw the symbols at the given orientation,
relative to the co-ordinate space.

Use the Grid settings to define the grid for placing symbols:

gap specifies the gap between each row of symbols

shear specifies the offset between the left edge of a symbol on
one row and the left edge of a symbol on the next row

spacing specifies the spacing between each column of symbols

slope specifies the angle at which the rows are to be drawn

origin specifies the coordinates for the origin of the grid; the
coordinates are interpreted in the selected co-ordinate
space

For example:

Symbal Fill details

Opaque [
Symbaol
& w Scale | 1,000 s«
Faont
Symbals 2 4 | Orientakion |0 w | Relative ko line [v]
Grid
Gap Shear Spacing
100rmm w Ornrm A 150mm v
Slope Origin
45 - Qo Ommf0rmm

If you draw a rectangle using this symbol fill, it appears as:
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Creating vertex strokes

Use a vertex stroke to mark various points on a vertex, line, and/or
segment. For example, to mark the start, end, and mid-point of every
segment of a primitive, you could define the symbols as shown:

Wertex

Wertex

Start [ - End E -

[internal w | [#Itidpoint M w
Segmenk

[ 5kart line + | [JEndline v

|:| Skart segment w |:| End segment ~

Symbol details

Font | DEFALLT w

Size Z.5mm v

The following examples illustrate various combinations of marking
vertex and segment points:

Vertex: Start, End, Internal, and Midpoint points

Segment: Start line and End line points

Segment: Start segment points

Segment: End segment points
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Symbol details

You can change the font for individual vertex and segment points. The
set of symbols that is available depends on the selected font.

p  Tochange the font for vertex or segment point
o under Vertex or Segment, select the check box for the appropriate point
MicroGDS indents the vertex or segment point to indicate that it is
the currently active property.
o from the Font list, select the font you require
o to specity the size for the symbol:
— If you are editing the details of a MicroGDS CV6 font, type
the size for the symbol or select from the list.
— If you are editing the details of a MicroGDS CV7 font, type
the scale for the symbol or select from the list, instead.
Note that if a symbol size attribute is assigned to the symbol, a Size
box is also shown, displaying the specified symbol size. (The Size

and Scale boxes are interlinked, that is, if you change one value, the
other changes accordingly.)

Drawing order of primitives

You draw objects on layers, and you use phases to reference the layers.
The order in which MicroGDS draws the graphics on a layer is defined
by the phase order in the Window Editor. For details, see Chapter 4,
Using layers and phases.

Generally, objects are drawn in a phase in the order the objects are
created. However, MicroGDS draws the primitives within an object in a
particular order. This order is important, particularly with filled,
closed-line primitives. The order in which primitives in an object are
drawn is:

e all closed-line primitives that have any type of filled stroke are
drawn first

Within the filled primitives, all graphics that are assigned the same
linestyle, and colour, are filled together (with the strokes being
drawn in the order in which they are defined).

e all non-filled strokes are then drawn, in their defined stroke order
o finally, all other graphics in the object are drawn

For details about filled linestyles, see page 176.
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Using linestyles as a mask

You can use a filled linestyle to mask out parts of a drawing. You define
a mask linestyle by setting a brush of 0% and a fill of opaque (so that
graphics underneath are covered by the background colour).

For example, you could use a mask linestyle if you are inserting
windows into a wall elevation. You can draw the wall in a hatched
linestyle—to represent the brickwork—and then create a new object,
and reference it in a different phase (or on a different layer), for a
window. If you then create the background rectangle of the window in a
mask linestyle (and the detail in a normal, visible linestyle), it masks
over the brickwork detail wherever you place it on the wall.

Sassssis

|

—

phase 1: wall phase 2: window  window masks over brickwork

B

For this to draw correctly, you will need to ensure that the phase in
which the wall is referenced is drawn first, the window background
rectangle is drawn next (because it is a filled linestyle) and the window
detail is drawn last.

Primitives drawn with mask linestyles will not mask:

e other primitives in the same object

e items on layers placed on top of the masked-object layer

Phases are drawn and printed in the order in which they are listed in the
Window Editor. Each phase is drawn on top of the previous phase. You

may need to reorder the phases if you want to mask out items on other
layers. For details, see Chapter 4, Using layers and phases.
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Modifying an existing linestyle
With the exception of DEFAULT and BLANK, you can modify any
linestyle that is available to the document.

> To modify a linestyle using the Document Organizer

1 In the Document Organizer, ensure that the appropriate document is
the current document.

2 On the Styles tab, locate the linestyle that you want to modify.

3 Double-click the linestyle name, or on the shortcut menu, click Edit.

This command is unavailable for any linestyle where a linestyle of
the same name exists in a location higher in the style search path.

If you want to edit a linestyle referenced in a style file, you can open
the style file for editing, using the shortcut menu.

MicroGDS displays the Linestyle dialog box.
4 Modify the characteristics as required.

5 To save the linestyle, do one of the following:
e to keep the same linestyle name, click Save

If you retain the linestyle name, all line primitives that use the
linestyle are immediately updated.

o to save the linestyle with a new name, click Save As, type the
name in the Style Name dialog box and click OK

If you modify a linestyle from an external style file, MicroGDS
creates a new local linestyle with the name you specity.

For more details about style files, see Chapter 2, Exploring
MicroGDS.

If you save a linestyle to a name that exists in an external style file, the
icon for the external linestyle changes colour in the Document
Organizer. This indicates that a local style of the same name now exists.
For more details, see Accessing linestyles on page 157.
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p  To modify a linestyle using commands
1 From the Line list on the status toolbar, select the linestyle to
modify.
Alternatively, select a primitive that uses the style you want to
modify.
2 On the Styles menu, click Linestyle Modify.

3 Modify the linestyle and then save the linestyle, as described in
step 5 in the previous procedure.

Deleting a linestyle

You can delete linestyles that are no longer required. You cannot
retrieve deleted linestyles.

If you select a graphic whose style has been deleted, the Line box on the
status toolbar is empty. You can see the name of the assigned linestyle
in the InfoTip, if you have hover highlighting on the Information bar
switched on. You can also see the name in the Properties window
(Ctrl+Q).

If you later create another linestyle with the same name as the deleted
linestyle, it is used by the graphics to which the style was originally
assigned (if you have not assigned a different linestyle in the
meantime).

You cannot delete the DEFAULT or BLANK linestyle.

p  Todelete a linestyle

1 In the Document Organizer, ensure that the appropriate document is
the current document.

2 On the Styles tab, select the linestyle that you want to delete.

You can delete multiple linestyles (or multiple styles of any type),
using Windows multi-select facilities.

3 Press Delete, or on the shortcut menu, click Delete.

4 To confirm the deletion, click Yes at the prompt.
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Working with text

All text primitives have a charstyle (character style), which defines
what the text looks like. A charstyle determines the height and width of
the text, the spacing and margins around the text, and the font that is

used.

For example:

Alc

Windows font

£A\Be

user-created font: linestyle with
a transparent, percentage fill

AlE

MicroGDS font

user-created font: linestyle with
a symbol fill
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MicroGDS provides a variety of built-in charstyles for you to use or
modify. When you create a new document, there is only one available
charstyle, DEFAULT. This uses a MicroGDS font that draws text in a
text box that has a height of Smm.

The DEFAULT charstyle is stored separately from any charstyles you
create and cannot be saved, deleted, or replaced.

Note that you specify the size for a charstyle using real-world
measurements. The size of the text shown in the window will vary
according to how much the view is zoomed. The size of text is
independent of the current axes scale, and the scale of the object.

You can add a charstyle to a document by selecting a built-in
MicroGDS style or by creating your own. When you create your own
charstyles, you can use either a Windows font or a MicroGDS font. You
can also create new fonts that you can then use to create or modify
charstyles. For details about creating your own fonts, refer to Help.

MicroGDS charstyles

MicroGDS provides a number of built-in charstyles, for example:

Defoult
3aA

PEUSS

a8

When you select a charstyle, MicroGDS shows you a sample of the
selected charstyle. You can use a charstyle as it is, or you can moditfy it
and save it for future use within the document.

Although MicroGDS charstyles are stored separately from your own
and cannot be overwritten, you can, however, accidentally overwrite
amended versions if you use the same name as that of a built-in
charstyle. For example, if you select AR25, change the font height and
save it with the same name, your version of AR25 takes effect. If you
later reselect AR25 from the built-in styles and save it to the same
name, your version is overwritten and all text boxes using this charstyle
now use the characteristics defined in the MicroGDS version.
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Accessing charstyles

For single-user documents, new charstyles are stored in the document.
They are saved when you save the document.

You can also access charstyles from external style files (called
CHARS.STY). To do this, you specify the folders in which the
CHARS.STY files are located using the Style Search Path command on
the File menu. You can add more than one folder to the style search
path, but only one CHARS.STY file can be stored in each location. If
you modify and save a style from an external style file, it is saved in the
document. For more details about style files, see Chapter 2, Exploring
MicroGDS.

For multi-user projects, all charstyles are stored in external style files
(CHARS.STY). New charstyles are saved in the first CHARS.STY
location on the style search path. A charstyle is saved in the style file as
soon as you save the style, even if you do not save project.

You can access charstyles available to a document from the Document
Organizer and also from the status toolbar.

> To access charstyles using the Document Organizer

1 On the Document Organizer, click the Styles tab:
Styles tab

EFIDEAFE

2 Double-click the Charstyles category, or click the plus sign (+) to
the left.

A list of all locations from where you can access charstyles is
shown:

o for a single-user document, the name of the document with
which you are working is shown first, followed by the path of
each style file defined in the style search path if any

o for a multi-user project, the name of the first style file defined in
the style search path for the project is shown first, followed by
the path of each subsequent location defined in the project
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If a CHARS.STY file exists in the location defined for styles and

fonts in your file location preferences, this location is shown last in
the list. This enables you to reference a set of global style files that
are available to all your documents. For more details, refer to Help.

3 To display a list of charstyles in a location, double-click the location
or click the plus sign (+) to the left.

For example:

=I-| Charstyles
=g kitchen. MAN
A arial ialic 40mm
_:—\ comic sans S0mm
A comic sans Smm
A comic sans 7Smm
A Courier Mew SOmrr
A ELEC
= ‘Eﬂ{ .. \Mew projects
A tncs
A cs
A acs
A Arial ikalic 40mm
A ELEC
Charstyles are prefixed by an icon. The colour of the icon

determines the availability of the style:

e charstyles that can be used in the document are prefixed by a red
icon

e charstyles that are not currently available to the document are
prefixed by a grey icon
(A charstyle is unavailable if a charstyle of the same name
already exists in a location higher in the style search path.)

4 To preview a charstyle, select the style and then, on the shortcut
menu, click Toggle Preview.

> To access charstyles from the status toolbar
e on the Char box on the status toolbar, click the arrow
All styles available to the current document are listed.
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Adding a charstyle

You can add a new charstyle to a document by saving one from those
available with MicroGDS or by creating your own.

When you add a charstyle, it immediately becomes current and any
selected text changes to use that charstyle. Any new text you create also
uses this charstyle.

Note that if you open a document in which there are missing charstyles,
for example, if they have been deleted, MicroGDS reports the error
conditions to the Problems dialog box. You can use the dialog box to
correct the errors by:

e changing the styles and fonts folder

o cditing the style search path

e adding new charstyles

This section tells you how to add a new charstyle to your document. For
details about each of the charstyle characteristics, see Charstyle
properties on page 201.

> To add a charstyle using the Document Organizer

1 Click the Styles tab on the Document Organizer, and then
double-click the Charstyles category.

2 Do one of the following:

e to create a new charstyle based on DEFAULT, select the
Charstyles category and then, on the shortcut menu, click New

e to create a new charstyle based on an existing style, select the
charstyle on which to base the new style from the required
location and then, on the shortcut menu, click New based upon

The Charstyle dialog box shows the characteristics of the current
charstyle.

3 If you want to use or amend a charstyle other than the current one,
do one of the following:

e to base the charstyle on an existing style in the document, click
‘Document style’, and then select the charstyle on which to base
the new style from the list
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e to base the charstyle on a built-in style, select ‘MicroGDS style’,
and then select the charstyle on which to base the new style from
the list

If you select a style from a list, all settings in the Charstyle dialog
box are reset to those stored with the selected charstyle.

Specify the settings in the Charstyle dialog box, as required.
Check that the charstyle is what you require in the Sample box.

Save the charstyle:

e to save the charstyle with the existing name, as shown on the
title bar, click Save

e to save the charstyle with a new name, click Save As, type the
name in the Style Name dialog box and click OK

The name must comply with the MicroGDS naming rules, as
described in the next section. You cannot save a charstyle with the
name DEFAULT.

The named charstyle is made current and its name is shown in the Char
box on the status toolbar.

To add a charstyle using commands

1

4
5

From the Char list on the status toolbar, select the charstyle on
which you want to base your new charstyle.

On the Styles menu, click Charstyle Modify.
MicroGDS displays the Charstyle dialog box.

Specify the settings in the Charstyle dialog box, as required.
Check that the charstyle is what you require in the Sample box.

Save the charstyle as described in step 6 in the previous procedure.

Rules for naming charstyles

[ )

a charstyle name can contain up to 256 characters

names can include spaces, except at the beginning or end of the
name

charstyle names are case sensitive, so ‘courier8’ and ‘Courier8’ are
two different charstyles

you cannot save to the name DEFAULT
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Changing the charstyle

When you add a charstyle, it immediately becomes current. To use
another charstyle, you select it from those available with the document.
When you change the charstyle, you can:

o change the current charstyle

o change the charstyle of selected text primitives

o change the charstyle of all text primitives using a specific charstyle
o override the charstyle of all text primitives for a particular phase
When you change to another charstyle or change the charstyle of

existing text, MicroGDS automatically refreshes the window so that
you can see its effect.

If you are working with a complex drawing, redraws may take some
time. You can speed up redraws by changing the view quality options.
These determine how linestyles, text, and selected graphics are to be
displayed. Note that the quality settings also affect the printed drawing.
For details on setting the view quality, refer to Help.

Changing the current charstyle

The current charstyle is assigned to new text that you draw. The name
of the current charstyle is shown in the Char box on the status toolbar.

Char | Avrial italic 40mm A

If you have selected several text primitives that have different charstyles
assigned, the Char box is blank.

Note that each time you click a text primitive, the current charstyle
changes to that primitive’s charstyle.

> To change the current charstyle
1 Select any text for which you want to change the charstyle.

2 Do one of the following:

o from the Charstyle list on the Properties window, select the
charstyle

o from the Styles tab on the Document Organizer, select the
charstyle and then click Set as current on the shortcut menu



198

Using MicroGDS 2010

e from the Char list on the status toolbar, select the charstyle

e on the Set menu, click Charstyle, type the name of the charstyle
in the prompt bar and press ENTER

The charstyle name must match a charstyle that you have already
added to the document.

Note that if you have enlarged, reduced, or stretched the text, and you
want to retain the size, ensure that you reapply the charstyle using the
Properties window. If you reapply the charstyle using any other method,
the text returns to the size set in the charstyle definition. For details
about enlarging and stretching graphics, refer to Help.

Changing the charstyle of existing text

To change the charstyle of existing text
1 Select any text for which you want to change the charstyle.

2 Select the replacement charstyle, as described in the previous
section.

Changing the charstyle globally

MicroGDS makes it very easy to change the charstyle of a number of
text primitives drawn using one charstyle to another charstyle. You
simply restrict editing to a specific charstyle.

To change the charstyle globally

1 Press F3 or on the Set menu, click Edit.

You can also use the SETEDIT button on the information bar (at the
bottom-right corner of the MicroGDS window) to set restrictions:

e if SETEDIT is not currently enabled, click the button

If SETEDIT is enabled, a single click of the button toggles the
current editing restrictions on and off

o if SETEDIT is currently enabled, double-click the button
The Set Edit Filter Editor is displayed.

2 From the Charstyle list, select the charstyle to which you wish to
restrict editing.

Alternatively, click the Charstyle Pick button and click a text
primitive to which the style is assigned.
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Set Edit Filter Editor

lnestyle |Is | [l v [rik ]
charstyle [15  w| | O AT vl [ rik ]
Material |Is vl | ke vl [ Pick. ]
w1 v| | <Al v| [k

Active wildcard J Schema Advanced

Preview ] [ Close ][ Help

3 Click Close.

When you have set up your restrictions, the SETEDIT button on the
information bar is pressed in and the text changes colour. You can
toggle the editing restrictions on and off by clicking the SETEDIT
button.

Ensure that you are in Select Primitives mode by pressing F9, or on
the Edit menu, click Select Primitives.

In your graphics window, select the relevant text primitives; the
status toolbar shows you the number of primitives selected and that
they all use the same charstyle.

You cannot select any text primitives that do not use the specified
charstyle.

To select all primitives drawn in the charstyle, press F7, or on the
Edit menu, click Select All.

6 Select the replacement charstyle, as described on page 197.

Remember to clear the editing restriction when you have changed the
charstyle.
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Overriding the charstyles for a phase

Usually, you assign charstyles to individual text primitives. This means
that a phase can show text primitives in many different charstyles. You
can, however, force all text primitives within one phase to be displayed
and printed in a single charstyle.

> To override the charstyle for all graphics in a phase
1 Press F2, or on the File menu, click Window, Edit.

2 From the phases list in the Window Editor, select the phase whose
charstyles you want to override.

3 From the Charstyle Overrides list on the Phase tab, select the
charstyle you wish the graphics in the phase to use.

All text primitives within the selected phase are now drawn using
the chosen charstyle. Note that although they appear on screen and
print using the charstyle override, their original charstyles are
unchanged and still appear in the Char box on the status toolbar.

You can also see the name of the charstyle assigned to a text
primitive using the Properties window (Ctrl+Q). For details about
the Properties window, see Chapter 13, Getting information.

If you later remove the override, the primitives are drawn using their
original assigned charstyles.

You would probably use this feature only as a temporary override. To
change the charstyle permanently, you would make the phase the only
phase editable, then select all the graphics, and change the charstyle.
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Charstyle properties

When you add or modify a charstyle, MicroGDS displays the Charstyle
dialog box. For example:

Charstyle - Arial italic 53
Load dialog with:
(*) Document style () MicroGDS style
| v
.

AaBbCc123 Arial
Font

Arial

Display

Colour | Neutral v| Units |mm v|
Size

Height |20 v| width |omm v|
Spacding

Character | Omm v| Line | 0.586mm v|
Margins

Top | 3 v| Bottom | 3 v|
Left | 3 v| Right | 3 v|
Outline

O None O Outer box

(O Inner box () Text lines

| Shaded outline v |
[ Save ] [Save As ] [ Close ] [ Help ]

The name of the currently specified charstyle is shown in the title bar. If
you are c